xserver crashes in RecordAReply when XRecord is enabled in syndaemon

Bug #774978 reported by Dave Gilbert on 2011-05-01
828
This bug affects 281 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
High
Unassigned
Natty
Undecided
Unassigned

Bug Description

[Impact]
Fairly widespread X crash that occurs seemingly randomly to users, but is actually triggered when a client application makes a call that results in a syndaemon call in the Xrecord module that fails.

[Development Fix]
Disable linking to the X record module in the synaptics package. See Robert Hooker's debdiff.

[Stable Fix]
Same fix as for development.

[Regression Potential]
XRecord was not enabled in maverick, so disabling it is not a regression from that version. It was enabled in natty to permit avoiding polling of the keyboard which presumably might save battery power usage; however it was found to cause widespread bugs shortly after introducing it - see comment #38 for historical discussion.

[Original Report]
Xserver crashed (landed me back at the gdm login); it happened just after I'd opened a page in firefox - nothing too special, it had some flash in but nothing too unusual and the page reopened fine now.

Seg is in the Xorg.0.log.org

Dave

Backtrace:
[ 15223.014] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a2626]
[ 15223.014] 1: /usr/bin/X (0x400000+0x6219a) [0x46219a]
[ 15223.014] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f8335203000+0xfc60) [0x7f8335212c60]
[ 15223.014] 3: /usr/lib/xorg/modules/extensions/librecord.so (0x7f8332bb8000+0x2920) [0x7f8332bba920]
[ 15223.014] 4: /usr/bin/X (_CallCallbacks+0x34) [0x432af4]
[ 15223.015] 5: /usr/bin/X (WriteToClient+0x21a) [0x461c9a]
[ 15223.015] 6: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x52) [0x7f833259fd82]
[ 15223.015] 7: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x59) [0x7f833259e479]
[ 15223.015] 8: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f833234b000+0x25030) [0x7f8332370030]
[ 15223.015] 9: /lib/x86_64-linux-gnu/libdrm.so.2 (drmHandleEvent+0x108) [0x7f83327a9478]
[ 15223.015] 10: /usr/bin/X (WakeupHandler+0x4b) [0x4322fb]
[ 15223.015] 11: /usr/bin/X (WaitForSomething+0x1b6) [0x45c786]
[ 15223.015] 12: /usr/bin/X (0x400000+0x2e032) [0x42e032]
[ 15223.015] 13: /usr/bin/X (0x400000+0x21a7e) [0x421a7e]
[ 15223.015] 14: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xff) [0x7f833414ceff]
[ 15223.015] 15: /usr/bin/X (0x400000+0x21629) [0x421629]
[ 15223.015] Segmentation fault at address 0x7f8335ceb010
[ 15223.015]
Caught signal 11 (Segmentation fault). Server aborting
[ 15223.015]
Please consult the The X.Org Foundation support
  at http://wiki.x.org

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,gnomecompat,move,place,regex,resize,mousepoll,session,snap,vpswitch,animation,wall,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
CurrentDmesg:
 [ 46.803341] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
 [ 46.920399] NFSD: starting 90-second grace period
 [ 48.517660] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
 [ 52.500035] eth2: no IPv6 routers present
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64: AP///////wBMozM2AAAAAAAPAQOAIRV4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB7hoAgFAgEDAQMBMAS88QAAAZAAAADwAAAAAAAAAAACOHAmQCAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xNTRYMy1MMDYKAHA=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Sun May 1 17:26:30 2011
DistUpgraded: Log time: 2010-07-24 18:47:52.187518
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff10]
   Subsystem: Toshiba America Info Systems Device [1179:ff10]
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: TOSHIBA Equium A100
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LC_MESSAGES=en_GB.UTF-8
 LANG=en_US.UTF-8
 LANGUAGE=en_GB:en
ProcKernelCmdLine: root=UUID=031a90fc-7cc9-4daf-bb3f-4bb3f68653ac ro quiet splash crashkernel=384M-2G:64M,2G-:128M
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: Upgraded to natty on 2011-03-12 (49 days ago)
dmi.bios.date: 10/23/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 2.10
dmi.board.name: MPAD-MSAE Customer Reference Boards
dmi.board.vendor: Intel Corporation
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr2.10:bd10/23/2006:svnTOSHIBA:pnEquiumA100:pvrPSAABE-00J008EN:rvnIntelCorporation:rnMPAD-MSAECustomerReferenceBoards:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: Equium A100
dmi.product.version: PSAABE-00J008EN
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.10.2-0ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Dave Gilbert (ubuntu-treblig) wrote :
bugbot (bugbot) on 2011-05-02
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) wrote :

Please collect a full backtrace on this crash - see http://wiki.ubuntu.com/X/Backtracing for guidance.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Robert Hooker (sarvatt) wrote :
description: updated
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Looks similar to bug #525066 but I wasn't able to trigger this using vnc.

Steps to reproduce this crash would be very helpful. I have some theories why it's crashing but would need to tinker with it locally to figure it out.

Bryce Harrington (bryce) wrote :

Alternatively, try launching Xorg on the server with strace and collect the last hundred lines of output. That might give some clues.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

Possible dupes: #771169, #775724

Ken H. (open-candu) wrote :

This appears to be the same thing that happens to me constantly when I browse http://www.tsn.ca/.

Ken H. (open-candu) wrote :

Oh, and I have a Radeon Xpress 200M

Bryce Harrington (bryce) wrote :

@Ken, Hmm, that website works for me on rv770 without crashing X, but I only poked at it for a minute or so. How much time does it seem to take you from landing on the page to the crash? Does it occur on the main page (which I note has lots of flash), or after navigating to sub-pages? Any particular page that crashes more often than the others?

I note this url has lots of flash on it, as mentioned in the original report.

Anything else unusual about your system beyond stock, that could help us replicate the crash?

Geoff (geoffch) wrote :

I am having the same trouble with an i915. My system is stock everything (upgraded from maverick to natty) except running the PAE kernel and the "ubuntu classic" gdm session. A freeze sometimes occurs within about five minutes of booting up and logging in, but doesn't happen at all if the session survives longer than that, as it usually does. I don't use Firefox, so it's not caused only by that. A freeze can happen randomly even when just popping up any menu. Then it restarts the session using tty8 and doesn't crash again. Here's a trace from the log file:

[ 907.242] Backtrace:
[ 907.242] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80eab1b]
[ 907.243] 1: /usr/bin/X (0x8048000+0x5fac8) [0x80a7ac8]
[ 907.243] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb76f440c]
[ 907.243] 3: /usr/bin/X (_CallCallbacks+0x3e) [0x8074e1e]
[ 907.243] 4: /usr/bin/X (WriteToClient+0x267) [0x80a7607]
[ 907.243] 5: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x62) [0xb72a6bf2]
[ 907.243] 6: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x75) [0xb72a4fc5]
[ 907.243] 7: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7243000+0x226bc) [0xb72656bc]
[ 907.243] 8: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7243000+0x87d2) [0xb724b7d2]
[ 907.243] 9: /lib/i386-linux-gnu/libdrm.so.2 (drmHandleEvent+0xf5) [0xb7294665]
[ 907.243] 10: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7243000+0x7937) [0xb724a937]
[ 907.243] 11: /usr/bin/X (WakeupHandler+0x52) [0x8074602]
[ 907.243] 12: /usr/bin/X (WaitForSomething+0x1ba) [0x80a1f3a]
[ 907.243] 13: /usr/bin/X (0x8048000+0x27f1e) [0x806ff1e]
[ 907.243] 14: /usr/bin/X (0x8048000+0x1a81c) [0x806281c]
[ 907.243] 15: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0xb740fe37]
[ 907.243] 16: /usr/bin/X (0x8048000+0x1a411) [0x8062411]
[ 907.243] Segmentation fault at address 0xb45e9008
[ 907.243] Caught signal 11 (Segmentation fault). Server aborting

stianst (stianst) wrote :

This happens to me as well. Didn't happen at all the first few days, but has suddenly started happening all the time. Every 15-30 mins. Not sure if it's relevant but I've had no other program besides Chromium running when it's happened.

I've got a fresh install of Ubuntu 11.04 on a Dell XPS (Intel Core i5)

Attached my Xorg log

Bryce Harrington (bryce) wrote :

@Geoff, stianst, thanks but actually the Xorg.0.log backtraces are too terse to be of any use here. What I think we need is to run X with strace and collect the output of that, to see the sequence of calls leading up to the failure.

Albert Damen (albrt) wrote :

I have tried running X under strace, but no success. I couldn't reproduce the crash, probably because X became too slow. Log file when calibre was running was 5 GB.

I also tried xtrace and valgrind without luck. xtrace only showed what calibre was doing. Valgrind shows errors, but only before and right after login. Also, with valgrind I couldn't reproduce the crash, as X was very slow again.

Then I enabled additional debugging in X by defining DEBUG_COMMUNICATION (in os/io.c). I added the requestbuffer address, request name and event name to the debugging output.
The attached log looks interesting to me. Right before the crash we see the same requestbuffer is used by 2 different clients:

[ 11518.727] REQUEST: ClientIDX: 6, type: 0x89 data: 0xa len: 8 buffer: 0x7f3071065010 name: DRI2
[ 11518.729] REQUEST: ClientIDX: 32, type: 0x35 data: 0x18 len: 4 buffer: 0x7f3071065010 name: CreatePixmap
[ 11518.746] REPLY: ClientIDX: 6 buffer: 0x7f3071065010 Xreply: type: 0x1 data: 0xff len: 0 seq#: 0x1802
[ 11518.747] Segmentation fault at address 0x7f3071065010

(clientidx 32 is calibre, clientidx 6 is most likely compiz)

As RecordAReply uses the requestbuffer to find the details of the DRI2 request, this looks very suspicious to me.

Ken H. (open-candu) wrote :

@Bryce Sorry to take so long to get back to you. It almost never happens when I first hit the site, but while I'm navigating. The time it takes varies. I was just on it today and no crash, but sometimes it crashes right away. If I remember correctly (but I'm not 100% sure), it never crashes after launch FF a second time.

The system is very stock. I've added a few things from Medibuntu, but as this is my girlfriends machine, I don't even have any extensions installed on FF.

Ken

Dave Gilbert (ubuntu-treblig) wrote :

Bryce: My problem is I can't trigger this on demand; it happens once in a while.

The machine was originally installed years ago and has been upgraded through alpha's and beta's too natty; it's running Unity
single headed on the laptops intel LCD. It mostly just runs pidgin watching irc and a terminal or two, and synergyc gluing it's keyboard to my other machine. I have a firefox that sits there and gets the occasional link I click on in irc, and it does seem to be related to firefox when it crashes. The firefox is in a separate workspace to the right of the one I'm in most of the time (I run 3x3 workspace).
The page it failed last time on was http://www.bmreports.com/bsp/bsp_home.htm although that's happy at the moment.

Dave

John Lewis (jlewis-johnlewis) wrote :

I tried to get a full backtrace with gdb, It doesn't look right. Perhaps someone might be able to tell me what I've missed? I did follow the instructions on debugging Xorg, apport didn't put anything in /var/crash so that's why I used gdb from another machine instead.

I've not done a backtrace before.

Lauro (lanhezini) wrote :

This bug also affects me; it usually happens randomly. The times it has happened they were when I was using Google Chrome browsing any kind of website. I think it should affect Firefox or orther applications too.

Albert Damen (albrt) wrote :

I have tracked down the crash a bit further, by adding debug prints when input buffers are freed.

[ 18735.941] REQUEST: ClientIDX: 6, type: 0x89 data: 0xa len: 8 buffer: 0x7fba90fa8010 name: DRI2
[ 18735.943] Add buffer to FreeInputs, aci: 0x2e7d8c0 buffer: 0x7fba90fa8010
[ 18735.943] REQUEST: ClientIDX: 32, type: 0x35 data: 0x18 len: 4 buffer: 0x7fba90fa8010 name: CreatePixmap
[ 18735.943] REQUEST: ClientIDX: 32, type: 0x37 data: 0x7 len: 4 buffer: 0x7fba90fa8020 name: CreateGC
[ 18735.943] Reallocating to make buffer bigger, oci->buffer: 0x7fba90fa8010
** Here the requestbuffer used by the compiz DRI2WaitMSC request gets freed
[ 18735.943] REQUEST: ClientIDX: 32, type: 0x48 data: 0x2 len: 23670 buffer: 0x7fba92a5d010 name: PutImage
[ 18735.944] Reallocating to free up space, oci->buffer: 0x7fba92a5d010
[ 18735.960] REPLY: ClientIDX: 6 buffer: 0x7fba90fa8010 Xreply: type: 0x1 data: 0xff len: 0 seq#: 0x17aa
** here we get the use after free segfault
[ 18867.362] Segmentation fault at address 0x7fba90fa8010

idx 6 is compiz, idx 32 is calibre

In maverick I didn't see the RecordAReply calls at all. It turns out these are enabled by xserver-xorg-input-synaptics in natty. After removing xxi-synaptics I no longer see the RecordAReply calls and the crash does not happen anymore.

Geoff (geoffch) wrote :

Several days passed for me with no crash, until another just now. I can't keep running strace for days at a time, due to the huge volume of output, so all I have to share is another traceback. This time the crash occurred upon the completion of a flash video displayed within Opera. I suppose that's consistent with the above comment about crashes while freeing buffers.

[ 2803.236] Backtrace:
[ 2803.236] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80eab1b]
[ 2803.236] 1: /usr/bin/X (0x8048000+0x5fac8) [0x80a7ac8]
[ 2803.237] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb77f340c]
[ 2803.237] 3: /usr/bin/X (_CallCallbacks+0x3e) [0x8074e1e]
[ 2803.237] 4: /usr/bin/X (WriteToClient+0x267) [0x80a7607]
[ 2803.237] 5: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x62) [0xb73a5bf2]
[ 2803.237] 6: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x75) [0xb73a3fc5]
[ 2803.237] 7: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7342000+0x226bc) [0xb73646bc]
[ 2803.237] 8: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7342000+0x87d2) [0xb734a7d2]
[ 2803.237] 9: /lib/i386-linux-gnu/libdrm.so.2 (drmHandleEvent+0xf5) [0xb7393665]
[ 2803.237] 10: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb7342000+0x7937) [0xb7349937]
[ 2803.237] 11: /usr/bin/X (WakeupHandler+0x52) [0x8074602]
[ 2803.237] 12: /usr/bin/X (WaitForSomething+0x1ba) [0x80a1f3a]
[ 2803.237] 13: /usr/bin/X (0x8048000+0x27f1e) [0x806ff1e]
[ 2803.237] 14: /usr/bin/X (0x8048000+0x1a81c) [0x806281c]
[ 2803.237] 15: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0xb750ee37]
[ 2803.237] 16: /usr/bin/X (0x8048000+0x1a411) [0x8062411]
[ 2803.237] Segmentation fault at address 0xbccb350
[ 2803.237] Caught signal 11 (Segmentation fault). Server aborting

stianst (stianst) wrote :

Don't know why, but I haven't seen this problem for a while now. Haven't done anything except for there's been a few updates for 11.04.

Marcelo Fernandez (fernandezm) wrote :

@Albert, I uninstalled the xserver-xorg-input-synaptics package and I still see the "record" extension being loaded in the /var/log/Xorg.0.log file....

Could you post some way to prevent that extension being loaded and test if X still crashes?

Regards

Albert Damen (albrt) wrote :

Marcelo, the record extension will still be loaded indeed. However, without synaptics the extension is not activated.
You can check this by attaching gdb to Xorg (from a second pc) and setting a breakpoint on RecordAReply. If the breakpoint is hit, record is active.
With synaptics installed (on a pc with a touchpad, so synaptics is actually used) you will see the breakpoint is hit, without synaptics it is not hit.

Btw, my current fix/workaround is to build synaptics without record support, by dropping the libxtst-dev build-dependency. This way the touchpad is working properly and X does not crash.

Sergio (sergio-otero) wrote :

I don't have the knowledge to know if it's the same bug, but i've got a way to reproduce a similar crash which generates this backtrace:

[ 14986.199] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a2626]
[ 14986.199] 1: /usr/bin/X (0x400000+0x6219a) [0x46219a]
[ 14986.199] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f53699ac000+0xfc60) [0x7f53699bbc60]
[ 14986.199] 3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f5366af4000+0x20373) [0x7f5366b14373]
[ 14986.199] 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f5366af4000+0x21777) [0x7f5366b15777]
[ 14986.199] 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f5366af4000+0x2b0e5) [0x7f5366b1f0e5]
[ 14986.199] 6: /usr/bin/X (0x400000+0xdc1b5) [0x4dc1b5]
[ 14986.199] 7: /usr/bin/X (0x400000+0xd5638) [0x4d5638]
[ 14986.199] 8: /usr/bin/X (0x400000+0x2e2a9) [0x42e2a9]
[ 14986.200] 9: /usr/bin/X (0x400000+0x21a7e) [0x421a7e]
[ 14986.200] 10: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xff) [0x7f53688f5eff]
[ 14986.200] 11: /usr/bin/X (0x400000+0x21629) [0x421629]
[ 14986.200] Segmentation fault at address 0x18
[ 14986.200]
Caught signal 11 (Segmentation fault). Server aborting
[ 14986.200]

Steps to reproduce:
 * Install wine 1.2.2 from Software Center
 * Download this minified js that consist in a very large line of javascript: http://bellard.org/jslinux/cpux86.js
 * Second button on the js file -> Open with Notepad
 * Scroll down to the end of the file with mouse or keyboard => CRASH

If you cannot reproduce the bug with these steps or need more info, please tell me.

Besides the bug, 2 things:
 * I opened the file with Notepad because opening with gedit was very slow on opening and moving. Maybe i should file another bug
 * The js is from an amazing Javascript PC Emulator available at http://bellard.org/jslinux. It runs a Linux inside Javascript !!

Cybah (jon-cybus) wrote :

Another "me too". Sorry, I only have the segfaults that were recorded in my Xorg logs; 3 of them in short succession. My 945GM laptop has been suffering from unpredictable hangs ever since upgrading to 11.04 (32-bit), which might be related. The 3 segfaults all happened within a very short period of each other and I haven't been able to reproduce them subsequently. I dropped back to the old kernel (2.6.35-22-generic) after the 2nd one and the same thing happened.

I note that Bryce said the Xorg logged backtraces aren't of any use. However, as well as the daily lockup incidents and the short burst of 3 segfaults, I also see occasional rendering artefacts when using gedit. Could all these be related? The system was very stable before the upgrade.

The most repeatable thing I could try to debug is the lockups. Can anyone tell me how to do that? I'm almost as frustrated as with the old Ubuntu 9.04 Intel problems; but not quite yet!

Robert Hooker (sarvatt) on 2011-05-23
affects: xserver-xorg-video-intel (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Triaged
Robert Hooker (sarvatt) wrote :

I have uploaded a fixed xserver-xorg-input-synaptics here, please test it out and let me know your results with it. It will take a few hours to build because launchpad is backed up.

https://launchpad.net/~sarvatt/+archive/sru3

Robert Hooker (sarvatt) wrote :

Also, disabling the "Disable touchpad while typing" option in the touchpad tab of the mouse preferences should avoid it for future reference, that is where syndaemon is getting started from.

tags: added: patch
Steven (steven3000) wrote :

I just got another crash with option "Disable touchpad while typing" disabled.
They both happened while typing in a terminal.

Attaching Xorg.log

Steven (steven3000) wrote :

Sorry for the previous comment it seems that my bug it's exactly this one:

https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/529230
which in turn is a duplicate of
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/532047
which is marked as fixed.

Sorry for beeing OT but should I reopen that one?

Dmitry Savin (envelsavinds) wrote :

I don't know what exactly causes the bug but I installed your package yesterday and used computer in the same manner as I used when catched the bug and there were no crashes. I hope it is fixed.

Robert Hooker (sarvatt) on 2011-05-24
summary: - xserver seg'd [945GM]
+ xserver crashes in _CallCallbacks when XRecord is enabled in syndaemon
summary: - xserver crashes in _CallCallbacks when XRecord is enabled in syndaemon
+ xserver crashes in RecordAReply when XRecord is enabled in syndaemon
Geoff (geoffch) wrote :

I have been having these crashes several times each week until now, and I had two crashes already today. The Xorg log trace is identical each time to the one that I posted above. Now I have installed Robert's ppa version of xserver-xorg-input-synaptics, so we'll see if that fixes the problem. If it goes a week from today without further crashes, I will consider the problem solved. Otherwise, I'll let you know right away.

Ivan Frederiks (idfred) wrote :

@Robert Hooker
Just got your xserver-xorg-input-synaptics package from xorg-edgers ppa.
My standard test sequence (see #780358) isn't causing crash anymore. Thank you!

Ivan Frederiks (idfred) wrote :

Oh shi... Enhanced test sequence caused crash again.

Ivan Frederiks (idfred) wrote :

Got same crash already twice during this morning.

Ivan Frederiks (idfred) on 2011-05-27
tags: added: i386
tags: removed: compiz-0.9 i386 running-unity
tags: added: i386
erm67 (erm67) wrote :

librecord.so is an Xorg extension, I had the same problem but after disabling the record extension it disappeared:

In /etc/X11/xorg.conf.d/10-modules.conf I added:

Section "Module"
             Disable "record"
EndSection

Avery (docaltmed) wrote :

errg. This bug is a real bear when I've just finished entering notes into a patient's chart. It seems to be totally random, though, I cannot connect the crash to any distinct user behavior.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.3.99+git20110116.0e27ce3a-0ubuntu14

---------------
xserver-xorg-input-synaptics (1.3.99+git20110116.0e27ce3a-0ubuntu14) oneiric; urgency=low

  * Drop libxtst-dev build dependency so syndaemon does not use XRecord,
    preventing a wide range of crashes in _CallCallbacks. (LP: #774978)
 -- Robert Hooker <email address hidden> Mon, 23 May 2011 10:13:09 -0400

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Triaged → Fix Released

Accepted xserver-xorg-input-synaptics into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-input-synaptics (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Bryce Harrington (bryce) on 2011-06-08
description: updated
Bryce Harrington (bryce) wrote :
Download full text (3.3 KiB)

I root-caused this bug to figure out what exactly went wrong here, also to help understand the ramifications of dropping xrecord.

Back in October last year, bug #598834 was filed in Debian[1] requesting that libxtst-dev be added as a dependency to xserver-xorg-input-synaptics, to enable syndaemon's -R option to work. The man page documents this option as:

  Use the XRecord extension for detecting keyboard activity instead of polling the keyboard state.

XRecord has kind of a mixed history and I even recall an X.org conference where it was considered to drop it[2] since it's not been too well maintained. Likely it's a bit buggy. But not a big deal; we didn't use -R for syndaemon in Ubuntu, but this would make the functionality available to anyone wishing to opt in to use it for testing or whatever. We didn't even take note of the new option.

But then one day, someone noticed that syndaemon was eating precious battery power due to polling and noticed it had this -R option which promised to make it stop doing it. Polling is bad. And so it was that on April 5th, gnome-settings-daemon opted to start calling syndaemon with the -R flag when people have the "Disable touchpad while typing" option flipped on.

Bug #754470[3] was filed shortly thereafter, on April 8th. It seemed that people were suddenly seeing syndaemon consuming 100% CPU either right after boot or some various point during use. Gah! Us X guys got a spate of these reports around this time, which was quite troubling because it was so near to release and (as far as we knew) we hadn't made any changes to X that would have caused this!

Chase Douglas was quite a hero and jumped right on the problem. He had been doing a lot of X development work for touch devices which had involved a number of uploads to -synaptics, and so he was both familiar with the code and perhaps worried his changes might have caused the problem people were seeing. He figured out that XRecord wasn't able to process all the different types of events that it was experiencing, and so would leave some events on the stack and get stuck in a loop trying to reprocess them. He added a patch that would work around this problem by just draining those unrecognized events. The CPU issue was solved. But everyone knew this was just papering over whatever the underlying problem was. His fix was uploaded 04-16.

Bug #771655[4] was filed on 4/26 suggesting a regression occurred starting around apr 20th. This bug #774978[5] was filed on 5/1. Quickly we started seeing a deluge of dupe bug reports about this X crash. (Check it: dozens of dupes and 37 affected; plus 28 on #760695, 15 on #776654, 22 on #780358, and 80! on #778490.)

On 5/23 Sarvatt figured out that disabling record made the problem go away. I'd really like to know how he had this brainstorm, and wish we'd pumped the fix out sooner after that point. Sarvatt kicks ass, we need to listen to him better. Anyway, subsequent testers on this bug confirm his findings, and here we are now today.

1: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598834
2: http://xorg.freedesktop.org/wiki/Events/XDC2008/Notes
3: https://bugs.launchpad.net/ubuntu/+source/...

Read more...

Bryce Harrington (bryce) on 2011-06-08
description: updated
Ondrej Certik (ondrej-certik) wrote :

Thanks Bryce for this wonderful explanation. I was wondering what the real problem is. Now it's quite clear I think.

Ivan Frederiks (idfred) wrote :

I repeat, it seems that bug is not fixed. Xorg log with backtrace is attached.

xserver-xorg-input-synaptics:
  Installed: 1.3.99+git20110116.0e27ce3a-0ubuntu12.1
  Candidate: 1.3.99+git20110116.0e27ce3a-0ubuntu12.1
  Version table:
 *** 1.3.99+git20110116.0e27ce3a-0ubuntu12.1 0
        100 /var/lib/dpkg/status
     1.3.99+git20110116.0e27ce3a-0ubuntu12.1~lp774978 0
        500 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/ natty/main i386 Packages
     1.3.99+git20110116.0e27ce3a-0ubuntu12 0
        500 http://de.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Ivan Frederiks (idfred) wrote :

@erm67
I tried your method (disabling record module in xorg.conf) but all I got was

[ 1394.228] (WW) "record" will not be loaded unless you've specified it to be loaded elsewhere.
...
[ 1394.228] (II) "record" will be loaded even though the default is to disable it.

Bryce Harrington (bryce) wrote :

@IFred, dude, you have xorg-edgers installed. And I can't tell whether or not the crash you experienced is the same as this bug:

Backtrace:
[ 811.942] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80b188b]
[ 811.942] 1: /usr/bin/X (0x8048000+0x65828) [0x80ad828]
[ 811.942] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x81140c]
[ 811.943] 3: /usr/bin/X (ProcessWorkQueue+0x30) [0x8063da0]
[ 811.943] 4: /usr/bin/X (WaitForSomething+0x60) [0x80a65c0]
[ 811.943] 5: /usr/bin/X (0x8048000+0x4dcce) [0x8095cce]
[ 811.943] 6: /usr/bin/X (0x8048000+0x1a81c) [0x806281c]
[ 811.943] 7: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0x353e37]
[ 811.943] 8: /usr/bin/X (0x8048000+0x1a411) [0x8062411]
[ 811.943] Segmentation fault at address (nil)

Your system is hardly stock. I don't think your findings are at all relevant to this bug.

Bryce Harrington (bryce) wrote :

@IFred, well maybe relevant. Near as I can tell you do have the fixed version installed. But having xorg-edgers installed confuses me.

Would be nice to get this confirmed as unfixed from someone not running xorg-edgers.

Bryce Harrington (bryce) wrote :

@IFred, also please provide a full backtrace. The Xorg.0.log backtraces are nigh-useless in situations like this since they tend to not include symbols and calling parameters and such.

Ivan Frederiks (idfred) wrote :

@Bryce Harrington
ppa-purge in progress

> provide a full backtrace
But how?

Hi Bruce/all, first of all thank you for the hard work. I can try to reproduce having the fix installed, but I haven't found a reliable way to.

@iFred, I saw your method involved running git citool from the Recovery console session. "git citool" doesn't do anything for me but complain "citool is not a command". Should I need to install something else above git?

Ivan Frederiks (idfred) wrote :

@Bryce Harrington
I purged xorg-edgers ppa.

xserver-xorg-input-synaptics:
  Installed: 1.3.99+git20110116.0e27ce3a-0ubuntu12
  Candidate: 1.3.99+git20110116.0e27ce3a-0ubuntu12
  Version table:
 *** 1.3.99+git20110116.0e27ce3a-0ubuntu12 0
        500 http://de.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Bug remains at it's place, simple test sequence with git citool in "Recovery Console" leads to crash.

@Eric Germán Burgueño
You need git-gui package.

Ivan Frederiks (idfred) wrote :

xserver-xorg-input-synaptics:
  Installed: 1.3.99+git20110116.0e27ce3a-0ubuntu12.1
  Candidate: 1.3.99+git20110116.0e27ce3a-0ubuntu12.1
  Version table:
 *** 1.3.99+git20110116.0e27ce3a-0ubuntu12.1 0
        500 http://de.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1.3.99+git20110116.0e27ce3a-0ubuntu12 0
        500 http://de.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

Bug remains at it's place.

Changed in xserver-xorg-input-synaptics (Ubuntu Natty):
status: Fix Committed → Confirmed
Ivan Frederiks (idfred) wrote :

I also tried to rename /usr/lib/xorg/modules/extensions/librecord.so to force xserver not to load this module.
Log says that module was not loaded, but bug is still present.

Maciej Rumianowski (rumianom) wrote :

No crashes with a patch. The way I could reproduce the bug is described in dupe #778490 comment 106

Carsten Agger (agger) wrote :

  596.564]
Backtrace:
[ 596.564] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80eab2b]
[ 596.564] 1: /usr/bin/X (0x8048000+0x5fad8) [0x80a7ad8]
[ 596.564] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb77b240c]
[ 596.564] 3: /usr/bin/X (_CallCallbacks+0x3e) [0x8074e1e]
[ 596.564] 4: /usr/bin/X (WriteToClient+0x267) [0x80a7617]
[ 596.564] 5: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x62) [0xb735fbf2]
[ 596.564] 6: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x75) [0xb735dfc5]
[ 596.565] 7: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb72f7000+0x226bc) [0xb73196bc]
[ 596.565] 8: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb72f7000+0x87d2) [0xb72ff7d2]
[ 596.565] 9: /lib/i386-linux-gnu/libdrm.so.2 (drmHandleEvent+0xf5) [0xb7348665]
[ 596.565] 10: /usr/lib/xorg/modules/drivers/intel_drv.so (0xb72f7000+0x7937) [0xb72fe937]
[ 596.565] 11: /usr/bin/X (WakeupHandler+0x52) [0x8074602]
[ 596.565] 12: /usr/bin/X (WaitForSomething+0x1ba) [0x80a1f4a]
[ 596.565] 13: /usr/bin/X (0x8048000+0x27f1e) [0x806ff1e]
[ 596.565] 14: /usr/bin/X (0x8048000+0x1a81c) [0x806281c]
[ 596.565] 15: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xe7) [0xb74c8e37]
[ 596.565] 16: /usr/bin/X (0x8048000+0x1a411) [0x8062411]
[ 596.565] Segmentation fault at address 0xb593c008
[ 596.565]
Caught signal 11 (Segmentation fault). Server aborting
[ 596.565]
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
[ 596.565] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 596.565]
[ 596.616] (II) Power Button: Close
[ 596.616] (II) UnloadModule: "evdev"
[ 596.616] (II) Unloading evdev
[ 596.676] (II) Video Bus: Close
[ 596.676] (II) UnloadModule: "evdev"
[ 596.676] (II) Unloading evdev
[ 596.676] (II) Sleep Button: Close
[ 596.676] (II) UnloadModule: "evdev"
[ 596.676] (II) Unloading evdev
[ 596.676] (II) Logitech Optical USB Mouse: Close
[ 596.676] (II) UnloadModule: "evdev"
[ 596.676] (II) Unloading evdev
[ 596.677] (II) CNF7017: Close
[ 596.677] (II) UnloadModule: "evdev"
[ 596.677] (II) Unloading evdev
[ 596.677] (II) AT Translated Set 2 keyboard: Close
[ 596.677] (II) UnloadModule: "evdev"
[ 596.677] (II) Unloading evdev
[ 596.677] (II) PS/2 Mouse: Close
[ 596.677] (II) UnloadModule: "evdev"
[ 596.677] (II) Unloading evdev
[ 596.680] (II) UnloadModule: "synaptics"
[ 596.681] (II) Unloading synaptics
[ 596.681] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 596.742] ddxSigGiveUp: Closing log

Just got this crash again, as reported in #780358. Is this still guaranteed to be the same problem, i.e. the Xrecord thing? The backtraces are not completely identical.

Bryce Harrington (bryce) wrote :

Directions on gathering full traces are here:

  http://wiki.ubuntu.com/X/Backtracing

From what I've seen, the easy Apport approach doesn't seem to work with this class of crash for some odd reason, so you'll probably need to use the gdb method. Install debug symbol packages for the xserver, intel driver, and libdrm2 as a minimum.

If you have this same crash, you should see a line with librecord.so towards the top of the stack. You should also see a CallCallbacks entry and possibly an entry for libpthread.so. If you don't see librecord.so at all, then you almost certainly have some unrelated crash, particularly if you have the 12.1 -synaptics installed, restarted X, and it still crashed.

Aside from the 12.1 package, there are also several workarounds which seem effective in preventing the crash:
  a. Turn off the "Disable touchpad while typing" option in the mouse settings gui
  b. Uninstall xserver-xorg-input-synaptics
  c. Rename the /usr/lib/xorg/modules/extensions/librecord.so to prevent the module from even loading

iFred, re-reviewing all the information you've provided, and especially the fact that you tried renaming librecord.so, I think you have some other unrelated crash bug. Please file a new bug report via 'ubuntu-bug xorg', and collect a full backtrace and attach to that bug report.

All X crash bugs basically have exactly the same symptoms - you're suddenly dropped back to the login screen, and some crude backtrace is listed in your Xorg.0.log. But those Xorg.0.log crash dumps are generally fairly worthless; sometimes it is enough to spot dupe bugs, but often (like in these cases) there can be some ambiguity. So it's unfortunately quite easy to confuse one person's crash with another (I even get them confused.) Full backtraces are needed to be absolutely sure. These provide exactly which line numbers and functions in each file were involved, and usually even shows the values of different variables. Often with the full traces a skilled eye can spot the flaw right off the bat. The Xorg.0.log crash dumps don't have any of this information.

Ivan Frederiks (idfred) wrote :

@Bryce Harrington
Thank you! I did as you suggested and understood, that my bug is not related to RecordAReply.
#794895 is now open for my case.

Oier Mees (oier) wrote :

I am attaching my gdb trace but the problem is that I could't get gdb to perform a backtrace beacuse it says "no stack". Any ideas?

Program received signal SIGSEGV, Segmentation fault.
RecordAReply (pcbl=0x7f2680, nulldata=<value optimized out>,
    calldata=0x7fff4678ada0) at ../../record/record.c:613
613 ../../record/record.c: No such file or directory.
 in ../../record/record.c
(gdb)
Continuing.

Program exited with code 01.
(gdb) backtrace
No stack.
(gdb) backtrace full
No stack.

Spartako (pablo-contact) wrote :

Hi, please find attached my gdb backtrace.
 It seems to be the same as for Oier Mees.

Rifester (rife-mark) wrote :

I can confirm this bug on two different computers with 11.04/Unity installed. Several times a day I am returned to GDM while opening Firefox or a bookmark. This does not happen at all while logged into Xubuntu desktop, only Unity.

Spartako (pablo-contact) wrote :

OK, by uninstalling xserver-xorg-input-synaptics I'm not able to reproduce it anymore.
I hope I can start working again without losing all the stuff!!
thanks everyone

I have not had a crash since I installed xserver-xorg-input-synaptics 1.3.99+git20110116.0e27ce3a-0ubuntu12.1 almost a week ago. I have been running Unity with plenty of effects and chromium, which used to make it crash. People that are still having crashes after installing the proposed update must have a different bug than I did. Thanks so much to the dev team that figured this nasty bug out.

I can confirm this error. This is bugging me since i installed natty. My X crashes while loading Pages with Flash-Content. First i thought it might be firefox but its happening in opera too. I will now try to uninstall xserver-xorg-input-synaptics.

After installing the xserver-xorg-input-synaptics 1.3.99+git20110116.0e27ce3a-0ubuntu12.1 package, at first everything seemed to work fine but after a while of browsing my X crashed again.

Martin Pitt (pitti) wrote :

William, thanks for testing!

Changed in xserver-xorg-input-synaptics (Ubuntu Natty):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Sebastian, so it seems to be at least helping a bit?

tags: added: verification-done
removed: verification-needed

I dont know if u can call it "helping"....i will try surfing around again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-input-synaptics - 1.3.99+git20110116.0e27ce3a-0ubuntu12.1

---------------
xserver-xorg-input-synaptics (1.3.99+git20110116.0e27ce3a-0ubuntu12.1) natty-proposed; urgency=low

  * Drop libxtst-dev build dependency so syndaemon does not use XRecord,
    preventing a wide range of crashes in _CallCallbacks. (LP: #774978)
 -- Robert Hooker <email address hidden> Mon, 23 May 2011 10:13:09 -0400

Changed in xserver-xorg-input-synaptics (Ubuntu Natty):
status: Fix Committed → Fix Released
teachop (teachop) wrote :

Is this fixed for everybody else... I have xserver-xorg-input-synaptics - 1.3.99+git20110116.0e27ce3a-0ubuntu12.1 and it is not fixed, crashes most every day at least once.

sysnoo (sysnoo) wrote :

Yep
Since that update, I have no crash.

Alex (a-t-page) wrote :

Still crashes for me.

Phuah Yee Keat (ykphuah) wrote :

I realize that it have been crashing if I use a combination of workrave (I assume this uses the record extension) and calibre together.

I have stopped using workrave and there hasn't been any crashes since.

Hannes Beyer (hannesbeyer) wrote :

Initially I had crashes like twice a day. After deleting the content of my entire home, it happened only once in two days. Since I installed the patch more than a week ago there was no single crash! Thanks for this fix.

Rifester (rife-mark) wrote :

xserver-xorg-input-synaptics update fixed the issue for me! Thank you very much for your work.

Dave Gilbert (ubuntu-treblig) wrote :

Bug 803610 looks like an adverse reaction to this fix.

Dave

Bob E (trurl9) wrote :
Download full text (9.8 KiB)

My laptop has:
xserver-xorg-input-synaptics 1.3.99+git20110116.0e27ce3a-0ubuntu12.1

Laptop randomly crashes X several times a day. Most recently I was typing a Libre Office document, the screen went black for a moment, then I was presented with the opportunity to login again.

11.04 is by far the buggiest and most displeasing experience I've had with Ubuntu. Up until Natty Ubuntu had worked so well for me that I hadn't spent much time troubleshooting. I don't know how to troubleshoot effectively since there seem to be many technical issues that are beyond my capabilities to resolve quickly.

1) My laptop is an Dell Precision M60
2) Video card is Quadro FX Go700 and Natty doesn't seem to like it very much
3) Doesn't run 3D Unity and I don't know if video card is capable of running Unity or not

Would've been nice if the Natty install said, "Dude, your system blows chunks. It isn't going to run Natty well so I'm going to quit before I brick your laptop." I've installed Natty cleanly twice but each install becomes an experience in frustration. No clear resolution what the problem is our how to resolve it.

When I reboot the laptop I see all sorts of white background and malformed text before the system gets to a login screen. Sometimes I don't get to the login screen and the system hangs with white screen and black malformed text. Here's output from the xorg log file.

Why is the nvidia kernel module found sometimes and other times not?

X.Org X Server 1.10.1
Release Date: 2011-04-15
[ 24.955] X Protocol Version 11, Revision 0
[ 24.955] Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
[ 24.955] Current Operating System: Linux book 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686
[ 24.955] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=1a90eb39-8d73-4637-8c48-cc130be25f72 ro quiet splash vt.handoff=7
[ 24.955] Build Date: 21 May 2011 11:38:35AM
[ 24.955] xorg-server 2:1.10.1-1ubuntu1.1 (For technical support please see http://www.ubuntu.com/support)
[ 24.955] Current version of pixman: 0.20.2
[ 24.955] Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
[ 24.955] Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 24.955] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 13 07:05:00 2011
[ 24.955] (==) Using config file: "/etc/X11/xorg.conf"
[ 24.955] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 24.955] (==) No Layout section. Using the first Screen section.
[ 24.955] (**) |-->Screen "Default Screen" (0)
[ 24.955] (**) | |-->Monitor "<default monitor>"
[ 24.956] (==) No device specified for screen "Default Screen".
 Using the first device section listed.
[ 24.956] (**) | |-->Device "Default Device"
[ 24.956] (==) No monitor specified for screen "Default Screen".
 Using a default monitor configuration.
[ 24.956] (==) Automatically adding devices
[ 24.956] (==) Automatically enabling devices
[ 24.956] (WW) The director...

Read more...

@Robert Ehelebe

I am sorry to hear that you are having such a hard time with Ubuntu. Since the XRecord bug has been fixed, your crashes must be related to a different bug. If you need help with your graphics drivers please post on ubuntuforums.org.

Kojo Gambrah (kgambrah) wrote :

@Robert Ehelebe

I had an issue which seemed to be related to the one described here but wasn't resolved by the fix here so I tried a couple of things that resolved the problem the problem for me;

1. re-installed all xorg packages
2. clean out gnome/x11/xsession files in home directory (I had made some changes to workaround some other bugs in the past)
3. removed all /etc/x11/xorg.conf* files (moved them actually)

Lucas R. (lucas02-ml) wrote :
Download full text (15.9 KiB)

Hello,
since I have updated my notebook to Ubuntu 11.04 (few days ago), I have noticed some problems like: in a certain period of time the section restarts automatically with no reason. When the section doesn't restart automatically, it gets “frozen” and it only stays normal again after a “forceboot” please, understand that a “forceboot” is that one in which I hold down the power button more than 3 seconds. And the most interesting thing I have ever seen was while playing a game that demands the usage of the X-Window, the scream changed its color into green and some letters appeared vertically producing something like the “Matrix” effects. It also happens while using Classic Ubuntu or Classic Ubuntu (with no effects).
Please, note that I reinstalled Ubuntu 10.04 LTS and I didn't notice none of these problems again.

Thank you very much.

My notebook is an:
Intelbras i221
Intel Celeron Dual Core
2 GB RAM
160 GB HD

Another important information: (please remember that I typed it from my Ubuntu 10.04 LTS, otherwise I couldn't complete to post, because the section would restart before I finish it) =/

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
 Subsystem: Elitegroup Computer Systems Device 903d
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
 Latency: 0
 Capabilities: <access denied>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp
00: 86 80 00 2a 06 01 90 20 03 00 00 06 00 00 00 00
10: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 19 10 3d 90
30: 00 00 00 00 e0 00 00 00 00 00 00 00 00 00 00 00

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
 Subsystem: Elitegroup Computer Systems Device 903d
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 28
 Region 0: Memory at f0000000 (64-bit, non-prefetchable) [size=1M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 1800 [size=8]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915
00: 86 80 02 2a 07 04 90 00 03 00 00 03 00 00 80 00
10: 04 00 00 f0 00 00 00 00 0c 00 00 d0 00 00 00 00
20: 01 18 00 00 00 00 00 00 00 00 00 00 19 10 3d 90
30: 00 00 00 00 90 00 00 00 00 00 00 00 05 01 00 00

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
 Subsystem: Elitegroup Computer Systems Device 903d
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Region 0: Memory at f0100000 (64-bit, non-prefetchable) [size=1M]
 Capabilities: <access denied>
00: 86 80 03 2a 07 00 90 00 03 00...

Mihir Mone (monemihir) wrote :

Encountered this problem today ...

Was working on a VMware Win 7 virtual machine when suddenly gdm logged me out. Was installing SQL Server 2008 R2 and lost the whole install since it killed VMware :(

Base system configs -
Ubuntu 11.04 x64
Kernel - 2.6.38-10-generic
CPU - Intel(R) Xeon(R) CPU E31245 @ 3.30GHz
Memory - 15.7GB

Virtual system configs -
Windows 7 Professional with SP1
Memory - 2GB

Relevant Syslog entries -
Jul 27 12:55:34 swati gdm-simple-greeter[20127]: Gtk-WARNING: /build/buildd/gtk+2.0-2.24.4/gtk/gtkwidget.c:5687: widget not within a GtkWindow
Jul 27 12:55:35 swati gdm-simple-greeter[20127]: WARNING: Unable to load CK history: no seat-id found
Jul 27 12:55:35 swati rtkit-daemon[1551]: Successfully made thread 20146 of process 20139 (n/a) owned by '106' RT at priority 5.
Jul 27 12:55:35 swati rtkit-daemon[1551]: Supervising 2 threads of 1 processes of 1 users.
Jul 27 12:55:35 swati rtkit-daemon[1551]: Successfully made thread 20147 of process 20139 (n/a) owned by '106' RT at priority 5.
Jul 27 12:55:35 swati rtkit-daemon[1551]: Supervising 3 threads of 1 processes of 1 users.
Jul 27 12:55:35 swati rtkit-daemon[1551]: Successfully made thread 20148 of process 20139 (n/a) owned by '106' RT at priority 5.
Jul 27 12:55:35 swati rtkit-daemon[1551]: Supervising 4 threads of 1 processes of 1 users.
Jul 27 12:55:35 swati init: tty1 main process ended, respawning
Jul 27 12:55:38 swati gdm-session-worker[20129]: GLib-GObject-CRITICAL: g_value_get_boolean: assertion `G_VALUE_HOLDS_BOOLEAN (value)' failed

There is only that one gdm-session-worker error that I can see in the syslog entries.

Hope that dump helps in resolving this issue.

Regards,
Mihir

Kimmo Satta (ksatta79) wrote :

I'm still getting this is in Xubuntu 11.04 with an older IBM NetVista comp.

I have:
Package: xserver-xorg-input-synaptics
Version: 1.3.99+git20110116.0e27ce3a-0ubuntu12.1

Shouldn't that include this fix? Maybe I'm having another problem then if this fix is already installed on my system.

Teo (teo1978) wrote :

I have Ubuntu 10.10 and I've just observed this issue a few minutes ago (for the first time in my life).

I read this has been fixed, and my update manager automatically gets all updates, so what do I have to do to get the fix? I thought all critical bugfixes would always be automagically installed through automatic updates as they became available...

jadi (jadijadi) wrote :

I still have this! ubuntu 11.10 fully updated. Thinkpag X220.

having this problem on ubuntu 11.10. Is there any way we could get a package that supports oneiric?

anyway we could get this fix for oneiric?

Retrokid (eatmywords) wrote :

I removed xserver-xorg-input-synaptics but still seem to be encountering the same problem described here.

Jules (julestex) wrote :

Hello,
I'm on Ubuntu 11.10. I'm fully updated but I still have this bug. It can happen many time in a row. Sometimes it is impossible to work.

I can send some logs if needed.

Dave Gilbert (ubuntu-treblig) wrote :

Jadi, Christian, Retrokid, Jules,
   Are you sure it's the same bug? Only a few random X crashes fit into this bug, It's only the same bug if the backtrace (in /var/log/Xorg.0.log.old after X restarts) ends in something like:

[ 15223.014] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f8335203000+0xfc60) [0x7f8335212c60]
[ 15223.014] 3: /usr/lib/xorg/modules/extensions/librecord.so (0x7f8332bb8000+0x2920) [0x7f8332bba920]

in the backtrace (not the librecord, normally with libpthread near to it).

If your backtrace doesn't include that, or if you're not sure please install the xdiagnose package and then just file a separate bug by running in a terminal:

ubuntu-bug xorg

when you log back in after an X crash.

If you are seeing those in the backtrace then please include your /var/log/Xorg.0.log.old showing the problem on this report.

Jules (julestex) wrote :

Ok I did what you said and it seems to be an other bug. I opened a new one : https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/940761

Thanks for your time.

Emerald214 (emerald-hieu) wrote :

I still have the same problem on Ubuntu 11.10. What's the solution for this f**king annoying boring long-lasting bug?

I also have this problem - and I agree it is very annoying.

FWIW - I also installed a utility to disable my touchpad when the mouse is plugged in. Could this be triggering the issue?

Nekhelesh Ramananthan (nik90) wrote :

I am having this issue with Ubuntu 12.04 as well. Although it started only a few days ago.

mrsirrisrm (m-keane) wrote :

Disabling the Record extension seems to have stopped the crashes for me (on 11.10), however Workrave currently requires Record to work. Are any other people on here using Workrave?

ispaniko1984 (fabio-bocconi) wrote :

I can repruduce this as follows:

1.Open totem or VLC.
2.Open Video File.

When it crashes, I get back lightdm login.

I'm on Ubuntu 12.04, with ubuntu restricted extras and the last amd proprietary Driver ( I can't install from jockey-gtk driver because it crash).
I have a Mobility Radeon HD 4200 Series..and i can't switch from Cpu to Cpu.

Jules (julestex) wrote :

Hello,
I used to have this bug at least 5times/day.
I was ready to do anything (virgin sacrifice at midnight, voodoo incantations, praying for Bill Gates,...).
So when Warren say something about the touchpad-indicator i tried to uninstall it. Just to see...
3 days later... no session crash. For me it "solved" the problem.

I'll post an update if i have the bug again.

varacanero (varacanero) wrote :

I had this nasty bug for weeks, getting crazy. After i read comment #89 I disabled Workrave and the problem is gone ! Wow !

It still is a workaround, because i would like to use workrave again. So i'm interested in getting a fix, but i am more patient right now...

http://www.workrave.org/

@varacanero

Probably you already know it but ... there is also a typing break built into gnome - go to System -> Preferences -> Keyboard and then select the "Typing Break" tab and tick the box. Of course, it is very simple comparing to the workrave.

Taylor Raack (track16) wrote :

I also use Workrave, and I'm experiencing this bug on 11.10. Pretty much the same symptoms as above.

mrsirrisrm (m-keane) wrote :

A recent update to Workrave (possibly 1.9.908?) has fixed this and I've had no further crashes (on 11.10) since the update. I don't think it has made it into the main repo yet, as I am installing from Rob Caelers ppa. So people having issues due to Workrave could try installing the ppa version from ppa:rob-caelers/workrave and see if that helps.

varacanero (varacanero) wrote :

I am using workrave 1.9.909-ppa1~oneiric1 from the ppa mentioned in #95, and didn't have a crash for approx. one week. So for me: Solved ! Thanks !

For me, it's still not solved. Ubuntu 12.04 (up-to-date) logged me out when I tried to intall something in Software Center.

Dr. Tyrell (dr.tyrell) wrote :

It has been happening to me for approx 1 month.
This ALWAYS AND ONLY happens to me when I CLOSE A BROWSER TAB , 99% of the time it's google chromium, and once or twice for firefox.
x86_64, intel graphics, ivy bridge, samsung laptop, wifi, pulse, and that silly "rtkit" realtime daemon.
xorg-edgers,
any recent kernel.... vmlinuz-3.2.0-25-generic or one I rolled vmlinuz-3.6.0-rc3

Nemes Ioan Sorin (nemes-sorin) wrote :

hi there,
we are in 2016 and the bug is still here
got this bug with Chrome, Firefox closing tabs ( in Mint 17.3 ), even with Font Manager
I use a Radeon hd 5570 graphic card - 4gb RAM - Intel Quad Core Duo cpu.

on another machine running on 60bit architecture using the same desktop configuration (but i7 cpu) I can't replicate this bug - can be this problem related only for 32bit architecture ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.