[Hardy][Regression] Touchpad vertical scroll does not work

Bug #173411 reported by Aaron Whitehouse on 2007-12-02
200
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
xorg (Ubuntu)
Critical
Timo Aaltonen
Hardy
Critical
Timo Aaltonen

Bug Description

Binary package hint: xserver-xorg-input-synaptics

After upgrading my Dell Inspiron 510m to Hardy Alpha 1, dragging my finger up and down the right-hand-side of my touchpad does not vertical scroll.

This worked in all releases from Dapper to Gutsy (see https://wiki.ubuntu.com/LaptopTestingTeam/DellInspiron510m )

I will attach my xorg.conf - let me know if you need anything else from me.

Related branches

Same problem here with a fresh install Hardy Alpha 1,vertical scroll does not work.
Laptop is a Thinkpad T43.
I'll attach the necessary information from https://wiki.ubuntu.com/DebuggingTouchpadDetection

Henrik Brink (henrikbrink) wrote :

After installation of Hardy Test 1, my touchpad stopped working for scrolling and dragging.

Laptop is Lenovo 3000 V100, so maybe the laptop name should be removed from the bug subject.

What files or output do you need?

armin (armin-hartmann) wrote :

see also Bug 173814: https://bugs.launchpad.net/bugs/173814

no xorg.conf created at installation, i.e. no touchpad configuration created?

Henrik Brink (henrikbrink) wrote :

I dont have an xorg.conf either, but as they also talk about in the other bug, it should work nonetheless. And it doesn't seem they actually solve the problem?

Strange you dont have a xorg.conf,here is mine from the Alpha 1

armin (armin-hartmann) wrote :

Johan, do you have a touchpad and does it work? In your xorg.conf I don't see an entry for a touchpad.

armin,

Yes I have a touchpad,only vertical scroll and dragging does not work.
The touchpad worked fine under Gutsy.

Timo Aaltonen (tjaalton) wrote :

This is known, since the xserver-xorg postinst phase no longer generates a section for synaptics. We will be using input hotplug for synaptics as well, so this will be fixed later in hardy.

Changed in xserver-xorg-input-synaptics:
importance: Undecided → Medium
status: New → Confirmed
armin (armin-hartmann) wrote :

Timo,

is there a way to fix my touchpad in the interim? Would make my life a lot easier and I would be able to stick with Hardy and help with the testing.

Thanks,
Armin

Timo Aaltonen (tjaalton) wrote :

try adding

Section "InputDevice"
        Identifier "Synaptics Touchpad"
        Driver "synaptics"
        Option "SendCoreEvents" "true"
        Option "Device" "/dev/psaux"
        Option "Protocol" "auto-dev"
        Option "HorizEdgeScroll" "0"
EndSection

to your xorg.conf. That's what was used by default before.

armin (armin-hartmann) wrote :

There are a few things required to make the xorg.conf work, which I figured out the hard way:

- Needs section "Module" with synaptics module to be loaded
- Needs SHMConfig set to "true" (not sure if "on" works) so that gsynaptics will start
- Needs ServerLayout section

I attached my new and improved xorg.conf as a guideline. I'd like to caution everyone trying this that I had to fix my xorg.conf several times in textmode (do you remember vi?) because my laptop wouldn't boot into graphical mode. Of course the easiest way is to keep a backup of the xorg.conf handy which has worked before so you don't have to dabble in vi.

I'm surprised it is actually working now...see attached:

Timo, adding that section does not fix the problem.

I have added it to the end of my xorg.conf, restarted the computer and
the vertical scroll still does not work.

I also have this issue on the second gen, C2D macbook. Since the upgrade (fresh install, 8.04 alpha 1) I have lost all but motion capability of the touchpad. scrolling, right and middle click are gone, which did work ootb in 7.10.

armin (armin-hartmann) wrote :

Again, I managed to fix my touchpad manually (please see my last post). All it takes are a few modifications to your xorg.conf, which you can model after mine (attached to previous post). Also, I installed gsynaptics to adjust sensitivity, etc.

I have no trouble with my touchpad if I re-create my old gutsy xorg.conf.
but since the new hardy X 7.3 doesnt need one, without it no one will be able to use the scrolls until some other way is found to store that info.

Eric Appleman (erappleman) wrote :

armin's method works. I get vertical scroll and everything.

One caveat. If you use it in tandem with a usb mouse, you can't use the mouse to open the men bar on top. this can be rectified by binding the windows/super key to the menu or clicking with the touchpad. strangely enough, the usb mouse can click within the menu once it is open.

Attached is my working xorg.conf

Eric Appleman (erappleman) wrote :

I take that back. Armin's method is incomplete. The touchpad will work flawlessly but the USB mouse will detect all left clicks as double clicks and will not detect any right clicks.

Eric Appleman (erappleman) wrote :

Here's the solution.

It works perfectly for me with zero ill effects. I based it off the xorg.conf a Gutsy Live CD session creates.

SHMConfig is included.

Eric Appleman (erappleman) wrote :

Also, restarting X after making these changes is not enough. You have to restart the system.

hmc8 (hmc8) wrote :

I can confirm this bug on my Acer Extensa 5220 Notebook!

JoshuaKersey (goodtimetribe) wrote :

I experience this bug on my Inspiron 1520. I haven't tried updating my xorg.conf cuz I'm only testing from liveCD for right now.

JoshuaKersey (goodtimetribe) wrote :

It doesn't occur when testing it in VirtualBox on the same system with the same .iso

JoshuaKersey (goodtimetribe) wrote :

Xorg created an xorg.conf.1 file for me, and I was just editing that file, assuming that since xorg created it, it would be smart enough to find it... obviously not. I had to rename it back to xorg.conf and then the armin's fix worked for me... however i noticed someone else labeled it "Modules" when it should be singular, "Module".

thanks for the solution at least.

Martin Pitt (pitti) wrote :

I confirm that the current Hardy CDs do not configure a stanza for synaptics. Thus scolling doesn't work, and you cannot disable tap-to-click in the gnome mouse prefs.

jtlb (jt-lb) wrote :

i confirm this bug. It has worked a short time in root session with the vesa driver but i did not keep the xorg.conf file nor the logs, sorry.

lizardmenke (lizardmenke) wrote :

I can confirm this bug, no vertical scrolling. (hardy alpha-3 live-cd session)
After adding:
Section "InputDevice"
        Identifier "Synaptics Touchpad"
        Driver "synaptics"
        Option "SendCoreEvents" "true"
        Option "Device" "/dev/psaux"
        Option "Protocol" "auto-dev"
        Option "HorizEdgeScroll" "0"
EndSection

in xorg.conf and restarting X it still does not work.
will attach original xorg.conf

Timo Aaltonen (tjaalton) wrote :

No need to confirm anymore, it's a well known and deliberate regression for now.

Changed in dell:
importance: Undecided → Medium
status: New → Confirmed
Harvey Muller (hlmuller) wrote :

Duplicate bug 177373: [hardy alpha 1 amd64] touchpad not detected / configured during install.

Seems to no longer be an issue in alpha 4. Pleasantly surprised to find it not necessary to add a synaptics section. Able to deselect tap-to-click.

Nicolò Chieffo (yelo3) wrote :

are you ableto scroll? if so, please attach your xorg.conf

I installed hardy alpha3 but now on my fully up-to-date box I'm still not
able to disable tap to click or enable scroll.

My xorg.conf is still the same that was generated during the installation,
though.

Aymeric (mulx) wrote :

I can scroll with my touchpad
I am on Hardy upgraded from Gutsy
I have include my xorg.conf
I have an Acer Aspire 9412z

Sander Jonkers (jonkers) wrote :

I have the same problem (touchpad scroll not working, results in right-mouse-click behaviour) on my Fujitsu Siemens Lifebook E8110. Installed 8.04 Alpha 4 Hardy Heron i386.

Everything worked pefect out-of-the-box with gutsy.

Copying gutsy's xorg.conf over hardy's xorg.conf 'solves' the problem. Both xorg.conf-files included.

ubuntu@ubuntu:/etc/X11$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
ubuntu@ubuntu:/etc/X11$

ubuntu@ubuntu:/etc/X11$ ls -al xo*
-rw-r--r-- 1 root root 2671 2008-02-03 21:39 xorg.conf
-rw-r--r-- 1 root root 0 2008-02-03 22:12 xorg.conf.20080203221205
-rw-r--r-- 1 root root 2671 2008-02-03 21:38 xorg.conf.gutsy.touchpad-scroll-ok
-rw-r--r-- 1 root root 1077 2008-02-03 21:36 xorg.conf.hardy-alpha4.no-touchpad-scroll
ubuntu@ubuntu:/etc/X11$

Sander Jonkers (jonkers) wrote :

And here gutsy's xorg.conf that makes my touchpad scroll button work on hardy Alpha 4.

The point is that hardy ships an xorg.conf that is quite empty, maybe
touchpad recognition is not implemented yet

Bryce Harrington (bryce) on 2008-02-21
Changed in xorg:
importance: Medium → Critical
milestone: none → ubuntu-8.04-beta
Timo Aaltonen (tjaalton) on 2008-02-26
Changed in xorg:
assignee: nobody → tjaalton
status: Confirmed → In Progress
Changed in xorg:
status: In Progress → Fix Released
Changed in dell:
status: Confirmed → Fix Released
unggnu (unggnu) on 2008-02-28
Changed in linux:
status: New → Invalid
21 comments hidden view all 101 comments

Hello, I can confirm that this bug still exists on my laptop with all Hardy updates until now and the dpkg reconfiguration.

_________________________________________________________________
Nieuw: Windows Live Messenger 2008! Gratis downloaden
http://get.live.com/messenger

der_vegi (m-may) wrote :

Well, I just did a fresh install of Alpha 5 (amd64) these days. At the beginning, scrolling did not work. But now, it has been working for 2 or 3 days, I did not change my xorg.conf manually or by running some reconfiguration, just did a normal update.

Alex Mauer (hawke) wrote :

I can confirm that the dpkg-reconfigure worked on my system with the new package.

Michelle Glorioso (gloriml) wrote :

On an Averatec 2370, a fresh install of Hardy Alpha 5 gaveme no vertical scroll. A generic xorg.conf update fixed this upon restart.

I confirm that my scroll is now working!
it took a while be its back again.

mattia (tiam87) wrote :

my scroll not works..i m using mac book and my xorg.conf is :

can confirm this, i just installed alpha 5 and it's still there. Laptop is hp compaq 8510, it worked with gutsy out of the box.

But it worked after doing this: 'sudo dpkg-reconfigure -phigh xserver-xorg

I can confirm it worked after sudo dpkg-reconfigure -phigh xserver-xorg, but my my Nvidia-card was messed then unfortunately (no Desktop-Effekts, no bling ), I'm looking forward to seeing both working! Thanks for the efforts!

2 comments hidden view all 101 comments
Ricky Campbell (cyberdork33) wrote :

you generated a new xorg.conf which replaced your driver line that specified the nvidia driver, you just need to add it back.

works for me too. Thanks for solving this !

~$ uname -a
Linux rhino 2.6.24-12-generic #1 SMP Mon Mar 10 15:32:00 UTC 2008 i686 GNU/Linux

It was working and it aint, again.

Is it necessary to do dpkg-reconfigure every time we get a new kernel?!

Changed in xorg:
status: Fix Released → New
benste (benste) wrote :

worked after rebuilding Xconfig - but it was not fixed in Alpha 6

benste (benste) wrote :

BUT !! Don't work again after "gksudo nvidia-xconfig"

benste (benste) wrote :

and when I use Restricted driver module to activate it, it's all fine (3d driver + touchpad)
I'm sorry, but I don't now how to edit a post.

Timo Aaltonen (tjaalton) wrote :

This bug is fixed. Note that the proprietary config tools don't know anything about synaptics, so don't expect them to preserve the changes.

If you still have issues with a recent livecd, open a new bug.

Changed in xorg:
status: New → Fix Released
benste (benste) wrote :

why did they now in Gutsy???

Noel J. Bergman (noeljb) wrote :

> Note that the proprietary config tools don't know anything about
> synaptics, so don't expect them to preserve the changes.

While technically accurate, few if any tools that edit xorg.conf are good at not stomping on the others, regardless of their form of licensing and availability of code.

Noel J. Bergman (noeljb) wrote :

> nvidia-xconfig (and aticonfig) should probably be dropped
> because they only mess things up

So the solution to having multiple devices needing to be configured in a shared file, the root cause of the problem, is to strip out necessary configuration for one device in order to support another?

Please note that the video configuration tools provided by the vendors include support for features not supported by jockey, et al.

The better solution would be to fracture xorg.conf, rather than have a single conflated file as we do today.

Max Randor (max-randor) wrote :

I have this problem in the Hardy beta on 29/3/2008.
With all the latest updates I still have no vertical scroll, left or right click or point or tap (the touchpad does not work at all)
'sudo dpkg-reconfigure -phigh xserver-xorg' Did not fix this problem it is still happening.

uname -a
Linux DANIELTHOMAS 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

Max Randor (max-randor) wrote :
Timo Aaltonen (tjaalton) wrote :

Max (or anyone else reading this and still having problems): please file a new bug. The reason why it doesn't work for you is different.

Max Randor (max-randor) wrote :

Well I fixed the problem, I followed armin's advice and modified my xorg.conf and then rebooted, It still was not working so I opened gsynaptics which now works and ticked the enable touchpad box. Now my touchpad works again :-)
Thank You armin!

etapia (etapia72) wrote :

 I have a Dell Inspiron 6400 and I got touchpad + scroll working using this configuration.

Section "InputDevice"
    Identifier "Mouse0"
    Driver "synaptics"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    Option "SHMConfig" "true"
EndSection

benste (benste) wrote :

This bug is only for third paty software isn't it?
normally touchpad with dpkg --reconfigure -ph (...) xorg
worked fine only a replacement of the driver to an nvidia driver (not with restriceted modules mangaer) - destroyed this config

Ricky Campbell (cyberdork33) wrote :

no, this was a bug in earlier versions of Hardy. I thought it was resolved though.

Timo Aaltonen (tjaalton) wrote :

Proprietary config tools (nvidia-settings etc) don't know about synaptics at all, so don't use them unless you know the implications.

benste (benste) wrote :

Synaptics is copied into the xorg also when using nvidia-settings, but you must use restricted manager to activate it. When you you another driver or envy ... than nvidia settings builds it's own xorg with missing touchpad section - maybe someone should report it in the nvidia forum

The xorg.conf at http://launchpadlibrarian.net/12368586/xorg.conf and attached to this bug is problematic for the following reason:
The last section is incomplete.

5 comments hidden view all 101 comments
Atanas Atanasov (thenasko) wrote :

I have a similar problem on a Dell Inspiron 1721 running the most recent Inrepid. The tapping and vertical scrolling on the touchpad are not working. I am attaching my xorg.conf. Any ideas?

Changed in somerville:
importance: Undecided → Medium
status: New → Fix Released
no longer affects: dell

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306075

no longer affects: somerville
Displaying first 40 and last 40 comments. View all 101 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers