software-center crashed with signal 5 with WebKit 2.0+

Bug #1163886 reported by Dennj Osele on 2013-04-03
This bug affects 463 people
Affects Status Importance Assigned to Milestone
WebKit
Fix Released
Medium
software-center (Ubuntu)
Critical
Unassigned
webkitgtk (Ubuntu)
Critical
Unassigned

Bug Description

software center crashes when I open it.

=== Steps to reproduce: (from xnox) ===

1) Download Ubuntu Desktop 13.10 i386 release (disk id 20131016.1), download links at
http://iso.qa.ubuntu.com/qatracker/milestones/305/builds/55929/downloads

2) Using Virtual Machine Manager - set a VM to have little RAM, e.g. 798 MB, boot from the above iso.

3) Click try ubuntu

4) Enable repositories:
- edit /etc/apt/sources.list to add universe component
- Enable gnome3 ppa:
sudo add-apt-repository ppa:gnome3-team/gnome3

4) update & dist-upgrade

5) Click on Ubuntu Software Centre icon from the launcher

It will appear to be loading, the UI will be fully rendered, but the full-width banner, which is white. The window goes gray, and disappears. There is a crash file generated for software-center in /var/crash/.

===

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: software-center 5.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
CrashCounter: 1
Date: Wed Apr 3 14:15:24 2013
Disassembly: => 0x7f104ac4f2c5: Cannot access memory at address 0x7f104ac4f2c5
ExecutablePath: /usr/share/software-center/software-center
InstallationDate: Installed on 2012-10-23 (161 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
Signal: 5
SourcePackage: software-center
Stacktrace:
 #0 0x00007f104ac4f2c5 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0x7fff92459230
StacktraceTop: ?? ()
ThreadStacktrace:
 .
 Thread 11 (LWP 16319):
 #0 0x00007f104c563ca4 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0x7f1017021e40
Title: software-center crashed with signal 5
UpgradeStatus: Upgraded to raring on 2013-04-01 (1 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Dennj Osele (dennj-osele) wrote :
information type: Private → Public
Jeremy Bicha (jbicha) wrote :

$ software-center
2013-04-10 23:18:18,940 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-04-10 23:18:28,376 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.Geoclue.Error.notAvailable: Geoclue master client has no usable Address providers'
2013-04-10 23:18:34,867 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-04-10 23:18:35,649 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-04-10 23:18:35,649 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-04-10 23:18:35,965 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-04-10 23:18:50,758 - softwarecenter.db.utils - INFO - software-center-agent finished with status 0

(software-center:30966): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2144 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

summary: - software-center crashed with signal 5
+ software-center crashed with signal 5 with the GNOME3 PPA on 13.04

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-04-11
Changed in software-center (Ubuntu):
importance: Undecided → Medium
CSRedRat (csredrat) wrote :

Affected. How to roll away GNOME to 3.6?

n0yd (d-harkleroad) wrote :

It is not "fix" per se. But I have found a workaround, if you need to use software-center rather than just using terminal tools like dpkg and apt, which is what I do. Also, I use gdebi for GUI based installing of packages I download with my browser, as it is much more slim than the Ubuntu Software Center.

Anyway, the fix/workaround to get it to load for tyhe time being is to just give it elevated privleges. So like this: "sudo software-center" without quotes in the terminal, and it will launch that for you

Rodney Dawes (dobey) wrote :

This looks like an issue caused by one of the updates in the GNOME 3 PPA. Does this occur without the packages from the PPA? Does this still occur today?

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Jeremy Bicha (jbicha) wrote :

Software Center is no longer crashing here with the GNOME3 PPA and all updates applied. Is anyone else still having Software Center crash when it starts?

fab (fab-head) wrote :

Yes, software Center is still crashing here.
I have applied all the updates from the GNOME 3 PPA.

software Center is still crashing

Peter Dezsi (dezsip88) wrote :

Same here, I'm using ubuntu 13.04 with with gnome 3.8

Angeloribas (angeloribas) wrote :

Software Center is still crashing here, even with all updates from GNOME 2 PPA.
Ubuntu 13.04 with with gnome 3.8

harontas (harontasgh) wrote :

same here just installed ubuntu gnome 13.04 with only gnome ppa (not staging) did updates and software center crushes.hope you solve it soon!thanks for your hard efforts!

Goyo (goyodiaz) on 2013-05-01
Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Peshko R. (peshko-us) wrote :

I guess no need to say that it still crashes...just installed 13.04 with Gnome 3.8. I did NOT install the gnome staging

Ditto the above, also n0yd's suggestion to run the software centre with elevated privileges still produced a crash.

Stacktrace:
 #0 0x00007f104ac4f2c5 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0x7fff92459230
StacktraceTop: ?? ()
ThreadStacktrace:
 .
 Thread 11 (LWP 16319):
 #0 0x00007f104c563ca4 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0x7f1017021e40

Changed in software-center (Ubuntu):
status: Confirmed → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

package libwebp2 does not exist, ignoring

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace

can this report help? i run software-center from terminal and this is the output

2013-05-09 22:28:34,457 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-05-09 22:28:35,058 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Geoclue.Master was not provided by any .service files'
2013-05-09 22:28:35,313 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-05-09 22:28:35,315 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-05-09 22:28:35,320 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-05-09 22:28:35,320 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-05-09 22:28:35,376 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

(software-center:10716): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2185 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Παγίδα Trace/breakpoint (core dumped)

Angeloribas (angeloribas) wrote :

I get exactly the same output as described in post #17 (except for the word "Παγίδα" which I believe was introduced by mistake before "Trace/breakpoint" in the last line).

I'm currently not able to install any third-party software (.deb) which is not accessible from the repositories via terminal or I'm able to use Synaptic Package Manager, as the software-center is crashing all the time. Tried also Gnome-Packagekit, but albeit it works for installing software from the repositories, it also fails to install third-party .deb packages.

Sinde I've upgraded to Gnome 3.8 via Gnome3-Team PPA (not staging) I've had to fire software-center twice in order to use it (it used to crash once and then start normally on the second try, albeit some graphic problems related to the list of software categories for browsing). However, for since a couple of days ago, software-center is crashing all the time, totally unusable.

I would like to help, but I'm not experienced enough to do the debugging recommended by the terminal output described on post #17, that is:

   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

harontas (harontasgh) wrote :

The word παγιδα is trap.its because my setup is in Greek .Anyways even though gnome 3.8 is still not officially supported in ubuntu 13.04 i hope this bug and many other tha come (totem glich on full screen , adobe flash plalyer crach etc) will be fixed.Man i dont know about others but 3.8 is an awsome job for me and i cant wait use it.keep up the good work and bring open source to many people!

Same problem here... Experiencing same output as described in post 17. I also use gnome shell 3.8.1 installed through gnome3 ppa.
When I do "software-center --version" in terminal to check a version, it shows

(software-center:6420): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1584:16: 'border-style' is not a valid color name
software-center 5.6.0

What is the reason behind this message? Can other people see this message?

Garonenur (dwillrodt) wrote :

same error messages with the BadDraw error in the end. sudo does not work around this for me.

harontas (harontasgh) wrote :

i suppose until next release that probably have gnome 3.8 installed by default no essential assistance would be given!so...patience for now!! :D

Jeremy Bicha (jbicha) wrote :

Re-opening this as a master bug since many people were affected by it.

Changed in software-center (Ubuntu):
status: Invalid → Confirmed
Tim (darkxst) wrote :

I managed to reproduce this on raring with gnome3 ppa.

Crash appears to happen while loading the webkitframes.
Clearing out ~/.cache/software-center/download-cache/ seems to help with reproduction of crash.

Attaching traces

Tim (darkxst) wrote :
Tim (darkxst) wrote :
Brian Visel (eode) wrote :

..anything I can do to help with this? ..it's happening for me, too, with the latest gnome3 ppa updates (non-staging).

Willem Hobers (whobers) wrote :

I get this too.

One of the suggested solutions was to re-install software center.
I tried that, but it was no help.

Please advice.

Tim (darkxst) wrote :

I have tracked this down to what appears to be a race condition triggered by

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/software-center/saucy/view/head:/softwarecenter/ui/gtk3/views/lobbyview.py#L162

It seems that somehow it is trying to render the banner ad before the download has completed. (Once the images are cached locally it is required to clear out the software center cache, to be able to reproduce the crash)

rm ~/.cache/software-center/piston-helper/*
software-center (crashes on startup)
software-center (loads correctly on the second run)

Removing that above line from the code will avoid the crash on startup.

Ari (ari-reads) wrote :

I tried deleting the cache and the configuration, and also removing the software-center package and reinstalling it.
Still fails. Gnome PPA (3.8.2 as of today)

Tim (darkxst) wrote :

deleting the cache helps to reproduce the crash, not fix it!

If you want a work around, comment out the following line from lobbyview.py:

self.exhibit_banner.set_exhibits([FeaturedExhibit()])

Greetings! Just started getting this error. SAME EXACT OUTPUT as listed in Post #17 above this one. Running Ubuntu 13.04 with latest Gnome PPA . Software Center simply will not start. Even if I run it with elevated sudo permissions, as suggested in Post #5, it still crashes, and will not run.

The work around in comment #31, by Tim (darkxst), solved for me! software-center working again...

Ari (ari-reads) wrote :

Thanks Tim - the workaround worked. Thanks!

The work around Tim (darkxst), solved for me!
Thanks Tim

tikend (metodrybar) wrote :

rm ~/.cache/software-center/piston-helper/*

did it for me on one of my computers, will test it later on the other one.

Esteban (tebanep) wrote :

The worked around in comment #31 by Tim work for me too! Thanks a lot!

Brian Visel (eode) wrote :

..latest ppa update for gnome3 worked for me.

yes, latest update for gnome3 worked for me too. software center is working without any problem. Thank you all...!!!

Jarosław Guza (jarekj83-4) wrote :

still not working for me

The workaround provided with comment #31, by Tim (darkxst), solves the problem

Jeremy Bicha (jbicha) wrote :

I'm bumping the importance to High because of the large number of duplicate bugs.

Changed in software-center (Ubuntu):
importance: Medium → High
Angeloribas (angeloribas) wrote :

The workaround provided by Tim (darkxst), in comment #31 solved the problem! software-center working again.
Kudos for Tim!

tikend (metodrybar) wrote :

Maybe I'm just too dumb, but I just don know what I have to do based on the #31 comment. :)

Hi,

using this command in a terminal (open with Ctrl+Alt+T):

gksudo gedit /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py

You have to search and comment the line in the file lobbyview.py that contains the following expression :
(to comment you've to put the character "#" in the begin of the line)

"self.exhibit_banner.set_exhibits([FeaturedExhibit()])"

after comenting that line, just save and close the file, and try to open the software-center - enjoy !!

Mike Powell (mikearpowell) wrote :

Tim's (darkxst) workaround and Herbert's (herbertbruchmann-c) fuller explanation of exactly what to do has worked perfectly for me. Many thanks guys!

Valerio Bozzolan (bozzy) wrote :

The workaround provided by Tim (darkxst), in comment #31 solved the problem.

Stian Liknes (stianlik) wrote :

The workaround in comment #31 fixed the problem for me also.

Rodney Dawes (dobey) wrote :

The commenting of the suggested line makes no sense, looking into the code. It is completely unrelated to the display of images which are downloaded. Even with that line commented, the featured items exhibit images will still be downloaded, and will still be displayed. The FeaturedExhibit() is a simple object, to let the software center display a default featured items image, while none have yet been downloaded, or in the event there are none to display. It does not connect to the network, or depend on any cached images. It points at an image file which is included directly in the software-center package, and which should always exist.

Removing the cache directory as mentioned, also does not induce a crash for me, albeit I am on 13.04 and not using the GNOME 3 PPA. Is there a way to reproduce this crash on 13.04 without the GNOME 3 PPA?

The software-center crash only occurs with Ubuntu 13.04 & GNOME 3.8.x (specifically, after installing gnome-shell and ubuntu-gnome-desktop from the GNOME 3 PPA). I have another computer that has Ubuntu 13.04 & GNOME 3.6.x and on that system, both software-center and ubuntu-tweak do not crash.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Rodney Dawes
Sent: Monday, June 24, 2013 9:54 AM
To: <email address hidden>
Subject: [Bug 1163886] Re: software-center crashed with signal 5 with the GNOME3 PPA on 13.04

The commenting of the suggested line makes no sense, looking into the code. It is completely unrelated to the display of images which are downloaded. Even with that line commented, the featured items exhibit images will still be downloaded, and will still be displayed. The
FeaturedExhibit() is a simple object, to let the software center display a default featured items image, while none have yet been downloaded, or in the event there are none to display. It does not connect to the network, or depend on any cached images. It points at an image file which is included directly in the software-center package, and which should always exist.

Removing the cache directory as mentioned, also does not induce a crash for me, albeit I am on 13.04 and not using the GNOME 3 PPA. Is there a way to reproduce this crash on 13.04 without the GNOME 3 PPA?

--
You received this bug notification because you are subscribed to a duplicate bug report (1189326).
https://bugs.launchpad.net/bugs/1163886

Title:
  software-center crashed with signal 5 with the GNOME3 PPA on 13.04

Status in “software-center” package in Ubuntu:
  Confirmed

Bug description:
  software center crashes when I open it

  ProblemType: Crash
  DistroRelease: Ubuntu 13.04
  Package: software-center 5.6.0-0ubuntu1
  ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
  Uname: Linux 3.8.0-16-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.9.2-0ubuntu5
  Architecture: amd64
  CrashCounter: 1
  Date: Wed Apr 3 14:15:24 2013
  Disassembly: => 0x7f104ac4f2c5: Cannot access memory at address 0x7f104ac4f2c5
  ExecutablePath: /usr/share/software-center/software-center
  InstallationDate: Installed on 2012-10-23 (161 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
  InterpreterPath: /usr/bin/python2.7
  MarkForUpload: True
  PackageArchitecture: all
  ProcCmdline: /usr/bin/python /usr/bin/software-center
  Signal: 5
  SourcePackage: software-center
  Stacktrace:
   #0 0x00007f104ac4f2c5 in ?? ()
   No symbol table info available.
   Cannot access memory at address 0x7fff92459230
  StacktraceTop: ?? ()
  ThreadStacktrace:
   .
   Thread 11 (LWP 16319):
   #0 0x00007f104c563ca4 in ?? ()
   No symbol table info available.
   Cannot access memory at address 0x7f1017021e40
  Title: software-center crashed with signal 5
  UpgradeStatus: Upgraded to raring on 2013-04-01 (1 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1163886/+subscriptions

Many thanks to Tim, the directions in post #31 worked for me!

Najeeb Anwer (najeeb-anwer) wrote :

The workaround suggested by Tim (post #31) works for me too. Now if only someone could suggest a workaround for ubuntu-tweak crashing, I'd be all set...

Jeremy Bicha (jbicha) wrote :

Dobey, I can reproduce this on Saucy…if I install WebKit 2.0 and delete that cache directory.

If you're on Saucy, you can install the latest WebKit from the GNOME3 PPA for Saucy. WebKit is the only thing we've uploaded for Saucy so far.

Jeremy Bicha (jbicha) on 2013-07-09
summary: - software-center crashed with signal 5 with the GNOME3 PPA on 13.04
+ software-center crashed with signal 5 with WebKit 2.0+
Rodney Dawes (dobey) wrote :

Can anyone get a useful full stack trace with debug symbols?

There's still no really useful information in the bug, and the suggested workaround still makes no sense. People removing the cache /may/ have had some corrupt data in the cache, but there is no clear indication of that being so. The cache removal and commenting that one line, are placebos.

No, they are not placebos. Placebos do not work with code, the code
doesn't care whether you believe or not.

I can't vouch for the veracity of the cache clearing -- I did nothing of
the sort. However, commenting that one line made it so that the
software center started.

Brian Visel (eode) wrote :

..and now I can vouch for the veracity of the cache removal. It does indeed reproduce the crash.

If software center is crashing:
 * comment out "self.exhibit_banner.set_exhibits([FeaturedExhibit()])" in lobbyview.py
 * start software center (it runs)
 * stop software center
 * uncomment "self.exhibit_banner.set_exhibits([FeaturedExhibit()])" in lobbyview.py
 * start software center (it runs)
 * stop software center
 * rm ~/.cache/software-center/piston-helper/*
 * start software center (it crashes)

..I'm not sure I did the stack trace correctly. I installed apport-retrace then ran apport-cli and updated the crash report with debug symbols.

Brian Visel (eode) wrote :

..did you see that Tim (darkxst) in comment #29 said he had traced it to a race condition where the image isn't yet available at the time the attempt to display it is made? ..that makes commenting out that line perfectly logical. If you don't attempt to display an image before it is loaded, you don't get a crash.

..I was a little offended by the 'placebo' comment, sorry if I seem a bit snippy.

Brian Visel (eode) wrote :

Bear in mind I am running the Gnome3 PPA, as others generally are in this bug.

Tim (darkxst) wrote :

dobey,
   I attached a stack trace back in comment #29. I was never able to get a useful python stack trace however.

with regards to cache, once the piston-helper data is successfully cached, software-center no longer crashes on startup. As soon as you clear it it will crash again.

I can reproduce the crash about 9/10 times on laptop (wifi) but only maybe 1/3 times on my faster desktop with direct internet connection (using Webkit 2.0).

Tim (darkxst) wrote :

actually comment #26 has the trace.

I don't know if this will help or not, but when I uninstalled gnome 3.8 and took the ppa:gnome3-team/gnome3 off of my sources list, it completely stopped crashing.

Before I uninstalled gnome 3.8, I had tried reinstalling and purging the software center through both apt-get and synaptic.

Once I downgraded back to the original gnome version that came with Ubuntu 13.04, it started working perfectly.

I hope this helps and I hope I am posting in the correct place.

Steve Desert (fux-psaux) wrote :

Open terminal and run software center the following way: software-center --force-rtl
I have gnome 3.8 and it's working for me :)
Try it

Roman Brodylo (roman-brodylo) wrote :

Ever since implementing the workaround from #31 (thanks Tim(darkxst) I've been able to start software center. Nevertheless it crashes often when installing new programs. But it seems to install.
But that just can't be it. If you have to implement workarounds to use very BASIC FUNCTIONS, the system has been rendered virtually useless for everyone except dedicated or specialist or technical folks. And because we're so happy to have found a workaround for our problems, we overlook the fact that the broad userbase must be deserting the Gnome desktop because aforementioned basic functionality isn't working, and ESSENTIAL FUNCTIONS like connectivity via Online Accounts aren't working without at least evil glitches.

Canonical has done a great deal for Linux, but we also shouldn't forget they achieved this by deriving from the very best that was already there: developers, users, Debian(!) ...

I find it very disturbing that Canonical is leaving Gnome in such a dismal state - and it feels a little bit like the arrogant stance of some big proprietary players (bullies): take it or leave it.

Is this the new Bug #1?

Kirill (mgkirs) wrote :

to day, i am send:
apt-get install libwebp2
its write, what install 0 package and 21 package don't upgraded
?????
PROFIT.
software-center work.

LaunchpadAccount (unfo) wrote :

I believe the solution offered by Kirill works for me as well. I haven't had any crashes since. Nothing was upgraded, one package was obsolete and removed.

SadHad (saeed-hadeed) wrote :

solution provided by Tim (darkxst) (#31) worked for me. thanks Tim

Willem Hobers (whobers) wrote :

Just tried the work-around provided by Tim (darkxst) in comment #31). Just installed a programme with the software center and it did nog crash. So, it seems, Tim's work-around is correct. Thanks Tim.

Rodney Dawes (dobey) wrote :

Everyone, if you don't have a new stack trace with debug symbols to add to the bug, please don't comment to say that it affects you or that a supposed workaround makes it usable for you. It is not at all helpful to discovering what is actually causing the bug.

I have tried every mentioned thing in this report which claims to result in a crashing software-center, but am unable to get it to crash. I'm sorry if it is crashing for some of you, but a bug which a developer cannot reproduce locally, or which is not obvious through other means (possibly with a full debugging stack trace, though not guaranteed to be, for example), the bug can't be fixed. If anyone who is seeing the crash, and has sufficient skills to understand the code in question, and has signed the Canonical CLA, can create a patch which does fix the problem, it is likely to be accepted. Attaching a patch which comments out a single line of code, which doesn't do what you think it does, however, is not an acceptable solution.

Tim (darkxst) wrote :

dobey,
  In _HtmlRenderer there is a call:
self.view.set_size_request(-1, ExhibitBanner.MAX_HEIGHT)

In the case where software-center crashes this results in a size request of (1,200). If I manually set the width in this line to >= 835 then the crash does not happen. I am not sure if the webkit view is failing to get the parent width or if the offscreen image has not finished rendering.

fwiw, I can reliably reproduce this on my slowish laptop, but not at all on my faster desktop. I will get you an updated stacktrace in a bit.

Roman Brodylo (roman-brodylo) wrote :

Thanks for your efforts dobey,
but:
workarounds help me getting this stuff to work and that's what it's all about, isn't it?
I am helping as good as I can sending a report EVERY time I experience a crash. If usable information is missing I'm sorry but I'm not the programmer - maybe the trigger to apport needs some rewiring?
I hope that the mere amount of crashes helps in assessing how hard bugs are hitting users and how urgent a fix is needed.

Keep up the good work. Thanks again.

Smot (smot-msn) wrote :

I don't know if the attached file will help - it's a debug log from software-center obtained by running this:
software-center --debug 2>software-center.log

Jade J. Munkey (jade-j-munkey) wrote :

This has only affected me since using gnome 3 desktop.

Jade J. Munkey (jade-j-munkey) wrote :

Kudos to Herbert Junior, his suggestion above has resolved this issue for me.

Eugene (ylamanosau) wrote :

 Herbert Junior, Thanks!

Running Ubuntu Gnome 13.10 Beta with Gnome 3.10 I get this bug.
Workaround from Herbert Junior seems to solve the issue.

Migueltsilva (migueltsilva) wrote :

I confirm that this error appear in a clean install Ubuntu Gnome 13.10 final release.
Workarround works fine. Thanks Herbet.

Vlad (vladimir-gomez) wrote :
Download full text (4.0 KiB)

Also confirm this error is present in Ubuntu Gnome 13.10 final release. I just installed it, updated everything and, sometimes, software-center crashes. Only first time it crashed it offered to send a crash reports; following times it just crashes. This is what I get if run software-center on the prompt and it crashes:

2013-10-21 09:51:12,019 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-10-21 09:51:12,394 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.DBus.GLib.UnmappedError.GeoclueErrorQuark.Code1: Geoclue master client has no usable Address providers'
2013-10-21 09:51:12,558 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-10-21 09:51:12,561 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-10-21 09:51:12,567 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-10-21 09:51:12,567 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-10-21 09:51:12,597 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

(software-center:11780): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2052 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

This is what I get when it does not crashes:

2013-10-21 09:52:51,043 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-10-21 09:52:51,239 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.DBus.GLib.UnmappedError.GeoclueErrorQuark.Code1: Geoclue master client has no usable Address providers'
2013-10-21 09:52:51,416 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-10-21 09:52:51,417 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-10-21 09:52:51,421 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-10-21 09:52:51,420 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-10-21 09:52:51,449 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-10-21 09:52:52,911 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/utils.py', 271, 'get_title_from_html')'
2013-10-21 09:52:52,911 - root - WARNING - failed to parse: '<div style="background-colo...

Read more...

James Ramsay (f-jack) wrote :
Download full text (6.2 KiB)

What I did is went to updates and told it to install prerealease updates it
fixed it after I updated
On Oct 21, 2013 10:11 AM, "Vlad" <email address hidden> wrote:

> Also confirm this error is present in Ubuntu Gnome 13.10 final release.
> I just installed it, updated everything and, sometimes, software-center
> crashes. Only first time it crashed it offered to send a crash reports;
> following times it just crashes. This is what I get if run software-
> center on the prompt and it crashes:
>
> 2013-10-21 09:51:12,019 - softwarecenter.ui.gtk3.app - INFO - setting up
> proxy 'None'
> 2013-10-21 09:51:12,394 - softwarecenter.region - WARNING - failed to use
> geoclue: 'org.freedesktop.DBus.GLib.UnmappedError.GeoclueErrorQuark.Code1:
> Geoclue master client has no usable Address providers'
> 2013-10-21 09:51:12,558 - softwarecenter.backend.reviews - WARNING - Could
> not get usefulness from server, no username in config file
> 2013-10-21 09:51:12,561 - softwarecenter.plugin - INFO - activating plugin
> '<module 'webapps_activation' from
> '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
> 2013-10-21 09:51:12,567 - softwarecenter.fixme - WARNING - logs to the
> root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51,
> 'find_module')'
> 2013-10-21 09:51:12,567 - root - ERROR - Could not find any typelib for
> LaunchpadIntegration
> 2013-10-21 09:51:12,597 - softwarecenter.db.pkginfo_impl.aptcache - INFO -
> aptcache.open()
>
> (software-center:11780): Gdk-ERROR **: The program 'software-center'
> received an X Window System error.
> This probably reflects a bug in the program.
> The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
> (Details: serial 2052 error_code 9 request_code 62 minor_code 0)
> (Note to programmers: normally, X errors are reported asynchronously;
> that is, you will receive the error a while after causing it.
> To debug your program, run it with the GDK_SYNCHRONIZE environment
> variable to change this behavior. You can then get a meaningful
> backtrace from your debugger if you break on the gdk_x_error()
> function.)
> Trace/breakpoint trap (core dumped)
>
> This is what I get when it does not crashes:
>
> 2013-10-21 09:52:51,043 - softwarecenter.ui.gtk3.app - INFO - setting up
> proxy 'None'
> 2013-10-21 09:52:51,239 - softwarecenter.region - WARNING - failed to use
> geoclue: 'org.freedesktop.DBus.GLib.UnmappedError.GeoclueErrorQuark.Code1:
> Geoclue master client has no usable Address providers'
> 2013-10-21 09:52:51,416 - softwarecenter.backend.reviews - WARNING - Could
> not get usefulness from server, no username in config file
> 2013-10-21 09:52:51,417 - softwarecenter.plugin - INFO - activating plugin
> '<module 'webapps_activation' from
> '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
> 2013-10-21 09:52:51,421 - softwarecenter.fixme - WARNING - logs to the
> root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51,
> 'find_module')'
> 2013-10-21 09:52:51,420 - root - ERROR - Could not find any typelib for
> LaunchpadIntegration
> 2013-10-21 09:52:51,449 - softwarecenter.db.pkginfo_impl.aptcache - IN...

Read more...

Dimitri John Ledkov (xnox) wrote :

Steps to reproduce:

1) Download Ubuntu Desktop 13.10 i386 release (disk id 20131016.1), download links at
http://iso.qa.ubuntu.com/qatracker/milestones/305/builds/55929/downloads

2) Using Virtual Machine Manager - set a VM to have little RAM, e.g. 798 MB, boot from the above iso.

3) Click try ubuntu

4) Enable repositories:
- edit /etc/apt/sources.list to add universe component
- Enable gnome3 ppa:
sudo add-apt-repository ppa:gnome3-team/gnome3

4) update & dist-upgrade

5) Click on Ubuntu Software Centre icon from the launcher

It will appear to be loading, the UI will be fully rendered, but the full-width banner, which is white. The window goes gray, and disappears. There is a crash file generated for software-center in /var/crash/.

I can provide remote access to this VM, crash-files, and/or recompile packages with debug symbols as needed.

Adolfo Jayme (fitojb) wrote :

As this is blocking webkit and other updated software (LP: #1186558) from entering the archive, bumping importance as per https://wiki.ubuntu.com/Bugs/Importance.

Changed in software-center (Ubuntu):
importance: High → Critical
description: updated
Adolfo Jayme (fitojb) on 2013-10-26
Changed in software-center:
status: New → Confirmed
Rodney Dawes (dobey) on 2013-10-28
Changed in webkit (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Changed in software-center (Ubuntu):
importance: Critical → Medium
Download full text (33.8 KiB)

The issue has been reported on https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1211887

The bug and duplicates don't have specific steps to reproduce, that's happening with software-center which is a python-webkit user. The webkit version is 1.10.2 but webkit2 updates seem to have similar issues

"#0 0x00007fe1520211f9 in g_logv (log_domain=0x7fe14fd95d46 "Gdk", log_level=G_LOG_LEVEL_ERROR, format=<optimized out>, args=args@entry=0x7fff7b1b15c8) at /build/buildd/glib2.0-2.37.5/./glib/gmessages.c:989
        domain = 0x0
        data = 0x0
        depth = 1
        log_func = 0x7fe152020990 <g_log_default_handler>
        domain_fatal_mask = <optimized out>
        masquerade_fatal = 0
        test_level = <optimized out>
        was_fatal = <optimized out>
        was_recursion = <optimized out>
        msg = 0x4514600 "The program 'software-center' received an X Window System error.\nThis probably reflects a bug in the program.\nThe error was 'BadDrawable (invalid Pixmap or Window parameter)'.\n (Details: serial 3589 "...
        msg_alloc = 0x4514600 "The program 'software-center' received an X Window System error.\nThis probably reflects a bug in the program.\nThe error was 'BadDrawable (invalid Pixmap or Window parameter)'.\n (Details: serial 3589 "...
        i = 2
#1 0x00007fe152021342 in g_log (log_domain=log_domain@entry=0x7fe14fd95d46 "Gdk", log_level=log_level@entry=G_LOG_LEVEL_ERROR, format=format@entry=0x7fe14fda1a08 "%s") at /build/buildd/glib2.0-2.37.5/./glib/gmessages.c:1025
        args = {{gp_offset = 32, fp_offset = 48, overflow_arg_area = 0x7fff7b1b16a0, reg_save_area = 0x7fff7b1b15e0}}
#2 0x00007fe14fd74970 in _gdk_x11_display_error_event (display=display@entry=0x24240c0, error=error@entry=0x7fff7b1b1760) at /build/buildd/gtk+3.0-3.8.2/./gdk/x11/gdkdisplay-x11.c:2556
        buf = "BadDrawable (invalid Pixmap or Window parameter)", '\000' <repeats 15 times>
        msg = <optimized out>
        display_x11 = 0x24240c0
        tmp_list = <optimized out>
        ignore = 0
#3 0x00007fe14fd7f321 in gdk_x_error (xdisplay=0x2416b00, error=0x7fff7b1b1760) at /build/buildd/gtk+3.0-3.8.2/./gdk/x11/gdkmain-x11.c:303
        error_display = 0x24240c0
        manager = <optimized out>
        displays = 0x0
        error = 0x7fff7b1b1760
        xdisplay = 0x2416b00
#4 0x00007fe14f829b9b in _XError (dpy=dpy@entry=0x2416b00, rep=rep@entry=0x43fc520) at ../../src/XlibInt.c:1581
        rtn_val = <optimized out>
        event = {type = 0, xany = {type = 0, serial = 37841664, send_event = 62914834, display = 0xe05, window = 33570313}, xkey = {type = 0, serial = 37841664, send_event = 62914834, display = 0xe05, window = 33570313, root = 140605681420488, subwindow = 0, time = 45003616, x = 806187680, y = 32737, x_root = 678147232, y_root = 32737, state = 37841664, keycode = 0, same_screen = 1408724085}, xbutton = {type = 0, serial = 37841664, send_event = 62914834, display = 0xe05, window = 33570313, root = 140605681420488, subwindow = 0, time = 45003616, x = 806187680, y = 32737, x_root = 678147232, y_root = 32737, state = 37841664, button = 0, same_screen = 1408724085}, xmotion = {type = 0, serial = 37841664, send_e...

Changed in webkit:
importance: Unknown → Medium
status: Unknown → New
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1163886

tags: added: iso-testing
Sasa Paporovic (melchiaros) wrote :

In respect to duplicate

https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/1251814

trusty is also affected.

Adding tag.

tags: added: trusty
Sasa Paporovic (melchiaros) wrote :

In respect to the comments above also adding saucy tag.

tags: added: saucy

Created attachment 218591
stacktrace of the issue, using GDK_SYNCHRONIZE=1

That's a stracktrace collected using GDK_SYNCHRONIZE=1 and b gdk_x_error

(the new stacktace is from webkit 2.3.2 ... those issues started in Ubuntu in 13.10, or we didn't change cairo or webkit that cycle, could it be a GTK issue? (we updated from 3.6 to 3.8 in the cycle where reports started))

Created attachment 218656
Patch

I could not reproduce this with WebKit master and cairo 1.12.16, it looks from the trace like resizing the window should be enough to trigger it, but that is not enough in GtkLauncher/MiniBrowser. Nevertheless, this should fix it.

Changed in webkit:
status: New → Fix Released

Created attachment 218742
new stacktrace of the issue

That's still an issue, could somebody reopen? :/

That's the change tested
https://launchpadlibrarian.net/158610191/webkitgtk_2.3.2-1ubuntu2_2.3.2-1ubuntu3~build1.diff.gz

software-center still hits the Xerror on start, new bt joined, it looks the same

Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in webkit (Ubuntu):
status: Confirmed → Triaged
Changed in software-center (Ubuntu):
importance: Medium → Critical
Changed in webkit (Ubuntu):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in software-center (Ubuntu):
assignee: nobody → Irfan Fauzan (irfan-it2988)
Changed in software-center:
assignee: nobody → Irfan Fauzan (irfan-it2988)

(In reply to comment #7)
> That's still an issue, could somebody reopen? :/

Hey, is this still crashing with webkit 2.4.x? Please confirm and I'll reopen the bug.

tags: removed: saucy
affects: webkit → webkit-open-source
tags: added: testcase
affects: webkit (Ubuntu) → webkitgtk (Ubuntu)
tags: added: metabug
Changed in software-center:
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in software-center (Ubuntu):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in webkitgtk (Ubuntu):
assignee: Irfan Fauzan (irfan-it2988) → nobody
Changed in software-center (Ubuntu):
assignee: nobody → adam thye (adam-adam-johannes)
Changed in software-center (Ubuntu):
assignee: adam thye (adam-adam-johannes) → nobody
Rodney Dawes (dobey) on 2015-12-18
no longer affects: software-center

(In reply to comment #8)
> Hey, is this still crashing with webkit 2.4.x? Please confirm and I'll
> reopen the bug.

I wasn't able to reproduce this bug with WebKit 2.4.11 so I dropped the patch from Ubuntu 16.10 "yakkety" today. We'll let you know if it ends up that the patch was needed after all.

Elias Lattash (eliaslat) wrote :

I'm having a Software Center crash; please see:
https://github.com/awesomeWM/awesome/issues/1828#issuecomment-307533174

Should I create a new issue for it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.