Ubuntu

software-center crashed with signal 5 in _XReadEvents()

Reported by Ken on 2013-08-13
452
This bug affects 55 people
Affects Status Importance Assigned to Milestone
Webkit
Fix Released
Medium
software-center (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
webkit (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
webkitgtk (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

* Impact: software-center hits Xerrors quite often

* Test case:
run software-center, it should be stable (or watch the error buckets on https://errors.ubuntu.com/problem/94f7beb32c9a9172de3f9281691510762d655d47)

* Regression potential:
check that webkit clients are stable (software-center, epiphany-browser, yelp, empathy...)

----------

Everytime I open software centre after about 30 sec. it crashes
Terminal output
kenn@kenn-520-1138cb:~$ software-center
/usr/lib/python2.7/dist-packages/gi/types.py:226: RuntimeWarning: Mixin class softwarecenter.ui.gtk3.widgets.stars.StarRenderer is an old style class, please update this to derive from "object".
  RuntimeWarning)
/usr/lib/python2.7/dist-packages/gi/types.py:226: RuntimeWarning: Mixin class softwarecenter.ui.gtk3.widgets.stars.ShapeStar is an old style class, please update this to derive from "object".
  RuntimeWarning)
2013-08-13 13:18:59,709 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-08-13 13:19:00,402 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-08-13 13:19:00,403 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-08-13 13:19:00,407 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-08-13 13:19:00,407 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-08-13 13:19:00,438 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

(software-center:15225): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 3604 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)
kenn@kenn-520-1138cb:~$

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: software-center 13.08-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-1.4-generic 3.11.0-rc4
Uname: Linux 3.11.0-1-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Tue Aug 13 12:55:55 2013
ExecutablePath: /usr/share/software-center/software-center
InstallationDate: Installed on 2013-07-10 (33 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130709)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: software-center
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReadEvents () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libcairo.so.2
 cairo_surface_flush () from /usr/lib/x86_64-linux-gnu/libcairo.so.2
Title: software-center crashed with signal 5 in _XReadEvents()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Ken (ken3-burtinsky) wrote :

StacktraceTop:
 _cairo_xlib_shm_surface_flush (abstract_surface=0x42535e0, flags=<optimized out>) at /build/buildd/cairo-1.12.14/src/cairo-xlib-surface-shm.c:696
 INT_cairo_surface_flush (surface=0x42535e0) at /build/buildd/cairo-1.12.14/src/cairo-surface.c:1510
 _cairo_xlib_surface_discard_shm (surface=surface@entry=0x59cb8a0) at /build/buildd/cairo-1.12.14/src/cairo-xlib-surface.c:369
 _cairo_xlib_surface_finish (abstract_surface=0x59cb8a0) at /build/buildd/cairo-1.12.14/src/cairo-xlib-surface.c:401
 _cairo_surface_finish (surface=0x59cb8a0) at /build/buildd/cairo-1.12.14/src/cairo-surface.c:1007

Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1211887

tags: added: iso-testing
information type: Private → Public
Sebastien Bacher (seb128) wrote :
Changed in software-center (Ubuntu):
importance: Medium → High
Changed in webkit:
importance: Unknown → Medium
status: Unknown → New
Doug McMahon (mc3man) wrote :

Crashes here only when trying to open to the default "All Software" window, otherwise is ok. The "All Software" can be opened if not the first or second action

Start from terminal on an app, Ex.

 software-center gedit

After it opens click on little arrow to the right of "All Software" icon, from the dropdown pick anything, "Provided by Ubuntu" will do.
After that opens then, if desired, you can click on the "All Software" icon to go to the main page.

tags: added: trusty
Sebastien Bacher (seb128) wrote :

There is a tentative patch that I've uploaded to the desktop ppa for trusty, https://launchpad.net/~ubuntu-desktop/+archive/ppa ... if somebody having the issue could try the fix there that would be great

Changed in software-center (Ubuntu Saucy):
importance: Undecided → High
status: New → Triaged
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Changed in software-center (Ubuntu Saucy):
status: Triaged → In Progress
Changed in webkit:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

seems like the fix is not enough, upstream is working on other changes

Sebastien Bacher (seb128) wrote :

webkitgtk (2.3.2-1ubuntu4) trusty; urgency=low

  * debian/patches/bugzilla_clear_surface.patch:
    - updated version of the change, should fix the software-center Xerrors
      reports. Thanks Benjamin Otte for the work on the issue
      (lp: #1211887)

Changed in webkitgtk (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Changed in webkitgtk (Ubuntu Saucy):
status: New → Invalid
importance: Undecided → High
Changed in webkit (Ubuntu):
status: New → Invalid
Changed in webkit (Ubuntu Saucy):
importance: Undecided → High
status: New → In Progress
Changed in webkit (Ubuntu):
importance: Undecided → High
Changed in software-center (Ubuntu):
status: In Progress → Invalid
Changed in software-center (Ubuntu Saucy):
status: In Progress → Invalid
description: updated
Brian Murray (brian-murray) wrote :

Sebastien - I don't actually see this fix in Trusty, but I'll approve the Saucy SRU anyway with the understanding that you'll sort out Trusty before we can release the Saucy SRU.

Changed in webkit (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed

Hello Ken, or anyone else affected,

Accepted webkit into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/webkit/1.10.2-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sebastien Bacher (seb128) wrote :

@Brian: webkit has been renamed webkitgtk in trusty, see https://launchpad.net/ubuntu/+source/webkitgtk/2.3.2-1ubuntu4

Ross Younger (crazyscot) wrote :

On my saucy box, I installed gir1.2-javascriptcoregtk-3.0 and gir1.2-webkit-3.0 version 1.10.2-0ubuntu3 from proposed.
I am happy to report that that resolved the issue for me.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webkit - 1.10.2-0ubuntu3

---------------
webkit (1.10.2-0ubuntu3) saucy; urgency=low

  * debian/patches/bugzilla_clear_surface.patch:
    - correctly clear the surfaces, should fix the software-center Xerrors
      reports. Thanks Benjamin Otte for the work on the issue
      (lp: #1211887)
 -- Sebastien Bacher <email address hidden> Thu, 12 Dec 2013 10:40:49 +0100

Changed in webkit (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.