software-center crashes after launching

Bug #1251814 reported by Chris J Arges on 2013-11-16
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

In trusty if I click on software-center it immediately crashes.

$ software-center
2013-11-15 22:22:18,822 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-11-15 22:22:19,261 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-11-15 22:22:19,263 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-11-15 22:22:19,271 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-11-15 22:22:19,271 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-11-15 22:22:19,325 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

(software-center:19742): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 3001 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: software-center 13.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.12.0-2.7-generic 3.12.0
Uname: Linux 3.12.0-2-generic x86_64
ApportVersion: 2.12.6-0ubuntu1
Architecture: amd64
Date: Fri Nov 15 22:19:20 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-11-13 (2 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Chris J Arges (arges) wrote :
Sasa Paporovic (melchiaros) wrote :

Can confirm.

Changed in software-center (Ubuntu):
status: New → Confirmed
møllerik (hussmian) wrote :

I found the reason why I could not download from the Software Center:
When I connected the cable instead of wireless, it suddenly easy.

Remember this!

dobey (dobey) wrote :

Is there a gdb trace from the crash? This looks very much like the issue caused by webkit 2.0.

Changed in software-center (Ubuntu):
importance: Critical → High
status: Confirmed → Incomplete
David Pires (slickymaster) wrote :

Uploading the backtrace of the crash, occurred with 32-bit Xubuntu Desktop image from 2013-12-02.

Hardware specs: http://phillw.net/hardware/Ed3c22qV

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1251814

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers