upower 0.99.1 transition

Bug #1330037 reported by Jackson Doak on 2014-06-14
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock-plug-ins (Ubuntu)
Undecided
Matthieu Baerts
cinnamon-control-center (Ubuntu)
Undecided
Unassigned
cinnamon-session (Ubuntu)
Undecided
Unassigned
cinnamon-settings-daemon (Ubuntu)
Undecided
Unassigned
gnome-applets (Ubuntu)
Undecided
Martin Pitt
gnome-control-center (Ubuntu)
Undecided
Tim Lunn
gnome-packagekit (Ubuntu)
Undecided
Matthias Klumpp
gnome-power-manager (Ubuntu)
Undecided
Martin Pitt
gnome-session (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Martin Pitt
gnome-shell (Ubuntu)
Undecided
Unassigned
gnome-shell-pomodoro (Ubuntu)
Undecided
Unassigned
indicator-power (Ubuntu)
Medium
Unassigned
kde-workspace (Ubuntu)
Undecided
Philip Muškovac
mate-applets (Ubuntu)
Undecided
Martin Wimpress
mate-power-manager (Ubuntu)
Undecided
Martin Wimpress
mate-session-manager (Ubuntu)
Undecided
Martin Wimpress
mutter (Ubuntu)
Undecided
Unassigned
powerd (Ubuntu)
Undecided
Unassigned
python-dbusmock (Ubuntu)
Undecided
Martin Pitt
razorqt (Ubuntu)
Undecided
Unassigned
sugar-0.96 (Ubuntu)
Undecided
Unassigned
sugar-0.98 (Ubuntu)
Undecided
Unassigned
telepathy-mission-control-5 (Ubuntu)
Undecided
Martin Pitt
tracker (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Medium
Iain Lane
unity-control-center (Ubuntu)
Undecided
Tim Lunn
unity-settings-daemon (Ubuntu)
Undecided
Tim Lunn
upower (Ubuntu)
Undecided
Unassigned
wmbattery (Debian)
Fix Released
Unknown
wmbattery (Ubuntu)
Undecided
Unassigned
xfce4-power-manager (Ubuntu)
Undecided
Martin Pitt
xfce4-session (Ubuntu)
Undecided
Jackson Doak
xfce4-settings (Ubuntu)
Undecided
Unassigned
xfce4-systemload-plugin (Ubuntu)
Undecided
Jackson Doak
xfce4-weather-plugin (Ubuntu)
Undecided
Unassigned

Bug Description

upower 0.99 needs uploading for gnome 3.12 to enter ubuntu. It drops the suspend/hibernate functions, as logind now does that. All major DEs have support for this,so nearly everything just needs a rebuild. This bug tracks the transition.

A transition is required as some features were removed and the SONAME was changed

All packages (and build logs) are staged in https://launchpad.net/~noskcaj/+archive/upower/+packages

sugar will probably need removing. If a package only needs a rebuild, mark it fix commited, if something else is needed, in progress.

cairo-dock-plug-ins: needs rebuilding
gnome-shell - ready, just need to drop upower revert.
gnome-control-center: WIP
gnome-packagekit: Upower dropped from newest upstream release.
gnome-power-manager: Fixed in newest upstream release. Merge from debian
gnome-session: Done in ppa, needs patches from git or new upstream release
gnome-settings-daemon: 3.12 is ready out of the box, however that also requires gnome-desktop transition. 3.8 and also u-s-d: I have a package that is mostly working, however had to cherry-pick quite a few patches and may just be better to backport 3.12 power plugin. (considering g-s-d patches will be temporary, but u-s-d not so)
kde: works fine with systemd, suspend broken with upstart, no rebuilds needed
cinnamon: Rebuild
mate: all mate packages need rebuilding
python-dbusmock: needs rebuild
sugar: Upstream bug now filed. Unlikely to be ready in time for 14.10. We should remove this from the archive till the next upstream release
telepathy-mission-control-5: Debian has dropped upower support, so it's done
wmbattery: needs rebuild
xfce4-power-manager: Needs rebuilding
xfce4-session: Fixed already, since we switched to logind
xfce4-settings: Needs rebuild
xfce4-systemload-plugin: needs rebuild

Related branches

Jackson Doak (noskcaj) on 2014-06-14
tags: added: utopic
Jackson Doak (noskcaj) on 2014-06-14
description: updated
description: updated
Tim Lunn (darkxst) wrote :

A Rough list of api changes is available here:
http://lists.freedesktop.org/archives/devkit-devel/2013-October/001519.html

I will take a look at g-s-d/g-c-c and then port changes to the unity counterparts. It would however be good if touch or desktop teams can look at porting powerd and indicator power.

Jackson, can you provide a full list of other r-depends that are missing upstream ports?

Jackson Doak (noskcaj) on 2014-06-14
description: updated
description: updated
Jackson Doak (noskcaj) on 2014-06-14
description: updated
Jackson Doak (noskcaj) on 2014-06-14
description: updated
Changed in cairo-dock-plug-ins (Ubuntu):
status: New → Fix Committed
Jackson Doak (noskcaj) on 2014-06-14
description: updated
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Tim (darkxst)
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Tim (darkxst)
Changed in unity-settings-daemon (Ubuntu):
assignee: nobody → Tim (darkxst)
Changed in unity-control-center (Ubuntu):
assignee: nobody → Tim (darkxst)
Changed in xfce4-session (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
Jackson Doak (noskcaj) on 2014-06-14
Changed in xfce4-systemload-plugin (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)
description: updated
Changed in xfce4-systemload-plugin (Ubuntu):
status: New → Fix Committed
Changed in wmbattery (Debian):
status: Unknown → New
Tim Lunn (darkxst) on 2014-06-14
description: updated
Charles Kerr (charlesk) wrote :

Confirmed, indicator-power will need to be updated for this: src/device-provider-upower.c is currently using some of the signals that got removed.

Changed in indicator-power (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Jackson Doak (noskcaj) on 2014-06-16
description: updated
Tim Lunn (darkxst) on 2014-06-16
description: updated
Iain Lane (laney) wrote :

ubuntu-system-settings uses at least the device-added/device-removed signals on the D-Bus API. It should be simple to modify it to watch the notify signals instead, and we have autopilot tests to cover this so ensure they keep working.

Philip Muškovac (yofel) wrote :

From a quick test with kde at least the suspend support has to be reworked as it doesn't work out of the box with ubuntu's logind (systemd-shim doesn't provide all used interfaces)

description: updated
Philip Muškovac (yofel) wrote :

Hm, nope, it's something else as it's supposed to work with upstart, looking into it

Changed in kde-workspace (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
Philip Muškovac (yofel) on 2014-06-21
description: updated
Philip Muškovac (yofel) on 2014-06-21
description: updated
Tim Lunn (darkxst) on 2014-06-23
description: updated
Philip Muškovac (yofel) on 2014-06-25
affects: kde-workspace (Ubuntu) → kde4libs (Ubuntu)
Jackson Doak (noskcaj) on 2014-06-26
description: updated
description: updated
Philip Muškovac (yofel) on 2014-06-26
description: updated
Martin Pitt (pitti) on 2014-06-26
Changed in gnome-packagekit (Ubuntu):
status: New → Fix Committed
Tim Lunn (darkxst) on 2014-06-26
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-packagekit - 3.12.2-1ubuntu1

---------------
gnome-packagekit (3.12.2-1ubuntu1) utopic; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - Drop build dependency on obsolete gtk-doc-tools and libapt-pkg-dev
    - Raise version of the libglib2.0-dev build dependency as per upstream
      configure.ac.
    - Alternatively depend on aptdaemon's PackageKit compatibility layer.
    - Drop transitional update-notifier package, we want to keep our's.
  * Drop unnecessary libupower-glib-dev build dependency.
  * This version does not use upower any more. (LP: #1330037)

gnome-packagekit (3.12.2-1) unstable; urgency=medium

  * New upstream release: 3.12.2
  * Bump standards version to 3.9.5
  * Drop tools package: No longer provided by upstream
 -- Martin Pitt <email address hidden> Thu, 26 Jun 2014 06:51:09 +0200

Changed in gnome-packagekit (Ubuntu):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) on 2014-06-27
tags: added: ubuntugnome-blocker
Jackson Doak (noskcaj) on 2014-06-27
description: updated
Philip Muškovac (yofel) on 2014-06-29
description: updated
Jackson Doak (noskcaj) on 2014-07-03
description: updated
Jackson Doak (noskcaj) on 2014-07-03
Changed in mutter (Ubuntu):
status: New → In Progress
Martin Pitt (pitti) on 2014-07-16
Changed in python-dbusmock (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Martin Pitt (pitti) wrote :

python-dbusmock already works with upower 0.99 (it queries "upower --version" to see which API it should emulate). I fixed the other test case failure in https://gitorious.org/python-dbusmock/python-dbusmock/commit/383b21f8a

Changed in python-dbusmock (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-dbusmock - 0.10.3-1

---------------
python-dbusmock (0.10.3-1) unstable; urgency=medium

  * New upstream release:
    - Fix TestCLI.test_template_system test with upower 0.99. (LP: #1330037)
    - ofono template: Support adding a second modem with AddModem().
      (LP: #1340590)

 -- Martin Pitt <email address hidden> Wed, 16 Jul 2014 13:32:03 +0200

Changed in python-dbusmock (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Iain Lane (laney)
importance: Undecided → Medium
status: New → Triaged
Changed in wmbattery (Debian):
status: New → Fix Released
Martin Pitt (pitti) wrote :

xfce4-power-manager 1.3.0-1ubuntu1 (bug 1334185) runs with logind now and is in utopic.

Changed in xfce4-power-manager (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :

https://launchpad.net/ubuntu/+source/xfce4-session/4.10.1-7ubuntu1 also supports logind, and it doesn't depend on libupower-glib at all any more.

Changed in xfce4-session (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Ah, xfce4-power-manager will still need a rebuild against libupower-glib2.

Changed in xfce4-power-manager (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

gnome-power-manager from PPA confirmed to work well. I'll use "In Progress" for things which are fixed in the PPA, but not uploaded.

Changed in gnome-power-manager (Ubuntu):
status: New → In Progress
Changed in xfce4-settings (Ubuntu):
status: New → In Progress
Changed in upower (Ubuntu):
status: New → In Progress
Changed in tracker (Ubuntu):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

gnome-applets is not affected. We haven't built the battstat applet since oneiric, and it doesn't build/binary depend on (lib)upower.

Changed in gnome-applets (Ubuntu):
status: New → Invalid
Changed in gnome-control-center (Ubuntu):
status: New → In Progress
Changed in gnome-session (Ubuntu):
status: New → In Progress
Changed in gnome-settings-daemon (Ubuntu):
status: New → In Progress
Changed in gnome-shell (Ubuntu):
status: New → In Progress
Changed in telepathy-mission-control-5 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Triaged
Martin Pitt (pitti) on 2014-07-23
Changed in telepathy-mission-control-5 (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-mission-control-5 - 1:5.16.2-1ubuntu1

---------------
telepathy-mission-control-5 (1:5.16.2-1ubuntu1) utopic; urgency=medium

  * Resynchronize with Debian. Remaining Ubuntu changes:
    - AppArmor confinement:
      + debian/apparmor-profile: Profile
      + debian/control: build-depend on dh-apparmor, suggest apparmor
      + debian/rules: install apparmor profile
    - Apport hook:
      + debian/telepathy-mission-control-5.apport
      + debian/rules: Install hook
  * Moves from upower to logind (LP: #1330037)

telepathy-mission-control-5 (1:5.16.2-1) unstable; urgency=low

  * New upstream bugfix release

telepathy-mission-control-5 (1:5.16.1-2) unstable; urgency=medium

  * Disable UPower support and rely on logind to be notified about suspend,
    the current UPower support is incompatible with 0.99 (Closes: #748938)
 -- Martin Pitt <email address hidden> Wed, 23 Jul 2014 07:13:35 +0200

Changed in telepathy-mission-control-5 (Ubuntu):
status: Fix Committed → Fix Released
Philip Muškovac (yofel) on 2014-07-23
description: updated
Philip Muškovac (yofel) wrote :

So the device management issues in kde were unrelated to upower 0.99, which leaves the suspend issues with upstart where I'm working on a fix.

affects: kde4libs (Ubuntu) → kde-workspace (Ubuntu)
Changed in kde-workspace (Ubuntu):
status: New → In Progress
Philip Muškovac (yofel) wrote :

Fixed in upstream git

Changed in kde-workspace (Ubuntu):
status: In Progress → Fix Committed
Philip Muškovac (yofel) wrote :

kde-workspace (4:4.11.11-0ubuntu2) utopic; urgency=medium

  * Cherry pick upstream 95529335232dcf04620c7f34ba92c9e8e6b190f5
    as upstream_fix-upstart-version-detect.diff so we use logind instead of upower

 -- Philip Muškovac <email address hidden> Thu, 07 Aug 2014 13:52:44 +0200

Changed in kde-workspace (Ubuntu):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) wrote :

Charles, are you planning on porting indicator-power? I think this is really the last thing blocking this transition....

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 3.3.99.rc1.1~20140818~bzr3115-0ubuntu1

---------------
cairo-dock-plug-ins (3.3.99.rc1.1~20140818~bzr3115-0ubuntu1) utopic; urgency=medium

  * New upstream snapshot.
  * Short Upstream ChangeLog:
    - All: updated due to recent API changes and changes in the global style
    - All: removed GTK2 support
    - DnD2Share: refresh support of some backend
    - GMenu:
      - Do not create empty menus
      - Show dialogue to open a new app after the end of the installation
      - Added an option to not show this dialogue
    - Gnome: support Cinnamon logout
    - Logout: display a message to reboot after the end of the update
    - Shortcuts: improve the support of bookmarks
    - Status-Notifier: support scroll events
    - System-Monitor: fixed RAM info
    - Terminal: open terminal on middle click, support Maj+Ctrl+[CV]
    - UPower: support 0.99 version (LP: #1330037 - was already patched)
    - Stop using GTK Stock icons
    - po: updated translations (added Korean)
    - Some bugs have been fixed, other tweaks (LP: #1303263)
  * debian/control:
    - Bumped Cairo-Dock (core) versions
    - Added libwayland (initial support, not enabled by default)
  * debian/patches:
    - Removed all patches: all of them were created from this version
 -- Matthieu Baerts (matttbe) <email address hidden> Tue, 19 Aug 2014 22:10:43 +0200

Changed in cairo-dock-plug-ins (Ubuntu):
status: Fix Committed → Fix Released
Changed in mate-applets (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-power-manager (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in mate-session-manager (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)

mate-session-manager has had upower 0.99/1.0 support since 1.8.0.

Changed in mate-session-manager (Ubuntu):
status: New → Fix Released

mate-power-manager has upower 0.99/1.0 support since 1.8.1.

Changed in mate-power-manager (Ubuntu):
status: New → Fix Released

mate-applets has upower 0.99/1.0 support since 1.8.1.

Changed in mate-applets (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.10.20140909-0ubuntu1

---------------
indicator-power (12.10.6+14.10.20140909-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * Add support for UPower 0.99. (LP: #1330037)
  * When the phone's battery goes down past a certain level, pop up a
    snap decision to warn the user. (LP: #1296431)

  [ Ted Gould ]
  * Synchronize process management across indicators
 -- Ubuntu daily release <email address hidden> Tue, 09 Sep 2014 04:22:52 +0000

Changed in indicator-power (Ubuntu):
status: Triaged → Fix Released
Eric Koegel (eric-koegel) wrote :

For Xfce Upower 0.99 support:

xfce4-weather-plugin
https://bugzilla.xfce.org/show_bug.cgi?id=10922

xfce4-systemload-plugin
https://bugzilla.xfce.org/show_bug.cgi?id=10923

xfce4-session
https://bugzilla.xfce.org/show_bug.cgi?id=9952

xfce4-settings
https://bugzilla.xfce.org/show_bug.cgi?id=10918

I noticed this bug meta-list missed the xfce4-weather-plugin. I was using http://qa-reports.gentoo.org/output/genrdeps/rindex/sys-power/upower from Gentoo for a list to work off of.

Jackson Doak (noskcaj) wrote :

I had left weather-plugin off as we don't enable the upower backend in ubuntu or debian

Jackson Doak (noskcaj) wrote :

weather manager's upower support is off by default

Changed in xfce4-weather-plugin (Ubuntu):
status: New → Invalid
Tim Lunn (darkxst) wrote :

gnome-applets does build the battstat applet now that we are in sync with debian, but is already ready. Just needs a rebuild

Changed in gnome-applets (Ubuntu):
status: Invalid → In Progress
Jackson Doak (noskcaj) on 2014-09-11
description: updated
Jackson Doak (noskcaj) on 2014-09-12
description: updated
Jackson Doak (noskcaj) on 2014-09-12
description: updated
summary: - upower 0.99 transition
+ [SRU] upower 0.99.1 transition

cairo-dock-plug-ins: needs rebuilding

Changed in cairo-dock-plug-ins (Ubuntu):
assignee: nobody → Matthieu Baerts (matttbe)
status: Fix Released → Fix Committed
Jackson Doak (noskcaj) on 2014-09-12
summary: - [SRU] upower 0.99.1 transition
+ [FFe] upower 0.99.1 transition

As a member of Xubuntu Team, I'm objecting to this landing as a Feature Freeze Exception as there is inadequate time to test this to ensure it works for 14.10. This is landing awfully late and as this is only a 9 months of support release we could avoid risks rushing it out now by having it wait for 15.04.

Final Beta Freeze is September 22nd. To test something new this late that would be added effectively across all flavors does not seem socially appropriate. I understand this may block GNOME 3.12 landing but Ubuntu's archive is shared among many desktop environments. There are always setbacks and things we do not get accomplished during semi-annual cycles. We can best look at this again during Victorious Velociraptor or whatever we name the next cycle.

Elfy (elfy) wrote :

As Xubuntu QA Lead and member of the Xubuntu Release Team I would like to register strong objection to this FFe and concur with #29

Sean Davis (bluesabre) wrote :

As Xubuntu Technical Lead and on behalf of the Xubuntu Release Team, I too would like to strongly object to this FFe.

Matthias Klumpp (ximion) on 2014-09-14
Changed in gnome-packagekit (Ubuntu):
assignee: nobody → Matthias Klumpp (ximion)
Simon Steinbeiß (ochosi) wrote :

As Xubuntu Project Lead and following my Xubuntu Release Team collegues, I would like to strongly object to this FFe. It really is extremely late in the cycle for something quite untested to land that affects so many desktops.

As requested by Jackson Doak (noskcaj) I have tested MATE 1.8.1 against the upower transitional PPA below.

  * https://launchpad.net/~noskcaj/+archive/ubuntu/upower

From `mate-applets` the Battery status panel applet works correctly. `mate-power-manager` and `mate-session-manager` continue to work together to provide suspend, hibernate, lock and resume functionality just as before. No regressions as far as I can determine.

On Mon, Sep 15, 2014 at 02:49:40PM -0000, Simon Steinbeiß wrote:
> As Xubuntu Project Lead and following my Xubuntu Release Team collegues,
> I would like to strongly object to this FFe. It really is extremely late
> in the cycle for something quite untested to land that affects so many
> desktops.

We've heard Xubuntu's objections. To me they seem strident enough to say
that we should delay this until the next cycle. I guess there could have
been more coordinated testing earlier on.

Jackson, Tim, are you okay with this? If everything stays ready, you
could upload first-ish thing in the V cycle. I'd help you with
sponsoring and prodding of Canonical upstreams if you need it.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Scott Kitterman (kitterman) wrote :

On Friday, September 19, 2014 11:03:59 you wrote:
> On Mon, Sep 15, 2014 at 02:49:40PM -0000, Simon Steinbeiß wrote:
> > As Xubuntu Project Lead and following my Xubuntu Release Team collegues,
> > I would like to strongly object to this FFe. It really is extremely late
> > in the cycle for something quite untested to land that affects so many
> > desktops.
>
> We've heard Xubuntu's objections. To me they seem strident enough to say
> that we should delay this until the next cycle. I guess there could have
> been more coordinated testing earlier on.
>
> Jackson, Tim, are you okay with this? If everything stays ready, you
> could upload first-ish thing in the V cycle. I'd help you with
> sponsoring and prodding of Canonical upstreams if you need it.

The only question I have is if we should consider a upower0.99 package for
this cycle only for Gnome to use to they won't be blocked on updating.

Iain Lane (laney) wrote :

On Fri, Sep 19, 2014 at 11:29:41AM -0000, Scott Kitterman wrote:
> […]
> The only question I have is if we should consider a upower0.99 package for
> this cycle only for Gnome to use to they won't be blocked on updating.

upower exposes a well-known name on the system bus, so consumers
expecting this would have to be patched. Then we'd need to either rename
the symbols or make sure that the two versions aren't going to be loaded
in the same process.

I feel like there's not much time remaining this cycle, but if someone
from GNOME wants to analyse and then do the work it might be okay.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

As Laney mentoned Shipping upower 0.99 only for GNOME would be a lot of work. I have however managed to untangle the gnome-desktop transition from upower, so we can now land that without upower 0.99, in which case landing upower transition as soon a V opens should probably be ok.

Doug McMahon (mc3man) wrote :

Is any of this the reason why the 'Brightness & Lock' panel settings are largely non-functional in an ubuntu session?
(the same pretty much for power settings panel in a gnome session

On Wed, Oct 08, 2014 at 05:03:10PM -0000, Doug McMahon wrote:
> Is any of this the reason why the 'Brightness & Lock' panel settings are largely non-functional in an ubuntu session?
> (the same pretty much for power settings panel in a gnome session

This transition isn't in Ubuntu. You're talking about

  https://bugs.launchpad.net/ubuntu/+source/gnome-desktop3/+bug/1377847

most likely, which will be uploaded in the next day.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

upower 0.99 synced from Debian.

Changed in upower (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

I uploaded a fakesync for gnome-applets, reverting build-dep back to 0.99.

Changed in gnome-applets (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

gnome-control-center changes committed to packaging bzr and uploaded.

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

gnome-power-manager 3.14 merged with Debian, uploaded.

Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2014-10-30
Changed in cinnamon-control-center (Ubuntu):
status: New → Fix Committed
Changed in cinnamon-session (Ubuntu):
status: New → Fix Committed
Changed in cinnamon-settings-daemon (Ubuntu):
status: New → Fix Committed
Martin Pitt (pitti) on 2014-10-30
Changed in xfce4-power-manager (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2014-10-30
Changed in xfce4-settings (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2014-10-30
Changed in mutter (Ubuntu):
status: In Progress → Fix Committed
Changed in wmbattery (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon-session - 2.2.2-5build1

---------------
cinnamon-session (2.2.2-5build1) vivid; urgency=medium

  * No change rebuild for upower 0.99.1 (LP: #1330037)
 -- Jackson Doak <email address hidden> Wed, 29 Oct 2014 19:36:18 +1100

Changed in cinnamon-session (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2014-10-30
Changed in gnome-shell-pomodoro (Ubuntu):
status: New → Fix Committed
Martin Pitt (pitti) on 2014-10-30
Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

The mate packages still need to get rebuilt against the new libupower-glib3. I'll upload those.

Changed in mate-power-manager (Ubuntu):
status: Fix Released → In Progress
Changed in mate-applets (Ubuntu):
status: Fix Released → In Progress
Martin Pitt (pitti) on 2014-10-30
Changed in mate-applets (Ubuntu):
status: In Progress → Fix Committed
Changed in mate-power-manager (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

I ported Tim's patches to current unity-{settings-daemon,control-center}, comitted to bzr, and uploaded.

Changed in unity-control-center (Ubuntu):
status: New → Fix Committed
Changed in unity-settings-daemon (Ubuntu):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

I extracted Tim's powerd patch and created an upstream MP for this.

Changed in powerd (Ubuntu):
status: New → In Progress
Martin Pitt (pitti) wrote :

gnome-session moved to systemd in https://code.launchpad.net/~darkxst/gnome-session/3.14/+merge/240212, thus dropping the upower dep.

Changed in gnome-session (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2014-10-31
Changed in gnome-session (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

gnome-settings-daemon committed/uploaded as well, which drops the "revert to 3.10 upower" patch.

To complete the transition, we now need to land these two MPs:

  https://code.launchpad.net/~pitti/powerd/upower0.99/+merge/240141
  https://code.launchpad.net/~laney/ubuntu-system-settings/upower0.99/+merge/230988

Everything else should be ready in -proposed now.

Changed in gnome-settings-daemon (Ubuntu):
assignee: Tim (darkxst) → Martin Pitt (pitti)
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

powerd and system-settings landed in -proposed now, too.

Changed in powerd (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2014-11-01
summary: - [FFe] upower 0.99.1 transition
+ upower 0.99.1 transition
Martin Pitt (pitti) on 2014-11-01
Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.0+15.10.20141030-0ubuntu1

---------------
unity-settings-daemon (15.04.0+15.10.20141030-0ubuntu1) vivid; urgency=medium

  [ Tim Lunn ]
  * Query logind instead of upower for "can suspend/hibernate", and rebuild
    against upower 0.99. (LP: #1330037)

  [ Martin Pitt ]
  * Add missing Vcs-Bzr: control field.
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 17:29:53 +0100

Changed in unity-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon-settings-daemon - 2.2.4.repack-7build1

---------------
cinnamon-settings-daemon (2.2.4.repack-7build1) vivid; urgency=medium

  * No change rebuild for upower 0.99.1 (LP: #1330037)
 -- Jackson Doak <email address hidden> Wed, 29 Oct 2014 19:42:56 +1100

Changed in cinnamon-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-pomodoro - 0.10.3-1build1

---------------
gnome-shell-pomodoro (0.10.3-1build1) vivid; urgency=medium

  * No-change rebuild against upower 0.99. (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 15:26:22 +0100

Changed in gnome-shell-pomodoro (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerd - 0.16+15.04.20141031.2-0ubuntu1

---------------
powerd (0.16+15.04.20141031.2-0ubuntu1) vivid; urgency=low

  [ Martin Pitt ]
  * Support upower 0.99. (LP: #1330037)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Tim Lunn ]
  * Support upower 0.99. (LP: #1330037)
 -- Ubuntu daily release <email address hidden> Fri, 31 Oct 2014 20:19:53 +0000

Changed in powerd (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.12.2-1ubuntu4

---------------
gnome-settings-daemon (3.12.2-1ubuntu4) vivid; urgency=medium

  * geoclue-2.0 build-deps were accidentally uncommented in the previous
    upload - remove them again.
 -- Iain Lane <email address hidden> Sat, 01 Nov 2014 13:32:00 +0000

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon-control-center - 2.2.11-4build1

---------------
cinnamon-control-center (2.2.11-4build1) vivid; urgency=medium

  * No change rebuild for upower 0.99.1 (LP: #1330037)
 -- Jackson Doak <email address hidden> Wed, 29 Oct 2014 19:27:57 +1100

Changed in cinnamon-control-center (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.12.1-5ubuntu3

---------------
gnome-control-center (1:3.12.1-5ubuntu3) vivid; urgency=medium

  * Drop power-panel-3.10.patch and bump upower build dep to >= 0.99.
    (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 12:17:35 +0100

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 3.14.1-1ubuntu1

---------------
gnome-power-manager (3.14.1-1ubuntu1) vivid; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - ctrl-q-quit.patch: Make Ctrl+q close the application.
    - Depend on gnome-settings-daemon-schemas so can work with
      unity-settings-daemon (LP: #1277487)
  * Build against upower 0.99 (LP: #1330037)

gnome-power-manager (3.14.1-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.6. No further changes.
  * Drop Depends on notification-daemon. The gnome-power-statistics binary,
    which is the only component still provided by the gnome-power-manager
    package, doesn't use it anymore.

gnome-power-manager (3.14.0-1) unstable; urgency=medium

  * New upstream release.

gnome-power-manager (3.12.2-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.5
  * Upload to unstable.

gnome-power-manager (3.12.0-2) experimental; urgency=medium

  * Bump libupower-glib-dev build-dependency to >= 0.99 as well.
    (Closes: #751129)

gnome-power-manager (3.12.0-1) experimental; urgency=medium

  * New upstream release.
  * Update build-dependencies according to configure.ac changes:
    - Bump libglib2.0-dev to (>= 2.36)
    - Bump intltool to (>= 0.50.0)
  * Bump dependency on upower to >= 0.99
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 12:29:32 +0100

Changed in gnome-power-manager (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-systemload-plugin - 1:1.1.1-4ubuntu1

---------------
xfce4-systemload-plugin (1:1.1.1-4ubuntu1) vivid; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - Add epoch.
  * Rebuild against upower 0.99 (LP: #1330037)

xfce4-systemload-plugin (1.1.1-4) unstable; urgency=medium

  * debian/control:
    - update standards version to 3.9.6.
    - add build-dep on xfce4-dev-tools, automake and libtool.
  * debian/rules:
    - call xdt-autogen before configure to regenerate config.{guess,sub} and
      gain support for new architectures. closes: #765274

xfce4-systemload-plugin (1.1.1-3) unstable; urgency=low

  [ Evgeni Golov ]
  * Correct Vcs-* URLs to point to anonscm.debian.org

  [ Jackson Doak ]
  * Support upower 0.99 closes: #752430
    - Add 01_upower-0.99.patch
    - Bump upower depend to >= 0.99
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 13:11:52 +0100

Changed in xfce4-systemload-plugin (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wmbattery - 2.45-2build1

---------------
wmbattery (2.45-2build1) vivid; urgency=medium

  * No-change rebuild against upower 0.99 (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 14:09:07 +0100

Changed in wmbattery (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-settings - 4.11.3-0ubuntu3

---------------
xfce4-settings (4.11.3-0ubuntu3) vivid; urgency=medium

  * No-change rebuild against upower 0.99. (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 13:34:09 +0100

Changed in xfce4-settings (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock-plug-ins - 3.4.0-0ubuntu2

---------------
cairo-dock-plug-ins (3.4.0-0ubuntu2) vivid; urgency=medium

  * No change rebuild for upower 0.99.1 (LP: #1330037)
 -- Jackson Doak <email address hidden> Wed, 29 Oct 2014 19:15:20 +1100

Changed in cairo-dock-plug-ins (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-power-manager - 1.4.1-2ubuntu1

---------------
xfce4-power-manager (1.4.1-2ubuntu1) vivid; urgency=medium

  * Merge from Debian. Remaining Ubuntu changes:
  * debian/control
    - Switch to using logind for session tracking. Depend on systemd-services
      and add libsystemd-login-dev build dependency.
    - Enable building of lxpanel plugin
    - Update depends for xfce4-power-manager-plugins to xfce4-panel | lxpanel
  * debian/rules
    - Do not include xfce4-panel in shlibs

xfce4-power-manager (1.4.1-2) unstable; urgency=medium

  * debian/patches:
    - 0001-Use-translated-device-type-for-unknown-devices-bug-1 added,
    cherry-picked from upstream to fix extra long battery names when the
    battery is not recognized by the system. closes: #763713
  * debian/control:
    - update standards version to 3.9.6.

xfce4-power-manager (1.4.1-1) unstable; urgency=medium

  * New upstream release.
  * debian/patches:
    - 0001-Fix-handle-lid-switch-with-loginD-Bug-11160 dropped, included
      upstream.
 -- Jackson Doak <email address hidden> Fri, 31 Oct 2014 18:36:56 +1100

Changed in xfce4-power-manager (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mate-applets - 1.8.1+dfsg1-3build1

---------------
mate-applets (1.8.1+dfsg1-3build1) vivid; urgency=medium

  * Rebuild against upower 0.99. (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 15:57:02 +0100

Changed in mate-applets (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20141031.2-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20141031.2-0ubuntu1) vivid; urgency=low

  [ Sebastien Bacher ]
  * Tweaks to try to make the section headers and titles closer to the
    design. Use a custom component, with tweaked margins and disabled
    tap effects, for that.

  [ Iain Lane ]
  * Move formatSize into a new Utilities class in the qml context and
    call this from the updates panel to consistently display sizes (LP:
    #1385286)
  * Update to work with UPower >= 0.99 as well as current versions (LP:
    #1330037)

  [ Albert Astals ]
  * i18n++ (LP: #1386730)

  [ William Hua ]
  * Re-translate the UI when reboot is cancelled after language change.
    (LP: #1377984)

  [ jonas-drange ]
  * [cellular] split "Cellular Data" and "Connection type" into two
    separate pieces in the UI for both single and multi SIM (LP:
    #1361226)
  * [wifi] use actiongroup to hide "connect to other networks" (LP:
    #1377076)

  [ Michael Terry ]
  * When the power button is held down, show the shutdown dialog like we
    do in the unity8 shell. (LP: #1381731)
  * Add a Continue button when choosing a passphrase. And fix a few
    other design nits with choosing a password.

  [ Michael Zanetti ]
  * Drop reboot notification label on launcher reset. (LP: #1376707)

  [ Mathieu Trudel-Lapierre ]
  * [bluetooth] Show bluetooth address instead of name while it's not
    detected; to be updated once available. (LP: #1382767)
 -- Ubuntu daily release <email address hidden> Fri, 31 Oct 2014 14:53:52 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.12.2-1ubuntu8

---------------
gnome-shell (3.12.2-1ubuntu8) vivid; urgency=medium

  * Drop revert-new-upower.patch and build against upower 0.99.
    (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 15:35:42 +0100

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tracker - 1.2.2-2ubuntu2

---------------
tracker (1.2.2-2ubuntu2) vivid; urgency=medium

  * No-change rebuild against upower 0.99. (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 15:13:35 +0100

Changed in tracker (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.12.2-1ubuntu4

---------------
mutter (3.12.2-1ubuntu4) vivid; urgency=medium

  * Drop revert_upower_api_changes.patch and build against upower 0.99.
    (LP: #1330037)
  * Skip version number for rejected -1ubuntu3.
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 15:02:03 +0100

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+15.04.20141030-0ubuntu1

---------------
unity-control-center (15.04.0+15.04.20141030-0ubuntu1) vivid; urgency=medium

  * Port to upower 0.99 (LP: #1330037)
 -- Tim Lunn <email address hidden> Thu, 30 Oct 2014 17:27:40 +0100

Changed in unity-control-center (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mate-power-manager - 1.8.1+dfsg1-1build1

---------------
mate-power-manager (1.8.1+dfsg1-1build1) vivid; urgency=medium

  * Rebuild against upower 0.99. (LP: #1330037)
 -- Martin Pitt <email address hidden> Thu, 30 Oct 2014 15:56:25 +0100

Changed in mate-power-manager (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Closing the tasks which are done in vivid now, but whose changelogs don't have a bug ref.

Changed in upower (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-applets (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I checked sugar-0.98, and the only usage seems to be in ./extensions/deviceicon/battery.py which only reads battery properties. This looks fine for upower 0.99.

Changed in sugar-0.98 (Ubuntu):
status: New → Invalid
Martin Pitt (pitti) wrote :

Same with sugar-0.96.

Changed in sugar-0.96 (Ubuntu):
status: New → Invalid
Martin Pitt (pitti) wrote :

razorqt also has a SystemdProvider class which can do the suspend/resume things. It's also not that important, see Debian bug #752442. So we can ignore this for this transition.

Changed in razorqt (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.