Comment 10 for bug 1330037

https://launchpad.net/ubuntu/+source/xfce4-session/4.10.1-7ubuntu1 also supports logind, and it doesn't depend on libupower-glib at all any more.