unity screen saver no longer blanks nor locks automatically

Bug #1377847 reported by Andy Whitcroft on 2014-10-06
504
This bug affects 57 people
Affects Status Importance Assigned to Milestone
gnome-desktop3 (Ubuntu)
Critical
Chintana Prabhu
Utopic
Critical
Chintana Prabhu
unity-settings-daemon (Ubuntu)
Critical
Unassigned
Utopic
Critical
Unassigned

Bug Description

After updating over the weekend the screen saver is no longer blanking or locking.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: unity 7.3.1+14.10.20140915-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
Uname: Linux 3.16.0-20-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.7-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Mon Oct 6 09:44:32 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-06-20 (472 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130618)
SourcePackage: unity
UpgradeStatus: Upgraded to utopic on 2013-11-10 (329 days ago)

Related branches

Andy Whitcroft (apw) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Confirmed. I did a fresh utopic daily install yesterday, and setting "switch off screen" to 1 min and "lock screen" to 30 s doesn't do anything at least for my account. This is with my ancient config, but I also confirmed this with a fresh user account.

Changed in unity (Ubuntu):
importance: Undecided → High
tags: added: regression-release
Iain Lane (laney) wrote :

Tim's going to look into this, it was caused by the gnome-desktop3 update - reverting this code to before the update fixes the issue (but may break gnome-shell)

affects: unity (Ubuntu Utopic) → gnome-desktop3 (Ubuntu Utopic)
Changed in gnome-desktop3 (Ubuntu Utopic):
assignee: nobody → Tim (darkxst)
Steve Langasek (vorlon) on 2014-10-06
Changed in gnome-desktop3 (Ubuntu Utopic):
importance: High → Critical
information type: Public → Public Security
Tim Lunn (darkxst) wrote :

gnome-shell uses idle monitor directly (as does unity-settings-daemon) if we revert the code in gnome-desktop we are going to have two independent idle monitors running, the one used via gnome-desktop plus the directly accessed one.

Alternatively if unity-settings-daemon exposes the d-bus interface then we only have one idle monitor that is accessed by everyone. This is more or less what I did previously in my displayconfig attempts, so I have copied the relevant bits (from mutter 3.10 with lots of renaming etc) and hooked it into u-s-d.

test package is at ppa:darkxst/libusd its mostly working but maybe crashing occassionally, trying to catch it in gdb so I can investigate

Seth Arnold (seth-arnold) wrote :

My trusty laptop has the same problem (bug 1378177 was duped here) -- just a note that 'xset dpms 300 9999 9999' allows my screen to turn off properly after five minutes.

tags: added: trusty
Tim Lunn (darkxst) wrote :

fwiw, crash I mentioned in #5 has been fixed, in my MP and updated ppa also.

Seth this bug can't exist on trusty, the code causing it doesnt exist there, best to keep your bug separate!

Tim Lunn (darkxst) wrote :

Just to clarify the cause of this bug, is that gnome-desktop 3.12 actually accesses the idle monitor through the mutter dbus API. gnome-session for the Presence module then in turn access the idle monitor via gnome-desktop. gnome-shell and unity-settings-daemon both directly use the idle monitor C-api so they were unaffected.

Seth Arnold (seth-arnold) wrote :

Thanks Tim, I'll go undup my bug again.

tags: removed: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Charles Profitt (cprofitt) wrote :

The command listed in #6 also worked on my Lenovo laptop.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.10.20141010-0ubuntu1

---------------
unity-settings-daemon (14.04.0+14.10.20141010-0ubuntu1) utopic; urgency=low

  [ Tim Lunn ]
  * Copy in Idle Monitor from 3.10 and hook up dbus interface (LP:
    #1377847)
 -- Ubuntu daily release <email address hidden> Fri, 10 Oct 2014 08:06:04 +0000

Changed in unity-settings-daemon (Ubuntu Utopic):
status: Confirmed → Fix Released
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Critical
Changed in unity-settings-daemon (Ubuntu Utopic):
importance: Undecided → Critical
Changed in gnome-desktop3 (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-desktop3 (Ubuntu Utopic):
status: Confirmed → Triaged
vvro (vvro) wrote :

On Ubuntu 14.10 with Gnome3 still doesn't turn the screen off or lock, with

unity-settings-daemon 14.04.0+14.10.20141014-0ubuntu1

even using the screen lock shortcut doesn't work.
Fresh install from the network installation.

Kirill Müller (krlmlr) wrote :

Same here: No locking with Ctrl+Alt+L, on timeout or after standby. Installing light-locker didn't help either.

Devon Cooke (devonavar) wrote :

This is showing of for me in the production release, and appears to have regressed in the latest version:

Currently installed version: 14.04.0+14.10.20141014-0ubuntu1

Happy to post logs if someone can tell me what to look for.

Devon Cooke (devonavar) wrote :

Note: Unlike the two comments above, I *can* use Ctrl-Alt-L to lock. Not sure if the screen will turn off in this mode. I will test.

Also, it doesn't seem to be 100% consistent. The screen has turned off once or twice since I upgraded to Utopic, but 90% of the time it hasn't.

Devon Cooke (devonavar) wrote :

Per comment above, the screen *does* turn off when I manually lock the system with Ctrl-Alt-L

Oliver Marks (oly) wrote :

I hit this problem just running gnome-screensaver & on the command line seemed to kick it back into action so that ctrl + alt + L now works seems its not started at boot.

Kirill Müller (krlmlr) wrote :

Still having the same problem. However, after issuing `gnome-screensaver-command -l` once, the screen saver seems to be active during the rest of the session. (Ctrl+Alt+L still doesn't work, though.)

Have the same problem, it works with ctrl alt l but not always by it self.

John Ferlito (johnf-inodes) wrote :

Should gnome-screensaver be running after login?

It isn't for me on utopic and once I have it running in the background then locking seems to work fine.

Tim Lunn (darkxst) wrote :

I don't think Unity uses gnome-screensaver anymore, afaik its only used by the legacy GNOME2-ish desktops.

Changed in gnome-desktop3 (Ubuntu):
assignee: Tim (darkxst) → nobody
Changed in gnome-desktop3 (Ubuntu Utopic):
assignee: Tim (darkxst) → nobody
Tin Tvrtkovic (tinchester) wrote :

So is this bug supposed to be fixed? Because I'm still having issues running unity-settings-daemon 14.04.0+14.10.20141014-0ubuntu1.

Actually, the screen will blank a couple of times on time, but as time goes by (days), it'll stop. The suspend timer still works, just the screen won't blank. I can actually temporarily fix it by going to the brightness and lock settings and changing the time (1 minute to 2 minutes) and back.

I have a system where the screen is locking, the screen is blanking, but at some point it is being powered again. I haven't investigated further what is causing this. I'm using plain Unity, 14.10 Ubuntu, and I have an Nvidia card in this system. Every morning when I arrive to my office I have the lightdm lock screen and the screen is not blank. I haven' t try what comment #24 says.

Claus Lensbøl (cmol) wrote :

I still have this issue too.
unity-settings-daemon is version 14.04.0+14.10.20141014-0ubuntu1

I can lock with ctrl + alt + l manually, but the screen doesn't lock automatically.

Roy Kimbrell (roy-kimbrell) wrote :

I am running 14.10 including all current Canonical patches. Screen will not blank - either automatically or with ctrl-alt-l. At reboot, it will blank by itself, but after I run some programs (browser, etc.) it will not blank automatically. Tried 'gnome-screensaver &' and got a response that it was already running.

Shoham Peller (shoham-peller) wrote :

This bug still happens in a freshly installed, fully patched Ubuntu - on both version 15.04 and 14.04. Hadn't tested on 14.10
On both versions the session is not locked after the time specified in unity-control-center.
ctrl+alt+L works on both

Ubuntu 14.04:
unity-settings-daemon 14.04.0+14.04.20140606-0ubuntu2
unity-control-center 14.04.3+14.04.20140922-0ubuntu1
gnome-desktop3 3.8.4-0ubuntu3.1

Ubuntu 15.04:
unity-settings-daemon is 15.04.1+15.04.20150408-0ubuntu1
unity-control-center is 15.04.0+15.04.20150410-0ubuntu1
gnome-desktop3 is 3.14.1-1ubuntu2

I think the "Fixed Released" state needs to be reverted

Changed in gnome-desktop3 (Ubuntu):
assignee: nobody → Chintana Prabhu (chintanarp98)
Changed in gnome-desktop3 (Ubuntu Utopic):
assignee: nobody → Chintana Prabhu (chintanarp98)
Changed in unity-settings-daemon (Ubuntu):
assignee: nobody → Chintana Prabhu (chintanarp98)
Changed in unity-settings-daemon (Ubuntu Utopic):
assignee: nobody → Chintana Prabhu (chintanarp98)
Changed in unity-settings-daemon (Ubuntu):
assignee: Chintana Prabhu (chintanarp98) → nobody
Changed in unity-settings-daemon (Ubuntu Utopic):
assignee: Chintana Prabhu (chintanarp98) → nobody
Changed in gnome-desktop3 (Ubuntu Utopic):
status: Triaged → Won't Fix

Same problem on 16.04 as well as 16.10, using standard Ubuntu/Unity desktop environment. Locking manually works fine, but the automatic timer does not.

This is a security requirement in my organization, and the fact that the Brightness & Lock settings panel reports that this setting is active when it actually isn't is a pretty serious concern.

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers