Upgrade from Ubuntu 9.04 to 9.10 fails with essential package 'ubuntu-minimal' can not be found anymore (mirror overloaded)

Bug #446956 reported by phsab on 2009-10-09
450
This bug affects 78 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt
Karmic
High
Michael Vogt
Lucid
High
Michael Vogt

Bug Description

Because of the overloaded servers update-manager gives a unclear error message that ubuntu-minimal is missing and aborts (doing a proper cleanup and no harm in any way to the system). The error message is problematic because the real problem is that the server in question is so loaded that it does not return useful data (a comination of 111 connection refused, 403, 404 was observed).

If you experience the problem, please run "update-manager --proposed (or do-release-upgrade --proposed) to get better error checking and let us know here in the bugreport if it helps getting at least a better error message (we can not do a lot to make the servers less loaded at this point).

TEST CASE (for SRU verification):
1. switcht to es.archive.ubuntu.com
2. run the upgrade (update-manager or do-release-upgrade)
3. watch it fail with a unclear error message about "ubuntu-minimal missing"
4. run "update-manager --proposed" (or do-release-upgrade --proposed)
5. watch it give a better error message about overloaded servers

Upgrade from UNR 9.04 to 9.10 fails after having retreived all the necessary files with the following error:

----
Invalid package information

After your package information was updated the essential package 'ubuntu-minimal' can not be found anymore.
This indicates a serious error, please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.
----

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: update-manager 1:0.111.9
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
Tags: ubuntu-unr
Uname: Linux 2.6.28-15-generic i686

phsab (phsab) wrote :
Shane Kavanagh (shane-kavanagh) wrote :
sys4096 (hla) wrote :

After your package information was updated the essential package 'ubuntu-minimal' can not be found anymore.
This indicates a serious error, please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

ruleant (dieter-adriaenssens) wrote :
ruleant (dieter-adriaenssens) wrote :
guivho (guivho) wrote :
guivho (guivho) wrote :

The original report is about the i386 version.

I have the problem on an amd64 architecture, running 9.04.

My uname reports Linux 2.6.28-16-generic x86_64.

My ProcEnviron section from apport reads:
LC_TIME=nl_BE.UTF-8
LC_MONETARY=nl_BE.UTF-8
PATH=(custom, user)
LC_TELEPHONE=nl_BE.UTF-8
LANG=en_US.UTF-8
SHELL=/bin/bash
LC_MEASUREMENT=nl_BE.UTF-8
LC_NUMERIC=nl_BE.UTF-8
LC_PAPER=nl_BE.UTF-8

NonfreeKernelModules: fglrx

Package: update-manager 1:0.111.9

My /var/log/dist-upgrade/main.log is available from my earlier post.

Grobbelaar (giatav) wrote :
Grobbelaar (giatav) wrote :
Spencer Bliven (quantum7) wrote :
joncaplan (joncaplan-gmail) wrote :

Got error when upgrading Kubuntu 9.04 to 9.10.

CrawfordBest (cbestsf) wrote :
CrawfordBest (cbestsf) wrote :
Wayne Moses Burke (wmburke) wrote :

I'm on Ubuntu 9.04 upgrading to 9.10.

All files in /var/log/dist-upgrade/ except the two apt-term.log files that wouldn't be read or opened.

Mike Sherman (michaelwsherman) wrote :

I also have this bug, 32 bit system, going from 9.04 to 9.10.

The first time I attempted to upgrade, the upgrade stalled on I think "Getting New Packages", I think while downloading file 392 of a lot more than that. I canceled the upgrade then rebooted. I started the upgrade again, and got this error on "Setting New Software Channels", "Checking Package Manager" at the bottom.

I am very new at this, sorry if this is useless information. I'd normally go to forums but cannot find any forums where this error is discussed.

saMar (juanangel) wrote :

I'm upgrading from 9.04(new desktop install) to 9.10 and the update-manager displays the same message.

I have commented all third party repositories by hand in /etc/apt/sources.list and then in worked.

Michael Vogt (mvo) wrote :

Thanks for your bugreport and for the logs.

I suspect that the problem is that the mirrors are overloaded and that this is insufficiently captured from update-manager and that it presents a bogus error message. If that happens to you, could you please run in a terminal:
$ ls -R /var/lib/apt/lists > /tmp/lists.txt
and attach /tmp/lists.txt ?

Could you also please run "sudo apt-get update" afterwards and see it shows any errors or warnings?

Changed in update-manager (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
- 'ubuntu-minimal' can not be found anymore
+ 'ubuntu-minimal' can not be found anymore (mirror overloaded?)

I was now able to reproduce this problem here with the es.archive.ubuntu.com mirror. It looks like the mirror is returning 111 (connection refused) because its too loaded. But update-manager does not capture this error condition that properly and continues. The sanity check about ubuntu-minimal later is then hit and the upgrade aborted. The good news is that nothing is changed and the jaunty system will be in its original state. I'm working now on capturing the error properly.

Weird. I filed this bug weeks ago and I cannot imagine that the
serverload was high then. However if it is though possible to capture
the error properly and it solves the issue: hurray! ;)

--

sjoerd blom

Verstuurd vanaf mijn iPhone

Op 30 okt 2009 om 09:40 heeft Michael Vogt <email address hidden>
het volgende geschreven:\

> I was now able to reproduce this problem here with the
> es.archive.ubuntu.com mirror. It looks like the mirror is returning
> 111
> (connection refused) because its too loaded. But update-manager does
> not
> capture this error condition that properly and continues. The sanity
> check about ubuntu-minimal later is then hit and the upgrade aborted.
> The good news is that nothing is changed and the jaunty system will be
> in its original state. I'm working now on capturing the error
> properly.
>
> --
> Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
> 'ubuntu-minimal' can not be found anymore (mirror overloaded?)
> https://bugs.launchpad.net/bugs/446956
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “update-manager” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: update-manager
>
> Upgrade from UNR 9.04 to 9.10 fails after having retreived all the
> necessary files with the following error:
>
> ----
> Invalid package information
>
> After your package information was updated the essential package
> 'ubuntu-minimal' can not be found anymore.
> This indicates a serious error, please report this bug against the
> 'update-manager' package and include the files in /var/log/dist-
> upgrade/ in the bug report.
> ----
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: update-manager 1:0.111.9
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: update-manager
> Tags: ubuntu-unr
> Uname: Linux 2.6.28-15-generic i686

Commenting all third party sources did the trick for me too.
I am upgrading right now.
So I wonder whether not catching the mirror error condition is really the only culprit.

Michael Vogt (mvo) on 2009-10-30
summary: Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
- 'ubuntu-minimal' can not be found anymore (mirror overloaded?)
+ 'ubuntu-minimal' can not be found anymore (mirror overloaded)
Changed in update-manager (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → High

Thanks Joerd and Guivho for the additional information. There may be another bug here hiding somewhere, I'm adding code for better error handling now.

summary: - Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
- 'ubuntu-minimal' can not be found anymore (mirror overloaded)
+ Upgrade from Ubuntu 9.04 to 9.10 fails with essential package 'ubuntu-
+ minimal' can not be found anymore (mirror overloaded)
Martin Pitt (pitti) on 2009-10-30
Changed in update-manager (Ubuntu Karmic):
assignee: nobody → Michael Vogt (mvo)

Accepted update-manager into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed

I reran the update 30 minutes later and did not see the bug again. Your
theory seems reasonable.

-Jon

On Fri, Oct 30, 2009 at 4:15 AM, Michael Vogt <email address hidden>wrote:

> Thanks for your bugreport and for the logs.
>
> I suspect that the problem is that the mirrors are overloaded and that this
> is insufficiently captured from update-manager and that it presents a bogus
> error message. If that happens to you, could you please run in a terminal:
> $ ls -R /var/lib/apt/lists > /tmp/lists.txt
> and attach /tmp/lists.txt ?
>
> Could you also please run "sudo apt-get update" afterwards and see it
> shows any errors or warnings?
>
> ** Changed in: update-manager (Ubuntu)
> Importance: Undecided => High
>
> ** Changed in: update-manager (Ubuntu)
> Status: New => Confirmed
>
> ** Summary changed:
>
> - Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
> 'ubuntu-minimal' can not be found anymore
> + Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
> 'ubuntu-minimal' can not be found anymore (mirror overloaded?)
>
> --
> Upgrade from Ubuntu UNR 9.04 to 9.10 fails with essential package
> 'ubuntu-minimal' can not be found anymore (mirror overloaded?)
> https://bugs.launchpad.net/bugs/446956
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “update-manager” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: update-manager
>
> Upgrade from UNR 9.04 to 9.10 fails after having retreived all the
> necessary files with the following error:
>
> ----
> Invalid package information
>
> After your package information was updated the essential package
> 'ubuntu-minimal' can not be found anymore.
> This indicates a serious error, please report this bug against the
> 'update-manager' package and include the files in /var/log/dist-upgrade/ in
> the bug report.
> ----
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: update-manager 1:0.111.9
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: update-manager
> Tags: ubuntu-unr
> Uname: Linux 2.6.28-15-generic i686
>

Giovanni G. (giovanni-g) wrote :

Ran update 2 times in a row and I got the bug on AMD64 (64 bit version). Now I am going to give it a 3rd run

Giovanni G. (giovanni-g) wrote :

Confirmed, third run was fine. So it definitely looks like a bad handled congestion problem

phsab (phsab) wrote :

Confirmed. It's working fine now.
Thank you for the quick solution!

Vïctor Agudo (vag-vks) wrote :
Vïctor Agudo (vag-vks) wrote :
Michael Vogt (mvo) on 2009-10-31
description: updated
Moryan (arnaud-deville) wrote :

After your package information was updated the essential package 'ubuntu-minimal' can not be found anymore.
This indicates a serious error, please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.

KrisJanuarius (kris-januarius) wrote :

Worked for me now, seems to confirm the server theory. Thanks !!!

Robert Di Gioia (digioiar) wrote :

I was able to upgrade successfully overnight. Thanks

Martin Pitt (pitti) on 2009-11-02
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.126.9

---------------
update-manager (1:0.126.9) karmic-proposed; urgency=low

  * DistUpgrade/DistUpgrade.cfg:
    - really stop enabling apport during the upgrade (LP: #465619)

update-manager (1:0.126.8) karmic-proposed; urgency=low

  * when the server is overloaded and no Release file information
    can be obtained, show a better error message instead of the
    bogus "ubuntu-minimal" is missing (LP: #446956)

update-manager (1:0.126.7) karmic-proposed; urgency=low

  * po/*.po:
    - update translations from LP (LP: #460547)
  * UpdateManager/Core/DistUpgradeFetcherCore.py:
    - check if running on a system with noexec /tmp and give a propper
      error message (LP: #461744)
  * DistUpgrade/DistUpgradeViewGtk.py:
    - add missing locale.bindtextdomain() (LP: #460547)

 -- Brian Murray <email address hidden> Fri, 30 Oct 2009 13:54:08 -0700

Changed in update-manager (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Michael, can't copy to lucid because lucid's version is newer than karmic's. Please fix in lucid ASAP.

Changed in update-manager (Ubuntu Lucid):
assignee: nobody → Michael Vogt (mvo)
milestone: none → lucid-alpha-1
status: Confirmed → Fix Committed
Michael Vogt (mvo) on 2009-11-13
Changed in update-manager (Ubuntu Lucid):
status: Fix Committed → Fix Released

In the last couple of days, I tried a couple of times to upgrade without any luck.
After I disabled all third-party repositories, the upgrade is working while i'm writing this comment.

2009/11/25 Bert Vorenholt <email address hidden>

> In the last couple of days, I tried a couple of times to upgrade without
> any luck.
> After I disabled all third-party repositories, the upgrade is working while
> i'm writing this comment.
>

About two weeks ago, I finally did manage to upgrade from, in my case,
Kubuntu 9.04 to 9.10 - including all the third party software repositories..
However, I needed to bug-fix something essential a few days after the
upgrade: a package that is essential for the interaction with the video
card. Now, the system is running quite well. Only the sound is again a point
of reflection and research. But I am not yet sure whether this is a hardware
or software problem.

Respectfully yours.

Bas.

>
> --
> Upgrade from Ubuntu 9.04 to 9.10 fails with essential package
> 'ubuntu-minimal' can not be found anymore (mirror overloaded)
> https://bugs.launchpad.net/bugs/446956
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Luke Ashe-Browne (lukeab) wrote :

I just want to update this bug as I am experiencing it with an old Dapper server, trying to update to Hardy, after multiple attempts, and trying the -p|--proposed switch gets me no further either.

I am attaching a tar.gz of my apt.log, main.log and main_pre_req.log from /var/log/dist-upgrade/ directory on the server.

To post a comment you must log in.