package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Couldn't configure pre-depend cups for cups-pdf, probably a dependency cycle.

Bug #262676 reported by Dereck Wonnacott on 2008-08-29
94
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

well, I see other users had this issue when upgrading in the past. I'll make those as duplicates of this bug shortly.

/var/log/dist-upgrade stuff attached

ProblemType: Package
Architecture: amd64
Date: Fri Aug 29 04:57:05 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Couldn't configure pre-depend cups for cups-pdf, probably a dependency cycle.

NonfreeKernelModules: nvidia
Package: update-manager 1:0.87.30
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.30 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Couldn't configure pre-depend cups for cups-pdf, probably a dependency cycle.
Uname: Linux 2.6.24-21-generic x86_64

Dereck Wonnacott (dereck) wrote :
Changed in update-manager:
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I was not able to reproduce this, but I would be very intressted to, could you please make tar.gz of your /var/lib/apt and /var/lib/dpkg directories and /etc/apt/ available somewhere ? alternatively I can try recreating your environment with the output of "dpkg --get-selections" and your sources.list

Changed in update-manager:
assignee: nobody → mvo
status: New → Incomplete
Dereck Wonnacott (dereck) wrote :

t'was probably a transient issue with the package, I can't produce the error currently. I ended up removing cups-pdf and later reinstalling it. if it would help I'll get you those files, but I think they are moot now.

Changed in update-manager:
status: Incomplete → New
Brian Murray (brian-murray) wrote :

We are still awaiting the information Michael requested so I am setting the status to Incomplete, perhaps a duplicate of this bug can get the files needed.

Changed in update-manager:
status: New → Incomplete
uvi (vladimir-umnov) wrote :

I have already upgraded by removing cups-pdf, I attached dist-upgrade files, but have no idea will it help now.

uvi (vladimir-umnov) wrote :

sources.list was like this and I used apt-cacher with http cgi interface, now I use apt-cacher as a proxy:
deb http://archive.ubuntu.com/ubuntu intrepid-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu intrepid-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu intrepid-backports restricted
deb http://archive.ubuntu.com/ubuntu/ intrepid main restricted universe multiverse
deb-src http://debian.ejohansson.se/debian/ sid main

Efrain Valles (effie-jayx) wrote :

I can second this bug. I have upgraded from dapper to hardy and now to intrepid. Same issue. I will try to install and go through te upgrade path to see if I can confirm again on clean repos.

Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

Hm, it looks like the fix is not sufficient, or at least it gives different behaviour from the default pre-depedns. It seems that the cups-pdf postinst depends on a running cups.

mhumm2 (mhumm2) wrote :

I just suffered the same error attempting to upgrade from 8.04 to 9.04, 32 bit.

Is the current work-around to delete cups-pdf, upgrade, then install cups-pdf on the new system? Please advise.

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 356781, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in update-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers