Ubuntu

[regression] Unity panel transparency (active blur) not updating properly

Reported by Ethan Duff on 2011-10-03
230
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Unity
Low
Daniel van Vugt
5.0
Low
Tim Penhey
unity (Ubuntu)
Low
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
1. Set the Unity panel to be partially transparent by changing its opacity in CCSM. You might have to log out and in again for this to take effect.
2. Drag a window under the panel using Alt+Left-click. Once the client area of the window goes under the panel it will redraw using a blur effect.
3. Drag the window back out from under the panel.
   -> Verify that the image of part of the blurred window DOES NOT remain under the panel and that the panel updates correctly

[Regression Potential]
Visual regressions, shell drawing problems. Part of a big change, many regression potentials.

Original description:

TEST CASE:

1. Set the Unity panel to be partially transparent by changing its opacity in CCSM. You might have to log out and in again for this to take effect.

2. Drag a window under the panel using Alt+Left-click. Once the client area of the window goes under the panel it will redraw using a blur effect.

3. Drag the window back out from under the panel. The image of part of the blurred window remains under the panel.

WORKAROUND:

Right-clicking on the desktop seems to force the panel to redraw and the artefacts to disappear.

ORIGINAL DESCRIPTION:

When changing desktops with "Ctrl + Alt + Up" the top panel will have the window color blended into it rather than the desktop background color

Compiz unity plugin panel opacity experimental option

Related branches

lp:~vanvugt/unity/fix-865006
Merged into lp:unity at revision 2410
Sam Spilsbury (community): Approve on 2012-06-14
Unity Team: Pending requested 2012-06-13
lp:~thumper/unity/regional-damage-sru
Merged into lp:unity/5.0 at revision 2394
Łukasz Zemczak: Approve on 2012-08-02
Marco Trevisan (Treviño): Approve on 2012-08-01
Daniel van Vugt: Approve on 2012-07-27
Robert Roth (evfool) on 2011-10-03
affects: ubuntu → unity (Ubuntu)
Cristian Andrade (emakedie) wrote :

i have the same bug

Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Ethan Duff (ejd9) wrote :

@Omer Akram

Steps to reproduce the bug
1
) Set the top panel opacity value to something like 20% in the unity plugin options for CompizConfig Settings Manager
2) open a full screen window, with a background color different to the desktop background color
3) shift down one desktop and then shift back up. The top panel should be a different color than it used to be

Omer Akram (om26er) wrote :

there is a confusion in understanding the exact problem, would it be possible for you to make a video to show the problem?

Daniel van Vugt (vanvugt) wrote :

Confirmed. This is a regression, seemingly related to the blur effect added in Ubuntu 11.10. Ubuntu 11.04 had no such problems redrawing.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
summary: - top panel transparency color not updating properly ubuntu 11.10
+ Unity panel transparency color not updating properly Ubuntu 11.10
tags: added: regression-release

Here's a video showing the bug.

description: updated
Daniel van Vugt (vanvugt) wrote :

When you start the Workspace Switcher (Super+S) the desktop background is still visible under the panel (but not the launcher). I suspect that's the same bug as this one.

tags: added: oneiric
Daniel van Vugt (vanvugt) wrote :

Looks like this bug might be solved by fixing bug 861061.

summary: - Unity panel transparency color not updating properly Ubuntu 11.10
+ Unity panel transparency (active blur) not updating properly Ubuntu
+ 11.10
summary: - Unity panel transparency (active blur) not updating properly Ubuntu
- 11.10
+ [regression] Unity panel transparency (active blur) not updating
+ properly Ubuntu 11.10

The workaround of right-clicking on the desktop to force the panel transparency to update doesn't work any more in Unity 4.28.0 (and presumably Unity 5.x?).

Sam, can you suggest any other possible workaround?

summary: [regression] Unity panel transparency (active blur) not updating
- properly Ubuntu 11.10
+ properly in Ubuntu 11.10

My workaround is to clear and repopulate the desktop (Ctrl-Alt-D twice, though I'm sure it used to be Super-D - not sure why/when mine changed)

None of the above workarounds fix it for me.

Also happens when

1) showing all desktops (super+s)

2) moving between them crtl+alt+arrow

3) changing the wallpaper

these 3 issues can be solved using alt+f2 type compiz --replace --lose-binding (enter)

but the issue dragging a window behind it remains, less noticeable but remains.

Sorry about my bad english.

Although there is a fix for bug 861061, this problem still persists in 12.04 Alpha.

Omer Akram (om26er) on 2012-03-01
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Low
X (s-u) wrote :

this problem appears for me too when I enable auto-change wallpapers and active blur.

Leuke (leuke) wrote :

I confirm this problem is still present in 12.04 Beta.

I do have the same problem and that's pretty annoying with ubuntu 12.04 !

Omer Akram (om26er) on 2012-04-02
summary: [regression] Unity panel transparency (active blur) not updating
- properly in Ubuntu 11.10
+ properly
Jonathan Ferreira (j0n4tfds) wrote :

I saw another annoying bug related to the panel transparency beyond the related above:

- The letters' shadows in the fading is not disappearing properly in transparency 100%, although the backgrounds updates okay.

I tried to reproduce the bug to exemplify in the attachment.
I am using Ubuntu 12.04 now, and I not remember see this bug back in 11.10.

Mario (mariodopico) wrote :

I have the same problem after the a suspend resume.

MY WORKAROUND:

Create a keyboard shortcut (I have it assigned to Ctrl-F12) with the following command:

sh -c 'gconftool-2 --type float --set /apps/compiz-1/plugins/unityshell/screen0/options/panel_opacity 1; sleep 1; gconftool-2 --type float --set /apps/compiz-1/plugins/unityshell/screen0/options/panel_opacity 0.3'

0.3 = My Panel Opacity, put the value that you like

Press Ctrl-F12 and panel opacity ok ;-)

Yep, 12.04 LTS it's affected too.
El 02/04/2012 16:06, "Alexandre Roux (Phoenamandre)" <
<email address hidden>> escribió:

> I do have the same problem and that's pretty annoying with ubuntu 12.04
> !
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (949420).
> https://bugs.launchpad.net/bugs/865006
>
> Title:
> [regression] Unity panel transparency (active blur) not updating
> properly in Ubuntu 11.10
>
> Status in Unity:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> TEST CASE:
>
> 1. Set the Unity panel to be partially transparent by changing its
> opacity in CCSM. You might have to log out and in again for this to
> take effect.
>
> 2. Drag a window under the panel using Alt+Left-click. Once the client
> area of the window goes under the panel it will redraw using a blur
> effect.
>
> 3. Drag the window back out from under the panel. The image of part of
> the blurred window remains under the panel.
>
> WORKAROUND:
>
> Right-clicking on the desktop seems to force the panel to redraw and
> the artefacts to disappear.
>
> ORIGINAL DESCRIPTION:
>
> When changing desktops with "Ctrl + Alt + Up" the top panel will have
> the window color blended into it rather than the desktop background
> color
>
> Compiz unity plugin panel opacity experimental option
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/865006/+subscriptions
>

I'm not quite sure if this is related to the bug - but where is transparency calculated? On the CPU or GPU?

Too me the transparency update behaviour reminds me of the pre-compiz days fake transparency seen in Eterm, or aterm.

I even think it's hard to encounter this bug if the transparency is calculated on the GPU, because you'd need to "keep" an old texture, for transparency you usually don't for being a trivial operation on the GPU, so you avoid caching and just recalculate every frame.

I guess you would only cache it if you use the CPU for calculating transparency. But that's not a good idea, right?

However, I think the update-behaviour should be in sync with the compiz refresh cycles, because the idea must be "every frame is perfect".

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity:
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2410

Changed in unity:
milestone: none → 6.0
Omer Akram (om26er) on 2012-06-27
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity/5.0 at revision 2394

description: updated
description: updated

Hello Ethan, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Alan Pope ㋛ (popey) wrote :

I can no longer reproduce this with -proposed enabled on 12.04. Looks fixed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.16.0-0ubuntu1

---------------
unity (5.16.0-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - Update libgeis-dev and libgrail-dev dependencies in debian/control
  * New upstream release.
    - launcher is not refreshed after user session switch (LP: #1016430)
    - Dragging windows around is slow/sluggish/laggy when multiple monitors
      are enabled (LP: #874619)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - Tooltips backgrounds are not refreshed (no active blur) (LP: #967112)
    - [regression] Unity panel transparency (active blur) not updating properly
      (LP: #865006)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Black background around after dash is restored (LP: #992516)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - [SRU regression] alt-grave not switching to next window unless 'grave'
      pressed twice (LP: #1035668)
    - [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
      incomplete/missing (LP: #1034164)
    - [nvidia] unity crashed in
      nux::GraphicsEngine::QRP_GLSL_1Tex (glDrawArrays) (LP: #1031554)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Compiz won't start if "unredirect fullscreen windows" is enabled
      (LP: #980663)
    - [regression] Unity launcher on-screen corruption on resume from suspend
      with nVidia proprietary driver (LP: #915265)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - [nvidia] compiz crashed with SIGSEGV in
      nux::BasePainter::PaintBackground (LP: #982626)
    - Update dependency on the renamed libgeis

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest nux as libgeis-dev and libutouch-geis-dev are
      conflicting (LP: #1047385)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Sep 2012 10:53:17 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers