Compiz crashes when (en|dis)abling a plugin (ccsm) aka compiz crashed with SIGSEGV in sigc::signal_base::impl()

Bug #685552 reported by Sam_ on 2010-12-05
This bug affects 429 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
unity (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: compiz

First off wasn't able to upload report while the crash occured due to message: disk space left only 1MB.
RAM is 1GB.
Removed .xession-errors which had more than 60MB, compiz crash report had 119MB. After that I was able to file this bug via terminal. So there is no .xsession-errors included.
Procedure:
Install CCSM.
Enable Ring Switcher. Result: crash ## Popup window: Due to Compiz shutdown, report a bug, restart or close.
I choose to restart, after this desktop reloads everthing, except CCSM in unity pane is gone (every time after restarting compiz).

Enable Desktop Cube. Result: crash and same popup window as above.
I choose to report a bug. Result: Total freeze, probably due to less space. No keys work e.g. to open a terminal, screen is empty, only CCSM is still open without window borders, graphic is corrupt. Doesn't let me make a screenshot due to less disk space. (Made it later after removing logfiles.)

Workaround: create a folder via right click on desktop, you're not able to give it a name, because you can't type anything.
Open the folder, it opens Nautilus. Navigate to /usr/share/applications and double click on 'compiz'. Desktop reloads, but still looks like the screenshot. Also removed logfiles.

Change wallpaper and transparency of viewport. Result: crash. No window borders, no key function.
Restart compiz via /usr/share/applications.
Now everthing comes up ok and due to cleaning some diskspace able to file a bug.

Live-session
$ ubiquity --version
2.5.3
$ dpkg -l unity; dpkg -l compiz; dpkg -l compizconfig-settings-manager
ii unity 3.2.2-0ubuntu2
ii compiz 1:0.9.2.1+glibmainloop2-0ubuntu1
ii compizconfig-settings-manager 0.9.2.1-0ubuntu1
$ lsb_release -a
Description: Ubuntu natty (development branch)
Release: 11.04
Codename: natty
$ uname -a
Linux ubuntu 2.6.37-7-generic #19-Ubuntu SMP Tue Nov 30 23:45:33 UTC 2010 x86_64 GNU/Linux

http://launchpadlibrarian.net/60140483/lspci.txt

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.2.1+glibmainloop2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic x86_64
Architecture: amd64
CompizPlugins: [shift,wobbly]
Date: Sun Dec 5 14:32:02 2010
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
Lsusb:
 Bus 002 Device 002: ID 046d:c03e Logitech, Inc. Premium Optical Wheel Mouse (M-BT58)
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-7185
PackageArchitecture: all
PciDisplay: 05:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)] [1002:5b60] (prog-if 00 [VGA controller])
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu2
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: compiz
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 08/14/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MS-7185
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd08/14/2006:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7185:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7185:rvr1.0:cvn:ct3:cvr:
dmi.product.name: MS-7185
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.37-7-generic
---
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgjpeg,imgpng,imgsvg,mousepoll,move,obs,place,regex,resize,screenshot,session,text,vpswitch,winrules,wobbly,animation,shift,workarounds,fade,opacify,cube,rotate,scale,unitymtgrabhandles,cubeaddon,expo,ezoom,switcher,unityshell,ring]
CompositorRunning: compiz
DRM.card0.HDMI.A.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1920x1080 1920x1080i 1680x1050 1280x1024 1280x1024 1440x900 1440x900 1280x960 1280x800 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBMLUoHAAAAABUUAQOANR54Cu6Ro1RMmSYPUFS/74BxT4EAgUCBgJUAlQ+zAAEBAjqAGHE4LUBYLEUAEyshAAAeAjqA0HI4LUAQLEWAEyshAAAeAAAA/QAYSxpRFwAKICAgICAgAAAA/ABTTUZYMjQ5MEhECiAgAYoCAxzxS5MEBRQDEhAfICEiIwkHB2cDDAAQALgtAR2A0HIcFiAQLCWAEyshAACeAR2AGHEcFiBYLCUAEyshAACeAR0AclHQHiBuKFUAEyshAAAejArQkCBAMSAMQFUAEyshAAAejArQiiDgLRAQPpYAEyshAAAeAAAAAAAAAAAAzg==
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
GdmLog2:

GraphicsCard:
 ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:174b]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
LiveMediaBuild__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
LiveMediaBuild___: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
LiveMediaBuild____: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
LiveMediaBuild_____: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
MachineType: System manufacturer System Product Name
Package: unity 3.8.10-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcKernelCmdLine_: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature___: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature____: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature_____: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
Tags: natty running-unity natty running-unity natty running-unity ubuntu compiz-0.9 natty running-unity natty running-unity natty running-unity ubuntu compiz-0.9
Uname: Linux 2.6.38-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/30/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0305
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5QLD PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0305:bd07/30/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5QLDPRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Related branches

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

Graphics are ok since 107,2MB are still free now. (s. screenshot) But after switching on or off random plugins Compiz doesn't restart itself. Windows are freezing, have no decoration and open in upper left corner. Compiz needs to be started via /usr/share/applications.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is missing the crash and without one there's nothing we can do. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.
If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Invalid
Erik B. Andersen (azendale) wrote :

Pedro,
I can reproduce this crash. However, there is no 'crash' directory in /var/ after the crash. I'm running natty, so it's definitely not an Ubuntu stable release.
Here's what happens on the terminal:
compiz --replace
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing gnomecompat options...done
Initializing mousepoll options...done
Initializing move options...done
Initializing place options...done
Initializing resize options...done
Initializing session options...done
Initializing vpswitch options...done
Initializing animation options...done
Initializing fade options...done
Initializing cube options...done
Initializing expo options...done
Initializing ezoom options...done
Initializing mag options...done
Initializing rotate options...done
Initializing scale options...done
Initializing staticswitcher options...done

** (<unknown>:5002): WARNING **: Unable to load GDesktopAppInfo for 'ubiquity-gtkui.desktop'

** (<unknown>:5002): WARNING **: Unable to load GDesktopAppInfo for 'ubuntuone-control-panel-gtk.desktop'
Initializing unityshell options...done
Setting Update "command_terminal"
Setting Update "run_command_terminal_key"
Setting Update "fullscreen_visual_bell"
IndicatorAdded: libappmenu.so
IndicatorAdded: libapplication.so
IndicatorAdded: libsoundmenu.so
IndicatorAdded: libmessaging.so
IndicatorAdded: libdatetime.so
IndicatorAdded: libme.so
IndicatorAdded: libsession.so
Setting Update "active_plugins"
Segmentation fault

How should I get apport to report this?

summary: - [Natty] compiz crash while switching plugins
+ [Natty] compiz crash while enabling or disabling plugins

On Fri, Dec 10, 2010 at 2:42 PM, Erik B. Andersen
<email address hidden> wrote:
> Pedro,
> I can reproduce this crash. However, there is no 'crash' directory in /var/ after the crash. I'm running natty, so it's definitely not an Ubuntu stable release.
> Here's what happens on the terminal:
> compiz --replace
> Backend     : gconf
> Integration : true
> Profile     : unity
> Adding plugins
> Initializing core options...done
> Initializing bailer options...done
> Initializing detection options...done
> Initializing composite options...done
> Initializing opengl options...done
> Initializing decor options...done
> Initializing gnomecompat options...done
> Initializing mousepoll options...done
> Initializing move options...done
> Initializing place options...done
> Initializing resize options...done
> Initializing session options...done
> Initializing vpswitch options...done
> Initializing animation options...done
> Initializing fade options...done
> Initializing cube options...done
> Initializing expo options...done
> Initializing ezoom options...done
> Initializing mag options...done
> Initializing rotate options...done
> Initializing scale options...done
> Initializing staticswitcher options...done
>
> ** (<unknown>:5002): WARNING **: Unable to load GDesktopAppInfo for
> 'ubiquity-gtkui.desktop'
>
> ** (<unknown>:5002): WARNING **: Unable to load GDesktopAppInfo for 'ubuntuone-control-panel-gtk.desktop'
> Initializing unityshell options...done
> Setting Update "command_terminal"
> Setting Update "run_command_terminal_key"
> Setting Update "fullscreen_visual_bell"
> IndicatorAdded: libappmenu.so
> IndicatorAdded: libapplication.so
> IndicatorAdded: libsoundmenu.so
> IndicatorAdded: libmessaging.so
> IndicatorAdded: libdatetime.so
> IndicatorAdded: libme.so
> IndicatorAdded: libsession.so
> Setting Update "active_plugins"
> Segmentation fault
>
>
> How should I get apport to report this?
>
> ** Summary changed:
>
> - [Natty] compiz crash while switching plugins
> + [Natty] compiz crash while enabling or disabling plugins
>

I know about this crash, it is because there is some signal not being
disconnected in the unityshell plugin, but I have not been able to
figure out which one.

> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in ubuntu.
> https://bugs.launchpad.net/bugs/685552
>
> Title:
>  [Natty] compiz crash while enabling or disabling plugins
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Affects me on my testing thinkpad t42. Have 2 users and both report "compiz crashed" when tryin to logout or shutdown. I have to wait a longer period then.
Packages 11.04 i386 from today.

[ 37.737393] compiz[1471]: segfault at 2c ip 0807e747 sp bfbaa4fc error 4 in compiz[8048000+68000]
[ 120.356534] compiz[1899]: segfault at 2c ip 0807e747 sp bffea23c error 4 in compiz[8048000+68000]
[ 445.265463] compiz[2234]: segfault at 6174733b ip 0807e74a sp bfaf468c error 4 in compiz[8048000+68000]
[ 473.944530] compiz[2520]: segfault at 2c ip 0807e747 sp bfe6a43c error 4 in compiz[8048000+68000]

ii compiz 1:0.9.2.1+glib

Sam_ (and-sam) on 2010-12-19
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
chillyperson23 (chillyperson23) wrote :

Enabled the crash handler. Seems to only happen when enabling the Unity plugin

chillyperson23 (chillyperson23) wrote :

Enabled the crash handler. Seems to only happen when enabling the Unity plugin

chillyperson23 (chillyperson23) wrote :

Enabled the crash handler. Seems to only happen when enabling the Unity plugin

affects: compiz (Ubuntu) → unity (Ubuntu)
summary: - [Natty] compiz crash while enabling or disabling plugins
+ [Natty] compiz crash while enabling or disabling unity compiz plugin

Compiz unloads (CompScreen dtor) and reloads (CompScreen ctor) almost all plugins each time a plugin is added or removed. All the Compiz plugins support that correctly, apart the Unity one which leaks GLib sources, GLib signals, sigc signals and some instances when it's unloaded. It crashes because some objects emit signals on instances that have already been destroyed.

It's a bug in Unity, but it revealed another bug in Compiz that shouldn't unload/reload plugins when a plugin is simply added/removed.

summary: - [Natty] compiz crash while enabling or disabling unity compiz plugin
+ Compiz crashes when enabling or disabling a plugin (ccsm)
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium

Are you sure that's a bug in Compiz? Perhaps it is unloading/reloading due to plugin inter-dependencies?

If so, that might be a "design flaw" in that plugins don't have set areas of "dependent" code vs "non-dependent" and a proper signaling mechanism for changes, but not really a "bug"...

Just tossing in my uninformed 2¢ on the bug that pushed me off Unity (well, that and window positioning and general performance of effects on my graphics card - that latter one being odd since I used to use compiz + a gaussian blur on translucent windows in 10.10 w/o issues).

Omer Akram (om26er) wrote :

Loic, Hey! since you have the fix in the linked branches why don't you propose a merge request?

Loïc Molinari (loic.molinari) wrote :

Omer: Unfortunately, that's still work in progress. The Unity plugin still crashes because of resources leaked at plugin destruction.

Kenny Strawn (realkstrawn93) wrote :

Bug 682499 is older than this one. However, trying to mark this bug as a duplicate of that one returns a timeout error.

Kenny Strawn (realkstrawn93) wrote :

And I have no idea why someone in this bug would go out of their way to mark a duplicate that this bug *happens to be a duplicate of*, *not* the other way around.

David Barth (dbarth) on 2011-03-28
Changed in unity:
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4

Changing title to make easier to people find this bug report (and don't report duplicates).

summary: - Compiz crashes when enabling or disabling a plugin (ccsm)
+ Compiz crashes when (en|dis)abling a plugin (ccsm) aka compiz crashed
+ with SIGSEGV in sigc::signal_base::impl()
David Barth (dbarth) on 2011-04-04
Changed in unity:
assignee: nobody → Loïc Molinari (loic.molinari)
hackel (hackel) wrote :

It concerns me that this bug is rated "medium" when we're so close to Natty's release... This is going to cause a lot of headaches for a *lot* of users once they try to upgrade, and it's going to drive them away from Unity, as already evidenced by comments on this bug report. Sorry that this comment is not actually helpful, I just hope it is given a higher priority as it already shows 35 people affected.

Download full text (5.4 KiB)

I have stated that several times before its a shame that this bug is at a
"medium" this bug can literary brake your Ubuntu system. leaving it so the
user would have to re-install or worse for ubuntu install another OS other
then ubuntu this is a critical error / bug in which it has the potential to
make or brake the ubuntu community. If anyone from canonical or head in the
ubuntu community you have been Warned.

On Mon, Apr 4, 2011 at 1:43 PM, hackel <email address hidden> wrote:

> It concerns me that this bug is rated "medium" when we're so close to
> Natty's release... This is going to cause a lot of headaches for a
> *lot* of users once they try to upgrade, and it's going to drive them
> away from Unity, as already evidenced by comments on this bug report.
> Sorry that this comment is not actually helpful, I just hope it is given
> a higher priority as it already shows 35 people affected.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (743780).
> https://bugs.launchpad.net/bugs/685552
>
> Title:
> Compiz crashes when (en|dis)abling a plugin (ccsm) aka compiz crashed
> with SIGSEGV in sigc::signal_base::impl()
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: compiz
>
> First off wasn't able to upload report while the crash occured due to
> message: disk space left only 1MB.
> RAM is 1GB.
> Removed .xession-errors which had more than 60MB, compiz crash report had
> 119MB. After that I was able to file this bug via terminal. So there is no
> .xsession-errors included.
> Procedure:
> Install CCSM.
> Enable Ring Switcher. Result: crash ## Popup window: Due to Compiz
> shutdown, report a bug, restart or close.
> I choose to restart, after this desktop reloads everthing, except CCSM in
> unity pane is gone (every time after restarting compiz).
>
> Enable Desktop Cube. Result: crash and same popup window as above.
> I choose to report a bug. Result: Total freeze, probably due to less
> space. No keys work e.g. to open a terminal, screen is empty, only CCSM is
> still open without window borders, graphic is corrupt. Doesn't let me make a
> screenshot due to less disk space. (Made it later after removing logfiles.)
>
> Workaround: create a folder via right click on desktop, you're not able to
> give it a name, because you can't type anything.
> Open the folder, it opens Nautilus. Navigate to /usr/share/applications
> and double click on 'compiz'. Desktop reloads, but still looks like the
> screenshot. Also removed logfiles.
>
> Change wallpaper and transparency of viewport. Result: crash. No window
> borders, no key function.
> Restart compiz via /usr/share/applications.
> Now everthing comes up ok and due to cleaning some diskspace able to file
> a bug.
>
> Live-session
> $ ubiquity --version
> 2.5.3
> $ dpkg -l unity; dpkg -l compiz; dpkg -l compizconfig-settings-manager
> ii unity 3.2.2-0ubuntu2
> ii compiz 1:0.9.2.1+glibmainloop2-0ubuntu1
> ii compizconfig-settings-manager 0.9.2.1-0ubuntu1
> $ lsb_release -a
> Description: Ubuntu natty (development branch)
> Release: 11.04
> ...

Read more...

I agree with hackel and antibushido. I installed beta1 and this happened within about 10minutes of it being installed (really!). My first thought was: "oh no, what have I done! Should I reinstall 10.10?". I'm persevering but Unity is still very buggy. +1 for raise to critical, this should definitely not be in the final release.

It cannot actually break a system, plus I believe the Medium rating is because ccsm is not installed by default. Finally, unity's current behaviour is to restart itself when it crashes, so this bug is not as harmful as it was.

FeNUMe (fenumed) wrote :

for me this crash occure before i install ccsm. I installed and run ubuntu tweak, then i start switching settings sections and compiz crashed.

sorry fo my english

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Omer Akram (om26er) wrote :

Even though ccsm does not come OOTB with Ubuntu but from the number of duplicates its quite clear how often people are going to crash unity while using ccsm. Raising the priority.

Changed in unity (Ubuntu):
importance: Medium → High

Ran into this same issue when I tried to uncheck the Enhanced Zoom Desktop plugin (which didn't seem to be serving any purpose as all the internal settings are set to 'disabled').

Got the same results when I installed ccsm and tested the same operation on a clean install under VirtualBox.

Only fix I could figure was to 'rm -rf .gconf/apps/compiz*' to blow away my settings. Just changing the settings back does not appear to work for all plugins.

On my case, I enabled "Crash handler" plugin and compiz disappeare

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
importance: Medium → High
antibushido (l337dperry) wrote :

found a good howto change from Desktop wall to Cube in Compiz. maybe someone can incorporate a fix from this here is a link

http://www.omgubuntu.co.uk/2011/04/compiz-cube-natty/?utm_source=feedburner&utm_medium=twitter&utm_campaign=Feed%3A+d0od+%28Omg!+Ubuntu!%29

pablomme (pablomme) wrote :

@antibushido: that is not a workaround for this bug. In fact, I don't understand the purpose of the OMG howto; you can enable the cube plugin via ccsm if you allow it to disable the unity plug in, then re-enable it yourself (it doesn't complain at that point), and run "unity --replace" from a terminal or a VT if compiz didn't respawn after the occurrence of this bug (twice, that is).

Had this bug a few minutes ago, reported in Bug #758521.

Johannes Postler (josi) wrote :

I can confirm, it also happens for the dbus-plugin of compiz (which is broken #749084)

Changed in unity (Ubuntu):
assignee: nobody → Loïc Molinari (loic.molinari)
David Klasinc (bigwhale) wrote :

Just tried enabling Resize Info plugin and I crashed compiz.

Jussier (jussierneto) wrote :

Just tried enabling Shift Switcher plugin and compiz crashes.
Same happens with Ring Switcher.

Jesús R Cabrera S (jrcsdev) wrote :

I think, this is a priority. Should be resolved soon... I need to use Ubuntu now!

Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
cgarre (cgarre) wrote :

The most interesting this is that it does error out ... and then compiz restarts again , we see the effects :) So actually the problem is it throws error, but if i ignore the error, everything seems to be fine :)

Doug McMahon (mc3man) wrote :

Hopefully it all gets fixed, if not the biggest issue is that some plugins, when enabled or disabled, will cause all the plugins to become unset
For newer users of natty this will cause some problems

Changed in unity (Ubuntu Natty):
milestone: none → ubuntu-11.04
Kenny Strawn (realkstrawn93) wrote :

According to Web Upd8 <http://www.webupd8.org/2011/04/final-ubuntu-1104-beta-2-has-been.html>, this bug has been fixed -- somewhat. You can now enable the Cube plugin easily, but apparently some other plugins don't enable that well according to you guys.

Michael X (crazedpsyc) wrote :

Yeah I just noticed yesterday that compiz completely crashes while enabling/disabling most plugins.
(I didn't notice before because I just upgraded)

Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
Didier Roche (didrocks) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → backlog
Sam_ (and-sam) wrote : BootDmesg.txt

apport information

tags: added: apport-collected compiz-0.9 running-unity ubuntu
description: updated

apport information

apport information

apport information

apport information

Sam_ (and-sam) wrote : GdmLog.txt

apport information

Sam_ (and-sam) wrote : GdmLog1.txt

apport information

Sam_ (and-sam) wrote : Lspci.txt

apport information

Sam_ (and-sam) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Sam_ (and-sam) wrote : UdevDb.txt

apport information

Sam_ (and-sam) wrote : UdevLog.txt

apport information

Sam_ (and-sam) wrote : UdevLog_.txt

apport information

apport information

Sam_ (and-sam) wrote : XorgLog.txt

apport information

apport information

apport information

Sam_ (and-sam) wrote : XorgLog_.txt

apport information

Sam_ (and-sam) wrote : Xrandr.txt

apport information

apport information

Sam_ (and-sam) wrote : xdpyinfo.txt

apport information

Sam_ (and-sam) wrote : xinput.txt

apport information

Sam_ (and-sam) wrote :

CCSM (compizconfig-settings-manager) crashed once and restarted, no further crash occured. Issues seem almost solved, great work, thanks.

Minor issues which can be worked around.
Live session Beta2 (24.04.)
Updates not installed because they're mostly just language packages (es).

Install CCSM and open it.
Reproducable.
Disable automatic plugin sorting.
Move cube, rotate, cubeaddon, ringswitcher, switcher to the right section.
Move wall and staticswitcher to left section.
Enable automatic plugin sorting.
General options -> desktop size: 8-1-1
Results:
global menu glitch, indicators disappear. (btw. sound-indicator was muted when desktop was loaded)
Switchers, Rotate, Workspaces work ok.

Workaround:
Enable Cube transparency e.g. 41000 - 22000.
Result:
Global menu appears again.

Enable all 'Image Loading' plugins.
Result: whole global menu colour disrupts.
Synaptic disappears from launcher, although it was marked as kept.
Synaptic doesn't appear anymore in launcher when running.
Gconf-editor can't be found through search. It finds gconf-cleaner.
Run it with Alt+F2. Although kept in launcher it doesn't appear anymore when closing and restarting.
It doesn't appear on search in recently used apps.

CCSM doesn't run in launcher after it's marked kept. Nothing happens, no notification what's wrong.

After logout (which is suppressed by default) all settings are ok, disappeared apps are in launcher again.

Not possible to make a screenshot from dash. (Tested with Alt+Print, Shift+Print (custom shortcut), Print and Compiz screenshot plugin.
## Should I log a new bug about this?

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
deuce (azinas) wrote :

wtf?!

Changed in unity (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in unity (Ubuntu Oneiric):
milestone: ubuntu-11.04 → none
Didier Roche (didrocks) wrote :

@Kate: the known crashers are fixed in natty finale.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released

  Hi, guys ! Let me just clarify that for myself the issue with Compiz crashing the Unity has still not been solved even with the stable 11.04 release today. Below you can find some more details.

My Computer: laptop
Model: Asus G73JH
Graphics Card: ATI Mobility Radeon HD5870
Operating System: Ubuntu 11.04 (final release - 28 April 2011)

Issue 1: When trying to install the Simple CompizConfig Settings Manager, getting an error: Package dependencies cannot be resolved
Details: The following packages have unmet dependencies: simple-ccsm:

Issue 2: After installing the Advanced Desktop Effects Settings (ccsm), when trying to enable Desktop Cube in CompizConfig Settings Manager, the left side panel and the top panel on the Desktop dissapear. Even after restaring the computer by pressing Ctrl + Alt + Del - Restart Computer , the 2 panels on the Desktop are still missing. I am able only to see the files saved on the Desktop and the connected external storage devices.

Those are the steps that I followed to get the issue 2:

1. Installing Advanced Desktop Effects Settings (ccsm)
2. Opening the CompizConfig Settings Manager and clicking on Desktop Cube. Then I get the message: Plugin Desktop Wall provides feature largedesktop which is also provided by Desktop Cube (snapshot-4.png). After that I click on Disable Desktop Wall and I am

3. getting the message : "Desktop Wall provides the feature largedesktop which is required by the plugins "Ubuntu Unity Plugin". (Don't disable Desktop Wall - Disable these plugins) (Snapshot-5.png)

I choose Disable these plugins and another message appears with the option to Disable Desktop Cube or Enable OpenGL (at that point the left side bar is not there anymore and when I click on the Ubuntu Circle in the left top corner nothing happens. In addition when I click on the PrtScreen button also nothing happens) After rebooting the computer the left side and top panels are completely missing and I can only see files that are saved on my Desktop and the external storage devices (e.g. USB flash card, ext. HDD) which are presented with icons on the Desktop. I am not able to open any application because the left side bar is gone even the prtscreen button option is not working. At that point my Ubuntu OS becomes completely useless and in order to fix the problem I have to reinstall it (without trying to enable Compiz).

  Guys, I really love Compiz 3D Cube and the Compiz effects , but this major bug prevents me from using the full potential of the OS GUI and my graphics card 3D Acceleration. If you need any further details regarding these two issues, kindly let me know and I will try to supply them as soon as possible. If you have any workaround until the issue 2 is eventually fixed, I would be really glad to know it. I believe also that this bug would be soon removed, because probably hundreds of people are experiencing it. Thank you in advance and have a great day.

Ivo

P.S. I have attached to my message .zip file with snapshots. For Issue 2 I was not able to take the final snapshots since the prtscreen option was not working at this point.

pablomme (pablomme) wrote :

@Ivo: the issue you report is not associated with this bug. This is about compiz crashing. In your case, you have simply disabled the unity plug-in - but since you're still using the unity profile, there is no gnome-panel fallback. Re-enable the unity plugin to get the functionality back. The fact that enabling cube disables unity is a separate problem.

Thank you for your fast reply, pablomme !

I think that regarding this issue I should refer to Bug #711561 - Compiz won't allow Desktop Cube plugin to load with unity (https://bugs.launchpad.net/unity/+bug/711561) . I have also found the article specifying how to manually fix the problem I experience : http://www.omgubuntu.co.uk/2011/04/compiz-cube-natty/ and I will follow the instructions there. Thank you again !

anthony (sagot-anthony) wrote :

Ivaylo BOTUSHAROVA, thank you for your link to manually correct the problem.
My problem was the same, but under "normal Ubuntu" instead of "Unity". It was impossible also to enable or disable a plugin without crashing the config of compiz.
I followed this article, and during my test, I had to use "compizconfig-settings-manager, preferences, Profile & Backend, return to the default (the one I use is" standard "and not " unity ").
Everything is then returned to normal, I can now use all the options I want without causing a crash.
I don't know why the "return to default" function, while the default config plant, but ... problem solved.
(excuse my English, but if that little help).

Why this bug is marked as Fixed? This is simply not true! The bug still exists in fully updated 11.04...

Changed in unity:
assignee: Loïc Molinari (loic.molinari) → ks64 (mango-k)
assignee: ks64 (mango-k) → nobody
Changed in unity (Ubuntu Natty):
assignee: Loïc Molinari (loic.molinari) → ks64 (mango-k)
Changed in unity (Ubuntu Oneiric):
assignee: Loïc Molinari (loic.molinari) → ks64 (mango-k)
Changed in unity (Ubuntu Natty):
assignee: ks64 (mango-k) → nobody
Changed in unity (Ubuntu Oneiric):
assignee: ks64 (mango-k) → nobody
Kenny Strawn (realkstrawn93) wrote :

If any fix is released, it sure ain't in Natty yet, as even with the Natty stable version when I try to enable the cube the same thing happens: when you enable the cube, Unity (and Compiz) crashes permanently with SIGSEGV. And enabling or disabling the plugin doesn't make a difference: Even when enabling the Cube (or any other) plugin in Ubuntu Classic (with effects) the same thing happens.

Kenny Strawn (realkstrawn93) wrote :

Apparently the fix was released to Oneiric users but not to Natty users, as the problem still persists in Natty.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions