[Gutsy Tribe-5] No Sound on Login Screen or during Login

Bug #129029 reported by mattz on 2007-07-29
132
Affects Status Importance Assigned to Milestone
gnome-session
Fix Released
Low
gnome-session (Ubuntu)
High
Sebastien Bacher
Nominated for Gutsy by FredBezies
libgnome (Ubuntu)
High
Martin Pitt
Nominated for Gutsy by FredBezies
udev (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by FredBezies

Bug Description

I have a Benq Joybook 8100 which has a Intel 82801DB-ICH4 Sound Card. I am running Gutsy Tribe 3

When I boot up ubuntu and reach the login screen, instead of the usual noise I get when it prompts you to enter in a username and password I get a system beep. When I log into ubuntu I get no Log-in Sound at all. However when I log out, the usual logout music plays.

I have no issues with sound once I am logged in and this was not an issue when I previously had Feisty 7.04 installed

Output of tail -2 /proc/asound/oss/sndstat

Mixers:
0: Realtek ALC250 rev 2

Also:
cat /etc/asound.conf ~/.asoundrc*
cat: /etc/asound.conf: No such file or directory
cat: /home/matt/.asoundrc*: No such file or directory

mattz (matt-ma77z) on 2007-07-29
description: updated
mattz (matt-ma77z) on 2007-07-29
description: updated

I also noticed when I'm deleting files for instance I also get the system beep.

description: updated
description: updated
mattz (matt-ma77z) wrote :
mattz (matt-ma77z) wrote :
mattz (matt-ma77z) wrote :
mattz (matt-ma77z) wrote :
mattz (matt-ma77z) wrote :
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add the full contents of '/var/log/udev' as an attachment to your bug report after booting up? Thanks in advance.

Ian Jackson (ijackson) wrote :

I have reproduced this with a fresh install of gutsy i386 d-i 20070808.

mattz (matt-ma77z) wrote :

Hi Brian. Thank you for your time with this bug. I have attached the /var/log/udev file.

  • udev Edit (317.4 KiB, application/octet-stream)

I'm attaching my /var/log/udev. However, I should also point out that I got login sounds working by selecting them in System | Administration | Login Window | Accessibility.

Neil Wilson (neil-aldur) wrote :

I have the same problem on a AMD64 Tribe 4 running on a Lenovo N100 0768 laptop. Sound is working, but the login/logout sounds are not playing - despite being listed in the 'System Sounds' part of the preferences (and they play from there perfectly).

TheWiseNoob (thewisenoob) wrote :

Like the person above me said, this also occurs in Gutsy Gibson AMD64 Tribe 4 for me.

Mathieu Pellerin (nirvn-asia) wrote :

No sound on welcome screen, no sound on login on Gutsy Gibson i386 Tribe 5.

Confirmed on Tribe 5- I think there are two problems to this:

1. GDM ready sound (the drums) is not playing- this I think is because the sound is not set up properly by default. Going to System->Administration->Login Window->Accessibility and choosing the proper sound (question.wav) results in proper behavior.

2. System login/logout sound (and perhaps all system sounds in general?) is not playing, though checking and playing them from the System->Preferences->Sound->System Sounds dialog box works fine.

3. All other sounds (for me at least) work fine.

I am on an Asus A8Jm, Intel ICH7 snd_hda_intel.

TJ (tj) wrote :

Confirmed on Gutsy Tribe-5 32-bit, Intel ICH7 & snd_hda_intel

TJ (tj) wrote :

Comparing /etc/gdm/gdm.conf of Gutsy Tribe-5 to Feisty I found that the login sound is disabled in Gutsy.

To enable it, find this section:

#SoundOnLogin=false
#SoundOnLoginFile=

And replace with:

SoundOnLogin=true
SoundOnLoginFile=/usr/share/sounds/question.wav

The Log=in sound (drum roll) now plays.

You could edit SoundOnLoginSuccess in a similar way but from looking at Feisty this isn't the way it is done. It appears to be set on a per-user basis.

Checking ~/.gnome2/sound/events/gnome-2.soundlist I found it was empty. Altering the Sound Preferences: Sounds "Log out" or "Log in" causes the changes to be written to gnome-2.soundlist. Changes to other options are written to gtk-events-2.soundlist in the same directory.

Unfortunately this doesn't help to make the user log-in sounds play. I am continuing to investigate.

Changed in udev:
assignee: nobody → intuitive-nipple
TJ (tj) wrote :

The system-wide sound settings *should* be read from /etc/sound/events/gnome-2.soundlist, but Gutsy Tribe-5 isn't accessing that file.

With an inotify watch on the file in a virtual terminal prior to log-in:

$ inotifywait -m /etc/sound/events/gnome-2.soundlist

no access to the file is reported. In Feisty the file is opened and accessed and, of course, the sounds play.

TJ (tj) wrote :

Not a udev issue

Changed in udev:
status: Confirmed → Invalid
Changed in gnome-session:
assignee: nobody → intuitive-nipple
status: New → Confirmed
Changed in udev:
assignee: intuitive-nipple → nobody
TJ (tj) wrote :

This issue is caused by wholesale changes to gnome-session between Feisty (gnome-session-2.18) and Gutsy (gnome-session-2.19.90) in gnome-session/gsm-sound.c

It appears to be a side-effect of the removal of the dependency on esound/ESD.

Wow, nice work on this TJ! Thanks a lot for tracking this bug down...

...is there anything we can help you with on this? Where do we go from here?

Thanks again!
-dafrabbit

TJ (tj) on 2007-08-26
Changed in gnome-session:
assignee: intuitive-nipple → ubuntu-desktop
TJ (tj) wrote :

I'm hoping the desktop team will give this a high priority, because although it is only an aural cosmetic touch, I think the Ubuntu brand recognition is very much tied to the distinctive login sounds.

Unless The Gnome developers upstream deal with it quickly, there are 2 options:

1) revert to gnome-session 2.1.18
2) undo the changes to gsm-sound.c

TJ (tj) wrote :

I've used the temporary work-around of removing the Gutsy gnome-session 2.19.90 and installing the Feisty 2.18.0 version.

In my previous comment I mistyped the version - it should of course have been 2.18.0, not 2.1.18!

1. Download the Feisty gnome-session v2.18.0 package
2. Uninstall the Gutsy gnome-session v2.19.90 package
3. Install gnome-session v2.18.0
4. Edit the apt preferences file to pin gnome-session so it won't be accidentally updated

At the GDM log-in prompt *before* logging in, switch to a virtual terminal by pressing Ctrl+Alt+F1, and log-in the do the following:

$ wget http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-session/gnome-session_2.18.0-0ubuntu3_i386.deb
$ sudo apt-get remove gnome-session
$ sudo dpkg -i gnome-session_2.18.0-0ubuntu3_i386.deb
$ sudo nano /etc/apt/preferences

Add the following 2 lines then save the file and exit with Ctrl+X:

  Package: gnome-session
  Pin: version 2.18.*

Put ubuntu-desktop back:

$ sudo apt-get install ubuntu-desktop

Now switch back to the GDM log-in screen using Ctrl+Alt+F7 and log-in. You should hear the login sound.

TJ (tj) wrote :

I neglected to mention in the previous comment about how to use gnome-session v2.18.0 that it will cause some functionality to be lost; such as access to the Suspend & Hibernate options and some of the new Accessibility / Assistive Technology functionality.

Changed in gnome-session:
status: Unknown → New
Changed in gnome-session:
assignee: ubuntu-desktop → desktop-bugs
importance: Undecided → Low
bwat47 (bwat47) wrote :

Confirmed Fresh Gutsy Tribe 5 Install i386 ICH5 AC'97 Audio

Ok, sounds good TJ.

So...will the edit to gdm.conf be committed? It seems a simple fix to make?

Making some noise in the upstream bug to see if someone will notice...

Changed in gnome-session:
status: Confirmed → Triaged
TJ (tj) wrote :

Updated upstream bug report since our #470348 has been marked as a duplicate of this one. Note upstream has this bug marked Unconfirmed/Minor.

Changed in gnome-session:
status: Unknown → New

I have a very similar problem to dafrabbit on 2007-08-25. I'm using Ubuntu 7.10 Alternative Tribe 5.

1. GDM ready sound is not playing. As he suggested, System->Administration->Login Window->Accessibility and choosing a sound (question.wav) results in it working.

2. System login/logout sounds are not playing, though checking and playing them from the System->Preferences->Sound->System Sounds dialog box works fine....so the sound card is detected & working.

3. The system sounds aren't working, but again playing them from the System->Preferences->Sound->System Sounds dialog box, they work fine.

afonic (afonic) wrote :

Sounds do not work due to the removal of Gnome splash screen.

Enable splash screen (in Configuration Editor, apps -> gnome-session -> enable show splash screen) and the sounds should work.

See:
https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/137118

description: updated
Sebastien Bacher (seb128) wrote :

not confirmed, enabling the splash screen doesn't make the sound work, that look like differents issues

afonic (afonic) wrote :

In System -> Sound -> Sounds in the login sound enabled?

This setting made no change in my case, until I turned splash screen on and it worked. Turning the splash screen off again disabled the sound.

TJ (tj) wrote :

I've tested the new gnome-session patch attached to the upstream bug but so far it hasn't produced sound, and it seems to lose the Ubuntu enhanced log-out dialog.

However, with standard Gutsy gnome-session 2.19.92 the sound *is* played if Accessible Login sound is set:

1. System > Preferences > Universal Access > Assistive Technology Preferences
2. Press "Accessible Login" button
3. Choose "Accessibility" (4th) tab
4. Change "Login successful" sound from '(None)' to 'startup3.wav'

On a side-note - enabling "Enable accessible login" here causes gdm to fail because the greeter fails to start.

If this happens, from a virtual TTY do 'sudo nano /etc/gdm/gdm.conf-custom' and in the "[daemon]" section comment out with a "#" "GtkModulesList" and "AddGtkModules".

I have no sound in a vwmare server (with enabled sound) and a gutsy tribe5 up-to-date, testing AMD64 version. Will try later with a live cd on my Acer Aspire T135 (Athlon sempron 3100+ with a K8 core).

Could be a blocker for gutsy beta, couldn't it ?

Changed in gnome-session:
importance: Low → High
uga (yegor-jbanov) wrote :

(Dell Inspiron 6400, Core 2 Duo, ATI X1400, Sound: HDA Intel SigmaTel STAC9200)

I'm on Gutsy Tribe 5 + all software updates. The problem is exactly as explained in the original bug report, i.e. a beep on welcome screen and no login sound. In the sound configuration I have login and logout sounds selected and working when I click "Play".

michelem (michele-marcucci) wrote :

I confirm it with latest Gutsy packages upgraded

I can also confirm this bug.

Clean install from daily build Sep 26

angryfirelord (angryfirelord) wrote :

Bug confirmed with the 9/25 snapshot + updates. The wav files themselves are fine.

I am able to get that "dum-dum" sound at the login window by going to System-->Administration-->Login Window-->Accessibility and selecting "question.wav".

josef (ok1dtm) wrote :

I can also confirm this bug.
New install Ubuntu GG beta Sep 28
System login/logout sounds are not playing. System->Preferences->Sound->System Sounds dialog box works fine....so the sound card is detected and working well.

Changed in dell:
importance: Undecided → High
status: New → Confirmed
knarf (launchpad-ubuntu-f) wrote :

Same but different here on Gutsy beta (updated from feisty using update-manager -c -d). No sounds during login, no sounds when trying to set them using System->Preferences->Sound->System Sounds (the test button does not produce any sound) but no problems with sounds in applications. Pulseaudio (which I had to manually install by the way...) works OK, applications use it, sound does not skip (had to add myself to the pulse-rt group first...) but no login/logout/ready sounds...

Ron Adams (tohuw) wrote :

Confirmed on a fresh install of Gusty Beta, with all updates as of 9/29.

mattz: System --> Preferences --> System Beep (this should have been disabled by default; that ugly beep is positively *archaic*)

Donnie Pennington: I confirm your statement as well

afonic: I do not confirm your solution; enabling the splash screen did not fix the problem for me (yes, I followed all your steps).

This should be a high priority, as TJ said, because the Ubuntu experience is crucial to its success in the desktop market.

All of my applicable log/report files do not differ significantly from those already posted, but I will post them on request.

Enryfox (enryfox) wrote :

Same problem on a IBM/lenovo t43p with gutsy beta fully updated at 30/9: system Beep at login though login and logout sounds are set in the preference pane and sound test is OK (also i can hear sound from video and mp3...).

mysticmatrix (mishra-anurag07) wrote :

I also confirm this bug when I upgraded from Ubuntu Feisty to Ubuntu Gutsy Beta.
I also tried to manually install pulse-audio and ESD(Only the packages, no configuration).

lspci output:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
This is onboard sound on Intel DG965RY Motherboard. All other sounds work fine

I'm sure this is a matter of poorly edited config files.

When Ubuntu dropped Enlightenment Sound there were lots of holes left over and this is one of them.

Has the GDM sound been fixed yet? That should be an easy fix since the only issue was that the sound file wasn't selected.

knarf (launchpad-ubuntu-f) wrote :

Hmmm, strangely enough I sometimes DO get the ready-to-login drumroll sound now. Sometimes, not always. Just like I sometimes have to kill bonobo-activation-server to get Nautilus to run (bug #90923: https://bugs.launchpad.net/ubuntu/+source/libbonobo/+bug/90923). Maybe these two are related?

Since last update of gdm, login sound is activated. It only misses now starting sound and this annoying "/usr/bin/esd" not found in console.

On 10/3/07, FredBezies <email address hidden> wrote:
>
> Since last update of gdm, login sound is activated. It only misses now
> starting sound and this annoying "/usr/bin/esd" not found in console.

I confirm that. I also found that login sound can NOT be enabled in "logon
screen" in administrative tools (don't know how it is translated into
english) but it can be in "Sound" in preferences menu. Unfortunately it
doesn't resolve problem of logout sound.

Splash screen absence remains the same.

I try to enable the start splash screen and it kills the playing of question.wav file on login screen (see comment #28 by afonic).

It is a very annoying and weird bug. I will try to see if adding starting sound in accessibility tab can make it be played or not. Anyway, shutdown sound is not played too.

Sebastien Bacher (seb128) wrote :

the splash screen not being used is not a bug but a decision

Khorne (szczygiel-piotr) wrote :

On 10/3/07, Sebastien Bacher <email address hidden> wrote:
>
> the splash screen not being used is not a bug but a decision

Yes, but the problem is that splash screen can NOT be enabled by ANY way.

Khorne : you can enable it, but you won't get starting sound at all. Any idea on how to get both starting and closing sound working on gutsy, 15 days before gutsy is released, please ?!

josef (ok1dtm) wrote :

On 10/03/07 dailly download UbuntuI 7.10 I also confirm confirm welcome and logout sound no playing. Test in sound preferences menu is everytime ok! Worked only login sound-drum.

Pedro Villavicencio (pedro) wrote :

Thanks for your comments folks, but there's no need to re confirm the report, the developers already know the bug is there and it will be fixed before gutsy release. thanks in advance.

Sebastien Bacher (seb128) wrote :

The bug has been milestone for gutsy rc and will be fixed, now if you can't work without the sounds effects you should use a stable version of the distribution, adding extra comment will not make the bug fixed faster, quite the contrary since it create extra bug activity for the maintainers

Dnia 03-10-2007, Śr o godzinie 15:53 +0000, Sebastien Bacher pisze:

> The bug has been milestone for gutsy rc and will be fixed, now if you
> can't work without the sounds effects you should use a stable version of
> the distribution, adding extra comment will not make the bug fixed
> faster, quite the contrary since it create extra bug activity for the
> maintainers
>

Thanks for your replies. It is good to know that the bug is known and
will be fixed. I think that we all only wanted to help to improve
Ubuntu. Thanks for your patience as well ;)

Sebastien Bacher (seb128) wrote :

I'll upload a fixed version tomorrow

Changed in gnome-session:
assignee: desktop-bugs → seb128
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

There is also some issues due to libgnome

Changed in libgnome:
assignee: nobody → seb128
importance: Undecided → High
status: New → Fix Committed
Changed in dell:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

gnome-session (2.20.0-0ubuntu2) gutsy; urgency=low

  * debian/patches/90_from_bugzilla_fix_session_sounds.patch:
    - patch from GNOME bug #466458, fix the session sounds
      (LP: #129029)

 -- Sebastien Bacher <email address hidden> Thu, 04 Oct 2007 23:10:50 +0200

Changed in gnome-session:
status: Fix Committed → Fix Released
Changed in libgnome:
assignee: seb128 → pitti
status: Fix Committed → Triaged

Erh... I might be deaf during login or logout, but no sound with latest gnome-session - Gutsy AMD64.

s$ ls /var/cache/apt/archives/
displayconfig-gtk_0.3.3_all.deb
gnome-app-install_0.4.13-0ubuntu1_all.deb
gnome-session_2.20.0-0ubuntu2_amd64.deb
gtk2-engines-ubuntulooks_0.9.12-8_amd64.deb
hpijs_2.7.7+2.7.7.dfsg.1-0ubuntu4_amd64.deb
hplip_2.7.7.dfsg.1-0ubuntu4_amd64.deb
hplip-data_2.7.7.dfsg.1-0ubuntu4_all.deb
hplip-gui_2.7.7.dfsg.1-0ubuntu4_all.deb
libxml2_2.6.30.dfsg-2ubuntu1_amd64.deb
libxml2-dev_2.6.30.dfsg-2ubuntu1_amd64.deb
libxml2-utils_2.6.30.dfsg-2ubuntu1_amd64.deb
linux-libc-dev_2.6.22-13.40_amd64.deb
partial
python-libxml2_2.6.30.dfsg-2ubuntu1_amd64.deb
ubuntu-docs_7.10.1_all.deb

Sorry if my comment is like a spam. If I understand well, a new version of libgnome will fix the problem ?

Sebastien Bacher (seb128) wrote :

yes, a libgnome changes are required as previously documented and indicated by the libgnome task opened there

Martin Pitt (pitti) wrote :

Uploaded, pending approval now:

 libgnome (2.20.0-1ubuntu4) gutsy; urgency=low
 .
   * Completely rewrite debian/patches/11_aplay_fallback.patch to make it
     work for sound events from gnome-session (like login/logout sounds), too.
     gnome_sound_sample_load() now keeps a map of sound name -> sound file, so
     that gnome_triggers_play_sound() has a chance to find the file name to
     call aplay on.
 .
     This still does not repair general sound events for all applications
     (since gnome-session preloads the sound events into esd usually, which we
     cannot do without esd), but for Gutsy purposes this is an unintrusive
     workaround. In Hardy we should either switch to pulse by default, or get
     upstream to drop this esound abdomination altogether. (LP: #129029)

Changed in libgnome:
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

libgnome (2.20.0-1ubuntu4) gutsy; urgency=low

  * Completely rewrite debian/patches/11_aplay_fallback.patch to make it
    work for sound events from gnome-session (like login/logout sounds), too.
    gnome_sound_sample_load() now keeps a map of sound name -> sound file, so
    that gnome_triggers_play_sound() has a chance to find the file name to
    call aplay on.

    This still does not repair general sound events for all applications
    (since gnome-session preloads the sound events into esd usually, which we
    cannot do without esd), but for Gutsy purposes this is an unintrusive
    workaround. In Hardy we should either switch to pulse by default, or get
    upstream to drop this esound abdomination altogether. (LP: #129029)

 -- Martin Pitt <email address hidden> Sat, 06 Oct 2007 11:54:27 +0200

Changed in libgnome:
status: Fix Committed → Fix Released

Thanks Martin !

It works at least. It was a very annoying polishing bug !

A good bug is a dead bug ;)

Wolf Rogner (war-rsb) wrote :

Sorry to say: It does not work on my machine

Seems that the sound control panel does not update /etc/gdm/gdm.conf

Sebastien Bacher (seb128) wrote :

gdmsetup edits the gdm.conf-custom configuration

Wolf Rogner (war-rsb) wrote :

In fact there are two control panels:

gdmsetup = Login Window
gnome-sound-properties = Sound

Both allow to adjust the sounds. However, they are not synchroized and they do not update gdm.conf in a consistent way.

Using gdmsetup I get the logon sound but no sound for the ready prompt (used to be question.wav)
Setting logon sound in both applets, I get the logon sound twice.
Turning sound of in gdmsetup turns of logon sound all together.

A synchronous behaviour would be required.

Btw. There is no logoff sound available on my test machine. 7.04 played logout.wav beautifully.

Works for me with latest Gutsy updates.

Changed in dell:
status: Fix Committed → Fix Released

Logout sound doesn't work. At least, login sound works, but both will be great. Any workaround besides using gdm-setup ?!

Sebastien Bacher (seb128) wrote :

gdmsetup is used to configure gdm not the sound using by the gnome session

This is weird, but gnome panel version 1:2.20.0.1-0ubuntu6 seems to cure the bug.

I applied the update, close gnome and restart it. When new session was opened both panel are shown flawlessly. Maybe somebody who applied this patch and restart the computer can confirm what I am seeing ?

I made a mistake for my last comment. It was mean to be written for bug 147943 :(

Sorry, sorry, sorry :(

josef (ok1dtm) wrote :

Gusty-rc logout sound no play. Test in settings is ok.

Wolf F. (wfogl) wrote :

Sorry for saying that: logoff sound doesn't work in the final version.

Wolf Rogner (war-rsb) wrote :

It now works on all of my machines

josef (ok1dtm) wrote :

Sorry but play only welcome sound. Logout no works in final Ubuntu 7.10.

ragnaroknroll (ragnaroknroll) wrote :

Same problem with me... Login sounds play perfectly but there's no logout sound on upgrade to gutsy...

macstevejb (macstevejb) wrote :

Identical problem here...using Gutsy final 7.10..log-in sound (drum-roll) works perfectly but no logout sound despite selecting in sound prefs and the sound playing there when play button pressed...this is an annoying bug and leaves an unpolished feel which will be noticed by new users

I have the same problem here.

Rockallite (rockallite-wulf) wrote :

I confirm the bug of no logout sound. Login sound plays well, but logout sound doesn't, which is correctly selected in Sound Preferences.

Rockallite (rockallite-wulf) wrote :

The original system was Feisty. I followed the Update Manager so as to upgrade to Gusty. Everything works well, except there's no logout sound when I logout from the GNOME desktop, which previously worked fine in Feisty.

Hi,

I had the same problem with no logout sound after upgrading from Feisty to Gutsy.

I've first been surprised by the Unistallation package window, which appears just before starting the upgrade. The package "esound" was listed as being uninstalled during the upgrade.

After the upgrade to Gutsy, /usr/bin/esd was no more present (because of esound uninstall), and thus, no sound at Gnome logout.

So I simply reinstalled those 2 packages using Synaptic:

esound (0.2.38-0ubuntu4)
esound-clients (0.2.38-0ubuntu4)

and now, /usr/bin/esd is back, and logout sound works perfectly.

If this can help ...

checkstein (checkstein) wrote :

Bingo!
Exactly that helped!
Thanks and best wishes.

checkstein

Changed in gnome-session:
status: New → Confirmed
Changed in gnome-session:
status: Confirmed → Fix Released
Changed in gnome-session:
importance: Unknown → Low
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306053

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.