package ubuntustudio-menu 0.10 failed to install/upgrade: there is no script in the new version of the package - giving up

Bug #276503 reported by eris23 on 2008-09-30
652
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubuntustudio-menu (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ubuntustudio-menu

It took 2 tries to update.
1st time:
Unpacking replacement ubuntustudio-menu ...
Removing `diversion of /etc/xdg/menus/applications.menu to /etc/xdg/menus/applications.menu.orig by ubuntustudio-menu'
dpkg-divert: rename involves overwriting `/etc/xdg/menus/applications.menu' with
  different file `/etc/xdg/menus/applications.menu.orig', not allowed
dpkg: warning - old post-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg: error processing /var/cache/apt/archives/ubuntustudio-menu_0.10_all.deb (--unpack):
 there is no script in the new version of the package - giving up
2nd time:
Unpacking replacement ubuntustudio-menu ...
Removing `diversion of /etc/xdg/menus/applications.menu to /etc/xdg/menus/applications.menu.orig by ubuntustudio-menu'
Setting up ubuntustudio-menu (0.10) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: there is no script in the new version of the package - giving up
Package: ubuntustudio-menu 0.9
PackageArchitecture: all
SourcePackage: ubuntustudio-menu
Title: package ubuntustudio-menu 0.9 failed to install/upgrade: there is no script in the new version of the package - giving up
Uname: Linux 2.6.27-4-generic i686

eris23 (jdkatz23) wrote :
Florin (tlenze) wrote :

Same thing for me.

Changed in ubuntustudio-menu:
status: New → Confirmed
Broomer68 (jbezemer) wrote :

first update: crash
second update: succes

Andycds (andycds) wrote :

At the second try, the update show no errors.

Changed in ubuntustudio-menu:
importance: Undecided → High
status: Confirmed → Triaged
Ezra Morris (ezramorris) wrote :

Pretty sure this is the same bug. Throughout upgrading from hardy to intrepid, i got:
-----------------------------------------------------------------------------
Could not install '/var/cache/apt/archives/ubuntustudio-menu_0.11_all.deb'

The upgrade will continue but the '/var/cache/apt/archives/ubuntustudio-menu_0.11_all.deb' package may be in a not working state. Please consider submitting a bugreport about it.

there is no script in the new version of the package - giving up
-----------------------------------------------------------------------------
Could not install 'ubuntustudio-menu'

The upgrade will continue but the 'ubuntustudio-menu' package may be in a not working state. Please consider submitting a bugreport about it.

package ubuntustudio-menu is already installed and configured

Dennis Lange (dennis-lumalab) wrote :

Same for me. Updating 8.04 with "Ubuntu Studio Look" to 8.10

Uwe Koch (uwe-koch) wrote :

I expected my PC not to run after the error, but surprisingly after reporting the bug, the terminal running the installation closed by itself and the PC asked to download the Ubuntu Studio Menu. I did that, updated any other missing file, and rebooted. All worked fine.

16bit (ipurba) wrote :

well, everything just works well after i shutdown my laptop and boot it again, i tried to update all my system after that, ubuntustudio-menu is installed fine

Yes,I fixed it after the update,I just installed ubuntustudio-menu myself:
 #sudo apt-get install ubuntustudio-menu
then reboot,fix x,compile the kernel 2.6.27.4,install the driver
NVIDIA-Linux-x86_64-177.80-pkg2.run.
Now, everything goes on wheels!
Thank you!

2008/11/3 16bit <email address hidden>

> well, everything just works well after i shutdown my laptop and boot it
> again, i tried to update all my system after that, ubuntustudio-menu is
> installed fine
>
> --
> package ubuntustudio-menu 0.10 failed to install/upgrade: there is no
> script in the new version of the package - giving up
> https://bugs.launchpad.net/bugs/276503
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Ezra Morris (ezramorris) wrote :

Same here. Is this still a bug in this case?

rju (rajae-nasri) wrote :

same ,but did not restart yet.

rju (rajae-nasri) wrote :

tried to restart but the terminal is just frozen
tried to use sudo apt-get install ubuntustudio-menu but no response in terminal

sodasound (morleytuttle) wrote :

Two bugs, this one and Update Manager. Had trouble deciding which server to go for, because antarctic.ca (whatever it is) is messed up. Took forever to pick sources, after burning another coaster and failing to update from it.

 I'm still pre-restart, so I hope I can get it fixed before I restart it. I've burned so many coasters this year I'm beginning to get superstitious about the severity of my attitude problem. (Ubuntu, UbuntuStudio, 64Studio, and I know how to burn iso's, if Brasero does what it's told). I'm becoming a fan of Live CD-R installers. DVD's are unreliable at best.

I have successfully restored my system, using the update method
described in the discussion of both bugs. I am blogging about it as
well, so the good word get's out as far as it can. Hopefully we can
prevent a few hung-systems, if not all of them.

The Update Manager does not appear to have updated, but I still have one
and everything else seems fine.

Superstition: can some of these problems be the result of attacks on
update/upgrade systems? Just a thought.

sodasound

http://sodasound.blogspot.com/
http://morleyblog.wordpress.com/

sodasound wrote:
> Two bugs, this one and Update Manager. Had trouble deciding which server
> to go for, because antarctic.ca (whatever it is) is messed up. Took
> forever to pick sources, after burning another coaster and failing to
> update from it.
>
> I'm still pre-restart, so I hope I can get it fixed before I restart
> it. I've burned so many coasters this year I'm beginning to get
> superstitious about the severity of my attitude problem. (Ubuntu,
> UbuntuStudio, 64Studio, and I know how to burn iso's, if Brasero does
> what it's told). I'm becoming a fan of Live CD-R installers. DVD's are
> unreliable at best.
>
>

Changed in ubuntustudio-menu (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.