tst_adaptivepagelayout: test_forced_synchronous_loading_bug1540449 is flaky

Bug #1561436 reported by Tim Peeters on 2016-03-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
Critical
Zsombor Egri
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

It fails some times (not always). Here is the log when it fails:

tim@tim-mbp:~/dev/ubuntu-ui-toolkit/m/fix-tests/tests/unit_x11/tst_components$ qmltestrunner -import ../../../qml/ -input tst_adaptivepagelayout.qml
********* Start testing of qmltestrunner *********
Config: Using QtTest library 5.5.1, Qt 5.5.1 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 5.3.1 20160225)
PASS : qmltestrunner::initTestCase()
PASS : qmltestrunner::test_add_page_to_current(Synchronously to current column)
PASS : qmltestrunner::test_add_page_to_current(Synchronously to current column, with params)
PASS : qmltestrunner::test_add_page_to_current(Synchronously to next column)
PASS : qmltestrunner::test_add_page_to_current(Synchronously to next column, with params)
PASS : qmltestrunner::test_add_page_to_current(Asynchronously to current column)
PASS : qmltestrunner::test_add_page_to_current(Asynchronously to current column, with params)
PASS : qmltestrunner::test_add_page_to_current(Asynchronously to next column)
PASS : qmltestrunner::test_add_page_to_current(Asynchronously to next column, with params)
PASS : qmltestrunner::test_add_page_to_current_does_not_prune_current()
PASS : qmltestrunner::test_add_page_to_next_column_doesnt_delete_prev_column_content_bug1544745()
PASS : qmltestrunner::test_add_page_when_source_page_not_in_stack()
PASS : qmltestrunner::test_add_page_with_null_sourcePage()
PASS : qmltestrunner::test_add_same_page_twice()
PASS : qmltestrunner::test_add_to_current_prunes_next()
PASS : qmltestrunner::test_add_to_next_first_prunes_next()
PASS : qmltestrunner::test_asynchronous_page_loading_incubator_forcecompletion()
PASS : qmltestrunner::test_change_primaryPage()
PASS : qmltestrunner::test_change_primaryPageSource(Component)
PASS : qmltestrunner::test_change_primaryPageSource(Document)
PASS : qmltestrunner::test_forced_synchronous_loading_bug1540449(To current column)
FAIL! : qmltestrunner::test_forced_synchronous_loading_bug1540449(To next column) Uncaught exception: Cannot read property 'object' of null
   Loc: [/home/tim/dev/ubuntu-ui-toolkit/m/fix-tests/tests/unit_x11/tst_components/tst_adaptivepagelayout.qml(325)]
XFAIL : qmltestrunner::test_hidden_page_keeps_geometry_bug1492343() no width change expected
   Loc: [/home/tim/dev/ubuntu-ui-toolkit/m/fix-tests/tests/unit_x11/tst_components/tst_adaptivepagelayout.qml(349)]
XFAIL : qmltestrunner::test_hidden_page_keeps_geometry_bug1492343() no height change expected
   Loc: [/home/tim/dev/ubuntu-ui-toolkit/m/fix-tests/tests/unit_x11/tst_components/tst_adaptivepagelayout.qml(351)]
PASS : qmltestrunner::test_hidden_page_keeps_geometry_bug1492343()
PASS : qmltestrunner::test_old_page_disappears_when_new_one_ready_bug1499178(CurrentColumn, wide)
PASS : qmltestrunner::test_old_page_disappears_when_new_one_ready_bug1499178(CurrentColumn, narrow)
PASS : qmltestrunner::test_old_page_disappears_when_new_one_ready_bug1499178(NextColumn, wide)
PASS : qmltestrunner::test_old_page_disappears_when_new_one_ready_bug1499178(NextColumn, narrow)
PASS : qmltestrunner::test_page_visible()
PASS : qmltestrunner::test_primaryPageSource_bug1499179(Component)
PASS : qmltestrunner::test_primaryPageSource_bug1499179(Document)
PASS : qmltestrunner::test_primaryPageSource_precedence_over_primaryPage()
PASS : qmltestrunner::test_primaryPage_change_clears_primaryPageSource()
PASS : qmltestrunner::cleanupTestCase()
Totals: 32 passed, 1 failed, 0 skipped, 0 blacklisted
********* Finished testing of qmltestrunner *********

On https://launchpadlibrarian.net/249767391/buildlog_ubuntu-vivid-amd64.ubuntu-ui-toolkit_1.3.1908+15.04.20160324-0ubuntu1_BUILDING.txt.gz we can see it fail like this:

Executing dbus-test-runner --task gdb -p --quiet -n tst_adaptivepagelayout.qml -m 300 -p --batch -p -ex -p 'set print thread-events off' -p -ex -p run -p -ex -p bt -p --return-child-result -p --args -p /«BUILDDIR»/ubuntu-ui-toolkit-1.3.1908+15.04.20160324/tests/unit_x11/tst_components/tst_components -p -input -p tst_adaptivepagelayout.qml -p -maxwarnings -p 100 -p -o -p /«BUILDDIR»/ubuntu-ui-toolkit-1.3.1908+15.04.20160324/tests/test_tst_adaptivepagelayout.qml.xml,xunitxml -p -o -p -,txt
Working directory: /«BUILDDIR»/ubuntu-ui-toolkit-1.3.1908+15.04.20160324/tests/unit_x11/tst_components
DBus daemon: unix:abstract=/tmp/dbus-9lOUiPAThu,guid=427c10a09ef7c580a05d770856f37454
tst_adaptivepagelayout.qml: Started with PID: 16859
Undefined command: "". Try "help".
tst_adaptivepagelayout.qml: [Thread debugging using libthread_db enabled]
tst_adaptivepagelayout.qml: Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
tst_adaptivepagelayout.qml: [New Thread 0x7fffe1ffb700 (LWP 16870)]
tst_adaptivepagelayout.qml: ********* Start testing of components *********
tst_adaptivepagelayout.qml: Config: Using QtTest library 5.4.1, Qt 5.4.1 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 4.9.2)
tst_adaptivepagelayout.qml: PASS : components::initTestCase()
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Synchronously to current column)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Synchronously to current column, with params)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Synchronously to next column)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Synchronously to next column, with params)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Asynchronously to current column)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Asynchronously to current column, with params)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Asynchronously to next column)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current(Asynchronously to next column, with params)
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_current_does_not_prune_current()
tst_adaptivepagelayout.qml: PASS : components::test_add_page_to_next_column_doesnt_delete_prev_column_content_bug1544745()
tst_adaptivepagelayout.qml: PASS : components::test_add_page_when_source_page_not_in_stack()
tst_adaptivepagelayout.qml: PASS : components::test_add_page_with_null_sourcePage()
tst_adaptivepagelayout.qml: PASS : components::test_add_same_page_twice()
tst_adaptivepagelayout.qml: PASS : components::test_add_to_current_prunes_next()
tst_adaptivepagelayout.qml: PASS : components::test_add_to_next_first_prunes_next()
tst_adaptivepagelayout.qml: PASS : components::test_asynchronous_page_loading_incubator_forcecompletion()
tst_adaptivepagelayout.qml: PASS : components::test_change_primaryPage()
tst_adaptivepagelayout.qml: PASS : components::test_change_primaryPageSource(Component)
tst_adaptivepagelayout.qml: PASS : components::test_change_primaryPageSource(Document)
tst_adaptivepagelayout.qml: FAIL! : components::test_forced_synchronous_loading_bug1540449(To current column) page not found
tst_adaptivepagelayout.qml: Actual (): Page1
tst_adaptivepagelayout.qml: Expected (): DynamicPage
tst_adaptivepagelayout.qml: Loc: [/«BUILDDIR»/ubuntu-ui-toolkit-1.3.1908+15.04.20160324/tests/unit_x11/tst_components/tst_adaptivepagelayout.qml(325)]
tst_adaptivepagelayout.qml: PASS : components::test_forced_synchronous_loading_bug1540449(To next column)
tst_adaptivepagelayout.qml: XFAIL : components::test_hidden_page_keeps_geometry_bug1492343() no width change expected
tst_adaptivepagelayout.qml: Loc: [/«BUILDDIR»/ubuntu-ui-toolkit-1.3.1908+15.04.20160324/tests/unit_x11/tst_components/tst_adaptivepagelayout.qml(349)]
tst_adaptivepagelayout.qml: XFAIL : components::test_hidden_page_keeps_geometry_bug1492343() no height change expected
tst_adaptivepagelayout.qml: Loc: [/«BUILDDIR»/ubuntu-ui-toolkit-1.3.1908+15.04.20160324/tests/unit_x11/tst_components/tst_adaptivepagelayout.qml(351)]
tst_adaptivepagelayout.qml: PASS : components::test_hidden_page_keeps_geometry_bug1492343()
tst_adaptivepagelayout.qml: PASS : components::test_old_page_disappears_when_new_one_ready_bug1499178(CurrentColumn, wide)
tst_adaptivepagelayout.qml: PASS : components::test_old_page_disappears_when_new_one_ready_bug1499178(CurrentColumn, narrow)
tst_adaptivepagelayout.qml: PASS : components::test_old_page_disappears_when_new_one_ready_bug1499178(NextColumn, wide)
tst_adaptivepagelayout.qml: PASS : components::test_old_page_disappears_when_new_one_ready_bug1499178(NextColumn, narrow)
tst_adaptivepagelayout.qml: PASS : components::test_page_visible()
tst_adaptivepagelayout.qml: PASS : components::test_primaryPageSource_bug1499179(Component)
tst_adaptivepagelayout.qml: PASS : components::test_primaryPageSource_bug1499179(Document)
tst_adaptivepagelayout.qml: PASS : components::test_primaryPageSource_precedence_over_primaryPage()
tst_adaptivepagelayout.qml: PASS : components::test_primaryPage_change_clears_primaryPageSource()
tst_adaptivepagelayout.qml: PASS : components::cleanupTestCase()
tst_adaptivepagelayout.qml: Totals: 32 passed, 1 failed, 0 skipped, 0 blacklisted
tst_adaptivepagelayout.qml: ********* Finished testing of components *********
tst_adaptivepagelayout.qml: [Thread 0x7fffe1ffb700 (LWP 16870) exited]
No stack.
tst_adaptivepagelayout.qml: [Inferior 1 (process 16861) exited with code 01]
tst_adaptivepagelayout.qml: Exited with status 256
tst_adaptivepagelayout.qml: Shutting down
DBus daemon: Shutdown
tst_adaptivepagelayout.qml exited with 0

Related branches

Tim Peeters (tpeeters) on 2016-03-24
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Critical
Tim Peeters (tpeeters) on 2016-03-24
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
status: New → Confirmed
Tim Peeters (tpeeters) wrote :

^that failure is without the attached MR applied.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → Critical
milestone: none → 11
Changed in canonical-devices-system-image:
status: New → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1938+15.04.20160412 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1938+15.04.20160412) vivid; urgency=medium

  [ Tim Peeters ]
  * Hide the PageStack back button when depth == 1. Fixes LP: #1565811
  * Add header subtitle. Fixes LP: #1399289
  * Reveal the header in gallery when changing the layout to two columns.
    Fixes LP: #1556860
  * Set correct colors for disabled actions in the header.
    Fixes LP: #1393485
  * Disable tst_datepicker.qml to unblock the staging.Fixes LP: #1567840
  * Prevent invisible header from setting the flickable topMargin.
    Fixes LP: #1560419, LP: #1560458, LP: #1566231.

  [ Zsombor Egri ]
  * Move MouseTouchAdaptor into UbuntuToolkit library. Fix adaptor code for
    Xenial. Fixes LP: #1561436

  [ Christian Dywan ]
  * Don't use a separate argument to distinguish touch events. If it's touch,
    it has our overloaded methods. Fixes LP: #1530802
  * Use export_qml_dir.sh in qmlapicheck and runtest Also add Usage to runtest.
    Fixes LP: #1567286.
  * Summary style error results with sections. Fixes LP: #1568804

  [ Andrea Bernabei ]
  * Mouse filter: check if mouse is inside the area on mouse moves and
    setHovered accordingly. Fixes LP: #1566378.

  [ Timo Jyrinki ]
  * Add latest changes for GLES.
  * Add back Provides: qtdeclarative5-ubuntu-ui-toolkit-plugin to resolve
    upgrade issue. Fixes LP: #1568817
  * Fix wrapper script auto-generated by Qt that incorrectly tries to execute
    itself. Fixes LP: #1560000
  * bileto_convert_to_gles: sort and add
    qml-module-ubuntu-performancemetrics-gles.install. Fixes LP: #1569217

  * Add additional Breaks as requested by archive admin.
  * Add latest changes for GLES.

  [ Zolán Balogh ]
  * Fix the UITK test plan script.

  [ CI Train Bot ]
  * Resync trunk. added: examples/ubuntu-ui-toolkit-gallery/po/nb.po

  [ Robert Park ]
  * Inline GLES packaging. added: debian/bileto_convert_to_gles
    debian/control.gles debian/rules.gles

 -- Zoltan Balogh <email address hidden> Tue, 12 Apr 2016 11:12:44 +0000

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1984+16.10.20160527.2

---------------
ubuntu-ui-toolkit (1.3.1984+16.10.20160527.2) yakkety; urgency=medium

  [ Christian Dywan ]
  * Slimmer frame for TextFields: 0.5dp. Fixes LP: #1578190.

  [ Albert Astals Cid ]
  * Add override
    The override specifier (since C++11) specifies that a virtual function
    overrides another virtual function. In a member function declaration or
    definition, override ensures that the function is virtual and is overriding
    a virtual function from the base class.

  [ Tim Peeters ]
  * Fix reference error in PullToRefreshStyle. Fixes LP: #1582843
  * Mark Tab, Tabs, TabBar, PageHeadConfiguration, PageHeadSections,
    PageHeadState, ToolbarButton, ToolbarItems as deprecated in the
    documentation. Fixes LP: #1566735, LP: #1566741.

  [ CI Train Bot ]
  * Resync trunk.

 -- Zoltan Balogh <email address hidden> Fri, 27 May 2016 07:08:44 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers