Progress bar in "Progress" section has a hole in it

Bug #1052936 reported by Matthew Paul Thomas on 2012-09-19
140
This bug affects 27 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
ubuntu-mate-artwork (Ubuntu)
Medium
Martin Wimpress
Xenial
Medium
Unassigned
ubuntu-themes (Ubuntu)
Medium
Will Cooke
Xenial
Medium
Unassigned

Bug Description

Problem occurs with: Ambiance, Radiance
Does not occur with: Adwaita

[ Description, QA ]

Open System Monitor, switch to "File Systems".

What you see: Progress bars with orange borders but white middles

What you should see: All colour

[ Fix ]

Don't use the border images - use CSS to colour the borders and backgrounds.

[ Regression potential ]

Could break styling of progress bars elsewhere; look in gtk3-widget-factory, unity-control-center and anywhere else you can think of to make sure they all still look good.

Related branches

Matthew Paul Thomas (mpt) wrote :
Matthew Paul Thomas (mpt) wrote :
description: updated
Gary Lasker (gary-lasker) wrote :

Interesting. This doesn't happen using the same USC code in Precise. Thanks for reporting this, mpt!

Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in light-themes (Ubuntu):
status: New → Confirmed
Andrea Cimitan (cimi) wrote :

I think it's not a bug in light-themes.

I think the ubuntu software center is using a background-color, overriding gtk theme ones, thus it colors the progressbar.
With Adwaita the problem is not noticeable because Adwaita is using a background-image, which in Gtk+ rendering has higher priority over background color.

Changed in light-themes (Ubuntu):
status: Confirmed → Invalid
Changed in software-center (Ubuntu):
importance: Low → Medium
Vincent Thiele (vincentthiele) wrote :

Still not fixed...

tags: added: quantal raring saucy
Adolfo Jayme (fitojb) on 2014-02-08
no longer affects: light-themes (Ubuntu)
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Medium
tags: added: trusty
description: updated
description: updated
Changed in software-center:
status: New → Confirmed
tags: added: wily
dobey (dobey) on 2015-12-18
no longer affects: software-center
affects: software-center (Ubuntu) → ubuntu-themes (Ubuntu)
franco_bez (franco-bez) wrote :

Since I upgraded to Xenial I have this problem in the system monitor and the synaptic software center.

Only occurs in Ambiance, Radiance is OK

see one of the duplicates of this bug 1574452 for screenshots.

tags: added: xenial

As Geert brought to my attention, bug 1052936 (reported in 2012) may be the same as this one I recently reported in Xenial (bug 1547119):
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1547119

(see screenshot in bug description)

Changed in ubuntu-mate-artwork (Ubuntu):
status: New → Fix Committed
assignee: nobody → Martin Wimpress (flexiondotorg)
Will Cooke (willcooke) on 2016-05-26
Changed in ubuntu-themes (Ubuntu):
milestone: none → xenial-updates
assignee: nobody → Will Cooke (willcooke)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mate-artwork (Ubuntu Xenial):
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu Xenial):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Please fix this in yakkety first before SRUing.

Iain Lane (laney) on 2016-06-17
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.10.20160620.1-0ubuntu1

---------------
ubuntu-themes (14.04+16.10.20160620.1-0ubuntu1) yakkety; urgency=medium

  [ <email address hidden> ]
  * Adds new CSS to style progress bars based on colours rather than
    images. This fixes the "empty progress bars" bug. (LP: #1052936)

 -- <email address hidden> (<email address hidden>) Mon, 20 Jun 2016 09:42:52 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released

Hello Matthew, or anyone else affected,

Accepted ubuntu-themes into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/14.04+16.04.20160621-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-themes (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
franco_bez (franco-bez) wrote :

Excelent work :-)

On my System ( Linux B513 4.4.0-24-generic #43-Ubuntu SMP Wed Jun 8 19:27:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux ) the bug is fixed.

Geert Jan Alsem (gj-alsem) wrote :

I can confirm the update in xenial-proposed also fixes the bug for me.

Corey Ptaszek (cptaszek) wrote :

The update in xenial-proposed also fixes the problem for me. Nice work!

Changed in ubuntu-themes (Ubuntu Xenial):
importance: Undecided → Medium
tags: added: verification-done
removed: verification-needed

Can I request that the fix for Ubuntu MATE also be released please.

Changed in ubuntu-mate-artwork (Ubuntu):
milestone: none → xenial-updates
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.04.20160621-0ubuntu1

---------------
ubuntu-themes (14.04+16.04.20160621-0ubuntu1) xenial; urgency=medium

  [ Iain Lane ]
  * Re-style progress bars to fix them having a border but no
    background, for example in gnome-system-monitor. (LP: #1052936)

 -- <email address hidden> (<email address hidden>) Tue, 21 Jun 2016 08:08:37 +0000

Changed in ubuntu-themes (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-themes has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Martin Pitt (pitti) wrote :

@Martin: Please fix it in yakkety first; according to the tasks for ubuntu-mate-artwork it's not yet fixed in y and not even uploaded for x

Changed in ubuntu-mate-artwork (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-mate-artwork (Ubuntu Xenial):
importance: Undecided → Medium

Hello Matthew, or anyone else affected,

Accepted ubuntu-mate-artwork into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-mate-artwork/16.04.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-mate-artwork (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed

This was fixed in yakkety via ubuntu-mate-artwork 16.10.3.

Changed in ubuntu-mate-artwork (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-artwork - 16.04.7

---------------
ubuntu-mate-artwork (16.04.7) xenial; urgency=medium

  * Make GTK2 and GTK3 scrollbars consistent. Closes (LP: #1581168)
  * Fix progress bars so they are one colour. Closes (LP: #1052936)

 -- Martin Wimpress <email address hidden> Wed, 06 Jul 2016 09:26:32 +0100

Changed in ubuntu-mate-artwork (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers