Ubuntu

Untranslated strings in manual partitioning window

Reported by Timo Jyrinki on 2007-09-25
24
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Colin Watson
Nominated for Intrepid by Ricardo Pérez López
Hardy
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

Thanks to the latest upload to Rosetta, "Advanced settings" on the last page is now fully translatable and probably is translated in ubiquity-gtk as soon as translations are again imported from Rosetta.

Also some new strings in the manual partitioning window were now offered for translation, namely edit partition, edit a partition, create partition and new partition size in megabytes. However, the following strings were not made newly translatable, and are also not found in the whole debian-installer.po file just downloaded from Rosetta:

"Delete partition"
"free space"
"unknown"

and the column headers:
"Device"
"Type"
"Mount point"
"Format?"
"Size"
"Used"

On the contrary, the edit partition dialog seems to be fully translatable now, with the strings mentioned already and the fact that "Use as:" and "Mount point:" apparently found their translations automatically in Rosetta.

Bug 103925 has the only other remaining i18n problem besides manual partitioning screen, ie. that the last "Install" button is not translated. I think it's actually a bit more important than the remaining manual partitioning screen problems, since it's visible for everyone. Of course everything should be translatable eventually.

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
Timo Jyrinki (timo-jyrinki) wrote :

Rechecked with ubiquity 1.6.0 that should have translations updated from Rosetta. All the strings listed one string per row in the description are still untranslated.

Additionally, "Edit partition" and "New partition" buttons are still not translated, and "Use as:" and "Mount point:" are not translated despite the translation existing in the PO file.

Colin Watson (cjwatson) wrote :

Fixed "Use as:" and "Mount point:".

Colin Watson (cjwatson) wrote :

I think I may not have time to get to the rest before gutsy now, unfortunately. Thanks for the detailed list, though, and it should now be relatively straightforward to take care of the rest in hardy.

Changed in ubiquity:
importance: Undecided → Medium
status: New → Triaged
Timo Jyrinki (timo-jyrinki) wrote :

Will those make it to hardy?-)

Ricardo Pérez López (ricardo) wrote :

Using current Hardy Live-CD (20080405), almost any string in manual partitioning window shows unstranslated. I attach an screenshot to illustrate what you can see when you select Spanish language and choose manual partitioning.

Please, please, fix this issue before Hardy release!!!!

Ricardo Pérez López (ricardo) wrote :

The last installation message shows unstranslated, too:

"Installation is complete. You need to restart the computer in order to use the new installation."

Screenshot attached.

Colin Watson (cjwatson) wrote :

The final message is translatable; the Spanish translation simply wasn't updated in Launchpad when we last did a translation sync. I imagine it's probably been updated since then and we'll pick it up.

I must beg you not to comment on this bug about other translation problems. Each one is a distinct bug and it gets very confusing if you lump them all together. (I'm OK with all the manual partitioning ones being in the same bug, since they're basically a logical unit, but the final message is completely separate.)

Ricardo Pérez López (ricardo) wrote :

Sorry, Colin, you are right; the last issue is a different one. Sorry again.

Colin Watson (cjwatson) wrote :

Fixed in bzr. I don't expect that the translation templates will be available in time for 8.04, unfortunately; but we have 8.04.1 planned for early July, and I expect there'll be time for an installer translation refresh around the beginning of June.

Changed in ubiquity:
assignee: nobody → kamion
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.3

---------------
ubiquity (1.8.3) hardy; urgency=low

  [ Colin Watson ]
  * Make all text in the partitioner translatable (LP: #144741).
    Unfortunately we don't have time to get translations in place for 8.04,
    but there ought to be time to do this for 8.04.1. This also involved
    moving the "Undo changes to partitions" button to a second line in order
    to avoid excessive horizontal growth.
  * Adjust po-debconf flags in ubiquity/install/copying_error/md5, so that
    ${FILE} doesn't get translated.
  * Offer a list of mount points when creating a partition (LP: #85713).
    Adjust this list (and also that offered when editing a partition) if the
    file system is changed to FAT or NTFS.
  * Guard against division by zero while copying files (LP: #211503).
  * Ensure that "Location for the new partition" always defaults to
    "Beginning" (LP: #207810).
  * Stop X forwarding code from breaking if we aren't running within X
    (LP: #214211).

  [ Evan Dandrea ]
  * Update the translations from Rosetta.
  * Automatic update of included source packages: debian-installer-utils
    1.50ubuntu3, localechooser 1.42ubuntu5, partman-basicfilesystems
    56ubuntu4.

  [ Jonathan Riddell ]
  * Fix exception in edit partitions dialogue use in kde_ui
  * Add minimum size to partition_edit_dialog.ui, closes LP: #203626
  * Fix buttons on question dialogue to use supplied text, closes LP: #203660

 -- Evan Dandrea <email address hidden> Thu, 10 Apr 2008 04:22:15 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released

I think it's not fixed yet:

1. There's no .POT file pending to upload into debian-installer Launchpad template:

     https://translations.launchpad.net/ubuntu/hardy/+source/debian-installer/+imports

2. In the latest version of ubiquity, some strings has been replaced with new ones:

     - "New Label" -> "New partition table"
     - "New" -> "New partition"
     - "Edit" -> "Edit partition"
     - "Delete" -> "Delete partition"

3. The above new strings aren't into the Launchpad template, nor the column headers yet ("Device", "Type", "Mount point", "Format?", "Size", "Used"), as you can see here:

     https://translations.launchpad.net/ubuntu/hardy/+source/debian-installer/+pots/debian-installer/es/+translate

Therefore, I can't see the results of the bugfix.

Do I miss something?

Timo Jyrinki (timo-jyrinki) wrote :

Ricardo: No, you're not missing anything, it's just that the Rosetta is updated manually, so subscribing Launchpad Translations now.

Changed in rosetta:
status: New → Confirmed

Can anyone describe what is expected from Launchpad Translations team? Colin, do we need to do any uploads for you? (if so, it'd be better to make an Answers ticket instead)

Changed in rosetta:
status: Confirmed → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

Latest debian-installer translation template should be imported to Rosetta, and it has been done manually because it involves some magic scripting or something... I'm not sure if Colin should generate the template for you or what.

Timo Jyrinki (timo-jyrinki) wrote :

Subscribed Jeroen, hinted by Colin on IRC.

So, the debian-installer itself is reportedly fixed, remaining are:
1. Getting the strings to Rosetta
2. Remembering to actually collect the translated strings later, preferably some weeks before the 8.04.1 release so they can be tested in the daily builds

Timo Jyrinki (timo-jyrinki) wrote :

Note that the new strings are now translatable in the debian-installer template in Rosetta. 12 new strings. After those have been translated and translations imported back to ubiquity, this'd be done.

Translations have already been done for Brazilian Portuguese, Dutch, Finnish, Hungarian, Italian, Simplified Chinese and Spanish, so people have noticed those new strings pretty quickly.

Changed in ubiquity:
status: New → Fix Released
Changed in rosetta:
status: Incomplete → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Noticed that new translation imports were mentioned in debian-installer changelog, so this oughta be fixed. Should be testable in the next http://cdimage.ubuntu.com/hardy/daily-live/ images (20080603 or any later).

Timo Jyrinki (timo-jyrinki) wrote :

Hmm, reopening, translations were not imported from Rosetta after all (or not working correctly). Downloaded http://cdimage.ubuntu.com/hardy/daily-live/20080606/hardy-desktop-i386.iso , the manual partitioning screen is mostly English, simlar to before.

Changed in ubiquity:
status: Fix Released → Confirmed
status: Fix Released → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :
Changed in ubiquity:
status: Confirmed → Fix Released
status: Confirmed → Fix Released

The problem reappears in latest Intrepid daily-live desktop CD.

Changed in ubiquity:
status: Fix Released → Confirmed

Screenshot of the Ubiquity installation from latest Intrepid daily-live desktop CD. Most of the strings are in English instead of Spanish.

Jeroen T. Vermeulen (jtv) wrote :

We're still working on getting the rest of the upstream translations into Intrepid.

Timo Jyrinki (timo-jyrinki) wrote :

This is not upstream translation, but Ubuntu's debian-installer translation, which is not a normal PO file and has traditionally been manually imported with some script building the strings to Rosetta, and then manually exported from Rosetta back to debian-installer. So it's not automatic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.10.5

---------------
ubiquity (1.10.5) intrepid; urgency=low

  [ Evan Dandrea ]
  * Filter out the net subsystem when calling update-dev to prevent the
    network connection from resetting (LP: #276383).
  * If ubiquity is installing from a disk, such as a USB drive, then default
    to writing grub to the disk that /boot or / is to be written to, as (hd0)
    will most likely be the installation medium (LP: #282037).
  * Automatic update of included source packages: apt-setup
    1:0.37ubuntu5, partman-auto 78ubuntu3, partman-base 121ubuntu7,
    partman-target 55ubuntu4, user-setup 1.20ubuntu9.

  [ Colin Watson ]
  * Fix typo in architecture detection for ntfsprogs dependency.
  * Work around lpia having DEB_HOST_ARCH_CPU=i686 (!).
  * Disable window minimise buttons if the installer is running in
    standalone mode (LP: #249045).
  * Update imported translations from gtk+2.0 2.14.3-0ubuntu3.
  * Update translations from Launchpad (LP: #144741, #218636, #277451).

  [ Emmet Hikory ]
  * Honor preseeded passwd/allow-password-empty (LP: #280014)

 -- Evan Dandrea <email address hidden> Mon, 13 Oct 2008 01:34:45 -0400

Changed in ubiquity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers