Ubuntu

Unable to shut down or restart on Karmic

Reported by Yosef Karo on 2009-11-01
238
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Wubi
High
Unassigned
Nominated for 9.04 by Tushar Mittal
Nominated for Trunk by Tushar Mittal
sysvinit (Ubuntu)
High
Evan Dandrea
Karmic
Undecided
Unassigned
Lucid
High
Evan Dandrea

Bug Description

This has been addressed by dropping the -f argument to umount calls when Wubi is present.

Patch:
http://launchpadlibrarian.net/35058732/sysvinit_2.87dsf-4ubuntu12.debdiff

To reproduce:
Install Ubuntu 9.04 using Wubi.
Upgrade to Ubuntu 9.10.
Shut down.

The original report follows:
I recently upgraded to ubuntu 9.10, Karmic Koala, and I discovered that I am unable to shut down or reboot. When I select shut down, Karmic starts the process and then hangs. What I get on my screen is this:

*Stopping Kernel Oops catching service kerneloops
*Shutting down ALSA...
*Asking all remaining processes to terminate...
*Deconfiguring network interfaces...
*Deactivating swap...
[ 171.180168] Buffer I/O error on device loop0, logical block 3834127
[ 171.180116] Buffer I/O error on device loop0, logical block 3856120
_

Then a blinking curser. I have no alternative at this point than to manually press the power button to shut down. I will follow this thread so please tell me if you require more information

-Yos

Related branches

Jack (marcocunhasj) wrote :

same problem here...

Yosef Karo (yos) wrote :

Jack, someone on the forums showed me a nifty trick to reboot until this is fixed:
http://kember.net/articles/231/reisub-the-gentle-linux-restart

He said you can change the B to O to shut down, he thinks...I haven't tried it yet.

-Yos

Jack (marcocunhasj) wrote :

ok. I'll try it too! thanks!

ebardazzi (ebardazzi) wrote :

Same issue here. Just for your info it was Jaunty 9.04 on Wubi and upgraded to Karmic 9.10 release. @ Yos, thx for the tip.

Agostino Russo (ago) wrote :

If confirmed, this is an important issue.
I do not seem to be able to reproduce it here though, anything you did that might help recreating the problem?

What is the output of

cat /proc/cmdline
cat /var/run/sendsigs.omit

?

You might have to manually run the shutdown commands (/etc/rc6.d) in the right order from terminal until you find the problematic one (probably S40 or S60).

ebardazzi (ebardazzi) wrote :

Ciao Agostino, FYI I have another laptop here (Dell Latitude D810) showing exactly the same behaviour... Even this one was running Jaunty on Wubi and was upgraded to Karmic. Here is the output you have requested:

$ cat /proc/cmdline
root=UUID=4E2CC33C2CC31E39 loop=/ubuntu/disks/root.disk ro quiet splash
~$ cat /var/run/sendsigs.omit
383

I will try to shut down manually as you have suggested and find the problematic one. One remark shutdown and restart worked like a charm on Jaunty before the upgrade.

Regards,
Enrico.

Jack (marcocunhasj) wrote :

here is the output:

marco@marcocunha:~$ cat /proc/cmdline
root=UUID=9C583FD5583FACC0 loop=/ubuntu/disks/root.disk ro quiet splash
marco@marcocunha:~$ cat /var/run/sendsigs.omit
438

Is it possible that this might have something to do with the 9.04 Wubi instalation ?

Agostino Russo (ago) wrote :

Is this a clean installation on 9.10? Are you using ntfs? If so there should be another boot paramter:

rootflags=syncio

Jack (marcocunhasj) wrote :

this is a upgrade from a 9.04 wubi installation under vista... I think I'm using ntfs but i'm a newbie. How do I check it out?

ebardazzi (ebardazzi) wrote :

I confirm I'm using NTFS file system. I did not edit the root parameters and let Karmic upgrade the system automatically.

Should I add this to the boot sequence? Any advice would be welcome...

Jack (marcocunhasj) wrote :

how and where should we add this? I'd tried to edit cmdline without success..

Agostino Russo (ago) wrote :

if you are using grub legacy (default for wubi 9.04), you should add it within /boot/grub/menu.lst in kopt
Then run: sudo update-grub

Do you experience the same issue with a clean installation of 9.10?

ebardazzi (ebardazzi) wrote :
Download full text (5.4 KiB)

I did not try it. I will do it on another pc and advise. It's not clear to me where I should add the parameter? Here is my menu.lst.

The kopt session is all commented.

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 0

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=4E2CC33C2CC31E39 loop=/ubuntu/disks/root.disk ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=()/ubuntu/disks

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## ...

Read more...

Agostino Russo (ago) wrote :

# kopt=root=UUID=4E2CC33C2CC31E39 loop=/ubuntu/disks/root.disk ro rootflags=syncio

Then run: sudo update-grub

Agostino Russo (ago) wrote :

Hmm the line above was split, it's all in one line:

# kopt= ... rootflags=syncio

ebardazzi (ebardazzi) wrote :

Done. Unfortunately it did not fix it. Now the error messages reports several errors "Buffer I/O error on device loop0, logical block xxxxxx".

Yosef Karo (yos) wrote :

Agostino,

You asked if the same thing happens on a clean install. I just moved away from wubi and did a clean install yesterday and now it works perfectly.

-Yos

Jack (marcocunhasj) wrote :

:(
I did something wrong... very wrong! now I can't startup my system!
It hangs on startup saying:

ALERT! /dev/disk/by-uuid/4E2CC33C2CC31E39 does not exist- Droping to a shell!
(initramfs)

how can i undu this mistake?

Agostino Russo (ago) wrote :

Hi please try the following from an dist-upgraded Wubi Jaunty installation:

edit /etc/rc6.d/S40umountfs

replace

fstab-decode umount -f -r -d $WEAK_MTPTS

with

fstab-decode umount -r -d $WEAK_MTPTS

and

fstab-decode umount -f -v -r -d $WEAK_MTPTS

with

fstab-decode umount -v -r -d $WEAK_MTPTS

Then try to reboot and let me know if it works

Agostino Russo (ago) wrote :

Jack, press "ESC" after selecting "ubuntu", then press "e" within the grub boot menu to edit the menu entries or "c" to get a console. In the console you can see what partitions are available. If the windows partition cannot be mounted or is not accessible from linux, you might have to check the file system from within windows.

Agostino Russo (ago) on 2009-11-03
Changed in wubi:
status: New → Confirmed
importance: Undecided → High
Jack (marcocunhasj) wrote :

Agostino, the windows partition is ok, can be mounted from the linux...
Is there any way to revert the changes I made in /boot/grub/menu.lst ?
now i'm stuck! I can't start up my ubuntu
When explaining something don't forget i'm a newbie! :)
thanks!

jack

Dave Morley (davmor2) wrote :

Confirmed.

With the upgrade now in place wubi refuses to restart from the end of the upgrade.

After powering down using the power button I can once again get into the system.

However once rebooted I can start and stop and restart the system at will.

Ago I can try against xp this afternoon if that will help?

Agostino Russo (ago) wrote :

Dave can you please test whether the changes in #19 help?

Agostino Russo (ago) wrote :

Does the issue only happen during the first reboot after the upgrade 9.04 -> 9.10 or does it happen every time after the upgrade?
From the other comments it looks like the latter is the case.

Dave Morley (davmor2) wrote :

davmor2@ubuntu:~$ mount
/dev/loop0 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda3 on /host type fuseblk (rw)
/host/ubuntu/disks/boot on /boot type none (rw,bind)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/davmor2/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=davmor2)

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Agostino Russo (ago) wrote :

Please see if you can reproduce that consistenly.
My best guess so far is that comment #19 should fix the issue.
Please confirm.

Agostino Russo (ago) wrote :

Untested patch

--- /etc/init.d/umountfs 2009-10-14 05:15:49.000000000 +0100
+++ /tmp/umountfs 2009-11-03 14:58:38.767258508 +0000
@@ -94,13 +94,14 @@
  #
  if [ "$WEAK_MTPTS" ]; then
   if [ "$VERBOSE" = no ]
+ # Do not use the -f umount option here
   then
    log_action_begin_msg "Unmounting weak filesystems"
- fstab-decode umount -f -r -d $WEAK_MTPTS
+ fstab-decode umount -r -d $WEAK_MTPTS
    log_action_end_msg $?
   else
    log_daemon_msg "Will now unmount weak filesystems"
- fstab-decode umount -f -v -r -d $WEAK_MTPTS
+ fstab-decode umount -v -r -d $WEAK_MTPTS
    log_end_msg $?
   fi
  fi

Jack (marcocunhasj) wrote :

Agostino...
i'm still stuck here... should i give up or is there hope for my case? I made something wrong when editing /boot/grub/menu.lst and know i can't even start my ubuntu ...

Jack (marcocunhasj) wrote :

ok, back on-line. The problem seams solved, but now the boot takes over 2.5 minutes. Any idea why?

ebardazzi (ebardazzi) wrote :

Ciao Agostino, I tried your solution # 19 and I'm glad to inform you it works! The system reboot now very quickly. Thank you very much for your help.

Enrico,

Agostino Russo (ago) on 2009-11-03
Changed in sysvinit (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
lunix (bob-l-lewis) wrote :

Hi Agostino: I also tried #19 remotely leading a 75 year old friend through these edits and he is now happy.
Now on to doing the same for a 89 year old guy who lives 1000 miles away. Many thanks for your hard work.

Andrew (waclarke) wrote :

Can confirm solved issue on a 9.04 Wubi upgrade to 9.10

Andrew (waclarke) wrote :

Sorry key haapy:- #19 Solve issue on Wubi 9.04 upgraded to 9.10

jahrra (jahrra) wrote :

Hi Agostino,
+1 confirmation that #19 solved the problem :)
thanks for the work, saved my day.

Agostino Russo (ago) wrote :
Agostino Russo (ago) on 2009-11-03
Changed in sysvinit (Ubuntu):
milestone: none → karmic-updates
Alex Kallinikos (alkalline) wrote :

I have the same problem on a HP mini since last night. I will try these fixes after I get back from work and see what happens. Thanks in advance :)

Alex Kallinikos (alkalline) wrote :

Btw, someone suggested to me to run on the terminal: sudo gedit /etc/init.d/halt
and add the following line to the top of the halt script: rmmod snd-hda-intel

I tried it and it does work. Not sure if it meshes with anything else though...
Cheers!

Agostino Russo (ago) wrote :

Alex, the fix above is only relevant if you installed via Wubi 9.04 and then upgraded to 9.10.

Evan Dandrea (ev) on 2009-11-05
Changed in sysvinit (Ubuntu):
assignee: Colin Watson (cjwatson) → Evan Dandrea (evand)
status: Confirmed → Fix Committed
Evan Dandrea (ev) on 2009-11-05
description: updated
Agostino Russo (ago) on 2009-11-05
Changed in wubi:
status: Confirmed → Invalid
Martin Pitt (pitti) on 2009-11-10
Changed in sysvinit (Ubuntu Karmic):
milestone: none → karmic-updates
Changed in sysvinit (Ubuntu Lucid):
milestone: karmic-updates → lucid-alpha-1
Changed in sysvinit (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
48 comments hidden view all 128 comments
Agostino Russo (ago) wrote :

Please either enable the karmic-proposed repository (see link in Martin's post #88) and then do a system upgrade. Or install one of the packages below which is appropriate for you.

For 32 bit ubuntu:
http://archive.ubuntu.com/ubuntu/pool/main/s/sysvinit/initscripts_2.87dsf-4ubuntu12_i386.deb

For 64 bit ubuntu:
http://archive.ubuntu.com/ubuntu/pool/main/s/sysvinit/initscripts_2.87dsf-4ubuntu12_amd64.deb

Then try to reboot and please report whether it works or not.

Certainly seems to have solved my shutdown issues thanks

The 32-bit package solved my shutdown problems. Thanks

Omer Akram (om26er) wrote :

its fixed great work

Martin Pitt (pitti) on 2009-11-10
tags: added: verification-done
removed: verification-needed
shiro (dreijun) wrote :

The solution proposed in #19 worked just fine for me, thank you very much for your help!

If we are to try the proposed package, should we undo the changes we made to the "S40umountfs" file before proceeding or is this not necessary?

Thank you. :-)

rhulse12 (hulse12) wrote :

What other "OS"'s uses Wubi? Can some one tell me..
Thank You

WeatherGod (ben-v-root) wrote :

rhulse12, http://wubi-installer.org/ should answer your questions.

Richiegs (richiegs) wrote :

Agostino Russo, after downloading the file on #89, my PC can shut down without a problem. Thank you very much for your help. However, I can only log in thru Failsafe Gnome, but not Gnome. Do you have any idea how to fix it?

WeatherGod (ben-v-root) wrote :

Richiegs, we can address the problem with logging into gnome from the bug report that you have already filed. If you can not find your original bug report, go to your launchpad user page to see the list of bug reports that you have contributed to.

yuanqing (zhen-ou) wrote :

thank you very much. Agostino !!

bonariabiancu (bonariabiancu) wrote :

Thanks, Agostino! Post#19 solution works for me, too

Alver (nekerev) wrote :

Hello Agostino, I too discovered the bug of 9.10 not stopping or restarting properly after a distribution upgrade. I applied your fix (item 19) and, lo and behold, it works flawlessly! As I am an absolute beginner in the Linux realm, I wanted to avoid a clean install for the time being. Thank you very much for your excellent guideline.

Thanks Agostino, I've only just found Launchpad, and within twenty minutes of reading down to #89 I'm impressed - it's fixed.
No more 'hard reset' by removing the battery on my laptop. Thank you.

helmut0 (helmut0) on 2009-11-15
Changed in sysvinit (Ubuntu Karmic):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Jairo (jairofsouza) wrote :

 #19 do not worked to me... After some shutdowns (three days after I changed /etc/rc6.d/S40umountfs), the problem came back.

Jairo (jairofsouza) wrote :

Adding information: I use Ubuntu 9.1, Wubi install. Some reboots worked ok, some reboots don't.
    Agostino, I didn't install the package that you informed on #89, cause, I think, the only change was in S40umontfs. Is it right?

WeatherGod (ben-v-root) wrote :

Jairo, can you upload your S40umountfs file to this report. It is possible that the update messed something up.

Jairo (jairofsouza) wrote :

I pasted S40umountfs file content here: http://paste.ubuntu.com/320338/

WeatherGod (ben-v-root) wrote :

Jairo, according to the file you pasted, you changed the wrong things, I think. That is why it is not working for you

On line 99, you left the -f option, but removed the -r option. That is incorrect. The -f option should have been removed, and the -r option kept.

Jairo (jairofsouza) wrote :

Oh, I`m sorry for this mess! I could swear it was OK. Can some program have changed it? Anyway, I`ll try again. Thanx a lot!

I've a 9.1 upgraded from 9.04 installed with Wubi in XP. I'd tried "sudo upgrade-grub" and it works well with reboot but not with shut down. If i try something, it will be #89. It looks more practic to me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sysvinit - 2.87dsf-4ubuntu12

---------------
sysvinit (2.87dsf-4ubuntu12) karmic-proposed; urgency=low

  * debian/initscripts/etc/init.d/umountfs: do not use the -f option when
    unmounting WEAK_MTPTS, in the case of bind mounts in particular, that
    results in the underlying device being unmounted, LP: #468589
 -- Agostino Russo <email address hidden> Tue, 03 Nov 2009 23:04:53 +0000

Changed in sysvinit (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in sysvinit (Ubuntu Lucid):
status: Fix Committed → Fix Released
aaricia (maricruz-garcia) wrote :

Thanks to Agostino Russo. I tried his solution (#19) and it worked

#$%&! The bug reproduces itself again after few days, as it had been said. It rebooted well without doing the same with shuting down. Now it is there, as if nothing happens. Updating Grub doesn't work. I'll try the .deb for amd64 of #89. I hope it won't stop my Ubuntu partition.

Ok. I checked karmic-proposed in "Software sources", the i run the Update Manager. I checked the 2.87dfs-4ubuntu12 and installed the package. Nothing happened. My machine still doesn't reboot or shut down. I've to do it manually, pushing the power or reboot button. What should i do?

WeatherGod (ben-v-root) wrote :

benditoelqueviene, could you please check your S40umountfs file to see if the appropriate changes were made?

Changed in sysvinit (Ubuntu Lucid):
status: Fix Released → Incomplete
Changed in sysvinit (Ubuntu Karmic):
status: Fix Released → Invalid
Micah Gersten (micahg) wrote :

@John Wheelwright

Please don't change bug statuses from Fix Released with talking to the Developer and commenting.

Changed in sysvinit (Ubuntu Karmic):
status: Invalid → Fix Released
Changed in sysvinit (Ubuntu Lucid):
status: Incomplete → Fix Released

Ok. I attach the file, but shutting down and reboot are just the same.

After a few days, reboot and shutting down start to work fine. I don't know why, but now it closes faster. Thanks! (i guess you'll find the reason...)

Landsman (dedilands) wrote :

Hi, I'm having Wubi Ubuntu 9.04. I got exactly the same symptoms with the problem to shut down, the difference is that my computer runs on Jaunty 9.04. and not Karmic 9.10 upgraded from Jaunty, so i guess the solution given at #19 isn't really the one for me. thanks for any help

WeatherGod (ben-v-root) wrote :

Landsman, yes, because you have a different OS, your symptom is not from the same cause. Therefore, it is probably best to file a separate bug report (maybe against Wubi?). Be sure to describe exactly what you are experiencing when shutting down. Also be sure to note your make/model of your computer.

Matteo Rossi (teo-red90) wrote :

I'm experiencing this bug with a fresh install of 9.10 on a dedicated partition -no Wubi- with other two NTFS partitions.

I fixed the bug after update to 2.6.31.16-generic using the workaround provided here:

https://bugs.launchpad.net/wubi/+bug/468589/comments/19

But after update to 2.6.31.17-generic #54-Ubuntu the bug appears again.

WeatherGod (ben-v-root) wrote :

Matteo, because you have a completely different cause than the others in this bug report, please file a separate bug report describing your issue. This bug report is only for those who are experiencing the issue having installed upgraded to 9.10 from 9.04 installed using wubi.

Also, please double-check the file you edited to see if the last update might have undone your changes.

Changed in sysvinit (Ubuntu Karmic):
status: Fix Released → Confirmed
WeatherGod (ben-v-root) wrote :

stsitiridis, please do not change the status of a bug report without at least submitting a comment explaining the change in status. I am currently returning this report back to "Fix Released" for Karmic.

Changed in sysvinit (Ubuntu Karmic):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Aadil H (aadilh) wrote :

I think its worth placing this comment in the hope that anyone looking for an answer might consider this simple GUI solution.

Problem at shutdown failure at deactivating Swap.... Solved on Karmic Ubuntu

After over a month, desperately searching the INTERNET launchpad and wherever the search engines took me. I found the solution for my system. It is so simple I'm surprised none of the experts of the many many forums ever suggested it.

I forced my system off, i restarted to bios and power it off from there, tried to modify scripts and power down using various commands, yet it all failed, the hours & hours wasted. After almost giving up & waiting for the next major update to Lucid Lynx meaning months to shutdown my system properly (silly but well what can i say)

OK to the point.... which really really doesn't make me happy.... because of its simplicity.

I decided to find some shutdown tools in the hope that an advanced tool might help... So I Entered Synaptic Package Manager

Did a search... typed shut (& of course the results had a few tools for shutting down) or you can search initscripts which is my solution

1. I right clicked (sweet no command line)
2. Mark for re-installation (sweet so simple)
3. Apply & let the task complete

4. Reboot / perhaps shutdown & your computer powers off itself (You must love technology that turns off when you tell it to)

As a new user, why of why didn't anyone say i could have reinstalled that, i was thinking how to reinstall shutdown but didn't know the term i needed. I'd be interested to know, does this solve a

WeatherGod (ben-v-root) wrote :

Aadil, when you reinstalled initscripts, you obtained the updated version of the initscript. You would have obtained the same result just be performing a system update.

The non-GUI way was from when we were testing the fix and have not released the fix for the update system. Now everyone who performs updates will get the fix.

Constan (constan-fdz) wrote :

Hello guys,

I was having this problem from a fresh install of karmik in a laptop along with XP. As rebooting the system and then turning it off from windows was a workaround, I never payed much more attention. But today I wiped the hard disk, did a fresh installation (no XP anymore), and upgrade of all packages - all of this straigh in 9.10 - . And again the same problem. it does restart properly, but it does not shut down. I´ve activated the karmic-proposed repositories, updated the system, and same issue. I tried also editing s40umount removing the -f option.

It´s the first time I´m using launchpad to report a problem, and it is because I haven´t find any other solution. If I can provide you with any information that may help you please let me know (my machine is an acer extensa 3000)

thanks.

WeatherGod (ben-v-root) wrote :

Constan, thank you for taking the time to report this issue to help make Ubuntu better. While your symptom is similar, the cause is obviously not the same cause that is addressed here. Therefore, it would be best if you file a new bug against ubuntu to help figure out your issue.

Constan (constan-fdz) wrote :

Thanks weathergod, I've created Bug #520706 in case someone want's to take a look...

Taiwo (fakoya) on 2010-03-10
Changed in sysvinit (Ubuntu Lucid):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) wrote :

Please don't change bug status without explanation.

Changed in sysvinit (Ubuntu Lucid):
status: Fix Committed → Fix Released
Displaying first 40 and last 40 comments. View all 128 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers