[SRU] screen server process can be crashed by byobu

Bug #1274720 reported by Anders Kaseorg on 2014-01-30
118
This bug affects 22 people
Affects Status Importance Assigned to Milestone
screen
Unknown
Unknown
byobu (Debian)
Confirmed
Unknown
byobu (Ubuntu)
Critical
Dustin Kirkland 
Trusty
Critical
Dustin Kirkland 
Utopic
Critical
Dustin Kirkland 
screen (Debian)
Confirmed
Unknown
screen (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned

Bug Description

screen crashed with SIGSEGV

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: screen 4.1.0~20120320gitdb59704-9
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jan 29 23:59:55 2014
ExecutablePath: /usr/bin/screen
InstallationDate: Installed on 2010-12-05 (1152 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcCmdline: SCREEN
SegvAnalysis:
 Segfault happened at: 0x7f4f000a1f15 <__GI_tcsetattr+117>: mov (%r8),%eax
 PC (0x7f4f000a1f15) ok
 source "(%r8)" (0x00001430) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: screen
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: screen crashed with SIGSEGV
UpgradeStatus: Upgraded to trusty on 2013-10-31 (91 days ago)
UserGroups:

[Impact]
 * Byobu users of the byobu-screen backend will find their screen process crashed, if they hit ctrl-a (screen's default escape sequence). This is a critical breakage for byobu-screen users.
[Test Case]
 * From a new or fresh Trusty installation (desktop or server), drop to a command line, and run 'byobu-screen'. You'll be interactively prompted to choose whether ctrl-a should be handled like screen or emacs. Choose (1) for screen. Your screen session is now crashed.
 * Upgrade to the package in trusty-proposed, launch a new byobu-screen session, and press ctrl-a-c to create a new window, and then ctrl-a-n and ctrl-a-p and that should all work perfectly well now.
[Regression Potential]
 * This fix does revert the change that was intended to fix a far more minor Bug: #814172. I have reopened that bug, will fix it separately, and upload another SRU later.
 * Otherwise, regression potential should be minimal. Once that recent commit was reverted, the code looks very much like it's looked for a very long, stable time.
[Other Info]
 * None

Anders Kaseorg (anders-kaseorg) wrote :
Changed in screen (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public

Any hint about what you were doing when it crashed?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in screen (Ubuntu):
status: New → Confirmed
Andreas Hasenack (ahasenack) wrote :

I get it to crash when I run:
rm -rf ~/.byobu
byobu-screen
hit ctrl-a c

Hi Andreas,

Andreas Hasenack wrote:
> I get it to crash when I run:
> rm -rf ~/.byobu
> byobu-screen
> hit ctrl-a c

That way I only get byobu's menu about which Ctrl-A behaviour I want.
But if I choose the "screen behaviour" and then I get a screen
(server) process zombie and a no more reacting screen (client)
process -- even if I kill these processes, start a new byobu-screen
session and press "Ctrl-A c" again, the same happens. (Everything
works fine, if I choose the "emacs behaviour".)

So thanks for that hint!

It does not only happen with "Ctrl-A c" but at least also "Ctrl-A m"
(repeat last message).

Marking this issue as "also affects byobu" as it seems to use screen
in an incompatible way. (IIRC it uses tmux as default backend
nowadays.) IMHO this should be fixed in byobu, too.

Nevertheless, getting screen to make its server process becoming a
zombie is clearly also an issue in screen -- which should be fixed.

I can also reproduce it on Debian Sid. "screen -ls" shows a dead
session there:

screen -ls
There is a screen on:
        30562.byobu (04/23/14 16:09:44) (Dead ???)
Remove dead screens with 'screen -wipe'.
1 Socket in /var/run/screen/S-abe.

I'll try to reproduce it with some simpler setup than byobu and
forward it to the GNU Screen upstream.

JFTR: I could reproduce it with byobu version 5.77-0ubuntu1 and screen
4.1.0~20120320gitdb59704-9 on trusty as well as with byobu 5.77-1 and
screen 4.2.0-1 (i.e. the newest GNU Screen upstream version, currently
in Debian Experimental).

  Regards, Axel
--
 ,''`. | Axel Beckert <email address hidden>, http://people.debian.org/~abe/
: :' : | Debian Developer, ftp.ch.debian.org Admin
`. `' | 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593 0EDE
  `- | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5

Axel Beckert (xtaran) on 2014-04-23
summary: - screen crashed with SIGSEGV
+ screen server process can be crashed by byobu

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in byobu (Ubuntu):
status: New → Confirmed
Adam Collard (adam-collard) wrote :

I can confirm that this is reproducible with the steps in comment 9 with an additional step of choosing Screen escape key (e.g. Ctrl-A).

Changed in byobu (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Critical
assignee: nobody → Dustin Kirkland  (kirkland)
Changed in byobu (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Dustin Kirkland  (kirkland)
milestone: none → trusty-updates
Changed in byobu (Ubuntu Utopic):
status: In Progress → Fix Committed
summary: - screen server process can be crashed by byobu
+ [SRU] screen server process can be crashed by byobu
description: updated

Hello Anders, or anyone else affected,

Accepted byobu into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/byobu/5.77-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in byobu (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in screen (Ubuntu Trusty):
status: New → Confirmed
Axel Beckert (xtaran) wrote :

No more crashes, but Ctrl-A now _always_ triggers the Ctrl-A behaviour menu, even after setting it once and then exiting the session and starting a new one. Can't get Ctrl-A to work properly with 5.77-0ubuntu1.1. :-(

Short said: The crash is unfortunately replaced with an annoying behaviour which is worse than https://bugs.launchpad.net/byobu/+bug/814172

Andreas Hasenack (ahasenack) wrote :

Same here, ctrl-a *always* triggers the menu, even after I have already made a selection. Please don't upload this to -updates.

Changed in screen (Debian):
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.78-0ubuntu1

---------------
byobu (5.78-0ubuntu1) utopic; urgency=medium

  * usr/share/byobu/profiles/dircolors:
    - give executables just a little more pop
    - use a light grey underline for symlinks
    - add whitespace before inline comment
  * usr/share/byobu/profiles/bashrc:
    - Enable Ubuntu-themed dircolors on Ubuntu systems
  * usr/bin/byobu-janitor.in: LP: #1311919
    - ensure that windows.tmux exists; fixes warning with F5
  * usr/bin/byobu-ctrl-a.in: LP: #1311177, #1274720
    - revert r2317 as this is breaking ctrl-a in byobu-screen in a bad way
 -- Dustin Kirkland <email address hidden> Sun, 30 Mar 2014 20:42:10 -0500

Changed in byobu (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in byobu (Debian):
status: Unknown → Confirmed
Andreas Hasenack (ahasenack) wrote :

ctrl-a always brings up the menu on 5.77-0ubuntu1.1. Please don't upload this to updates.

tags: added: verification-failed
removed: verification-needed
CSRedRat (csredrat) wrote :
Changed in byobu (Ubuntu Trusty):
status: Fix Committed → In Progress
Dustin Kirkland  (kirkland) wrote :

FYI, I have uploaded byobu_5.77-0ubuntu1.2 to trusty-proposed, with a fix for this issue. The patch was missing a double-quote.

It tests fine for me now. Please retry, @ahasenack, and let us know if that works better!

Nikkel Pikkel (nikkelpikkel) wrote :

I am not able to download the byobu_5.77-0ubuntu1.2 version from trusty-proposed. Still getting 5.77-0ubuntu1.1 and am able to duplicate the issue noted by ahasenack. Did the upload of byobu_5.77-0ubuntu1.2 succeed? Should I wait longer for some upload propagation process to complete? First use of LP, so apologies in advance for missing what is obvious to the experienced. Would love to test byobu_5.77-0ubuntu1.2

UUoC shows:

cat /etc/apt/sources.list | grep proposed
deb http://archive.ubuntu.com/ubuntu/ trusty-proposed restricted main multiverse universe

apt-get install -s byobu/trusty-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '5.77-0ubuntu1.1' (Ubuntu:14.04/trusty-proposed [all]) for 'byobu'
The following NEW packages will be installed:
  byobu
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Inst byobu (5.77-0ubuntu1.1 Ubuntu:14.04/trusty-proposed [all])
Conf byobu (5.77-0ubuntu1.1 Ubuntu:14.04/trusty-proposed [all])

Chris J Arges (arges) wrote :

Hello Anders, or anyone else affected,

Accepted byobu into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/byobu/5.77-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in byobu (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed

Note that you will need to `rm -f ~/.byobu/keybindings` after your
failed run. I suppose I could add this to byobu-janitor, if
necessary.

Cheers,

:-Dustin

On Tue, Jul 29, 2014 at 4:21 PM, Chris J Arges
<email address hidden> wrote:
> Hello Anders, or anyone else affected,
>
> Accepted byobu into trusty-proposed. The package will build now and be
> available at http://launchpad.net/ubuntu/+source/byobu/5.77-0ubuntu1.2
> in a few hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: byobu (Ubuntu Trusty)
> Status: In Progress => Fix Committed
>
> ** Tags removed: verification-failed
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1274720
>
> Title:
> [SRU] screen server process can be crashed by byobu
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/screen/+bug/1274720/+subscriptions

Andreas Hasenack (ahasenack) wrote :

5.77-0ubuntu1.2 from trusty-proposed works for me, thanks!

Scott Moser (smoser) on 2014-07-30
tags: added: verification-done
removed: verification-needed
Nikkel Pikkel (nikkelpikkel) wrote :

5.77-0ubuntu1.2 fixes this issue for me. Thx.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.77-0ubuntu1.2

---------------
byobu (5.77-0ubuntu1.2) trusty-proposed; urgency=medium

  * usr/bin/byobu-ctrl-a.in: LP: #1274720
    - cherry pick upstream r2338, r2363
    - revert r2317, as this is breaking ctrl-a in byobu-screen in a bad way
      + add bindkey line back, this line is *essential*; there was a
        syntax error in it previously, but removing the line was not
        the correct fix; fix a missing double quote in last upload

  * usr/bin/byobu-janitor.in: LP: #1311919
    - cherry pick upstream r2337
    - ensure that windows.tmux exists; fixes nasty warning with F5
 -- Dustin Kirkland <email address hidden> Wed, 23 Apr 2014 18:28:16 -0500

Changed in byobu (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for byobu has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in screen (Ubuntu Trusty):
importance: Undecided → Medium
Changed in screen (Ubuntu Utopic):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.