Please remove reportbug-ng from Intrepid

Bug #175508 reported by Mind Booster Noori on 2007-12-11
22
Affects Status Importance Assigned to Milestone
GLibC
Invalid
Undecided
Unassigned
reportbug-ng (Ubuntu)
High
Unassigned
Nominated for Hardy by Alain Baeckeroot

Bug Description

Please, remove reportbug-ng source and binary from Intrepid, for the following reasons:

There makes no sense for people to send Ubuntu bugs to Debian. That annoys some DDs and they are sometimes closed directly (we also close PPA bugs without looking into them, so we know how annoying that is).
There's for many applications the Launchpad integration in the Help menu
Making it send bugs to ubuntu-users@l.u.c makes no sense as they can be real bugs and will get lost

Changed in reportbug-ng:
status: New → Confirmed
Changed in reportbug-ng:
importance: Undecided → Wishlist
Mind Booster Noori (marado-isp) wrote :

I'm sorry, can you explain me why is this tagged as "wishlist"?
When a Ubuntu user uses reportbug-ng he is reporting a bug against an Ubuntu package, possible an Ubuntu version that might have that problem in Ubuntu, that bug report might have been reported already on Ubuntu and the problem might only affect Ubuntu, so the importance of knowing it is to the Ubuntu community. /If/ the bug is also present upstream, or if the package is from Debian, then yes, the bug report should be forwarded to Debian, but the tools for reporting bugs in Ubuntu should report them to Ubuntu and not to Debian. This isn't just a feature I would like to see in reportbug-ng (that would fit into the wishlist), this is a bug that messes up with the usefullness of the package and can damage the quality of the Ubuntu project itself.

Dan Am (da-lonx) wrote :

This bug is still going to date. FWIW...

Bugs concerning ubuntu send by reportbug to debian goes to /dev/null

This package is unusable if it does not point to ubuntu. It is IMPORTANT/CRITICAL to fix it, or just remove the package to prevent messing debian with ubuntu bugs.

Why downgrade to wishlist ?

This bug makes the package unusable, so it is at leat IMPORTANT.
It impacts all other packages, whose bugreports are lost for ubuntu BTS.

An it is only a 2 lines patch needed ! It would have been faster for maintener to fix it and close the bug, rather than maintain it open and downgrade it. </unhappy>

Andrew Hampe (andrew-hampe) wrote :

I don't think that launchpad has a SOAP interface, so it's not just a two line quick change. The program would have to be redone using something else (maybe using the python-launchpad-bugs library). I don't understand why the importance is set to wishlist though, as it's totally pointless to send the bugs to the debian bug tracker for a ubuntu package.

On Tuesday 29 April 2008 21:01, Andrew Hampe wrote:
> I don't think that launchpad has a SOAP interface, so it's not just a
> two line quick change. The program would have to be redone using
> something else (maybe using the python-launchpad-bugs library). I don't
> understand why the importance is set to wishlist though, as it's totally
> pointless to send the bugs to the debian bug tracker for a ubuntu
> package.

Well, if the package is useless, as it seem to be, than it should be removed.
Having it there is just not acceptable, not only because it sends useless bug
reports to Debian, but mainly because it gives a false sense of "ok, I've
reported and they'll fix it" to Ubuntu users. This isn't a "wishlist" bug,
this is critical.

--
Marcos Marado

What leads you to believe that reportbug-ng should be used to report bugs about Ubuntu?

Neal McBurnett (nealmcb) wrote :

To report bugs in Ubuntu (to quote Brian's ubuntuopenweek talk today: https://wiki.ubuntu.com/MeetingLogs/openweekhardy/ReportBugs2 )

For Ubuntu the "Report a Problem" functionality has been integrated into lots of applications and is the preferred way to report a bug.
Additionally, apport has a command line interface, called apport-cli, where you can report a bug about a specific package via 'apport-cli -f -p PACKAGE' which is useful for non GUI applications.
Further information about reporting bugs can be found at [WWW] https://help.ubuntu.com/community/ReportingBugs

This web site does not post my reply to Brian Murray (i received his post in my mail box):

Le samedi 3 mai 2008, Brian Murray a écrit :
> What leads you to believe that reportbug-ng should be used to report
> bugs about Ubuntu?

1/ because its in the repositories :) I dont expect it to report to Redhat
     or Gentoo or Debian, but just to Ubuntu/Canonical.

2/ because its very convenient for the user, and i think for canonical,
    as it automatically includes many useful informations that users tend
    to forget in webinterface.

2/ because reportbug (not ng) is configured to send bugs to Ubuntu
     so i guess it is for some reason, and i hope those bugs report
     does not go to /dev/null

If it not used, these packages should be removed.

As reported by someone it gives the false feeling to have done the right
thing, for reporting a bug.

A personnal taste, it is much better to use reportbug-ng than to go on
the web site, subscribe, search with very unpractical interface for related
topics/bugs. I have already spend too much time on this 175508 ;-)

Best regards.
Alain B.
(sysdmin with Debian and Ubuntu-server)

Apport is not available on version 6.10 and older.
i just
$ apt-cache search bug|grep report

to find reportbug-ng. Sorry if i know only tools that were available earlier on Debian, and if i don't guess that reportbug works but reportbug-NG is broken.

This started by filling a bug report about nscd ignoring /etc/nsswitch.conf which endend in debian trashcan.

We all have spend too much time in useless things and discussion, this won't have happened if this bug had been fixed in time instead of been downgraded to whishlist.

Time for action, remove the tools you don't want users to use.

Brian Murray (brian-murray) wrote :

I'm closing the GLibC task as invalid as this bug doesn't affect the glibc project.

Changed in glibc:
status: New → Invalid
Brian Murray (brian-murray) wrote :

Because Ubuntu is a derivative of Debian and because some packages are directly sync'ed from Debian packages it is possible that someone would want to report a bug about one of those packages to Debian and that is why reportbug-ng is included in Ubuntu.

I'll work on getting the description of apport updated so it is more obvious that it has bug reporting tool.

Emilio Pozuelo Monfort (pochu) wrote :

reportbug-ng should be updated to send bugs to <email address hidden> as reportbug does. I've seen quite a few bug reports coming from Ubuntu users in the Debian BTS, which have sometimes annoyed Debian Developers. If someone wants to user reportbug(-ng) to report bugs to Debian, they could still change the configuration or install the Debian package.

reportbug (3.39ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - send bug reports to the ubuntu-users mailing list.

Changed in reportbug-ng:
importance: Wishlist → High
status: Confirmed → Triaged
Siegfried Gevatter (rainct) wrote :

If you change this, please add an option to let it continue sending the options to Debian.

Siegfried Gevatter (rainct) wrote :

ehm... s/options/bugs

Ubuntu's version of reportbug is a fork that protects against this particular issue, so it might be wise to follow their example. There must be a patch file somewhere, but diff'ing the latest versions of each shows roughly how they square this particular circle. The sources are available at:

 * https://launchpad.net/ubuntu/intrepid/+source/reportbug/3.39ubuntu3/+files/reportbug_3.39ubuntu3.tar.gz
 * http://ftp.de.debian.org/debian/pool/main/r/reportbug/reportbug_3.39-0.1.tar.gz

Without really understanding how any of this works, the main differences seem to be that the Ubuntu version:

 * strips out some Debian-specific behaviour - e.g. handle_debian_ftp()
 * Changes several references in failure messages from "blah blah <name of debian server>" to "blah blah <type of server>"
 * Defines a specific SMTP server in the config file (presumably because Ubuntu doesn't have an SMTP server by default?)
 * Posts to <email address hidden> by default
 * For bug reports to ubuntu-users, prints the following message:

Your bug report has been sent to <email address hidden>.
You can subscribe to this mailing list at
    http://lists.ubuntu.com/mailman/listinfo/ubuntu-users
An archive of this mailing list can be found at
    http://lists.ubuntu.com/archives/ubuntu-users/

In addition to the above, I think it would be a good idea to prepend the following text (or something like it) to the REPORTBUG_NG_INSTRUCTIONS variable in MyMainWindow.py:

=== START TEXT ===

<h2>Please use <a href="https://bugs.launchpad.net/bugs/+filebug">Ubuntu's bug reporting tool</a> to report bugs in Ubuntu</h2>

<p>This program was designed to report bugs in Ubuntu's parent project, Debian. Unless you know what you're doing, you should report your bug with <a href="https://bugs.launchpad.net/bugs/+filebug">Ubuntu's bug reporting tool</a>.</p>

<p>Bugs reported with reportbug-ng will be sent to the <a href="mailto:<email address hidden>">Ubuntu users mailing list</a>. You can subscribe to this mailing list by going to <a href="http://lists.ubuntu.com/mailman/listinfo/ubuntu-users">http://lists.ubuntu.com/mailman/listinfo/ubuntu-users</a>, or read the archive by going to <a href="http://lists.ubuntu.com/archives/ubuntu-users/">http://lists.ubuntu.com/archives/ubuntu-users/</a>.</p>

=== END TEXT ===

Brian Murray (brian-murray) wrote :

I don't think that sending bugs to the ubuntu-users mailing list is really the best idea because as far as I know nothing happens to those bug reports.

Brian Murray wrote:
> I don't think that sending bugs to the ubuntu-users mailing list is
> really the best idea because as far as I know nothing happens to those
> bug reports.
>

Then let's just remove the package completely, because sending bugs to Debian is
worse.

For those people wanting to send bugs to Debian, they can still use mail or
install the package from Debian...

Whatever the eventual fix, it should be applied to reportbug too. Both packages should be removed, or both should send reports to Debian, or both send to ubuntu-users. I think reportbug's current behaviour is the least insane alternative short of removing them altogether, which is fine by me too.

Emilio Pozuelo Monfort (pochu) wrote :

I think we should remove it, for the following reasons (already mentioned in the report):

There makes no sense for people to send Ubuntu bugs to Debian
We have for many applications the Launchpad integration in the Help menu
Making it send bugs to ubuntu-users@l.u.c makes no sense as they can be real bugs and will get lost

Am I missing something? If not, I'll subscribe ubuntu-archive and officially request its removal.

Emilio: yes, I think you didn't miss anything.

description: updated
Jon Dowland (jond) wrote :

Amazing. So if the diff was applied properly, it would do the wrong thing (mail ubuntu-users), and without, it files it in the Debian bugtracker? Why on earth was this package imported?

Reinhard Tartler (siretart) wrote :

TBH, I find the package pretty useful, even in ubuntu. This way I can easily browse the bugs of my packages in debian.

Reinhard Tartler wrote:
> TBH, I find the package pretty useful, even in ubuntu. This way I can
> easily browse the bugs of my packages in debian.
>

If it's not removed, it should really not mail Debian by default.

Scott Kitterman (kitterman) wrote :

Yes. By Debian to default is bad and should be fixed as it was for reportbug (or hopefully better).

Reinhard Tartler (siretart) wrote :

I think a better approach could be to improve the GUI to make it more
clear where the bug goes to.

Steve Langasek (vorlon) wrote :

2008-08-28 03:38:37 INFO Removing candidates:
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid amd64
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid hppa
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid i386
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid ia64
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid lpia
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid powerpc
2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid sparc
2008-08-28 03:38:37 INFO Removed-by: Steve Langasek
2008-08-28 03:38:37 INFO Comment: submits bug reports to Debian by default; LP: #175508
2008-08-28 03:38:37 INFO 8 packages successfully removed.
Confirm this transaction? [yes, no] yes
2008-08-28 03:38:52 INFO Transaction committed.
2008-08-28 03:38:52 INFO The archive will be updated in the next publishing cycle.

Should this package also be blacklisted for intrepid+1?

James Westby (james-w) wrote :

On Thu, 2008-08-28 at 03:39 +0000, Steve Langasek wrote:
> 2008-08-28 03:38:37 INFO Removing candidates:
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid amd64
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid hppa
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid i386
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid ia64
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid lpia
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid powerpc
> 2008-08-28 03:38:37 INFO reportbug-ng 0.2008.06.04 in intrepid sparc
> 2008-08-28 03:38:37 INFO Removed-by: Steve Langasek
> 2008-08-28 03:38:37 INFO Comment: submits bug reports to Debian by default; LP: #175508
> 2008-08-28 03:38:37 INFO 8 packages successfully removed.
> Confirm this transaction? [yes, no] yes
> 2008-08-28 03:38:52 INFO Transaction committed.
> 2008-08-28 03:38:52 INFO The archive will be updated in the next publishing cycle.
>
> Should this package also be blacklisted for intrepid+1?
>

Yes, I think so. If we want to make it available using launchpadlib
or similar then we know where to find the Debian package. Having
the package in Ubuntu is a risk.

Thanks,

James

Scott Kitterman (kitterman) wrote :

As noted, reportbug and reportbug-ng have utility in Ubuntu for people that interact with Debian BTS regularly. I'd say leave it blacklisted, but if someone proposes a solution to get it to report to Ubuntu by default, then I think it should be allowed back in.

Steve Langasek (vorlon) wrote :

blacklisted, closing.

Changed in reportbug-ng:
status: Triaged → Fix Released

What about 8.04 LTS ? This bug has been renamed :-( , which is a very bad idea !

The origianl bug title said that reportbug-ng reports to Debian which is wrong. This is *not* solved for Hardy, which will last longer than Intrepid.

Not fixed in Hardy which will last longer than Intrepid.

Changed in reportbug-ng:
status: Fix Released → Incomplete
James Westby (james-w) wrote :

Hi,

Thanks for your concern. This bug is "Fix Released", as it is fixed in the
development version, that is the way that we use the status. If you
are concerned about hardy then please "Nominate for release" and
choose "Hardy".

Thanks,

James

Changed in reportbug-ng:
status: Incomplete → Fix Released
Emilio Pozuelo Monfort (pochu) wrote :

Furthermore, we can't remove packages from stable releases. We could patch it so that it doesn't send messages without an ack or something.

BTW, I haven't seen bugs from Ubuntu to the GNOME packages in Debian for a while.

Ok, i nominated it for Hardy.

Some additionnal remarks about bug management and quality:

1/ The renaming of the bug should not be possible like what happened here. It was a bug against a package for all release, and suddenly it changed to a request for removal in next one, which is very different.

2/ I thought that bugs fixes were always commit to LTS release

Scott Kitterman (kitterman) wrote :

No, that's not generally how the process works. Generally we just fix the development release and only in the case of severe bugs do fixes go back to earlier releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers