Ubuntu

Muon-updater doesn't ask for password

Reported by šumski on 2011-08-24
166
This bug affects 55 people
Affects Status Importance Assigned to Milestone
qapt (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to use muon-updater , but it doesn't work. When selecting Install updates, the following message appers: "This operation cannot continue since proper authorization was not provided"

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: muon-updater 1.2.0-0ubuntu2
Uname: Linux 2.6.39-4.dmz.1-liquorix-amd64 x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Aug 24 16:58:58 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
ProcEnviron:
 LANGUAGE=hr_HR
 LANG=hr_HR.UTF-8
 LC_MESSAGES=hr_HR.UTF-8
 SHELL=/usr/bin/zsh
SourcePackage: muon
UpgradeStatus: Upgraded to oneiric on 2011-08-23 (0 days ago)

Related branches

affects: muon (Ubuntu) → polkit-kde-1 (Ubuntu)

Installing polkit-kde-1 solves the issue, should polkit be added at least to Recommends?

Jonathan Thomas (echidnaman) wrote :

Hmm, yeah.

The assumption had been that since kdebase-workspace-bin depends on polkit-kde-1, KDE users would have it, and that since a lot of Ubuntu's default software depended on policykit-1-gnome GNOME users would have a policykit frontend.

This seems to have been a poor assumption, seeing as you had neither. ;-)

I'll add a or dependency on polkit-kde-1 or policykit-1-gnome to libqapt-runtime, which does the actual polkit calls.

affects: polkit-kde-1 (Ubuntu) → qapt (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qapt - 1.2.0-0ubuntu2

---------------
qapt (1.2.0-0ubuntu2) oneiric; urgency=low

  * Add an or dependency between polkit-kde-1 and policykit-1-gnome to ensure
    we have a policykit frontend installed. (LP: #833058)
 -- Jonathan Thomas <email address hidden> Thu, 25 Aug 2011 21:40:33 -0400

Changed in qapt (Ubuntu):
status: New → Fix Released

I use --no-install-recommends , so that's why i didn't have it. Anyway, thanks :)

Murz (murznn) wrote :

I have use qapt-batch 1.2.1-0ubuntu2 on oneric and expiring this problem.
I'll try to change policykit-1-gnome to polkit-kde-1 and check solving issue.

Murz (murznn) wrote :

Changing policykit-1-gnome to polkit-kde-1 helps solve the problem. But qapt-batch and muon have no hard dependency on polkit-kde-1, so if user updates to oneric with installed policykit-1-gnome (as I got in my system), it isn't replaced to polkit-kde-1 automatically.

finndo (finndo77) wrote :

just a note this is still an issue.

I fresh/clean installed LUbuntu 11.10 on release day, yesterday I installed kde-desktop and switched over. I was also having this issue, and had to install polkit-kde-1 manually.

still having the issue. I'll try logging out and back in.

I also tried running muon under sudo from a terminal, it gave me errors about the .conf file being owned by use 1000 not 0.

Gert van Dijk (gertvdijk) wrote :

This issue is marked as 'Fix released', but I don't agree about that. As Murz describes in comment 7, one will still need to install polkit-kde-1 manually after installing KDE on an existing regular ubuntu installation.

Creating this 'or' dependency on polkit-kde-1 for qapt is not sufficient, clearly.

axel (axel334) wrote :

Yesterday I installed kubuntu-desktop and I had this bug. Some people in duplicate bugs comments report that installing polkit-kde-1 solve their problem, but I want to point out that this should be made in a way that new users shouldn't be forced search for bugs reports and solutions to bugs because this may easily discourage them. Please release an update with some dependency or whatever so that user can just fix the problem by regular update (from terminal or Synaptic).

Gert van Dijk (gertvdijk) wrote :

As axel points out in comment 10: this bug is about the need to install some package manually after Kubuntu installation (on standard Ubuntu install) in order to do system updates. I think more people would agree with me that installing packages manually before being able to install updates or install new packages is very user unfriendly and should be considered a workaround, not a fix.

Besides, did you notice the circular dependency here? Users aren't able to solve this bug due to the bug, unless they stumble upon this bug report and take a dive in the raw package management (something not based on qapt). Also, as a consequence they will probably not be installing (security) updates (or updates to solve this issue) until the workaround is applied. And hey, shouldn't the latter be a reason to set some level importance to this bug?

This affects still all users moving from Gnome/Unity (and probably other DE's too) to KDE by using the Software center within their current installation.

So, to summarize, in my opinion, this bug has *not* been solved, should not have the status 'Fix released' and have some level op importance set. Please reopen.

N.B. Re-reading my comment before posting: sorry for being a bit too grumpy between the lines.

axel (axel334) wrote :

Exactly. I was wrong with Synaptic, I guess it can't be used for update, but indeed I installed kubuntu-desktop on top of other DE, so I still can use updater from Ubuntu. Anyway, this should be solved by simply
sudo apt-get update & sudo apt-get upgrade
or a better solution: a new fixed version of muon-updater should be released that would install along with kubuntu-desktop.
I have kubuntu-desktop 4.8.1 from backports.

Tim Edwards (tkedwards) wrote :

I think the problem is that even with the 'fix' there is no hard dependency on polkit-kde-1.

Let's look at it logically:
Muon is specifically designed to run on the desktops of unprivileged users and update their systems. To do that it needs root privileges and to get those it needs a mechanism to ask the user to authorise it to run as root.

Therefore having polkit-kde-1 installed is necessary for Muon to function properly, so it should be a hard dependency not a 'recommends' or anything else.

Gert van Dijk (gertvdijk) wrote :

Tim, your explanation in comment 13 is unfortunately jumping to conclusions; it isn't *that* simple as you suggest, assuming you mean a dependency on Muon.

A hard dependency on muon for polkit-kde-1 will pull in a lot of KDE-stuff (e.g. depends: kde-runtime) - if one not running KDE wants to install Muon, this is not acceptable.
Please note that Muon should work without polkit-kde-1 in a Gnome environment (for example), because it can also use Gnome's PolicyKit provided in policykit-1-gnome. And probably do so for other PolicyKit DE-specific implementations as well.

The thing here is, I believe: when starting KDE, Gnome's PolicyKit isn't running, but dependencies on it are satisfied for the package management.

So, in order to make sure some PolicyKit implementation designed for the current DE, that should be a hard or semi-hard dependency on the metapackage for the DE, in my opinion. I.e. "kubuntu-desktop depends [...] polkit-kde-1 [...]"

By the way, I don't understand this (on Ubuntu Oneiric):
$ apt-cache show polkit-kde-1
[...]
Task: kubuntu-desktop, [...]

So this tells me it should be installed when installing kubuntu-desktop? Or I might not get Tasks in apt.

Tim Edwards (tkedwards) wrote :

Ok I didn't realise it was that complicated. In my case I install a 'Kubuntu' system by first installing Ubuntu and then installing the kubuntu-desktop metapackage, since I want to have all the config tools that come with Ubuntu and I find some of the GTK apps better than any QT-based alternative (GIMP, Firefox, Libreoffice etc.).

So if kubuntu-desktop always installed polkit-kde-1 like you suggest this should be enough to solve the problem for me, and for most people I guess. But that wasn't the case with 11.10 when I installed it a few months ago.

Jonathan Thomas (echidnaman) wrote :

In precise the situation is better, as polkit-kde-1 is now pulled in by the kubuntu-desktop metapackage.

pawmar (pawmar) wrote :

I have this problem since at least 11.04, hoped that some next release will fix it but it's still present in precise. polkit-kde-1 package is installed and nothing changed.

Tim Edwards (tkedwards) wrote :

pawmar if you're still having problems after polkit-kde-1 is installed I think that's a separate bug.

The problems reported in this bug were all resolved once polkit-kde-1 installed - the bug (now fixed) was that that package was not installed automatically with kubuntu-desktop.

a_flj_ (flj-mail) wrote :

@tkedwards: it seems the initial bug description was forgotten during the discussion: Trying to use muon-updater , but it doesn't work. When selecting Install updates, the following message appers: "This operation cannot continue since proper authorization was not provided"

I just did sudo apt-get install --reinstall polkit-kde-1, then tried to use muon-updater again. I still receive precisely the same error message. So what exactly are the problems reported in this bug which were fixed?

I think this bug led to the discovery of some problems which were indeed fixed, but the root cause for this particular problem was neither identified nor fixed.

a_flj_ (flj-mail) wrote :

Correction: for some reason, I had to repeat the sudo apt-get install --reinstall polkit-kde-1 + reboot twice, but then muon-updater started behaving properly.

Tim Edwards (tkedwards) wrote :

@a_flj
The original reporter of the bug posted in the first comment "Installing polkit-kde-1 solves the issue, should polkit be added at least to Recommends?". The rest of the discussion was about how best to ensure polkit-kde-1 gets pulled in by dependencies.

From your 2nd comment it looks like you've got it fixed, but if you see this problem even though polkit-kde-1 is installed I reckon you've hit a new issue and need to open a new bug.

lnxusr (bjwest) wrote :

I've just completed a fresh install of Kubuntu 12.04 (64bit), and system update to latest KDE (4.8.3), kernel, and whatever else was updated. Prior to the update, Muno was working just fine. Just after update and reboot, Muon now gives me this error dialog. Polkit-kde-1k is installed.

Rosemary Hendley (catbells) wrote :

Yesterday, I did a fresh install of Kubuntu. I've never used it before. Muon gives me the same message that Sumski reports #1.

Also kubuntu-firefox-installer failed to run because of a lack of proper authorisation. I don't know whether this is a related issue.

About me: I'm pretty computer literate for someone who has never learnt about linux code and, who has never worked with computers. For example, I did a little Fortran, Basic and Pascal programming in the early 1980's and used DOS before Windows 3.1. I've used Ubuntu since August 2010. I'd like to suggest that if I can't make essential packages work on first install of an operating system, it is not user friendly enough for the general population.

Tim Edwards (tkedwards) wrote :

Rosemary what do the following commands output on your system?:
dpkg -l | grep polkit-kde
cat /etc/os-release

The bug should be fixed in 12.10 and possibly also in the 12.04.1 release.

J. Joseph Felten (jjfelten-d) wrote :

Same problem as Rosemary Hendley (catbells). Fresh install of 12.04.1 LTS (amd 64bit) on a new computer (AMD A6 APU). Did not connect to the Internet to install patches during OS install. After OS install, and connecting to the Internet, muon-installer and muon-updater launched from the GUI application launcher O.K. and asked for a password for elevated privilages and ran properly. Used muon-updater to install all patches and rebooted. After patching/rebooting, launching either resulted in the "This operation cannot continue since proper authorization was not provided" error. They did NOT ask for a password. The problem seems to be them not asking for elevated privilages and therefore not being able to actually install software/patches. I had to manually run them via kdesudo from the command line which did work, but a new user would not know to do that and would be stuck. Was this bug re-introduced when I ran the update?

I also saw this same problem a few months ago when I installed 12.04 LTS in a vm under virtualbox. I just worked around it at the time since I was just trying Kubuntu 12.04 LTS out then and figured it was such a major bug it would be soon fixed. I am very surprised it has not been fixed by now.

I also saw the firefox installer problem. The installer started from the application launcher would run, not ask for a password, lie that it had completed successfully, but not actually do anything. I had to install Firefox manually.

Note again this was a clean install on a new hard drive.

I hope this help someone fix this problem as it would sour a new user on Kubuntu which otherwise is excellent.

cat /etc/os-release
NAME="Ubuntu"
VERSION="12.04.1 LTS, Precise Pangolin"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu precise (12.04.1 LTS)"
VERSION_ID="12.04"

sudo apt-get install polkit-kde-1
[sudo] password for jfelten:
Reading package lists... Done
Building dependency tree
Reading state information... Done
polkit-kde-1 is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-23-generic linux-headers-3.2.0-23
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

uname -a
Linux heidi 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Gert van Dijk (gertvdijk) wrote :

From comment 21 by Tim Edwards (tkedwards):

> if you see this problem even though polkit-kde-1 is installed I reckon you've hit a new issue and need to open a new bug.

This bug is not resolved. It keeps coming back.

One should be able to add also affects Ubuntu 12.10. Why can't one add a newer distribution?

Rael (rael-gc) wrote :

I installed Kubuntu LTS 12.04, and this bug affected me. I tried change configuration for Login Screen, and I was getting the permission error.

It was solved only installing polkit-kde-1 package.

This package should come in the default Kubuntu install, at least in the standalone install from CD/DVD.

Lorenz (lqb) wrote :

Today I had the same error on muon. I had to reinstall the polkit-kde-1 package. Some days ago this muon worked without this errormessage.

Dima Ryazanov (dima-gmail) wrote :

Started happening to me just today, after I've been using Kubuntu for a while. I have 13.04.

Dima Ryazanov (dima-gmail) wrote :

I've had this happen when kded4 ran out of file descriptors (https://bugs.kde.org/show_bug.cgi?id=306908), so maybe that was the cause...

Geoff (palmerg) wrote :

Reinstalling polkit-kde-1 doesn't work for me. I even tried;

sudo apt-get purge polkit-kde-1
sudo apt-get install polkit-kde-1

I suspect it doesn't work because it doesn't actually restart the polkit process. Only logging out and logging back in does that. When I do so, "ps -e | grep pol" shows

  1547 ? 00:00:00 polkitd
19929 ? 00:00:00 polkit-kde-auth

but there's no actual commans to start polkit. Anyone know what it is so I don't have to logout/login?

(This is on Ubuntu 13.04, Raring Ringtail running KDE 4.10.2)

Muon Package Manager doesn't ask for a password - just displays the error "This operation cannot continue since proper authorization was not provided"

Fresh install of Kubuntu 13.10, new user account, no configuration.
sudo apt-get install -reinsta

.... (sorry, accidental submit)

sudo apt-get install --reinstall polkit-kde-1 <-- had no effect.

Marc Baas (marc-baas) wrote :

I can confirm that on a fresh Kubuntu 13.10 install this bug shows up again, and reinstalling polkit-kde-1 has no effect.

Harald Sitter (apachelogger) wrote :

Please file a new bug at bugs.kde.org against muon, this is most certainly not the same issue as this bug here.

If you run into the issue please make sure you have the package "debsums" installed and run the following in a terminal, then put the entire output in a file and attach it to the bug report.
echo "-------------------------env"
env
echo "-------------------------ps"
ps -A
echo "-------------------------debsums"
sudo debsums -c

Additionally, please check if running the following helps with the problem:
`sudo pkill -9 qaptworker2`

then restart whatever muon application was misbehaving.

Trevorlay (trevorlay) wrote :

Working Fix!

I just installed a fresh install of Kubuntu 13.10 I was having this issue, the `sudo pkill -9 qaptworker2` WORKED!! hours upon hours fixed with that simple command, thanks!

Harald Sitter (apachelogger) wrote :

That is not a fix, please read everything I wrote above the kill command :P

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.