Muon: "This operation cannot continue since proper authorization was not provided"

Bug #875657 reported by Tommy_CZ
This bug report is a duplicate of:  Bug #833058: Muon-updater doesn't ask for password. Edit Remove
140
This bug affects 28 people
Affects Status Importance Assigned to Milestone
qapt (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

I tried to install package using Muon and it showed me this bug: "This operation cannot continue since proper authorization was not provided".
So the installation was unsuccesfull.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: muon 1.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sun Oct 16 13:28:39 2011
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
ProcEnviron:
 LANGUAGE=
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
SourcePackage: muon
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Tommy_CZ (t-kijas) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in muon (Ubuntu):
status: New → Confirmed
affects: muon (Ubuntu) → polkit-kde-1 (Ubuntu)
Revision history for this message
Todor Buyukliev (todorb) wrote :

i'm not sure this is a duplicate of bug #867737. for me the error message appears only in a nx session (nomachine server, opennx client). muon works fine in a local session.

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

Ah, okay. If it's a remote session thing, then that's definitely different. I've just done some quick research and it seems that the policykit authorization policy that the QApt worker uses by default disallows remote access, such as via an nx server. When I get home tonight I can post a replacement policy file to be placed at /usr/share/polkit-1/actions/org.kubuntu.qaptworker.policy

affects: polkit-kde-1 (Ubuntu) → qapt (Ubuntu)
Revision history for this message
John Larimer (jtliiiis) wrote :

It isn't a remote session thing. I am unable to install or update anything and I am logged in locally.

Revision history for this message
Julius Kyle (elyk-julius) wrote :

hi. i have been trying to understand what are all those codes that you people are using and i really am so lost. i went to your http://jontheechidna.wordpress.com/ and i understand you´ve got a solution. but then i am a new user and i don´t understand what you were saying. .. i am also having this problem with muon and if you´ve got the time, pls do a STEP by STEP thing like 1. go to terminal and type this. 2. type etc. & etc.

thank you very much and waiting for your response

Revision history for this message
Terri (terriko) wrote :

For the record, this was easy to get around with

gksudo muon-updater

(or kdesudo muon-updater)

But since muon seems to run automatically to check for updates, this means you have to exit it and run manually to get it to work. Not an ideal situation.

Revision history for this message
PiroXiline (piroxiline) wrote :

When I run Muon, update-apt-xapi run simultaneously. After closing Muon" update-apt-xapi remains in process.

Revision history for this message
Steve Ferson (sferson) wrote :

I'm not sure this is a duplicate. If the other bug was resolved, I'm not sure this one has been. I'm experiencing it in Lubuntu 12.04.

Revision history for this message
Rael Gugelmin Cunha (rael-gc) wrote :

I'm using Kubuntu LTS 12.04 with KDE backports PPA and faced this again today, while launching muon-updater from the systray notification.

Revision history for this message
arraia_1 (oleks-kost) wrote :

Kubuntu 12.04, KDE 4.10.2 The problem may be resolved with:

sudo apt-get install polkit-kde-1

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers