phatch is not installable

Bug #710874 reported by Olivier Tilloy on 2011-01-31
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Phatch
Undecided
Unassigned
phatch (Debian)
Fix Released
Unknown
phatch (Ubuntu)
Medium
Micah Gersten
Natty
Medium
Micah Gersten
pyexiv2 (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

python-pyexiv2 was updated to its latest release (0.3.0) in natty on 2011-01-27.
The package is marked as breaking phatch-cli (<< 0.3), which is correct, but as a consequence it makes phatch in natty (currently 0.2.7-5) not installable.

I am attaching a (rather large) patch for phatch that adapts it to pyexiv2’s new API. Testing and feedback are welcome.
Note that if this patch were to be merged, the "Breaks" field of pyexiv2 would have to be relaxed.

Olivier Tilloy (osomon) wrote :
tags: added: patch
Angel Abad (angelabad) on 2011-02-02
Changed in phatch (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) on 2011-02-03
tags: added: natty regression-release
Changed in phatch (Ubuntu Natty):
milestone: none → natty-alpha-3
importance: Undecided → High
status: Confirmed → Triaged
Micah Gersten (micahg) wrote :

Sorry, this should be Medium according to https://wiki.ubuntu.com/Bugs/Importance since it's a non-core app, milestoning for Alpha-3 as that's right around feature freeze and we either should get this patch in or rollback the pyexiv2 upgrade.

Changed in phatch (Ubuntu Natty):
importance: High → Medium
Olivier Tilloy (osomon) wrote :

Continuing here the discussion from a duplicate bug report:

> It looks like the porting work was done upstream (phatch bug 585169),
> but I don't know if there will be a release in time for natty
> Maybe someone more familiar can look at this

I’ve been in touch with phatch’s main author, and AFAIK there is no new release planned anytime soon. Which is why I worked on the patch attached to ensure we can upgrade to the latest version of pyexiv2 without being detrimental to phatch. Give the patch a try, feedback is appreciated. If that helps, I can publish a patched package for phatch in pyexiv2-developers’ PPA (https://launchpad.net/~pyexiv2-developers/+archive/ppa?field.series_filter=natty), though that will also require a custom version of pyexiv2 to relax the "Breaks" field.

Olivier Tilloy (osomon) wrote :

Note that rolling back the pyexiv2 upgrade would also require rolling back libexiv2 to an older version as pyexiv2 0.1.x (unmaintained) doesn’t compile against the newest libexiv2.

Olivier Tilloy (osomon) wrote :

I published a patched version of phatch (0.2.7-5ppa1~natty1) and new version of pyexiv2 with the Breaks field relaxed (0.3.0-1ubuntu1ppa1~natty1) in pyexiv2-developers’ PPA (https://launchpad.net/~pyexiv2-developers/+archive/ppa?field.series_filter=natty). Please test.

Martin-Éric Racine (q-funk) wrote :

I'm not sure of what to test for but these packages indeed work. At last, my existing Phatch scripts still work.

Olivier Tilloy (osomon) wrote :

Thanks for testing Martin-Éric. What needs to be tested here is that my patch doesn’t introduce regressions. The fact that all your existing Phatch scripts still work is a very good indicator. You can also play with Phatch’s image inspector and check that it works as expected on your photos.

Micah, do you think you could lend a hand on testing this patch? Having tested it thoroughly myself, I’m pretty confident it’s safe, but the patch is large nevertheless, so the more testers, the better.

Olivier Tilloy (osomon) wrote :

@Micah, have you had a chance to test my patch? Note that for convenience, I’ve published packages in pyexiv2-developers’ PPA (https://launchpad.net/~pyexiv2-developers/+archive/ppa?field.series_filter=natty).

Martin Pitt (pitti) on 2011-03-02
Changed in phatch (Ubuntu Natty):
assignee: nobody → Micah Gersten (micahg)
Changed in pyexiv2 (Ubuntu Natty):
status: New → Invalid
Changed in phatch (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Martin-Éric Racine (q-funk) wrote :

These (pyexiv2 and phatch) seem to be the only two packges left among those I use that haven't been yet sorted out for Natty. Olivier's PPA packages work fine, so they would seem to be a valid basis for the solution. Can we get this into the repository any time soon?

mlaverdiere (mlaverdiere) wrote :

Just want to point out that I've tried the PPA packages and everything works well, including with my scripts.

+1 for integration in Natty repository!

Micah Gersten (micahg) wrote :

Since Debian is in the same boat and we have a little breathing room timewise, I decided to forward the patch to them. I'll keep an eye on this bug and the Debian one so that we can get this solved one way or the other by beta.

tags: added: patch-forwarded-debian
Scott Kitterman (kitterman) wrote :

According to the watch file, there's a new upstream release that's not packaged. http://packages.qa.debian.org/p/phatch.html - How much of this is already fixed by upstream?

Changed in phatch (Debian):
status: Unknown → New
Martin-Éric Racine (q-funk) wrote :

I just had a quick look at the diff and, as far as I can tell, not much is fixed. Of course, it would be a lot easier if upstream got into the habit of publishing a ChangeLog. Btw, it seems that upstream uses Launchpad as its RCS: https://launchpad.net/phatch/

Scott Kitterman (kitterman) wrote :

OK. I've added an upstream task to the bug then.

Scott Kitterman (kitterman) wrote :

POX will review/upload this to Debian.

Martin-Éric Racine (q-funk) wrote :

We need both a new pyexiv2 with relaxed Breaks and the patched Phatch, for this to work.

Micah Gersten (micahg) wrote :

python-pyexiv2 binary depends need to be relaxed after the sync, so reopening this task

Changed in pyexiv2 (Ubuntu Natty):
importance: Undecided → Medium
status: Invalid → Triaged
Changed in phatch (Debian):
status: New → Fix Released
Micah Gersten (micahg) wrote :

Filed bug #736937 to sync phatch with this patch from Debian

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyexiv2 - 0.3.0-3ubuntu1

---------------
pyexiv2 (0.3.0-3ubuntu1) natty; urgency=low

  * Sync on Debian
  * debian/control:
    - Relax python-pyexiv2 breaks phatch to 0.2.7.1-1~ (LP: #710874)

pyexiv2 (0.3.0-3) unstable; urgency=low

  * Use upstream fix for sphinx changed parameters (Closes: #613841).
  * Migrate to dh_python2.

pyexiv2 (0.3.0-2) unstable; urgency=low

  * Upload to unstable. I know it makes phatch impossible to install, but it
    needs to be fixed anyway.
 -- Micah Gersten <email address hidden> Thu, 17 Mar 2011 10:48:49 -0500

Changed in pyexiv2 (Ubuntu Natty):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phatch - 0.2.7.1-1

---------------
phatch (0.2.7.1-1) unstable; urgency=low

  * New upstream release
  * Add pyexiv2.patch to use new pyexiv2 API (thanks to Olivier Tilloy,
    closes: #614008 and LP: #710874)
  * Bump python-pyexiv2's minimum required version to 0.3
  * Bump Standards-Version to 3.9.1 (no changes needed)
 -- Martin-Eric Racine <email address hidden> Wed, 16 Mar 2011 20:09:14 +0100

Changed in phatch (Ubuntu Natty):
status: Triaged → Fix Released
Olivier Tilloy (osomon) wrote :

The issue is tracked by bug #585169 upstream.

Changed in phatch:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.