phatch does not work with pyexiv2 ≥ 0.2

Bug #712203 reported by Martin-Éric Racine on 2011-02-03
This bug report is a duplicate of:  Bug #710874: phatch is not installable. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
phatch (Ubuntu)
High
Unassigned
Natty
High
Unassigned
pyexiv2 (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

The new version of pyexiv2 that was recently imported from Debian/experimental will force the removal of "phatch" upon upgrade from Maverick, because of a new ABI incompatibility between pyexiv2 and phatch-cli. This is extremely undesirable, because there isn't any new upstream version of phatch to use the new ABI nor any substitute for phatch in the Ubuntu repository. As such, I would kindly ask you to revert to the pyexiv version from Maverick for Natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-pyexiv2 (not installed)
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i586
Architecture: i386
Date: Thu Feb 3 02:22:58 2011
ProcEnviron:
 LANGUAGE=fi_FI.UTF-8:fi:et_EE.UTF-8:et:en_US.UTF-8:en
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: pyexiv2

Micah Gersten (micahg) on 2011-02-03
tags: added: regression-release
Micah Gersten (micahg) wrote :

It looks like the porting work was done upstream (phatch bug 585169), but I don't know if there will be a release in time for natty Maybe someone more familiar can look at this

Changed in pyexiv2 (Ubuntu Natty):
importance: Undecided → High
milestone: none → natty-alpha-3
status: New → Triaged
summary: - please revert to Maverick version for Natty
+ phatch does not work with pyexiv2 ≥ 0.2
Changed in phatch (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers