All sound is static screeching popping and distorted

Bug #367544 reported by Mark Limbach on 2009-04-26
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

Using Ubuntu 9.04 on a Dell 620 laptop.

All sound is screeching/distorted all the time. It's horrible to have any sound play since all sound is static. When I play a sound (any sound) for 5 seconds after playback is stopped the static continues.

Sound worked on Ubuntu 8.10, after upgrading to 9.04 sound does not work.

I can make the static-ness not happen in the System -> Preferences -> Sound test buttons if I select OSS as the output, but if pulseaudio or ALSA is selected then I get static on the test. I can hear the correct sound under the static noise, but all sound is accompanied with static. I've removed then reinstalled all the ALSA and pulseaudio drivers with no luck. I assume that means this is a problem with PulseAudio or ALSA? Here's the output of lspci -vv

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
 Subsystem: Dell Device 01c2
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 21
 Region 0: Memory at efebc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- RBE- FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Possibly same as bug 264784?

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: limbach 3446 F.... pulseaudio
                      limbach 3690 F.... mixer_applet2
 /dev/snd/controlC1: limbach 3446 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801c2,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 12
   Simple ctrls : 7
Card1.Amixer.info:
 Card hw:1 'pcsp'/'Internal PC-Speaker at port 0x61'
   Mixer name : 'PC-Speaker'
   Components : ''
   Controls : 4
   Simple ctrls : 3
DistroRelease: Ubuntu 9.04
Package: pulseaudio 1:0.9.14-0ubuntu20
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
Uname: Linux 2.6.28-11-generic i686
mtime.conffile..etc.pulse.daemon.conf: 2009-04-26T13:42:19

Mark Limbach (cooldudeman01) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

  status incomplete
  assign ubuntu-audio
  done

On Sun, 26 Apr 2009, Mark Limbach wrote:
> All sound is screeching/distorted all the time. It's horrible to have
> any sound play since all sound is static. When I play a sound (any
> sound) for 5 seconds after playback is stopped the static continues.

Have you tried the test kernel at http://kernel.ubuntu.com/~dtchen/ ?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFJ9MCxe9GwFciKvaMRAgHPAJ9hy2CLlHN2PjVYnm2X4MnZjO8JhACgniKZ
nTcPsSC4hCbHBFFuxgh0wnA=
=KVnX
-----END PGP SIGNATURE-----

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Brad R. (bgreaves421) wrote :

I'm running a Dell Inspiron E1505 with the same audio card and have a similar problem after a botched partial upgrade to 9.04(that I didn't initiate; apt must have gotten confused somewhere...) . The only difference is that I only get "static"-like pops. Switching to OSS works just fine, but neither ALSA or PulseAudio work for me either.

Does PulseAudio just not play nice with this card?

NoBugs! (luke32j) wrote :

Similar problem happens with the intel sound on macbook.
Sometimes the sound in all apps turns to static, and muting/unmuting it or plugging in headphones doesn't change it.

antibios (matt-klassen) wrote :

Confirmed on 9.10 with a Dell 620 laptop. Pulseaudio screetches, but direct play from xine to alsa works perfectly.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)
03:01.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller (rev 40)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: pcsp [pcsp], device 0: pcspeaker [pcsp]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Headset [Logitech USB Headset], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

On Tue, Aug 18, 2009 at 7:15 AM, antibios<email address hidden> wrote:
> Confirmed on 9.10 with a Dell 620 laptop.  Pulseaudio screetches, but
> direct play from xine to alsa works perfectly.

Please use "apport-collect -p alsa-base 367544".

Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/dsp1', '/dev/snd/controlC0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1p', '/dev/snd/controlC1', '/dev/snd/pcmC1D0p', '/dev/snd/pcmC1D0c', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer2', '/dev/sequencer'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdfffc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801c2,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 13
   Simple ctrls : 8
Card1.Amixer.info:
 Card hw:1 'Headset'/'Logitech Logitech USB Headset at usb-0000:00:1d.2-2, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a0c'
   Controls : 6
   Simple ctrls : 2
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_AU.UTF-8
 LANGUAGE=
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv plugdev sambashare video

antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
antibios (matt-klassen) wrote :
Mio (m10) wrote :

i have the same problem with a sony vaio fz31s with an upgraded 8.10->9.04 but on the same machine with a clean install sound works huh? but i donn't want to make a clean istall because of migration issues(eg reinstall all apps etc)

NoBugs! (luke32j) wrote :

This may fix it sometimes:
Try clicking sound, volume control,
Make sure Master, PCM, and Front are loud enough,
Stop all music players, and toggle the mute/unmute button for Master, PCM, and Front.
When sound is unmuted try again, it should sound normal.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Confirmed
Cameron Gorrie (sastraxi) wrote :

I have the exact same problem as this:

"""
I'm running a Dell Inspiron E1505 with the same audio card and have a similar problem after a botched partial upgrade to 9.04(that I didn't initiate; apt must have gotten confused somewhere...) . The only difference is that I only get "static"-like pops. Switching to OSS works just fine, but neither ALSA or PulseAudio work for me either.

Does PulseAudio just not play nice with this card?
"""

Mine however did not start with an upgrade to 9.04; I've been running it stably from its release up to about 4 days ago, when this started happening. Playing audio through pulse or ALSA just has static that almost seems "in time" with whatever sound I'm attempting to listen to. Playing audio through OSS works *flawlessly*. Windows 7 on the same computer does not display any difficulty, and there have been no hardware changes as of late. I'm also experiencing intermittent USB failures so I can't 100% guarantee that this is not hardware related, but maybe the two have the same source in software (both are part of the ICH7 controller, I think?)

Finally, I noticed that this started at the same time as the sound being muted automatically whenever Ubuntu starts up. Hope any of this helps! OSS is a perfectly acceptable work-around for me, at the moment.

Dominique Brazziel (dbrazziel) wrote :

I have the same problem, and per this bug report, tried using '-ao oss' with mplayer, which is the only way to stop the screeching distortion that occurs when adjusting the volume via gnome-volume-control-applet. The sound card in question is Ensoniq 1371.
On another machine with Intel HDA the problem doesn't occur.

xeranto (ceranto) wrote :

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: xeranto 24792 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'AudioPCI'/'Ensoniq AudioPCI ENS1371 at 0x2080, irq 19'
   Mixer name : 'Cirrus Logic CS4297A rev 3'
   Components : 'AC97a:43525913'
   Controls : 24
   Simple ctrls : 13
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=it_IT.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

tags: added: apport-collected
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.