sound volume always resets to 100% after reboot

Bug #204536 reported by Master Ar2ro on 2008-03-21
224
This bug affects 44 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Every time I reboot I get the sound volume back to 100%, but the sound works fine apart from this. It's just *very* annoying to have to reset the volume every time I boot the PC. I set the volume from the volume icon in the system tray. I have two sound cards installed on my system (one on the motherboard and a SB Audigy), but I'm using only the Audigy. Another thing is that the mixer applet often incorrectly shows volume as muted when it's not.

I'm using the hardy beta (hardy-desktop-amd64) from march 19th 2008.

Master Ar2ro (ar2ro) wrote :

I can confirm this.
I'm running a clean install ubuntu-8.04-beta-desktop-i386.iso on a Znote 6214W

Master Ar2ro (ar2ro) wrote :

Another thing I have noticed is that when I run an application using SDL Mixer (the game Pingus - I decided to give a try to a few random available games), the volume control in system tray does not work (no matter which device or channel volume I change, it stays the same). I will probably try a clean reinstall of the system in a few days with the latest hardy cd image to see if anything changed.

Master Ar2ro (ar2ro) wrote :

Just a note before a clean install. I tried turning off the integrated sound card, and it doesn't help. However, I noticed that only one volume is not remembered. When I open the window and want to choose the device from the menu, this is the list of available devices:
1. CA0106 (Alsa mixer)
2. mixer00 (OSS mixer)
3. Playback: ALSA PCM on front: 0 (CA0106) via DMA (PulseAudio Mixer) <-- this one causes problems
4. Capture: Monitor Source of ALSA PCM on front: 0 (CA0106) via DMA (PulseAudio Mixer)
5. Capture: ALSA PCM on front: 0 (CA0106) via DMA (PulseAudio Mixer)

I choose the 3rd device (and this is the one that the volume is not remembered). It has only one channel available (Master). When I change the volume of the CA0106 device, it is remembered and does combine with the Playback one (if I set the volume of CA0106 to 50%, and the Master on 3rd device will remain at 100%, the final volume will be 50%, but the applet will still show 100%). After restart the volume of CA0106 will remain at 50%. But if I go the other way around (set the CA0106 to 100% and the Master on 3rd device to 50%, the final volume again is 50%) and restart the system, the volume of the 3rd device is reset to 100% and the volume is back at 100% after reboot. That generally describes the entire problem I have. Now on to a clean install ;)

Master Ar2ro (ar2ro) wrote :

One more thing I noticed. When I selected the mixer applet to show the volume of CA0106 in system tray, the icon (and hint) incorrectly tell me that the device is muted when the volume is above 50% and the sound works fine.

Master Ar2ro (ar2ro) wrote :

Nothing changes after doing a clean install from today's (march 28) image (hardy-desktop-amd64.iso). Device 3 (list in comment above) channel Master is reset to 100% on reboot, and mixer applet incorrectly shows volume as muted when it's not (happens randomly but very often).

Master Ar2ro (ar2ro) on 2008-03-28
description: updated
Pedro Villavicencio (pedro) wrote :

thanks for your report, to be confirmed by someone else experiencing the same issue, it works fine here for me at least.

Changed in gnome-applets:
importance: Undecided → Low
SeanK (seank) wrote :

I just installed Mythbuntu Hardy on a frontend machine and am having the same problem. Every time I reboot, PCM and Master reset themselves to the 2/3 level marks which makes the sound almost inaudible. Extremely annoying to me since I only turn on this computer when I'm going to watch television.

Installed the lastest Mythbuntu (labelled Mythbuntu 8.04 Beta) and have all upgrades/dist-upgrades installed.

Thanks

carbide20 (carbide20) wrote :

I had the same issue up until the April 18-20th release. Somewhere in that time period it started working correctly.

I just did a fresh install of UbuntuStudio Hardy. I still experience this problem, after every reboot my volume is at 100%. I had to disable the system sounds to prevent my laptop speakers from blowing up.

I use a Realtek ALC861 which has always worked. It also worked on Hardy development (installed in february) Only after the fresh install this problem occurs.

A very annoying problem. Are there any fixes?

gulli3864 (bmansoux) wrote :

A trick to set default volume at boot time if you are using ALSA

edit the /etc/rc.local file
insert "amixer -q set Master 3% unmute"
before the last line "exit 0"

Pedro Villavicencio (pedro) wrote :

Is someone still seeing this? could be an alsa issue rather than an applet one

Changed in gnome-applets:
status: New → Incomplete
Jens Berke (jensberke) wrote :

I'm seeing it the other way around: sound volume always resets to 0% (muted) after reboot. This didn't happened when I had Hardy installied clean and freshly. It must have been introduced with one of the subsequent Hardy updates. Maybe my "mute" problem is related to the 100% problem of this bug report.

TomekPaczkowski (oinopion) wrote :

I confirm this: every reboot my PCM volume is set to 100%.

I confirm this as well with an ASUS R1F. As with the previous commenter, the volume is at 100% after every reboot regardless of where it was prior to shutting down.

Tomofumi (tomofumi) wrote :

I am using an aging PC 2-channel speakers that I need to set left/right volume differently, but after reboot, the volume of both left & right is reset back to 100%, is it related to the volume control applet? My device mentioned is called "Playback: ALSA PCM on front:0 (ALC883 Analog) via DMA (PulseAudio Mixer)" with only Master control.

Changed in gnome-applets:
status: Incomplete → New
Caroline Ford (secretlondon) wrote :

I have the same issue on intrepid beta. It's embarrassing when you are supposed to be quiet in a session and the machine insists of playing the start up noises.

I'm not sure it is low priority as it means you can't boot your laptop in eg a library.

Silent Ninja (kuteninja) wrote :

I'm using the Ubuntu Intrepid release (not beta) with an amd64 machine, and I have the same issue. I've tested the amixer fix, but it still reset the master volume to 100%. The other volume records are fine and they keep their settings, but the Master volume of the "ALSA PCM on front:1 (USB Audio) via DMA (PulseAudio)", that one, keeps resetting to 100%. And that one is my master volume for all the sound output.

I have some big speakers and they REALLY sound when the volume is at 100%, it's not a ultra important bug, but it's really anoying eg. if you restart the computer during night and suddenly it wakes up everyone.

Knedlyk (yupadmin) wrote :

I confirm this. After clean Intrepid install my sound gnome applet always shows muted volume after each reboot. I'm using alsa (personally I don't like freaky pulseaudio). I added
amixer -q set Master 85% unmute
amixer -q set PCM 85% unmute
to /etc/rc.local, but it is temporary solution. It looks like alsa issue, alsa looses mixer settings after reboot.

Simon Morgan (sjmorgan) wrote :

Is anybody experiencing this bug *not* using a 64bit build?

I'm running the 64bit version of 8.10 and have the same problem.

Changed in alsa-utils:
status: New → Confirmed
Eric O'Callaghan (eric1207) wrote :

I'm getting my PulseAudio "Master" volume cranked to 100% on every reboot on 32-bit

aztektum (mehlert) wrote :

Same here. Mine resets to 100% on reboot. I have a Creative Live 24-Bit 5.1 ... Doesn't do it on my Lenovo T400 notebook

Michael Alexander (ftmichael) wrote :

I'm running 32-bit Intrepid and have the same problem with Volume Control; it's not set to 100% though, maybe 60%. It resets itself on reboot, and I have to crank the volume back up again every time.

ETM (meyer-rice) wrote :

I can confirm this issue exists for 32-bit Intrepid and is still a problem in Jaunty (also 32-bit). It happens anytime the computer does a low-battery or sudden shut-down. I can't seem to get it to happen in a normal restart.

I agree that this should be high-priority. I had to mash the power-off button in class after the bang-bang drum sound came on... very uncool, especially on a Dell which is LOUD.

Michael Cook (michaelcook-mjc) wrote :

I see this currently everytime I reboot gracefully or shutdown gracefully on Jaunty.

Michael Cook (michaelcook-mjc) wrote :

Sorry, I've just had a coffee and re-read the comment... my problem is on Jaunty the volume is muted and set to 0%... not 100%. Maybe there is a different bug for this? ;o)

Michael Cook (michaelcook-mjc) wrote :

I found if I issue shutdown from cmd line and reboot then the sound settings are preserved. If I logout/shutdown/hit-the-power-button through the GUI the sound settings are reset to 25% volume, muted for any user on power-up.

Michael Cook (michaelcook-mjc) wrote :

Switching between users, (not logging out), the volume returns to 25% and muted on return to an already logged in user.

Jan Kaláb (pitel) wrote :

I have same problem as Michael Cook. Volume is muted and set to 0 % after startup.

Sebastien Bacher (seb128) wrote :

the volume is usually stored and reloaded, that seem a bug some users are running into rather than a hundredpapercut design issue

Alex (alex-vandeputte) wrote :

Same problem - the sound is muted after each reboot. However, this happens regardless of using alsa or pulseaudio

Michael Cook (michaelcook-mjc) wrote :

A bit more user-experience info here: I have several accounts and it auto-boots into one on startup, lets call user1.

The volume control is set to 10% and muted if:
 - If the box is shutdown using the shutdown menu option from this user (user1)
 - If I login (user GUI menu) as second user (user2) then go back to user1's session

I noticed user2's volume settings are normally saved, non-muted and intro music is heard.
I recall user1's intro music used to sound too but no longer since always muted.

The volume settings for user1 are maintained if I issue a cmd-line shutdown and on subsequent reboot the volume settings are as I left them for user1.

Neither user1 or 2 are 'admin' users. user1 has very restrictive access to the computer resources (as per GUI settings for users). There seems to be some 'bleeding' between user sessions and switching between them... as user1 is used to run xbox-media-centre and not much else... user2 is the user allowed to ftp new stuff to the media-station which is done occasionally. user1 auto-boots up when the machine is started and launches XBMC.

Daniel T Chen (crimsun) wrote :

already fixed for karmic alpha 2 (bugs #315971, #352732): http://bazaar.launchpad.net/~crimsun/pulseaudio/ubuntu/revision/92#patches/0090_fix_sw_mute_desync.patch

also, agree with seb128 - not a 100pc issue

affects: alsa-utils (Ubuntu) → pulseaudio (Ubuntu)
Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: New → Invalid
Martin-Éric Racine (q-funk) wrote :

Sorry, no, this is NOT fixed as of Karmic Alpha 5.

Changed in pulseaudio (Ubuntu):
status: Fix Released → New

2009/9/7 Martin-Éric Racine <email address hidden>:
> Sorry, no, this is NOT fixed as of Karmic Alpha 5.

The root cause for this bug is already fixed. You're experiencing a
separate bug even though the symptoms are similar. The Karmic bug is
due to alsa-utils and exacerbated by flatvol (though you can configure
PA to behave differently).

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
status: Confirmed → New
mezquitale (mezquitale) wrote :

I am experiencing the same issue on my laptop using karmic ubuntu studio, the issue is definetely pulse audio. I installed ubuntu studio alplha version and had a lot of issues with sound. I purged pulse audio from my laptop and everything was fine, after a reboot my sound settings would be OK.

I reimaged, this time using the ISO for karmic ubuntu studio and my machine now has the same issue, volume is all the way up after a reboot.

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: elf 2715 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with STAC9750,51 at irq 16'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 38
   Simple ctrls : 24
DistroRelease: Ubuntu 9.10
Package: pulseaudio 1:0.9.19-0ubuntu4
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.152-rt
Uname: Linux 2.6.31-9-rt i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected
mezquitale (mezquitale) wrote :

any developments on this bug? The obvious solution is to just uninstall pulse audio but then I have to configure alsa manually and that is a pain. The same issue is affecting. both my laptop and desktop. I am using karmic in ubuntustudio.

Michael Cook (michaelcook-mjc) wrote :

This is similar to me and still suffering from no solution... but volume is always zero now if I nicely exit out of Karmic desktop. EVERY time I log in I have to adjust the audio back to some level. The only exception is if I issue a shutdown from the cmd-line. Then it seems to persist. I assume desktop-environment is storing the user-session as I leave, somehow zeroing audio level. I've tried a script to use aumix to put the volume at 100% on startup but this doesn't seem to work on startup, only on cmd-line.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
mezquitale (mezquitale) wrote :

Is there a way that we can apply the fix to karmic or will we have to wait to upgrade to lucid?

 Every time I log in to my machine I have to use gnome-alsamixer to lower "PCM" volume and "Headphone" volume because volume is set way too high. I am unable to use the pulse audio icon volume in my panel because it's almost all the way down.

Once the volume is all the way down and I attempt to raise the volume using the pulse audio volume icon on my panel both "Headphone" and "PCM" volume is affected in gnome-alsamixer. As a result the volume is raised too high. I have to use the gnome-alsamixer utility to adjust the volume. I have to do this every time I reboot my machine.

xanadoo (apalmrich) wrote :

why is this still unfixed in Lucid? 2.5 years after being reported such an annoying bug is still an issue?

Thing (gnechto) wrote :

+1. Still not fixed.

Ubuntu 10.04, pulseaudio
Version: 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14

$ cat /proc/asound/cards
 0 [Live ]: EMU10K1 - SB Live! 5.1
                      SB Live! 5.1 (rev.7, serial:0x80641102) at 0x1000, irq 18
 1 [USB ]: USB-Audio - E-MU 0202 | USB
                      E-MU Systems, Inc. E-MU 0202 | USB at usb-0000:00:1a.2-1, full speed
 2 [SAA7134 ]: SAA7134 - SAA7134
                      saa7133[0] at 0xa3000000 irq 22

USB soundcard set as default, all okay, but after reboot sound is 100%, at the same time gnome volume control's level indicates another value (not 100%) like was before reboot.

Matt Harrison (mattharrison) wrote :

I'm still having the same issue in Ubuntu Maverick (had it since Jaunty). I have it on all 4 of my Ubuntu machines (2 desktops and 2 laptops).

Sound always starts at 100% at boot. I have to manually turn it back down to 20%.

This is very annoying as if I forget to turn it back down to 20% after I boot, my ears get a pounding when sound plays at full volume.

AsstZD (eskaer-spamsink) wrote :

As it was stated, it's still in Maverick.

Pavel Malyshev (afunix) wrote :

Ubuntu 11.10 still has this bug.
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Daniil Lopatin (dlopatin) wrote :

I have problem with saving audio configs in Ubuntu 11.10 too.
System: 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 GNU/Linux
pulseaudio 1.0

Mariusz Cielecki (xodeus) wrote :

I have this bug too.
Ubuntu 11.10
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Everytome I boot my laptop the sound volume resets to 100% and blasts my ears.

Ryan Prior (ryanprior) wrote :

Failing to save and load user data as expected (in this case, data about volume preference) is absolutely unacceptable. It makes the computer feel unreliable, gives inexperienced or insecure users the idea that they are doing something wrong, and ruins the auditory experience that a user wishes to maintain in their living space or workspace.

Given that this bug still clearly persists in default Ubuntu installations, can we change the status away from "fix released", or identify a new target project?

raevol (raevol) wrote :

Until this gets fixed, here's a workaround for Xubuntu. If someone could write up an equivalent for Ubuntu that'd be dandy.

- Go to Settings -> Sessions and Startup -> Application Autostart tab
- Click the Add button.
- Enter whatever Name and Description you want.
- For command enter:
   /bin/bash -c "sleep 2; pactl set-sink-volume alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00-CODEC.iec958-stereo 10%; notify-send \"Volume set to 10%\""

Replace alsa_output.usb-Burr-Brown_from_TI_USB_Audio_CODEC-00-CODEC.iec958-stereo with whatever your sound sink is, find it by running "pactl list sinks" in a terminal. Note that I set my volume to 10%, and sent a "notify-send" message about it to remind myself. Change either of these if you like.

Hing-Yap Mak (pasu24) wrote :

I have this problem too. I am not sure if it is caused by setting the /tmp/ and the /var/log to ramdisk. (I am using SSD drive)

fixes I tried:
1. Adding amixer -q set Master some_number% unmute to /etc/rc.local didn't help.

2. Entering the same command manually after Ubuntu starts:
It only works if the % number is different than the previous one. For example the volume suppose to be at 30% and it shows correctly in gnome volume control. However when I play something, the volume is actually at max. Entering amixer -q set Master 30% unmute does not help but a different number do set the volume correctly. The problem is, I am too lazy to type the command every time. It is much faster to press the volume button from my keyboard.

3. Finally I use similar methods raevol suggested. I change the script to

amixer -q set Master 20% unmute
amixer -q set Master 30% unmute

and it works.
Hope Ubuntu got this problem fixed soon, and thanks for all the information all people provided :D

Hing-Yap Mak (pasu24) wrote :

Additon information to last post:

Instead of adding the commands directly to startup application command box, I set it to the script that contains the commands:
sh '/usr/local/sbin/mystartupscript.sh'

I'm also looking for a solution to this problem. I'm running the latest version of Ubuntu and this issue started in my computer when I upgraded to this latest version (didn't have it before). I have tried the /etc/rc.local trick, but didn't work as expected. However, I did observe that when restarting (before you log in), the volume is set to the value specified in the /etc/rc.local file. (In my case, I'm just setting the speaker to mute because I want my computer to start mute). However, when I log into my machine, the volume is set to 100%. So, there's something that is happening during logging in that is setting the volume to 100%. Don't know what it is.

I tried adding the "amixer -q Master mute" command to a booting script but it didn't work. I followed this method:
http://embraceubuntu.com/2005/09/07/adding-a-startup-script-to-be-run-at-bootup/

I also tried adding the same command to a script added to the Startup Applications Preferences (Dash home -> search for "startup" and select "Startup Applications"), but that didn't work either. HOWEVER, in that same window there's an option to turn off the GNOME Login Sound (just uncheck "GNOME Login Sound") and now, even if I my laptop starts at 100% volume, at least it won't play the loud ubuntu login sound every time! But I still need to remember to turn down the volume manually before the system makes any sound, which of course it will be very easy to forget!!! So, this issue is still not fixed for me.

This is really an important issue. As somebody mentioned earlier, it means you can't boot your laptop in a library. But also, in a meeting, hospital, etc., etc. There are so many situations where you need to work in silence. It really it's not acceptable to have this issue not fixed.

You know, this is one of the small annoying details that makes Ubuntu being short of really competing against Windows or MacOS. Yes, Ubuntu is quite good when compared to other Linux distros, but it's not good enough to depend on it. Windows has really worked out most if not all of the annoyances of Windows Vista and previous versions. But sadly Ubuntu just keeps having its quirky issues that make it quite rough around the edges to be honest. And it's not just one or two annoyances, it's many and when you search online you have to spend ages to find a solution and many times you don't get a satisfactory one, like in this case. At least you know that if users pressure Microsoft hard enough, they will release an update that will fix the issues. Unfortunately, that doesn't happen with Ubuntu. It's really sad because I do want to give Ubuntu and open source a go but it stops just short of being good enough to be dependable.

David Barnett (mu-mind) wrote :

I started seeing this bug after upgrading to Natty and switching to Gnome Shell. Note:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Two people reported this problem with an Intel 82801H, so I think there's definitely a connection, but it seems like maybe there was an earlier bug with identical symptoms (i.e., volume resets to 100% on first login after reboot) that was fixed in pulseaudio. Shall I file a separate bug for this issue still happening on Intel Audio? Is there any particular debugging info I can provide?

Yfrwlf (yfrwlf) wrote :

In Ubuntu 12.04 my master digital output S/PDIF always resets to 100%, extremely loud and annoying. However, at least when I hit the volume button once either up or down, it pops back to the previous level.

In Ubuntu 13.04 my master digital output S/PDIF always resets to 100%, extremely loud and annoying. Hitting the down or up volume button doesn't reset it to the previous volume, so I have to lower it again all the way from 100%.

Things are getting worse with something as simple as saving a user's volume level...

Rebooted cleanly in all cases.

Same issue as described above by Yfrwlf. Upon reboot using Ubuntu 13.04 the volume is reset to 100% which causes blaring speaker volumes unless turned down to the previous level. This bug only started occurring for me after a fresh install of Ubuntu 13.04. Previously on a 12.10 install upgraded from 12.04 the issue did not happen.

Serge Victor (ser) wrote :

13.10, gnome-shell, SPDIF, volume still always 100% upon reboot

laeb@biosustain.dtu.dk (laeb) wrote :

13.10, logitech USB headset. It also happens when I leave the computer for a while and it goes to screensaver. Then when I type in my password it resets the volume.

Richard Boudreau (rbo83) wrote :

On 13.10, the 100% reset over reboot happens also on hdmi out on AMD/ATI Wrestler HDMI Audio Radeon HD 7340.
But the volume setting is kept properly across sessions without reboot.
Does anyone know the name of the file where this volume info is stored upon shutdown ?
The user session info seems to be stored in ~/.config/pulse

infernet (guattari) wrote :

Audio settings are not kept after rebooting. The input and output sources are reset to some weird defaults (not what I have set).

Richard Boudreau (rbo83) wrote :

BUSTED LED TV SPEAKERS !!! Further to post #70, this is getting serious. volume set at 100% over reboot busted speakers on flat screen tv connected on hdmi.

Kovanecz Ivor (kovanecz-o) wrote :

Trying the ALSA and PULSE audio settings recommended on various sites had a strange result: the volume icon and slider show the preset volume (~40%) after boot, but the real, I mean audible volume is @ 100%. Simply clicking the volume slider will set the volume right.
Another strange thing: today the clock/calendar items did't appear on startup, and the real volume was correct (40%)!
Bringing back the clock with sudo killall unity-panel-service the volume reset to 100% while the slider still showed 40%.

Ubuntu 13.10 64-bit, Intel HDA, DisplayPort

Tom Goeckel (norak2) wrote :

I had this bug in all previous Ubuntu Versions and still have it with a fresh install of Ubuntu 14.04.

Richard Boudreau (rbo83) wrote :

Tried with the latest kernel 3.13.6 which includes lots of new hdmi radeon stuff, but with same 100% volume problem upon boot.

Kevjin (kevjin) wrote :

I also tried this on the latest kernel 3.13.0-24-generic , Ubuntu 14.04, Asus G73JH, same 100% volume problem on reboot.

really (wlfbck) wrote :

This bug is *NOT* fixed. I'm too unexperienced with launchpad, how can we get a "fix denied" here?

rush (rush131) wrote :

I can also confirm this problem on fresh install of 14.04. I'm using an integrated sound card on Gigabyte M720-US3 motherboard.

Andreas Erhard (andreas5232) wrote :

I'm also affected by this annoying bug. I am on 13.10 64-Bit and the sound volume of my pulseaudio is on 100% after reboot. I have an Intel on Board soundcard connect to my AV-Receiver via SPDIF.
Hope, this gets fixed soon.

Tim Erbes (timerbes) wrote :

This is also happening to me. Fresh install of Xubuntu 14.04 x64.

$ lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

Simon (simontipping21) wrote :

This has affected me for the last two releases (13 & 14).

Creative Soundblaster USB card

Pedro Neves e Castro (pmnc61) wrote :

I have the same problem after a clean install of Ubuntu 14.04.
The volume level is always at 100% at boot.

Yatsenko Anton (yatsenkoanton) wrote :

I confirm, that I have the same problen under ubuntu 14.04

I have a Trust SC-5500p USB Sound Card and the same Problem (14.04 64bit).

I even had to set default-sample-channels = 6 in /etc/pulse/daemon.conf in order to get the rear speakers and Subwoofer working (with 12.04 this worked out of the box), but that is another probem.

Every time I reboot, the volume is set to 100%, although the applet shows the volume level from before boot and when I hit a mediakey for volume, this is where is continues. Example: I have the volume at 20%, reboot, everything will now play at 100% volume but the indicator shows 20% volume. When I hit "volume-up"- Mediakey now, the volume is set to ~25%.

I already tried to circumvent this problem with setting "amixer -D pulse sset Master 25%" in .profile. but this is only setting the indicator to 25%, sound will still play at 100% until I hit a volume key or set the volume by mouse.

Anybody know if you can set the soundvolume via pulseaudio? Relevant pulseaudio documentation is kinda hard to find in the net... [insert general rant here].

@tim.timwahrendorff
pactl set-sink-volume `pactl list sinks short | awk '{print $1}'` 30%

Hrotkó Gábor (roti-al) wrote :

This problesm still exists on my system: ubuntu 14.04.1
pulse package version: 1:4.0-0ubuntu11

$ lspci -v | grep -i audio
00:04.0 Multimedia audio controller: NVIDIA Corporation CK804 AC'97 Audio Controller (rev a2)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series]
05:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 04)
05:08.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
 Subsystem: Pinnacle Systems Inc. PCTV pro (TV + FM stereo receiver, audio section)

I use the SB Live as the output.

soul_departed (mukit-tc) wrote :

Facing the same problem. I'm using an USB sound card from Siberia.

mukit@lifebook:~$ cat /proc/asound/cards
 0 [PCH ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf1600000 irq 45
 1 [Device ]: USB-Audio - USB PnP Sound Device
                      C-Media Electronics Inc. USB PnP Sound Device at usb-0000:00:1d.0-1.1, full spe
mukit@lifebook:~$ uname -a
Linux lifebook 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:07 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Richard (r-j-v-m-sterken) wrote :

Same here on an Acer laptop.
After every reboot the volume is up to 100%...but, if muted, it stays muted.

really (wlfbck) wrote :

This bug is *NOT* fixed. I'm too unexperienced with launchpad, how can we get a "fix denied" here?

reposting because still bugged.

brian (byork9) wrote :

its still bugged posting 14.04.... anyone fix yet or is this no important at all?

Jacob (dead-feminine) wrote :

Same thing happening to me on Ubuntu 16.04. Sound always resets to only 50% and even worse, it's only the left side. Right side is dropped to 0%.

Aleksey (evenfrost) wrote :

Same here on 16.04 and Gnome 3.18.5. Volume resets to maximum after every reboot.

Martin Heine (vssage) wrote :

The bug is still there. Very annoying. Every time, you forget to torn the Volume down of your Stereo, the Speakers almost blow when Ubuntu starts. Can't be that heart to fix this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers