ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not display crisply

Bug #551013 reported by Paolo Sammicheli on 2010-03-29
714
This bug affects 150 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Medium
Unassigned
Nominated for Karmic by jp.seixas
Nominated for Lucid by jp.seixas
Nominated for Maverick by Dart

Bug Description

Binary package hint: plymouth

After last fixes for #526892 now the Graphical Splash looks ugly in a 640x480 resolution and with poor color depth.

Falling back to nuveau drivers it looks normal.

Model: nVidia 8600 GTS

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.1-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-17-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Mar 29 18:35:22 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100329)
MachineType: System manufacturer P5K-E
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic root=UUID=d16bb604-c459-407e-a581-f7820f395b1f ro quiet splash
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VGA16 VGA
SourcePackage: plymouth
dmi.bios.date: 05/25/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0307
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K-E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Paolo Sammicheli (xdatap1) wrote :
Paolo Sammicheli (xdatap1) wrote :

lshw attached.

Jacob Henderson (lmeditato) wrote :

I have the same issue.

tags: added: boot
tags: added: nvidia splash
Changed in plymouth (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this issue and help to improve Ubuntu.

Unfortunately, this is the expected behavior. When the binary nvidia drivers are in use, the only framebuffer we can reliably expose in the kernel is a VGA framebuffer. And VGA is 4-bit color, 640x480. So this isn't a plymouth bug.

(Further improvements are expected to the graphic used with vga16fb so that it looks crisper - but it's still going to be 640x480 with poor color depth.)

Changed in plymouth (Ubuntu):
status: Confirmed → Invalid
Zen Shaolin (zen-shaolin) wrote :

Same bug for me => Nvidia GTX 260

Nicolas Delvaux (malizor) wrote :

And what about this idea ?
http://brainstorm.ubuntu.com/idea/17355/

Is this unreliable to at least look for 1024x768 capabilities ?
(and I think there is the same issue with the binary ati driver)

Steve Langasek (vorlon) wrote :

The only place to "look for" such capabilities, since the binary driver doesn't expose this to the kernel, is by using the vesa framebuffer driver instead. That doesn't work reliably on all hardware, so is not enabled by default. You can choose to enable it using one of the 'vga=xxx' boot-time options.

Nicolas Delvaux (malizor) wrote :

Ok, thank you for your answer ;)

Paolo Sammicheli (xdatap1) wrote :

@Steve: Thank you, now it's clear from the technical prospective. Btw, I opened this bug from the ISO Testing prospective, so for me as a tester this bug isn't fixed until "it looks decent". As a tester I wouldn't care how it will be fixed, a better image or a better resolution, I'm just following the test case and report the issues I found. :)

What do you think if we set it "in progress" and we assign it to the guy who's charge for improving the splash image at low resolution? This bug would be linked from all proprietary driver tests on xorg.qa.ubuntu.com tracker and maybe it would avoid future duplicates and discussions.

Regards

fair enough - reopening.

summary: - [Lucid Beta1] Ugly graphical splash (res. 640x480) with nVidia
- proprietary drivers
+ [Lucid Beta1] ubuntu-logo on VGA fb (as with nvidia binary drivers) does
+ not display crisply
Changed in plymouth (Ubuntu):
importance: Undecided → Medium
status: Invalid → Triaged

It happens to me and I use the nvidia drivers at 1280x800 and 50 GHz.

If its fault of the propietary driver, i've had an idea to solve this.
Maybe we can run plymouth with the nouveau driver and later when plymouth ends running change the mouveau driver for the nvidia propietary driver.

The only problem is that I dont know how to make all this changes and make a patch.

summary: - [Lucid Beta1] ubuntu-logo on VGA fb (as with nvidia binary drivers) does
- not display crisply
+ ubuntu-logo on VGA fb (as with nvidia binary drivers) does not display
+ crisply

Another option is that when you install nvidia propietary drivers the installer uninstall and installs the old splash that worked fine with the propietary drivers. I think is important for a system to have a polished startup because it's the first impression that people has. And we have to find a way to have a polished startup even when unsers are using nvidia propietary dirvers, because nowadays nouveau drivers does not support 3D acceleration.

On Fri, 2010-04-02 at 07:28 +0000, opengeek wrote:

> Another option is that when you install nvidia propietary drivers the
> installer uninstall and installs the old splash that worked fine with
> the propietary drivers.
>
The old splash code doesn't support the facilities for displaying fsck
progress messages, prompting for passowrds, questions, etc. during boot.

Scott
--
Scott James Remnant
<email address hidden>

Ok, I understand.
And what about run plymouth using the nouveau driver and when nouveau finishes load the nvidia porpietary dirver to have 3d acceleration, is possible to do it?

Julian Alarcon (alarconj) wrote :

So, what about this "workaround":
http://ubuntuforums.org/showthread.php?t=1446132
??

Paolo Sammicheli (xdatap1) wrote :

@Julian: This workaround doesn't works 100% cards and also when it works you lose the textual TTYs. Definitely not a solution!

What we need is just an image that would looks decently at low resolution.

Steve Langasek (vorlon) on 2010-04-06
summary: - ubuntu-logo on VGA fb (as with nvidia binary drivers) does not display
- crisply
+ ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not
+ display crisply
wavded (wavded) wrote :

I'm interested in just running the Nuveau drivers to fix this issue and see how the system performs. Is there any tutorial on how to do that? Do I disable Compiz?

Just disable the proprietary drivers.

This solution is not very useful if you need 3D acceleration.
I insist, maybe a solution could be that.
1. The default drivers for nvidia cards are nouveau.
2. if you want 3d acceleration you install the propietary drivers.
3. When you install the propietary drivers form the repositories the package
configures the system for use the nouveau driver to boot up and run
plymouth, and after running plymouth the system unloads the nouveau driver
and loads the propietary driver to use the 3D accelerated desktop.

Is possible to do it or I'm only imagining things.

2010/4/7 Tesselode <email address hidden>

> Just disable the proprietary drivers.
>
> --
> ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not
> display crisply
> https://bugs.launchpad.net/bugs/551013
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: plymouth
>
> After last fixes for #526892 now the Graphical Splash looks ugly in a
> 640x480 resolution and with poor color depth.
>
> Falling back to nuveau drivers it looks normal.
>
> Model: nVidia 8600 GTS
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: plymouth 0.8.1-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-17-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Mon Mar 29 18:35:22 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100329)
> MachineType: System manufacturer P5K-E
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic
> root=UUID=d16bb604-c459-407e-a581-f7820f395b1f ro quiet splash
> ProcEnviron:
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 VGA16 VGA
> SourcePackage: plymouth
> dmi.bios.date: 05/25/2007
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 0307
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: P5K-E
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: P5K-E
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/551013/+subscribe
>

On Wed, Apr 07, 2010 at 09:29:09PM -0000, opengeek wrote:
> This solution is not very useful if you need 3D acceleration.
> I insist, maybe a solution could be that.
> 1. The default drivers for nvidia cards are nouveau.
> 2. if you want 3d acceleration you install the propietary drivers.
> 3. When you install the propietary drivers form the repositories the package
> configures the system for use the nouveau driver to boot up and run
> plymouth, and after running plymouth the system unloads the nouveau driver
> and loads the propietary driver to use the 3D accelerated desktop.

> Is possible to do it or I'm only imagining things.

No, that's not possible. Once the console is bound to the KMS driver,
getting the nouveau module is infeasible.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Jason S. Wagner (jasonswagner) wrote :

opengeek, Tesselode was assisting wavded. He was not insisting that the solution is not to use proprietary drivers.

I'm pretty sure using nouveau with plymouth and the proprietary driver under X is not possible. Even if it were, it would still break the seamless transition, which AFAIK, is the point of using plymouth. We'd be just as well served by the old usplash.

Have we considered moving this bug upstream? Does this occur under Debian or other distributions?

u-foka (ufooka) wrote :

My god :(

Who the hell cares about KMS, i know, i know it's a good thing, I agree,
but can not compared to have a good looking boot with an accelerated
X... and a switch in a second between the two... Nowdays, the mayoralty
of users have lcd displays, where the native resolution much more
important (because lower resolutions results a blurred image) than the
mode switch which is smooth (and many users even don't notice it)
without kms...

So what I mean... kms is GOOD, plymouth is GOOD, nouveau is GOOD, but I
absolutely sure, that who pays for any NVIDIA gpu, he/she want to use
it's power, so it's pointless to say that use nouveau instead of the
proprietary driver... Good to have nouveau instead of nv on the livecd,
but it pointless to ask users to use it on their installed systems,
until it can't provide stable efficient 3D support for all gpu's! So
this HAVE to be fixed! As far as I know, plymouth doesn't depends on
KMS, so we have to make vesafb to work for nvidia users (I use it since
ages, and have no problems at all nor suspend or any other problems,
only Bug #550104 that seems to caused by plymouth itself)

And finally, thanks for all the crew to making ubuntu the BEST os
around, but I can't understand that HYPE around the bootsplash...
usplash was really good, I liked it (even made some themes for it) but
since ubuntu started to "improve" it's boot experience I no more have a
native resolution boot out of the box, and now I even can't make it work
by hand :( so please KEEP ubuntu the best!!

On 04/08/2010 12:06 AM, Jason Wagner wrote:
> opengeek, Tesselode was assisting wavded. He was not insisting that the
> solution is not to use proprietary drivers.
>
> I'm pretty sure using nouveau with plymouth and the proprietary driver
> under X is not possible. Even if it were, it would still break the
> seamless transition, which AFAIK, is the point of using plymouth. We'd
> be just as well served by the old usplash.
>
> Have we considered moving this bug upstream? Does this occur under
> Debian or other distributions?
>
>

wavded (wavded) wrote :

Disabling brought the resolution up for the bootscreen. I have to agree w/ what's being said, it unfortunate that the proprietary drivers look a like a joke in the splash when it seems like they could be harnessed for more, better resolution, 3d something. But I have no knowledge of how the programming works for ubuntu, which I understand there are roadblocks to that goal. Maybe the OS drivers will catch up, maybe nvidia will pay more attention to linux.. regardless, keep up the good work.

Ok, I understand. You're doing a good work. Then I think the better soluiton
is use a plymouth image with less coor depth, then the nvidia cards with the
propietary driver will draw it properly.

2010/4/8 wavded <email address hidden>

> Disabling brought the resolution up for the bootscreen. I have to agree
> w/ what's being said, it unfortunate that the proprietary drivers look a
> like a joke in the splash when it seems like they could be harnessed for
> more, better resolution, 3d something. But I have no knowledge of how
> the programming works for ubuntu, which I understand there are
> roadblocks to that goal. Maybe the OS drivers will catch up, maybe
> nvidia will pay more attention to linux.. regardless, keep up the good
> work.
>
> --
> ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not
> display crisply
> https://bugs.launchpad.net/bugs/551013
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: plymouth
>
> After last fixes for #526892 now the Graphical Splash looks ugly in a
> 640x480 resolution and with poor color depth.
>
> Falling back to nuveau drivers it looks normal.
>
> Model: nVidia 8600 GTS
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: plymouth 0.8.1-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-17-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Mon Mar 29 18:35:22 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100329)
> MachineType: System manufacturer P5K-E
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic
> root=UUID=d16bb604-c459-407e-a581-f7820f395b1f ro quiet splash
> ProcEnviron:
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 VGA16 VGA
> SourcePackage: plymouth
> dmi.bios.date: 05/25/2007
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 0307
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: P5K-E
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: P5K-E
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/551013/+subscribe
>

I found this bug because I thought my card might be defective, but I see this is the 'norm'.

If something isn't done to alleviate the ugly appearance, I predict there will be a lot of new Kubuntu users opening tickets here next month for "broken" bootsplash screens.

I'm going to see if I can change the kernel options to disable splash. Maybe that could be a "solution": Add grub changes to the repos' nvidia packages to turn off the splash if using their binary blob?

OlivierP (unineurone) wrote :

I would second 3vi1' workaround. Better off with no splash than the horrid purplish blob I see on a GeForce 7300M powered laptop. 640x480 is really ugly when upscaled to 1440x900 (17" laptop)

Søren Holm (sgh) wrote :

I allso agree with OlivierP. Especially when KArmic looked pretty nice, then lucid should not be ugly.

Jason S. Wagner (jasonswagner) wrote :

If lucid ships with this bug open, perhaps we should consider putting users on affected drivers on usplash with a comparable logo, and then roll everyone over to plymouth once the bug is confirmed resolved? Or is that too drastic of a change post-release?

Steve Langasek (vorlon) wrote :

usplash isn't even remotely suitable as a substitute for plymouth in Lucid.

mabawsa (mabawsa) wrote :

Black is better than ugly. Plain text if the disk is being checked. It should also be on the release notes that this is a won't fixer.

Sel Goona (alieneye) wrote :

The ugliness has only just begun, as we have started to change the packages. Normally, plymouth falls back to a text-mode when a proprietary driver is installed, and this is much better than, if all users get a lower nice bootscreen.

PLEASE SIMLPY GET BACK TO THIS PREVIOUS BEHAVIOUR AND ALL ARE HAPPY. You have tried it and now everybody could see that it dont work acceptable.

mabawsa (mabawsa) wrote :

OK after reading the uvesafb manual I came up with this rather simple workaround that makes my boot experience much better, still a bit jumpy.

sudo gedit /etc/initramfs-tools

add:
uvesafb mode_option=1280x800-32 mtrr=3 scroll=ywrap

obviously changing your resolution to what you want then:

sudo update-initramfs -u

On my M1330 with a nVidia G8400M this worked. Probably not a general workaround though.

mabawsa (mabawsa) wrote :

Oh I got nice hires ttys as well. The set gfxpayload=keep workaround borked my ttys.

mabawsa (mabawsa) wrote :

oopa made a mistake:

-sudo gedit /etc/initramfs-tools
+sudo gedit /etc/initramfs-tools/modules

sorry

mabawsa (mabawsa) wrote :

Also before I started I had v86d installed which is apparently essential,

Pavel Malyshev (afunix) wrote :

Thanks, mabawsa! This workaround worked for me with nVidia GeForce 8400M GS on Dell Inspiron 1520!

afunix, did you do any special steps? I have the same gpu in my vostro
1310 and I can't get it work with uvesafb :(

i installed v86b too...

On 04/10/2010 09:07 PM, afunix wrote:
> Thanks, mabawsa! This workaround worked for me with nVidia GeForce 8400M
> GS on Dell Inspiron 1520!
>
>

mabawsa (mabawsa) wrote :

u-foka
Strange as this is the same GPU to my one (can you run the following command to make sure?)
~$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M GS] (rev a1)

What kind of boot experience do you get?
Did you alter any of the grub files? if so you will have to comment these out and update-grub.

can you type:

cat /proc/fb

If it says 0 VESA VGA then VESA is loaded and you may have to play around with mode_option=1280x800-32, else it may be that you have uvesafb blacklisted somewhere. In that case you need to check the blacklist files in modprobe.d directory.

There may be something in the dmesg log so check this as well.

u-foka (ufooka) wrote :

mabawsa, thanks for your reply!

Now I found my way trough this...
First I blacklisted vga16fb, and then uvesafb started working but sadly loaded after plymouth, so I seen the text mode splash on a high res terminal at the top-left corner... then I removed uvesafb from the modules file, and put instead in the video= kernel parameter and that work's fine, even when I removed the blacklist from vga16fb...

So the solution that works for me:
install v86d
edit /etc/default/grub and add video=uvesafb:mode_option=1280x800-32,mtrr=3,scroll=ywrap after splash in the GRUB_CMDLINE_LINUX_DEFAULT line.

Thanks!

New 16-color artwork committed

Changed in plymouth (Ubuntu):
assignee: nobody → Scott James Remnant (scott)
milestone: none → ubuntu-10.04
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.8.2-1

---------------
plymouth (0.8.2-1) lucid; urgency=low

  [ Steve Langasek ]
  * New upstream release.
  * debian/plymouth.plymouth-stop.upstart: trust the new kdm to stop plymouth
    for us, too. LP: #540177.
  * plymouth needs to depend on initramfs-tools to avoid calling
    update-initramfs when the stack isn't configured yet and rendering the
    system unbootable with a broken initramfs. LP: #358654.
  * src/client/ply-boot-client.c: ply_boot_client_flush() needs to process
    the incoming queue before the outgoing, otherwise we get a deadlock.
    LP: #554737.
  * src/plugins/splash/script/script-lib-image.c: call script_obj_is_null()
    to check for the presence of the alpha argument, otherwise all our labels
    are rendered invisibly...
  * src/plugins/renderers/drm/plugin.c: temporarily disable the drm backend
    for nouveau, until we can get to the bottom of the DRM lockup in bug
    #539655. This is not as pretty, but it boots to the desktop without
    hanging regardless of how many displays are used, and that takes
    precedence. LP: #533135.

  [ Scott James Remnant ]
  * Implement a Window.GetBitsPerPixel() function in the script library,
    and the necessary support in ply_pixel_display, ply_renderer and in
    the vga16fb and frame-buffer renderers to make that information
    available. This will return "0" on drm and x11 where the answer is
    "lots". LP: #558352.
  * Modify vga16fb to only fallback to reducing colors if it's overflowed
    the 16-color palette already, so if you stick to the same 16 colors,
    you can get exact matches.
  * Use alternate 16-color images when we have only 4bpp. LP: #551013.

  [ Alberto Milone ]
  * ubuntu-logo: accept a format string from mountall for the disk check
    progress, so that localization is possible. LP: #553954.
 -- Steve Langasek <email address hidden> Thu, 15 Apr 2010 00:55:46 +0000

Changed in plymouth (Ubuntu):
status: Fix Committed → Fix Released
vista killer (vistakiller) wrote :

Is not fix. We have in lucid plymouth 8.2-2 but the problem still exist.

Yes it happens to me too on nVidia GForce 9400M GS

2010/4/25 vista killer <email address hidden>

> Is not fix. We have in lucid plymouth 8.2-2 but the problem still exist.
>
> --
> ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not
> display crisply
> https://bugs.launchpad.net/bugs/551013
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: plymouth
>
> After last fixes for #526892 now the Graphical Splash looks ugly in a
> 640x480 resolution and with poor color depth.
>
> Falling back to nuveau drivers it looks normal.
>
> Model: nVidia 8600 GTS
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: plymouth 0.8.1-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-17-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Mon Mar 29 18:35:22 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100329)
> MachineType: System manufacturer P5K-E
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic
> root=UUID=d16bb604-c459-407e-a581-f7820f395b1f ro quiet splash
> ProcEnviron:
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 VGA16 VGA
> SourcePackage: plymouth
> dmi.bios.date: 05/25/2007
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 0307
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: P5K-E
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: P5K-E
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/551013/+subscribe
>

pauls (paulatgm) wrote :

please also be aware of bug 569960 for the fact that the password prompt on the new artwork is cut off horizontally and vertically, making it difficult to observe password entry.

Marius Nestor (marius-nestor) wrote :

NOTHING was fixed! The bug is still there, at least on today's (April 26th) daily ISO build. Tested by me on different Nvidia systems (7300 GT, 7300 GS, FX 5500, FX 5200). Plymouth looks like crap with the Nvidia (and probably ATI) proprietary video drivers! Please do NOT leave this bug in the final release for Thursday!

Steve Langasek (vorlon) wrote :

This bug report is "Ubuntu logo does not display crisply." That bug most certainly has been fixed, I have personally verified it.

If your objection is actually that the logo is *oversized*, that's bug #563878, which will not be resolved for the final release.

Jason S. Wagner (jasonswagner) wrote :

All that has been achieved so far is the logo looks slightly less terrible when plymouth chooses the worst possible video mode. That might be acceptable if Lucid is going to ship with this bug still open, but it does not resolve the bug.

plymouth to display the splash screen in our native resolutions with full color depth when using proprietary drivers, as it does when we disable the proprietary drivers.

Please see the bug description and the descriptions of the duplicate bugs for evidence.

On Mon, 2010-04-26 at 19:01 +0000, Jason Wagner wrote:

> plymouth to display the splash screen in our native resolutions with
> full color depth when using proprietary drivers, as it does when we
> disable the proprietary drivers.
>
We don't have the source to the proprietary drivers, so we can't fix
them; and even if we did somehow obtain the source, we wouldn't have
permission to distribute the fixed version.

The only solution is for the open drivers to improve to the point where
can we drop the proprietary drivers altogether.

Since that is a solution that does not involve Plymouth, it doesn't make
sense to keep the bug open just to track whether or not we're there yet.

Scott
--
Scott James Remnant
<email address hidden>

mabawsa (mabawsa) wrote :

I am a bit perplexed uvesafb and efifb (shipped with grub2 and activated quite simply) work well with nvidia, radeon and nouveaux (I don't know about all models or ATI propriety). So couldn't the fb from either of these be used or parts of the code to either patch or replace the vga16fb at least for magic mollusc.

On Mon, 2010-04-26 at 23:40 +0000, mabawsa wrote:

> I am a bit perplexed uvesafb and efifb (shipped with grub2 and
> activated quite simply) work well with nvidia, radeon and nouveaux (I
> don't know about all models or ATI propriety). So couldn't the fb from
> either of these be used or parts of the code to either patch or replace
> the vga16fb at least for magic mollusc.
>
That's our rough plan for 10.10, yes - now that we understand (mostly)
the quirks needed to do suspend/resume with a vesa or efi framebuffer

Scott
--
Scott James Remnant
<email address hidden>

mabawsa (mabawsa) wrote :

Thanks Scott,

Damn I never realised the code name had been released Maverick Meerkat. Sticking with higher animals I see. Maybe we will have to wait for Yabbling Yeast till we see something a bit lower.

Marius Nestor (marius-nestor) wrote :

@Steve Langasek:

OK, my bad about my comments on this bug... they are all related, like Jason Wagner said, so...

Anyway, I don't understand how can Canonical leave such as nasty bug in a LTS release!? Really! It's unacceptable if you ask me... Every Lucid user with Nvidia and ATI graphics cards will have an enormous and ugly Ubuntu logo at boot.

Alvin (alvind) wrote :

Because it serves as a reminder of why closed source drivers are bad ;-)
RMS would be proud.

kahrytan (kahrytan) wrote :

This bug, i believe, effects both ATI and Nvidia. On my system, I also get same problem w/o ATi driver.

Yes I have an ATI Mobility Radeon X300 with the privative driver installed
and I hve this bug.

2010/4/30 kahrytan <email address hidden>

> This bug, i believe, effects both ATI and Nvidia. On my system, I also
> get same problem w/o ATi driver.
>
> --
> ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not
> display crisply
> https://bugs.launchpad.net/bugs/551013
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: plymouth
>
> After last fixes for #526892 now the Graphical Splash looks ugly in a
> 640x480 resolution and with poor color depth.
>
> Falling back to nuveau drivers it looks normal.
>
> Model: nVidia 8600 GTS
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: plymouth 0.8.1-1ubuntu3
> ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-17-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Mon Mar 29 18:35:22 2010
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100329)
> MachineType: System manufacturer P5K-E
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic
> root=UUID=d16bb604-c459-407e-a581-f7820f395b1f ro quiet splash
> ProcEnviron:
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 VGA16 VGA
> SourcePackage: plymouth
> dmi.bios.date: 05/25/2007
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 0307
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: P5K-E
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev 1.xx
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: P5K-E
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/551013/+subscribe
>

I installed with a brand new ATI 5870 today and saw the same horrible screen. :\

alexeagar (alexeagar) wrote :

This problem occurred for me, but I found a very good solution which I hope will be pushed upstream. The changes should be applied when proprietary graphics drivers are enabled and reverted when proprietary graphics are disabled. One of the steps involves choosing the ideal resolution for the splash screen, but since the system would most likely already be using the ideal resolution when the proprietary graphics driver is enabled, the installer could just detect what resolution is currently being used.

http://idyllictux.wordpress.com/2010/04/26/lucidubuntu-10-04-high-resolution-plymouth-virtual-terminal-for-atinvidia-cards-with-proprietaryrestricted-driver/

alexeagar (alexeagar) wrote :

By pushed upstream, I mean applied to Ubuntu.

alexeagar (alexeagar) on 2010-05-02
Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed
alexeagar (alexeagar) wrote :

Changed the status to confirmed because the bug has not been fixed as of the final release of Ubuntu 10.4 and there are countless reports of this bug on Launchpad and all over the Internet. Please commit a proper fix.

alexeagar (alexeagar) wrote :

Here is the same solution targeted at Linux beginners. http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

Countless Ubuntu users enable a proprietary graphics driver when the hardware drivers notification icon first appears right after logging in for the first time. This bug is going to leave a bad impression on every single one of them when the splash screen which they will have previously seen at the correct resolution is suddenly at the wrong resolution during every subsequent startup. Many of those users will search and find this difficult-for-a-beginner seven-step workaround. Many others will search and find either harder to follow instructions or inaccurate instructions.

Alvin's lighthearted comment, that Canonical allowed this bug to slip in order to serve as a reminder that closed source drivers are bad, which I hope has no truth to it, is the very real and very negative impression which people will be left with. From their perspective, the fully functional 'bad' closed source drivers are being intentionally ignored in order to promote the significantly less functional 'good' open source drivers.

Because of the high visibility of this bug to such an extremely large portion of the Ubuntu user base, I implore you, for the sake of Ubuntu's reputation and public image, please commit a proper fix to automatically make the necessary system changes when a proprietary graphics driver is enabled so that the native resolution, or as close to the native resolution as the video BIOS interface will allow, will be be displayed on the full disk encryption password screen, the boot splash screen and the virtual terminal screen. If the proper fix is outside the scope of plymouth, someone please forward this bug to the appropriate developer.

idyllic (idyllic) wrote :

Hmph, they remediate my guide without even credit me by at least by linking to my original post. Not a fair act to me by Softpedia.

That's Softpedia...

sanctimon (dj.martin) wrote :

Same here, on a 64-bit system, fresh install (upgraded from 9.04 and then did fresh install to test if it solves the issue). No splash screen appears after GRUB selection. A long black screen, only during the late stages of which the hard drive can be heard doing anything.
Intel Core Two Duo
nVidia GeForce 8800 640MB (current version drivers installed)

After a relatively long wait (was not the case with 9.04 and previous versions), there are 5 dots with scrambled colours on screen followed by 3 "Ubuntu" logos appearing on screen with a few dots beneath them. This only lasts a second and then the logon screen appears.

Same phenomenon when shutting down (3 "Ubuntu" logos coloured weird and with blurred lettering pop up for a second).

I will give this proposed solution a try, providing it does not remove the proprietary drivers.

alexeagar (alexeagar) wrote :

sanctimon, it sounds like you are experiencing Bug #516958 which looks like it is awaiting more detailed user feedback. If you can manage it, I recommend you attach a picture of the three Ubuntu logos to that bug. Also post which version of plymouth you have installed, then subscribe to the bug so that you'll be notified if more feedback is requested and finally, click on the following link while you're logged in to Launchpad, to let the developers know that this bug affects you too. https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/516958/+affectsmetoo

Steve Langasek (vorlon) wrote :

This bug report is about the *crispness* of the logo. That has been fixed. Do not reopen this report.

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
alexeagar (alexeagar) wrote :

It has not been fixed. It is not 'crisp' as of the final release of Ubuntu 10.4. It can never be 'crisp' so long as the wrong resolution is being used when the logo is being used.

alexeagar (alexeagar) wrote :

Steve, or someone with equal or more authority, please reopen this bug report.

alexeagar (alexeagar) wrote :

I submitted my disagreement about the resolution of this bug as a launchpad question. https://answers.launchpad.net/launchpad/+question/109331

Jason S. Wagner (jasonswagner) wrote :

The Canonical folks believe they have delivered a fix to the title of this bug. Let's let this one lie.

I corrected the erroneous linking of my bug as a duplicate of this bug. Now, it is its own bug. If you are affected by plymouth's poor choice of resolution when using a proprietary display driver, please subscribe to Bug#553854 (link below) and continue working toward a resolution.

plymouth: after installing proprietary nvidia driver, splash screen displays in low color/low resolution mode
https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/553854

alexeagar (alexeagar) wrote :

This bug and Bug #553854 are duplicates of each other, but I have no problem with ignoring this bug. Resolution of the underlying problem is all that is important to me, not the organization or interpretation of duplicates. The only reason I focused on this bug rather than another duplicate was because it started with more duplicates assigned to it than any of the other duplicates. From now on I will will focus on Bug #553854 and ignore Bug #551013. I have marked the aforementioned question where I expressed my disagreement as solved.

James Smith (emailjpsmith) wrote :

Exact same problem here using the non-free ATI Driver. On a fresh install everything is perfect until i install the ATI Drivers.

here's what I do:
1. sudo apt-get install hwinfo
2. sudo hwinfo --framebuffer
3. I get something like this:
  Mode 0x031b: 1280x1024 (+5120), 24 bits
4. Then I pick my desired resolution and:
sudo gedit /etc/default/grub
and add the desired mode into this line:
GRUB_CMDLINE_LINUX=""
like this:
GRUB_CMDLINE_LINUX=" vga=0x031b"
then sudo update-grub2
5. also to show the splash longer than 1 or 2 seconds I add FRAMEBUFFER=y in this file:
sudo gedit /etc/initramfs-tools/conf.d/splash
Save the file and exit, then:
sudo update-initramfs -u
I have no need to use the uvesafb or something like this.
But the problem is that 1280x1024 and lower resolutions show properly,but the logo is centered and I get a ~1cm vertical line on the right, and if I set like 1620x1200 then the logo is ugly and I get flickering and some text like it was in alpha2 or beta1 releases. I've ataching some photos with different resolutions. Hope it will help to solve this bug.

Affects me too...

My video card is a 9800 GT XFX on 1920X1080 23' Screen. When this ugly bug will be fixed?

I tried the http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml solution and not work for me...

XFACT (avinandan) wrote :

Recently at a Softpedia blog I read about the solution, which works fine with nice glossy view!
http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

But at last I would like it more if Canonical itself solves this resolution issue :)

@Rafael Passos de Oliveira
same for me with native 1920x1080 on 22'. best that works for me is 1280x1024x24 with the softpedia method. also to show it properly centered I need manualy change the horizontal position while booting.

Julian Alarcon (alarconj) wrote :

On Fri, May 7, 2010 at 7:05 AM, Tomas Šaduikis <email address hidden> wrote:
> @Rafael Passos de Oliveira
> same for me with native 1920x1080 on 22'. best that works for me is 1280x1024x24 with the softpedia method. also to show it properly centered I need manualy change the horizontal position while booting.
>
> --
> ubuntu-logo on VGA fb (as with nvidia or fglrx binary drivers) does not display crisply
> https://bugs.launchpad.net/bugs/551013
> You received this bug notification because you are a direct subscriber
> of the bug.
>

TTY's are still working after this workaround?

ermmm. I don't know, never checked it. how to check it?

ctrl+alt+F1 and so on work good

@Tomas Šaduikis

Eu tentei um monte de resoluções mas nenhuma delas ficou boa, todas a logo do 10.04 não aparecia e as letras UBUNTU 10.04 ficavam defeituosas. :(

@Julián Alarcón

It did not work for me. The TTY is all bad, you can not see anything on the screen. But I do not use it much, I am a new user of Ubuntu, just four months.

I changed the configuration file for grub and I can not return to normal. At startup is not appearing anything, just some distorted images and goes straight to the login screen.

In Karmic Koala had no such problems.

PS: Have you noticed that when starting at 10:04 LiveCD splash screen is perfect? Even at 1920x1080 resolution on my monitor 23 '.

Ernesto Gutierrez (ernesto-g3) wrote :

I tried the http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml solution and it worked for me =D

But I must say, the default ubuntu driver was able to display plymouth at a higher resolution (it seemed like 1920x1200) than the measly 1280x1020 that this fix provides. But still it works ^_^

Sorry, Rafael I dont understand your language, I'm lithuanian ;)
theres no need to use the softpedia method if you have 1280x1024 or less monitor. all you have to do is this:
GRUB_GFXMODE=1280x1024
GRUB_GFXPAYLOAD_LINUX=1280x1024
I use it on my 1920x1080 monitor and it looks quite good. the TTY's also look good.

also to show it longer it's needed to add FRAMEBUFFER=y to /etc/initrams-tools/conf.d/splash
then:
sudo update-grub2
and:
sudo update-initramfs -u

@Tomas Šaduikis

Sorry man, i type and forgot to translate to english... but i said:

I tried a lot of resolutions but none of them was good in all, the logo of 10:04 did not show up correctly and the displayed text (UBUNTU 10.04) were defective. : (

Yesterday I reinstalled the system and started to ignore the screen that is now appearing for a few seconds. :D

Thanks.

Byrtax (lanonyma) on 2010-05-11
Changed in plymouth (Ubuntu):
status: Fix Released → Fix Committed
Changed in plymouth (Ubuntu):
assignee: Scott James Remnant (scott) → nobody
Steve Langasek (vorlon) on 2010-05-11
Changed in plymouth (Ubuntu):
status: Fix Committed → Fix Released
Ernesto Gutierrez (ernesto-g3) wrote :

Steve, does this mean there is no need to use the softpedia solution (http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml) anymore? NVIDIA cards now work dandy with plymouth?

Steve Langasek (vorlon) wrote :

It mans this is not the right place to track whatever remaining issues you're having with nvidia cards.

Shaikailash (steve-doc-brown) wrote :

The fix didn't fix fully the problem on kubuntu 10.04 64bit. Now the screen is at 1024*768 (or something similar), but it still ugly on a 1440*900 panel for example.
I think that manual workaround cannot be considered a solution for the mass public, which can fix it only through an official update from the ubuntu repo. Is something more coming or that's all?

I didn't get any fix. there's nothing in the updares.

i don't know how to actually status should be but for me this "fix" didn't help

Changed in plymouth (Ubuntu):
status: Fix Released → Invalid
Steve Langasek (vorlon) on 2010-05-17
Changed in plymouth (Ubuntu):
status: Invalid → Fix Released
Changed in plymouth (Ubuntu):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) on 2010-08-13
Changed in plymouth (Ubuntu):
status: Fix Committed → Fix Released
DjznBR (djzn-br) wrote :

The Softpedia workaround fix worked for me.

Don't know *WHY* this is marked as Fix Released.

I have 10.04.1 from a fresh install and updates done, and this bug was still coming up.
(The remaster for 10.04.1 was released days after this fix).

Steve Langasek (vorlon) wrote :

This bug report tracks the *color map* issues when displaying on a VGA framebuffer. That issue has been fixed. The size of the logo is a different issue, tracked as a separate bug (bug #563878)

Dart (dragoon-master-10) wrote :

Im not sure what "Fixed" is meant to look like. :(

I found a nice Windows 7 Plymouth screen and it simply looks like a huge eyesore with 4-bit color.

I haven't tried the Softpedia workaround yet...lil hesitant, don't want to break anything. Cant it be included in 10.10?

Hans-Peter (hanspeterg) wrote :

I'm on 10.10 and I am using the proprietary fglrx driver for my Radeon3100. I have an ugly splash screen, ugly boot messages and ugly console screens. So nothing happened, as far as I can see, to this in Meerkat. I've tried modifying /etc/default/grub setting GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX. Modifying GRUB_GFXMODE changes the grub boot menu, GRUB_GFXPAYLOAD_LINUX doesnt have any effect.

wavded (wavded) wrote :

IMO this isn't fixed until the resolutions can match up, I get a flickery purple screen with text on 10.10. This is not a good user experience. I don't see why users should be punished for having good graphics cards when my wife's ubuntu has a generic Intel based and it looks great. Windows 7 looks sharp, and streamlined, Ubuntu can do better, this is the first impressions!

jp.seixas (joaopseixas) wrote :

The workaround works fine with Kubuntu Maverick Meerkat (10.10). I just can't understand why there's no fix if a workaround is already out, so, the problem AND solution is already known.

When I try to show Kubuntu (or Ubuntu) to a Windows user, the first thing they notice is the UGLY boot... :(

Buddha001 (ndrego) wrote :

The softpedia workaround works for me using proprietary Nvidia drivers, BUT when I hibernate my machine, it won't come resume - it just hangs. Not sure if this reported as another bug or not, but some googling has indicated that using uvesafb with the proprietary nvidia drivers can cause hibernate/resume problems. Is there any workaround for this?

isatis39871 (isatis39871) wrote :

The problem remains in
11.04.

This problem also persists in Ubuntu 11.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers