plymouth: after installing proprietary nvidia driver, splash screen displays in low color/low resolution mode

Bug #553854 reported by Jason S. Wagner
454
This bug affects 100 people
Affects Status Importance Assigned to Milestone
Plymouth
New
Undecided
Unassigned
plymouth (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by jp.seixas
Nominated for Maverick by jp.seixas

Bug Description

Binary package hint: plymouth

While using the 'nouveau' driver during live CD installation, or after installation, plymouth displays the very pretty rebranded ubuntu logo at my native resolution, and supports a clean transition into the gdm logon screen.

As soon as I install the proprietary NVIDIA driver (I only tested with "(version current) [Recommended]", this is 190 or 195, I believe, I'm sure the logs will indicate), plymouth displays the Ubuntu logo in what appears to be a 256-color mode, the resolution appears to be 640x480.

I'm not sure how to troubleshoot this further, so if this isn't immediately clear or a duplicate, you may need to provide detailed instructions if you need additional information from me.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: plymouth 0.8.1-4
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Apr 2 00:54:54 2010
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
EcryptfsInUse: Yes
InstallationMedia:

MachineType: MSI MS-7586
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=ec7de000-c474-4930-b0b5-4c8a7f6b384a ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcFB: 0 VGA16 VGA
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 07/28/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.0
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P55-CD53 (MS-7586)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.0:bd07/28/2009:svnMSI:pnMS-7586:pvr1.0:rvnMSI:rnP55-CD53(MS-7586):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7586
dmi.product.version: 1.0
dmi.sys.vendor: MSI

Revision history for this message
Jason S. Wagner (jasonswagner) wrote :
Revision history for this message
Jeff Joker (jeffjoker) wrote :

I have the same experience and know at least 3 people who encountered the same thing, we all have different hardware.
The work around found is either editing the config file myself or use startup-manager to patch the boot resolution.
But I definitely think this should be patched.

Revision history for this message
Jason S. Wagner (jasonswagner) wrote :

This bug is about plymouth being unable to determine the correct native resolution when using proprietary display drivers.

I removed the reference to bug #551013, which is poor display quality of the logo in 16colors (now resolved).

Revision history for this message
Jason S. Wagner (jasonswagner) wrote :

Can anyone with ATI hardware, using the proprietary ATI driver please attempt to reproduce the issue and post the results.

Revision history for this message
Jason S. Wagner (jasonswagner) wrote :

Apparently, this workaround is resolving the issue for some users (linked below). I haven't had time to test this. Perhaps this could be investigated and used towards developing a solution. (LaunchPad user idyllic claims to have devised this solution - https://launchpad.net/~idyllic)

http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

Revision history for this message
Marius Nestor (marius-nestor) wrote :

I agree with Jason here... and the WHOLE fault is Canonical's... they should NOT have adopted Plymouth in the first place if they knew this...

"For nVidia and ATI users, the default "nouveau" and "radeon" drivers are Kernel Mode Setting enabled, but do not always
provide 3D capability at the current time. By switching to using the restricted/non-free nvidia-glx or fglrx drivers, you will gain 3D capability at the loss of a high-color splash screen."

That's the problem! And the above temporary fix, apparently invented by idyllic, is a good workaround. People can live with this... as it is much better than that ugly ... thing. Softpedia's tutorial was created for Linux beginners, based on documentation found on Ubuntu forums! See here for example http://ohioloco.ubuntuforums.org/showthread.php?p=9127493

Revision history for this message
Robert Bredereck (rbredereck) wrote :

Well, I think this bug is not so critical and fixing it is not very important (there are more important ones).
However, I'm wondering why it is possible that whether the package maintainer nor anyone of the testing crew noticed it?

Are nvidia or ati cards so rare or are the proprietary drivers also completely untested? (I don't think so: they are working much better than in some other distributions.)

I don't want to offend someone. I really like you work very much, but I'm just very very confused how such things can happen.. Now, it is much harder to convince anyone of the quality of Ubuntu. Those things are not ignored by ordinary people, especially if I show "unlocking my encrypted root partition".. It looks like an MS-DOS VGA program with corrupted fonts.. sorry.

Revision history for this message
Nicolas Gorguès (gorni-siloh) wrote :

Another (shorter) workaround suggests to set the native screen resolution as GRUB_GFXPAYLOAD_LINUX in /etc/default/grub:
http://ubuntuforums.org/showthread.php?t=1469475

It wasn't sufficient for me however, and I had to follow the whole process at http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml to eventually fix the problem (with nVidia ION hardware / nvidia-glx)

Even if only cosmetic, I find this bug rather problematic: indeed, the crippled logo is the first thing a user will see when powering up his system, and the last when powering down, setting the mood for the whole experience...

Revision history for this message
griffinpeterson (griffinpeterson) wrote :

Following fix worked perfectly for me:
http://idyllictux.wordpress.com/2010/04/26/lucidubuntu-10-04-high-resolution-plymouth-virtual-terminal-for-atinvidia-cards-with-proprietaryrestricted-driver/
I think it's the same as the one from softpedia. Now my boot splash is in 1024x768, as this was the highest resolution shown by hwinfo --framebuffer. My native resolution would be 1280x800, but still it's much better than before.
I attach my dmesg.txt hoping it will be helpful. I have an asus a6m notebook with a nvidia geforce go 6100 graphic card and ubuntu lucid amd64.
The other stuff like gfx_payload=keep or so didn't work for me at all.

Revision history for this message
eoepandorra (eoepandorra) wrote :

I have an ATI video card, and it is the same result. I think that this bug should be fixed automatically. It is a good tutorial but some users cannot feel confident enough to manipulate system files.

Thanks

Revision history for this message
axelsvag (darinsson) wrote :

I have the same problem as the rest of you on a nvidia 8200M. I tried the suggested workaround. The first time the logo went from big and ugly to super big and super ugly. I tried to get back but now the logo is gone completely though the grub menu gets nice and in high resolution./etc/default/grub

Revision history for this message
jp.seixas (joaopseixas) wrote :

The workaround works fine with Kubuntu Maverick Meerkat (10.10). I just can't understand why there's no fix if a workaround is already out, so, the problem AND solution is already known.

When I try to show Kubuntu (or Ubuntu) to a Windows user, the first thing they notice is the UGLY boot... :(

Changed in plymouth (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers