Pressing <Enter> causes X to freeze

Bug #516412 reported by Zaphod on 2010-02-03
550
This bug affects 102 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Unassigned
Declined for Dapper by Steve Langasek
Declined for Hardy by Steve Langasek
Declined for Intrepid by Steve Langasek
Declined for Jaunty by Steve Langasek
Declined for Karmic by Steve Langasek
Nominated for Lucid by ROB3RT

Bug Description

Binary package hint: plymouth

I am running ubuntu 10.04 Alpha2 and after last nights updates pressing the enter key causes the whole system to freeze and I have to hard reboot.

Only removing Plymouth would allow me to work normally.

The system still respond to ssh.

WORKAROUND (thanks to Simon Baconnais): kill X by pressing Ctrl+Alt+Print+K fixes the problem until the next reboot.

Related branches

Harry (harry33) wrote :

This is true.
I have Nvidia graphic card (285 GTX) and 64-bit Lucid-alpha2.
This makes using terminal impossible.
As a workaround one has to downgrade the packages "plymouth" and "libplymouth2" back to the version 0.8.0~-7

So just download the packages (64-bit lucid) from:
https://edge.launchpad.net/ubuntu/lucid/amd64?text=plymouth
and then reboot to recovery mode, drop to terminal, go to the directory where you downloaded packages, then run:
dpkg -i plymouth_0.8.0~-7_amd64.deb libplymouth2_0.8.0~-7_amd64.deb
and reboot.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Alfredas Beinartas (fuxialis) wrote :

Same here. Nvidia 7900 GS ant 64-bit Lucid-alpha2. System seems completely frozen but reboots with Alt+SysRq+b. So maybe it is only graphics problem. Temporareliy solved this problem by removing Plymouth.

Harry (harry33) wrote :

This bug does not seem to affect 32-bit installations. At least those with ATI cards.
I tested this with 32-bit Lucid-alpha2 in a laptop with ATI Mobility Radeon 9700.

Mike (bild85) wrote :

Happens for me using 32-bit w/nvidia on a Latitude D630. It's as if the Enter key was remapped to a "system freeze" function. I can log in and do many tasks using the mouse to click through confirmation dialogs, but as soon as I hit the Enter key, be it at the terminal or to press a highlighted button, the system freezes and cannot be recovered. Only holding down the power button will power it off (I did not try the alt-sysRq+b sequence.)
Removed the "plymouth" package through aptitude in the recovery console and now it's fine.

$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 135M (rev a1)

$ uname -a
Linux hostname 2.6.32-12-generic #16-Ubuntu SMP Wed Jan 27 18:34:19 UTC 2010 i686 GNU/Linux

Zaphod (vilppu777) wrote :

I also have an nvidia card. I think it is effecting nvidia users only.

ROB3RT (rob3rt) wrote :

I concur that it is only NVIDIA cards. I have an NVIDIA 9600M GT, and it happens to me too. Hopefully this can be resolved ASAP.

Anton Kraus (done) wrote :

Uninstalling plymouth made the bug disappear.

Two related bugs disappeared as well:
1) I'm no longer experiencing graphical corruption (flickering pixels) along the top edge of the screen.
2) Previously, when GDM came up on my Nvidia Twinview setup (two monitors), only the primary screen would work, whereas the secondary monitor just gave me an "out of range" message. The workaround was a quick switch to a TTY and back again. With Plymouth gone, both screens now work immediately.

Should I file separate bugs?

My graphics card is an Nvidia GeForce 6600LE.

Hernando Torque (htorque) wrote :

Nvidia 6600 GT/BLOB/32-bit: for me the enter key just kills X, after logging in again everything works fine. I remember reading somewhere that starting Plymouth in text mode while having X running will crash X - maybe that's connected?

Hernando Torque (htorque) wrote :

Happens also with a Go 7600/Nouveau/32-bit with KMS enabled.

Alfredas Beinartas (fuxialis) wrote :

Just updated to latest NVIDIA beta drver 195.36.03. Thought maybe it is a driver problem. Same hang. Tried nv driver. The same. Bug is definitely connected to NVIDIA hardware in spite of architecture or driver.

Aron Xu (happyaron) wrote :

I have this problem with my Nvidia 8500GT card with x86_64 Lucid installed, plymouth version 0.8.0-~8.

YunQiang Su (wzssyqa) wrote :

it effect me.too.
i am using lucid amd64,and geforce 8600m gs,with nvidia's 195.30 driver.

but,i seem not only press enter key,and using mouse.

Simon Baconnais (smon) wrote :

Same thing here with lucid amd64 and Intel Corporation Mobile 945GM/GMS

ROB3RT (rob3rt) wrote :

Yes, the flickering pixels have also come up for me too, and are extremely annoying. I believe that this bug should be marked High importance.

christian (chmathieu) wrote :

I have the same bug with ATI 9550.

Simon Baconnais (smon) wrote :

Upgrades this morning have solved the problem :)

Hernando Torque (htorque) wrote :

I still can reproduce it.

Elfy (elfy) wrote :

Still an issue here for me

Simon Baconnais (smon) wrote :

Okay, i think i have a solution !

Actually, this morning xserver-xorg-video-intel have been upgraded and it have solved the problem.

But a few minutes ago i had a new plymouth upgrade that brought back the problem.

So I tried to reinstall xserver-xorg-video-intel, and it solved the problem.

I think that plymouth upgrades just break the xorg conf (or something like that), but an aptitude reinstall xserver-xorg-video-intel (or ati, or nv, etc.) can fix it :)

Simon Baconnais (smon) on 2010-02-06
Changed in plymouth (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
phillamg (me-phillg) wrote :

I'm running an AMD64 system with a NVidia card and I managed to get things working again (without a reboot) by re-installing xserver-common, xserver-xorg-core, xserver-xorg-video-intel and nvidia-current through GDebi (used nautilus to go to /var/cache/apt/archives). Hope that helps someone else, sorry I didn't have time to narrow it down to just one package!

Elfy (elfy) wrote :

Updated and reinstall of plymouth and all is well here now. No re-installing of any other packages were necessary for me

Harry (harry33) wrote :

Jannis, actually the Arch-linux Gnome problem is a different issue, nothing to do with plymouth.

Those having a Nvidia graphics card really should use Nvidia proprietary drivers (nvidia-current).
And in fact what plymouth is for the time being, it is pretty useless with Nvidia.
I think it is better to remove the package plymouth from lucid, the problems will disappear.
Then you can upgrade the package libplymouth2.
I also have found out that plymouth slows down the boot process and shutdown process in lucid.

Hernando Torque (htorque) wrote :

I can confirm that reinstalling the video driver works, whereas reinstalling Plymouth didn't change a thing.

summary: - Pressing <Enter> causes the system to freeze
+ Pressing <Enter> causes X to freeze
description: updated
Fred (ian-bews) wrote :

AMD64 with 7900GT GX2

Tried reinstalling xserver-xorg-video-nv -still freezes on enter.

Tried reinstalling plymouth -still freezes on enter.

What's with plymouth on nvidia anyway? I haven't seen a lucid splash screen on this machine ever :-(

phenest (steve-clark) wrote :

nVidia 7950GTX here. Removing plymouth fixed it.

Eddie Ringle (eddie.ringle) wrote :

I started experiencing the problem a few minutes ago when I upgraded Plymouth to 0.8.0~-9.
I removed it, rebooted, and it fixed the problem.

Good riddance, my boot-up is faster without it.

Fred (ian-bews) wrote :

Removed Plymouth (was using 0.8.0~-9) and I can now press enter again.

Steve Langasek (vorlon) on 2010-02-06
Changed in plymouth (Ubuntu):
importance: Undecided → High
Yann Dìnendal (yannbreliere) wrote :

Hi, I have the same problem. I also have an NVidia card (and plymouth has never shown me any graphical boot).

But I have noticed something else : if I type the key « (or maybe any other unicod character, I haven't tried), it would crash my gnome session and return to GDM. I believed it was not the same problem at all… But once I do that and my session crashes, I can then type ENTER or the "«" key without any problem !

I would gladly give more details or try some tests if it could help.

Yann Dìnendal (yannbreliere) wrote :

Oh, There might be a confirmation of what I was saying on duplicate bug #516807 :

> The computer automatically randomly logged me out, and it no longer crashes when hitting enter. IT only crashes when hitting enter after startup. Very weird...

yankeeboy254, did you noticed if you were logged out after typing some particular character?

ROB3RT (rob3rt) wrote :

As a matter of fact, any time I press SHIFT + 2, for the @ symbol when signing into my email, it does log me out. Then, when I log back in, it doesn't happen any more... It is very, very strange, but it only happens sometimes when I press SHIFT + 2, AKA @. This is the strangest bug I've ever seen...

I'd also like to suggest that this be moved up to critical, as it affects many people (30). I'm not sure how many people the bug needs to be affected by for it to be critical, but this is one heckuva important bug.

Anyone know what exactly Plymouth is doing to cause this? It has something to do, with Plymouth, and the NVIDIA drivers... I'm not sure how they relate, but all I know is that I can't successfully reboot, or shut down until this is fixed... Hard boots are bad for your HDD, so I hope this gets resolved ASAP!

Steve Langasek (vorlon) wrote :

My current understanding is that this is likely to be a side effect of broken VT switching code in plymouth, an issue that we're expecting to receive an upstream fix for later this month.

ROB3RT (rob3rt) wrote :

Wow... This is the strangest bug I've ever seen. I've never seen anything as simple as this, cause such a big issue. I also hope to see improved NVIDIA drivers which are... Not decent... I also really want to see improved Flash support, because in Karmic we took a step forward, and now we've taken 2 steps back... Something I assume will be improved in the final releases.

And, for the record. THIS is why I love open source. If this happened in Windows, we wouldn't see a fix for this until the Fall.

Simon Baconnais (smon) wrote :

Ok, my bad ...

Reinstalling xserver-xorg-video-* doesn't fix this bug :P

But, in my case, killing X by Ctrl+Alt+Print+K fix the problem until the next reboot.

Hop it will help you ...

+1 ... removing plymouth has helped.

But not just to waste digital space I have to add, that I saw graphical boot with Nvidia graphic card. It was working for about 2 days on lucid (daily updated) and what I can recall is that it was between nuoveau and lbm?-nuoveau (real module name, not alias) was put on blacklist. But cannot find that text in plymouth changelist - was it another package?

shankao (shankao) on 2010-02-07
description: updated
ROB3RT (rob3rt) wrote :

Hey, I think I have a solution. Temporarily at least, as the other one doesn't work for me. Anytime I type in a number (1-9), into anything, such as a search bar, I am auto-logged out. Then, I log back in, and it is fine! It doesn't work all the time, but I'm going to do some more testing with it to see if I can get exact specs.

ROB3RT (rob3rt) wrote :

I HAVE DONE IT!!! I have found a permanent temporary solution! Okay, as soon as you boot up, go into firefox or anything with a search bar. I use my dictionary search bar that I have on my top panel. Then, just click on the search bar, and press 2. You will be logged out. Just log back in, and the problem is solved! I don't know if it will work for anyone else, but it works great for me! I suggest doing it as soon as you boot up. Can somebody else try this and see if it works. As soon as you press 2 into the search bar, you should be auto-logged out, so do this as soon as you boot up, so you don't lose any work.

Harry (harry33) wrote :

Yankeeboy254,
I would not call that a solution.
A solution is to remove the package plymouth until it is fixed.
See post #32 of Steve Langasek.

Harry (harry33) wrote :

It seems this is quite a big and widely affecting nasty bug.
With NVidia you get the <enter> freeze, not much more,
but with Intel and ATI you get freeze during boot etc. and that one is reported here:
https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/510524

Steve Langasek (vorlon) wrote :

The vast majority of Intel users are not seeing such freezes. And bug #510524 discusses Intel only, not ATI; anyone seeing problems on ATI video should open a separate bug report.

shankao (shankao) on 2010-02-09
tags: added: lucid
removed: 10.04
Changed in plymouth (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
Simon Baconnais (smon) on 2010-02-12
Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed
Steve Langasek (vorlon) on 2010-02-12
Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
64 comments hidden view all 144 comments
Sense Egbert Hofstede (sense) wrote :

shankao: Yes, that does sound like the best option, especially considering the enormous mess this bug report has become.

00raq00 (00raq00) on 2010-02-12
Changed in plymouth (Ubuntu):
assignee: nobody → 00raq00 (00raq00)
status: Fix Released → Incomplete
Sense Egbert Hofstede (sense) wrote :

Please don't change the status without providing a reason and please don't subscribe yourself if you're not the one working on the bug.

Changed in plymouth (Ubuntu):
assignee: 00raq00 (00raq00) → nobody
status: Incomplete → Fix Released
00raq00 (00raq00) wrote :

Problem is still in plymouth, remove only works....

Matt Joiner (anacrolix) wrote :

Currently running libplymouth and plymouth 0.8.0~-10 and still crashes at X.

Simon Baconnais (smon) wrote :

Problem remains

Simon Baconnais (smon) wrote :

By the way, the original bug submitter say that the bug isn't fixed. So Steve Langasek surely fixed a bug, but not the good one ...

First of all, sorry for my bad english.

I discovered various things.

1 - Press Enter key don't cause more crashes after our session log out automatically or we manualy logout the first login since boot and re-log in same account.

2 - There it a random time to session logout without do anything. After that no problem with pressing Enter key.

Theo Nolte (theo-nolte) wrote :

For me the behavior has changed now since Steves fix. Previously pressing ENTER caused X to freeze, now gdm is frozen from the start, I can't even move the mouse or enter a password. As previous, Alt-Print-K restarts X and fixes it.

1. I use lucid 64 bit with Nvidia GeForce 9300M G with binary drivers (nvidia-current)

2. I see no logo

3. I see blue and white bars at bottom of screen

4. The bars disappear when the spinning cursor appears

5. $ cat /proc/fb
    0 VGA16 VGA

6. $ ps aw | grep X.*vt
 1732 tty7 Rs+ 0:16 /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-4h7UJ8/database -nolisten tcp vt7

7.
dpkg -l plymouth libplymouth2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii libplymouth2 0.8.0~-10 graphical boot animation and logger - shared
ii plymouth 0.8.0~-10 graphical boot animation and logger - main p

Hope that helps.

ROB3RT (rob3rt) wrote :

Hey, what worked for me was:
Reboot into safe mode.
Sudo apt-get remove Plymouth
Reboot
Reinstall Plymouth

What it did:
No more Fscks at boot.
No more crashes when pressing ENTER. It seems like this bug still affects some people, which means that there should probably be a seperate bug report, to see why this is still going on.

00raq00 (00raq00) wrote :

git clone git://anongit.freedesktop.org/plymouth

Next configure and compile it:

> cd plymouth
> ./autogen.sh --prefix=/usr/ --with-system-root-install
> make
> make install

it resolve problem :) but i'm waiting for .get from repository

Ari Torhamo (ari-torhamo) wrote :

I was affected by this bug. Pressing Enter at any time forward from the login screen froze the system. No Ubuntu logo was visible during the boot, but there was a blue and white progress bar at the bottom of the screen.

Removing plymouth fixed the bug (removed it in Synaptic, not in safe mode)
- reinstalling plymouth brought the problem back
- removed plymouth again, and the bug is now gone
(removing plymouth made the system freeze at shut down - had to reset)

System:
Ubuntu Lucid daily live of 13.2.2009
AMD 64 bit
Nvidia Geforce 8800 GT with binary driver

Simon Baconnais (smon) wrote :

I still affected by this bug.

Anthony Hook (anthonyhook) wrote :

As a normal user, not a bug-patcher, etc, this is what I see:

When I press 'Enter,' X Freezes. It still happens with the latest Plymouth. As far as I know, this bug isn't fixed.

Occasionally when I try to switch to a TTY to log in before I log into GDM (which then allows me to use 'Enter' properly), I get the attached screenshot which leaves me having to hard-power down my laptop.

Harry (harry33) wrote :

I can confirm the bug is not fixed yet.
Still affected by this in a fully updated lucid_amd64, NVidia GLX285, driver: nvidia-current.

Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed
UGN (eugene-korneev) wrote :

i have same issue on my asus eee pc 701 and last lucid,
after boot and autologon my system ican wait some time and X crush, and\or press "2" (not "enter") X restarts and i can logon into systen (not auto) and continue wotrk...

Sense Egbert Hofstede (sense) wrote :

Guys, please read the comments on this bug. This has become such a mess that it is undoable to continue to use this bug report to track this symptom. What's more, the developer indicated several times that the cause for this particular bug has already been found and eliminated.

Please do not change the status of this bug again.

Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
shankao (shankao) wrote :

I have just added the bug report #522692 for those still affected by similar symptoms. Let's try to solve it there.

Benny Källström (benny-k) wrote :

I agree, this bug is a mess.

Casey J Peter (caseyjp1) wrote :

As of this morning's updates, I will add that on my amd64 x2 rig with 190.xx nvidia drivers, this is still an issue.
alt+printscrn+k restarts gdm and no further issues until the next reboot. I've added "affects me" to the 522692 bug report as well. this isn't resolved, at least for the prop. nvidia folks.

Mio (m10) on 2010-02-18
Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed
Mio (m10) on 2010-02-18
Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
tsm124 (tsm1248) wrote :

Release the update in the update manager...

Joel Ebel (jbebel) on 2010-02-18
tags: added: glucid
jan.san@libero.it (jan-san) wrote :

Installed all the updates, still affected

This issue seems really similar to one that appeared las year, and was
caused by starting Xorg and a VT on the same console.
Can a developer check?

Comment #125

Changed in plymouth (Ubuntu):
status: Fix Released → Confirmed
Andrew Gee (andrewgee) wrote :

Nicolò,

I think that's the problem I'm having, as I get a blank terminal with a flashing cursor, over the login window, until I switch to another tty and back.

Steve Langasek (vorlon) on 2010-02-19
Changed in plymouth (Ubuntu):
status: Confirmed → Fix Released
Paolo Sammicheli (xdatap1) wrote :

Hello,

During Xorg Team Alpha testing, 22 Feb Image changed behaviour. Now pressing enter, X did Crash and it fall back to GDM login. It's a step ahead indeed :)

http://xorg.qa.ubuntu.com/qatracker/result/3603/419

Marco Simonelli (sumydi) wrote :

Il 22/02/2010 21:41, Paolo Sammicheli ha scritto:
> Hello,
>
> During Xorg Team Alpha testing, 22 Feb Image changed behaviour. Now
> pressing enter, X did Crash and it fall back to GDM login. It's a step
> ahead indeed :)
>
> http://xorg.qa.ubuntu.com/qatracker/result/3603/419
>
>
I had the same behaviour with plymouth 0.8.0~-10ubuntu1, now I removed
it. I use nvidia-current blob but no splash, only text.

--
Marco Simonelli

Please open a new bug.
This was fixed and no (quite) one looks here :)

On Tue, Feb 23, 2010 at 07:54, Marco Simonelli <email address hidden> wrote:

> Il 22/02/2010 21:41, Paolo Sammicheli ha scritto:
> > Hello,
> >
> > During Xorg Team Alpha testing, 22 Feb Image changed behaviour. Now
> > pressing enter, X did Crash and it fall back to GDM login. It's a step
> > ahead indeed :)
> >
> > http://xorg.qa.ubuntu.com/qatracker/result/3603/419
> >
> >
> I had the same behaviour with plymouth 0.8.0~-10ubuntu1, now I removed
> it. I use nvidia-current blob but no splash, only text.
>
> --
> Marco Simonelli
>
> --
> Pressing <Enter> causes X to freeze
> https://bugs.launchpad.net/bugs/516412
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: plymouth
>
> I am running ubuntu 10.04 Alpha2 and after last nights updates pressing the
> enter key causes the whole system to freeze and I have to hard reboot.
>
> Only removing Plymouth would allow me to work normally.
>
> The system still respond to ssh.
>
> WORKAROUND (thanks to Simon Baconnais): kill X by pressing Ctrl+Alt+Print+K
> fixes the problem until the next reboot.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/516412/+subscribe
>

shankao (shankao) wrote :

It's open as bug #522692 (see comment #121)

MJ (mjjaa) wrote :

Hey,

i have a similar problem, when I press enter, Gnome crashes and goes back to the login screen, when I login now and press enter again this error does not occur. I have auto login switched on and I am using Alpha 3

Sense Egbert Hofstede (sense) wrote :

MJ: I think you're having bug #522692.

burivoy (burivoy) wrote :

Bull sheet no fix release has been released yet.

I have installed Lucid on HP Pavilion zv5000 with ATI Mobility Radeon(TM) 9000 IGP. Ufter update of this bloody plymouth I never started X. After pressing Enter I hear the login sound and cursor appers but that is all. Nothing helped - neither uninstalling plymouth nor reinstalling xorg. Developers should test such a things on different graphic cards prior to send it to repo.

Sense Egbert Hofstede (sense) wrote :

burivoy: Please read the previous comments. As the developer indicated that this specific bug was fixed. There might be other bugs with the same symptoms, but they are different bugs. Maybe you're using different hardware than the original reporter. Furthermore, the fact that removing Plymouth doesn't solve the issue for you is another indication that you're suffering from a different bug, most likely in GDM.

About the testing: if you could provide the developers with the hardware and the time for testing new packages that extensively, then we'd be happy to do more extensive testing. Otherwise, please consider reinforcing the testing team, which can use some help as well.

Please also mind your language.

>
> Developers should test such a things on different
> graphic cards prior to send it to repo
>
Also, what did you expect from a _development_ release?

On Tue, Mar 2, 2010 at 17:29, Sense Hofstede <email address hidden> wrote:

> burivoy: Please read the previous comments. As the developer indicated
> that this specific bug was fixed. There might be other bugs with the
> same symptoms, but they are different bugs. Maybe you're using different
> hardware than the original reporter. Furthermore, the fact that removing
> Plymouth doesn't solve the issue for you is another indication that
> you're suffering from a different bug, most likely in GDM.
>
> About the testing: if you could provide the developers with the hardware
> and the time for testing new packages that extensively, then we'd be
> happy to do more extensive testing. Otherwise, please consider
> reinforcing the testing team, which can use some help as well.
>
> Please also mind your language.
>
> --
> Pressing <Enter> causes X to freeze
> https://bugs.launchpad.net/bugs/516412
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: plymouth
>
> I am running ubuntu 10.04 Alpha2 and after last nights updates pressing the
> enter key causes the whole system to freeze and I have to hard reboot.
>
> Only removing Plymouth would allow me to work normally.
>
> The system still respond to ssh.
>
> WORKAROUND (thanks to Simon Baconnais): kill X by pressing Ctrl+Alt+Print+K
> fixes the problem until the next reboot.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/516412/+subscribe
>

burivoy (burivoy) wrote :

Does not fucking work on HP Pavioin zv5000 and ATI Mobility Radeon 9000 IGP.

Anthony Hook (anthonyhook) wrote :

That language is unacceptable in the Ubuntu Community, as you were already previously informed. Please review the Code of Conduct http://launchpad.net/codeofconduct/1.1 and http://www.ubuntu.com/community/conduct before you decide to post again.

Most of us are volunteers and this type of behavior is unacceptable.

Matthieu Baerts (matttbe) wrote :

I agree with Anthony Hook !

 > "Most of us are volunteers and this type of behavior is unacceptable."

If you don't like Plymouth, simply uninstall it... Or if you didn't like Ubuntu and its Code of Conduct, there are other solutions !

Even if I agree with you on the language matter, I must point out a thing:

root@Jarvis:~# apt-get remove plymouth
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più
richiesti:
  linux-backports-modules-nouveau-2.6.32-14-generic db4.6-util libbttracker0
  libbtutil0 libmcrypt4 libapache2-mod-bt libdb4.6
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno RIMOSSI:
  cryptsetup plymouth plymouth-x11
0 aggiornati, 0 installati, 3 da rimuovere e 0 non aggiornati.
Dopo quest'operazione, verranno liberati 2269kB di spazio su disco.
Continuare [S/n]? n
Interrotto.

I need cryptsetup and I cannot remove it without being unable to use my
system

On Wed, Mar 3, 2010 at 00:51, Matthieu Baerts <email address hidden> wrote:

> I agree with Anthony Hook !
>
> > "Most of us are volunteers and this type of behavior is
> unacceptable."
>
> If you don't like Plymouth, simply uninstall it... Or if you didn't like
> Ubuntu and its Code of Conduct, there are other solutions !
>
> --
> Pressing <Enter> causes X to freeze
> https://bugs.launchpad.net/bugs/516412
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “plymouth” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: plymouth
>
> I am running ubuntu 10.04 Alpha2 and after last nights updates pressing the
> enter key causes the whole system to freeze and I have to hard reboot.
>
> Only removing Plymouth would allow me to work normally.
>
> The system still respond to ssh.
>
> WORKAROUND (thanks to Simon Baconnais): kill X by pressing Ctrl+Alt+Print+K
> fixes the problem until the next reboot.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/516412/+subscribe
>

burivoy (burivoy) wrote :

I thought I would never see my Desktop again.

I'm seeing this on Oneiric (64-bit) with Xubuntu. I have a very repeatable test case:

1. Reboot.
2. Wait for autologin to occur.
3. Press enter on desktop.
4. X will crash, and I get dumped back to password prompt to login.
5. Then it works ok till I reboot again.

I tried the recommended suggestion of removing plymouth, but it isn't possible to do that in oneiric without removing the entire base-system.

Incidentally, I'm using a Lenovo S205 laptop, which has a radeon GPU but where I have NOT installed the binary driver, and the bootloader is grub-legacy (grub-2 won't work with EFI).

Steve Langasek (vorlon) wrote :

On Sat, Dec 17, 2011 at 05:28:03AM -0000, RichardNeill wrote:
> 1. Reboot.
> 2. Wait for autologin to occur.
> 3. Press enter on desktop.
> 4. X will crash, and I get dumped back to password prompt to login.
> 5. Then it works ok till I reboot again.

Do you have any custom init scripts or upstart jobs installed on this
system? If so, chances are that one of these is breaking the console
underneath X.

> I tried the recommended suggestion of removing plymouth, but it isn't
> possible to do that in oneiric without removing the entire base-system.

This is NOT recommended. This has only been recommended by people who have
no involvement with Ubuntu development. You are correct, plymouth is part
of the base system. This is not a bug and not an accident.

> Incidentally, I'm using a Lenovo S205 laptop, which has a radeon GPU but
> where I have NOT installed the binary driver, and the bootloader is
> grub-legacy (grub-2 won't work with EFI).

I expect this is entirely unrelated, but note that there is a grub-efi
package for grub2 EFI support.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Displaying first 40 and last 40 comments. View all 144 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers