Mobile broadband connections fail to connect

Bug #334122 reported by Jeffrey Seguerra on 2009-02-25
244
This bug affects 33 people
Affects Status Importance Assigned to Milestone
knetworkmanager
Fix Released
Medium
plasma-widget-networkmanagement (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by Patrick Callahan

Bug Description

Binary package hint: plasmoid-network-manager

I can't configure and connect using mobile broadband on Kubuntu Jaunty. I'm currently using Alpha 4.

Kubuntu detected my Huawei E220 fine just like in Intrepid bu I can't configure it.

Hope we can look in to this and implemented on Alpha 6 or Beta Release.

TuxFan (make) wrote :

I haven't got mobile broadband working either by using my mobile phone and USB cable in Alpha 5. The plasma-widget-network-manager detects the phone after plugging the phone in by showing (the kinda ugly) black and white phone image, but it never seems to even try to start connecting.

Jeffrey Seguerra (jepong) wrote :

yeah... the mobile broadband way too ugly...

Christiansen (happylinux) wrote :

I can confirm that connecting with Huawei E220 do not work for me too since the first plasmoid-network-manager (think it was the one released with Janty Alpha 3) was upgraded. Using the latest plasma-widget-network-manager-0.0+svn930811 on Kubuntu Janty Alpha 5, the fail according to the 'syslog', seeems to have changed from a serial baud rate misconfiguration to a timeout on PIN checking. I'm have disablede the PIN demand on the SIM card, and using it with Mythbuntu Janty 5 works okay. Using another another modem than Huawei fails too.

dyug (dyug) wrote :

first setup:

Mar 3 22:51:41 dyug-test NetworkManager: <info> Starting pppd connection
Mar 3 22:51:41 dyug-test NetworkManager: <debug> [1236113501.973826] nm_ppp_manager_start(): Command line: /usr/sbin/pppd nodetach lock nodefaultroute ttyACM0 noipdefault 103 noauth refuse-mschap-v2 nobsdcomp require-mppe mppe-stateful usepeerdns mru 7274540 mtu 120389742 lcp-echo-failure 5 lcp-echo-interval 30 ipparam /org/freedesktop/NetworkManager/PPP/0 plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so

mtu and mru -ERROR!

Started Nokia E65 Utel
work from gnome applet

lanzen (lanzen) wrote :

For a start I've been having all that has been reported here and now, though I have notices some improvments, I have the following.

My Hauwei e196 [E620] is recognized and appears in the applet as disconnected, but there is no way to get it to connect.

However, if I modify my broadband connection setting to auto start and the modem stick is in the usb sock from boot, one logged in my modem will connect. Unfortunately there's no way do disconnect.

OS: Kubuntu Jaunty beta updated.

TuxFan (make) on 2009-03-29
Changed in plasma-widget-network-manager:
status: New → Confirmed
TuxFan (make) wrote :

I am able to get mobile broadband working using wvdial, so this rules out the possibility that the bug would be somewhere deeper in the system.

Scott Abbey (malakhi) wrote :

Indeed, mobile broadband works just fine with Gnome's nm-applet. This is peculiar to plasma-widget-network-manager.

TuxFan (make) wrote :

This could however be a problem with network-manager-kde (AFAIK to be able to use Gnome's nm-applet you have to use network-manager-gnome). When I plug my phone in, I get the following in my daemon.log:

nm-system-settings: SCPlugin-Ifupdown: device added (udi: /org/freedesktop/Hal/devices usb_device_421_4ce_noserial_if0_0_serial_unknown_0_0, iface: (null)): iface not found
NetworkManager: <info> (ttyACM0): found serial port (udev:GSM hal:GSM)
NetworkManager: <info> (ttyACM0): new Modem device (driver: 'cdc_acm')
NetworkManager: <info> (ttyACM0): exported as /org/freedesktop/Hal/devicesusb_device_421_4ce_noserial_if0_0_serial_unknown_0_0
NetworkManager: <info> (ttyACM0): device state change: 1 -> 2
NetworkManager: <info> (ttyACM0): deactivating device (reason: 2).
NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
NetworkManager: <info> (ttyACM0): device state change: 2 -> 3

And after this, if I click the plasma widget, it says under Mobile Broadband "Serial Port Disconnected".

Christiansen (happylinux) wrote :

I'm not sure that knetworkmanager (KNM) and plasma-widget-network-manager (PWNM) has anything to do with each other - only that PWNM should become a more KDE4 like replacement for KNM.
If you uninstall PWNM by "apt-get remove plasma-widget-network-manager", you are able to start the old KNM from cli by executing "knetworkmanager". Running it and creating a new mobile connection witch works fine with my Huawei E220, and I can dis- and enable it as I wish. Of course you need to configure it manually, as the nice guide Ubuntu has isn't avalible in Kubuntu.

So still no luck with PLASMA-WIDGET-NETWORK-MANAGER and mobile devices in my up to date 9.04 Beta.

BTW I tried only to remove the PWNM applet from the panel not uninstalling it, and KNM did work this way too - I guess it do not occupy the DBus then, and thereby keeping KNM form using the same device.

Wong CS (lilwong) wrote :

Did some digging around and compared the plasma widget configuration files ($HOME/.kde/share/apps/networkmanagement/connections) and previous knetworkmanager configuration files ($HOME/.kde/share/config/knetworkmanagerrc).

The only obvious error in /var/log/daemon.log when trying to connect using my Huawei E220 mobile broadband modem is the following snippet:

--------------------------
Apr 13 02:44:59 ladyjaye NetworkManager: <info> (ttyUSB1): ignoring due to lack of mobile broadband capabilties
Apr 13 02:44:59 ladyjaye nm-system-settings: SCPlugin-Ifupdown: device added (udi: /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial_if0_serial_usb_0, iface: (null)): iface not found
Apr 13 02:44:59 ladyjaye NetworkManager: <info> (ttyUSB0): found serial port (udev:GSM hal:GSM)
Apr 13 02:44:59 ladyjaye NetworkManager: <info> (ttyUSB0): new Modem device (driver: 'option')
Apr 13 02:44:59 ladyjaye NetworkManager: <info> (ttyUSB0): exported as /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial_if0_serial_usb_0
Apr 13 02:45:04 ladyjaye NetworkManager: <info> (ttyUSB0): device state change: 1 -> 2
Apr 13 02:45:04 ladyjaye NetworkManager: <info> (ttyUSB0): deactivating device (reason: 2).
Apr 13 02:45:04 ladyjaye NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Apr 13 02:45:04 ladyjaye NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Apr 13 02:45:04 ladyjaye NetworkManager: <info> (ttyUSB0): device state change: 2 -> 3
--------------------------

Googling for the search term "nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed", I found the following page: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/289690

The findings in that page seems to indicate that the modem was not unlocked by NetworkManager using the correct PIN (or any PIN at all). So that led me to thinking maybe this same error is affecting the plasma widget.

Looking through my configuration file for my mobile broadband connection, I noticed that there the parameter for the PIN was defined in knetworkmanagerrc but was stored in kwallet instead for the plasma widget.

I'm wondering if it's possible that the plasma widget fails to submit the PIN information to NetworkManager to unlock the modem leading to this issue. I know that the maintainer of this package may not have the resources to test using mobile broadband modems but if this clue leads to something we'd be much happier for it :)

TuxFan (make) wrote :

I use my phone to get mobile broadband on my laptop, which means that the phone is already turned on when I plug it in via USB. So there is no need for even trying unlocking it, and I've never configured my PIN anywhere.

That of course doesn't mean that the widget wouldn't try unlocking the phone, and fail doing it...

But for now I'm happy with wvdial, which I got working automagicly with udev every time I plug the phone in. :)

Tuomas Aavikko (taavikko) wrote :

Also affected is Nokia 6500.

plamoid notifies that it's been plugged in, but connection to /dev/ttyACMO0 is disconnected.

Jeffrey Seguerra (jepong) wrote :

I'm using Kubuntu 9.04 RC and mobile broadband still not working specifically Huawei E220.

Tuomas Aavikko (taavikko) wrote :

Output of DMESG
[508944.244010] usb 4-2: new full speed USB device using uhci_hcd and address 5
[508944.416762] usb 4-2: configuration #1 chosen from 1 choice
[508948.976038] usb 4-2: USB disconnect, address 5
[508949.712013] usb 4-2: new full speed USB device using uhci_hcd and address 6
[508949.886490] usb 4-2: configuration #1 chosen from 1 choice
[508949.940538] cdc_acm 4-2:1.1: ttyACM0: USB ACM device
[508949.955001] usb 4-2: bad CDC descriptors
[508949.955014] usb 4-2: bad CDC descriptors

Some relevant bugs from RH
https://bugzilla.redhat.com/show_bug.cgi?id=495446
https://bugzilla.redhat.com/show_bug.cgi?id=496683

Regression, as this used to work in Intrepid 8.10

Chris Puttick (cputtick) wrote :

Ok, confirmed problem is in plasma-widget rather than anywhere else. Using Blueman to control bluetooth, connecting dial-up service adds rfcomm0 correctly but widget seems to be unable to hook up the correctly configured (Vodafone UK) mobile broadband. Errors are as per Wong CS comment above (https://bugs.launchpad.net/ubuntu/+source/plasma-widget-network-manager/+bug/334122/comments/10).

Using old KNetworkManager works perfectly (although have to manually configure speed to use 3G well - will test if this causes issues when speed setting is greater than is available on network). How to get this prioritised for a fix? Raise a customer support issue with Canonical?

Rasidee (rasidee) wrote :

I just clean installed Kubuntu 9.04 Jaunty release, and yes, I can confirmed the problem still there. Here is my dmesg log. I'm using Nokia 5800 phone as a broadband modem.

Apr 25 10:44:54 sidee-kubuntu NetworkManager: <info> Activation (ttyACM0) starting connection 'Celcom3G'
Apr 25 10:44:54 sidee-kubuntu NetworkManager: <info> (ttyACM0): device state change: 3 -> 4
Apr 25 10:44:54 sidee-kubuntu NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 25 10:44:54 sidee-kubuntu NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) started...
Apr 25 10:44:54 sidee-kubuntu NetworkManager: <debug> [1240627494.730852] nm_serial_device_open(): (ttyACM0) opening device...
Apr 25 10:44:54 sidee-kubuntu NetworkManager: Invalid baudrate '149091162'
Apr 25 10:44:54 sidee-kubuntu NetworkManager: Invalid bits (0). Valid values are 5, 6, 7, 8.
Apr 25 10:44:54 sidee-kubuntu NetworkManager: Invalid parity (
Apr 25 10:44:54 sidee-kubuntu NetworkManager: Invalid stop bits (0). Valid values are 1 and 2)
Apr 25 10:44:54 sidee-kubuntu NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) complete.
Apr 25 10:45:49 sidee-kubuntu NetworkManager: Error in writing (errno 5)
Apr 25 10:45:49 sidee-kubuntu NetworkManager: <info> (ttyACM0): device state change: 4 -> 9
Apr 25 10:45:49 sidee-kubuntu NetworkManager: <debug> [1240627549.883600] nm_serial_device_close(): Closing device 'ttyACM0'
Apr 25 10:45:49 sidee-kubuntu NetworkManager: <info> Marking connection 'Celcom3G' invalid.
Apr 25 10:45:49 sidee-kubuntu NetworkManager: <info> Activation (ttyACM0) failed.
Apr 25 10:45:49 sidee-kubuntu NetworkManager: <info> (ttyACM0): device state change: 9 -> 3
Apr 25 10:45:49 sidee-kubuntu NetworkManager: <info> (ttyACM0): deactivating device (reason: 0).
Apr 25 10:45:49 sidee-kubuntu NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Apr 25 10:45:49 sidee-kubuntu NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed

Normal connection by manually modifying "/etc/ppp/peers/provider" and executing "sudo pon" on terminal was a success.

Jeffrey Seguerra (jepong) wrote :

still unusable... i have to configure and use wvdial to connect my huawei e220. btw, firefox can't browse when connected by wvdial. I Thank KDE for Konqueror.

For reference, remove the network widget and use the old
KNetworkManager - works fine, just not as pretty :)

--
My employers website: http://thehumanjourney.net - opinions in this
email are however very much my own and may not reflect that of my
current employer, past employers, associates, friends, family, pets etc..

Documents attached to this email may be in ISO 26300 format:
http://iso26300.info

This bug affects me too. Is there any real solution yet? BTW: Remote bug watches do not seem related to this bug. Can someone remove them?

I'm also with this problem using a N95 as a 3G modem plugged in USB. Please developers, give some priority to this bug. At least for those who commented here I think it has some kind of urgency and it acctually it doesnt seems to be a big problem. Thanks!

lanzen (lanzen) wrote :

I've added https://launchpad.net/~kubuntu-experimental/+archive/ppa and after the update my hauwei is working nicely. I am now connected through Broadband.

Nice one!

Wong CS (lilwong) wrote :

I can confirm lanzen's report. It's working now.

Whoever coded and/or packaged the fix, thank you so much :)

Here is another confirmation that the package from the kubuntu-experimental PPA is working.

No, it's still not working with 3G modems! At least now it's connecting to wireless networks but 3G is my biggest problem yet. Please, fix it!

Jeffrey Seguerra (jepong) wrote :

Wifi works but still not working for me and my msi wind w/ huawei e220... i'm using wvdial to connect mobile broadband.

Wong CS (lilwong) wrote :

I would suggest users such as jepong and Waldemar submit their logs for analysis rather than just saying that it's "still not working".

FWIW, I think the logs most worth submitting is /var/log/messages and /var/log/daemon.log.

Ok Mr. Wong. Here it goes.

When I first connect my N95 as a 3G modem it is quickly recognized by plasma-widget-network-manager. So I edited the connection settings and then I clicked on connection name "Vivo Internet" and pray expecting it to work as it should. So I wait and I wait a little more and nothing happens, and worst, the notebook freezes for 2 or 3 minutes. So I decided to take a look in what really happens and this is what i got from a "tail -f /var/log/syslod" while attempting to connect:

May 14 09:47:28 wsjunior-laptop NetworkManager: <info> Activation (ttyACM0) starting connection 'Vivo Internet'
May 14 09:47:28 wsjunior-laptop NetworkManager: <info> (ttyACM0): device state change: 3 -> 4
May 14 09:47:28 wsjunior-laptop NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) scheduled...
May 14 09:47:28 wsjunior-laptop NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) started...
May 14 09:47:28 wsjunior-laptop NetworkManager: <debug> [1242305248.426168] nm_serial_device_open(): (ttyACM0) opening device...
May 14 09:47:28 wsjunior-laptop NetworkManager: Invalid baudrate '3'
May 14 09:47:28 wsjunior-laptop NetworkManager: Invalid bits (0). Valid values are 5, 6, 7, 8.
May 14 09:47:28 wsjunior-laptop NetworkManager: Invalid parity (
May 14 09:47:28 wsjunior-laptop NetworkManager: Invalid stop bits (0). Valid values are 1 and 2)
May 14 09:47:28 wsjunior-laptop NetworkManager: <info> Activation (ttyACM0) Stage 1 of 5 (Device Prepare) complete.

And it stops and just come back after typing "/etc/init.d/NetworkManger restart"

I used to love KDE but now I'm starting to see it with evil eyes. It just seems to be a BIG step back. They seems to want to implement big new changes and just forget the simple and essential things. I really sad about it. And guess what, everything works flawlessly with Ubuntu and GNOME. Even Windows 7 Release Candidate is more consistent in this part than KDE 4 right now. It is a shame. :(

Note following standard software workaround:

install KNetworkManager

remove network plasma-widget (right click widget, select Remove)

add menu item for KNetworkManager (right click launcher, select menu
editor, not sure why it doesn't add a menu item itself)

right click KNetworkManager menu item and use options to place on
convenient location (we use desktop and have a blueman icon too)

fire up KNetworkManager

connect phone with Blueman

edit new rfcomm connection as necessary (only needed first time)

Works just fine. Super.

No idea why it doesn't work in shipping network-widget, I guess the
middle is not the same (backend of course is). Was unwilling to use
the one from Kubuntu-experimental as these are Dell Mini 9 netbooks
being used by non-technical senior management and I had no idea what
the dependencies were it wanted and how that might affect the
otherwise stable installation.

Clarification: I'm not the maintainer so I can't do much about your problem directly either. I was just suggesting that you submitted more information so that the maintainer can actually see if he/she can do anything about it.

In any case, I think most of us know that the NM widget isn't exactly fully ready yet by now. But it's not as if they just let us run into a brick wall with no way around it. The legacy knetworkmanager still can be used and I was using it to get on 3G quite satisfactorily. Please do use that as a workaround. If even that cannot work, I think it'd be another separate bug report.

But in my limited capacity, let's see if I can help out or not:

1) Your NM widget configuration files are in $HOME/.kde/share/apps/networkmanagement/connections
2) You'll see quite a few files in there, I gather. Run the command "grep Vivo *" to find the configuration file for your 3G connection.
3) It *may* be possible that your phone wasn't initialized properly to dial out so let's compare your NM widget configuration with your knetworkmanager configuration (assuming that you were using that in previous versions of Kubuntu)
4) The knetworkmanager config file is in $HOME/.kde/share/config/knetworkmanagerrc. Open it and be prepared to compare manually.
5) Assuming that you had named your connection "Vivo Internet", search for that string inside the file.
6) For e.g., my connection was called "Celcom3G" and I found that string in a block containing the following:

[ConnectionSetting_lzWk2MQybtGkFIQh_connection]
Type=connection
Value_autoconnect=<bool>false</bool>\n
Value_id=<string>Celcom3G</string>\n
Value_timestamp=<uint32>1241581159</uint32>\n
Value_type=<string>gsm</string>\n
Value_uuid=<string>lzWk2MQybtGkFIQh</string>\n

7) Note the string "lzWk2MQybtGkFIQh" at the top (the string will be different in your case). That is the unique ID for your connection settings.
8) After that, there will be a successive sequence of sections with that same unique ID. E.g.:

[ConnectionSetting_lzWk2MQybtGkFIQh_connection]
[ConnectionSetting_lzWk2MQybtGkFIQh_gsm]
[ConnectionSetting_lzWk2MQybtGkFIQh_ipv4]
[ConnectionSetting_lzWk2MQybtGkFIQh_ppp]
[ConnectionSetting_lzWk2MQybtGkFIQh_serial]

Note that they all share the same unique ID. The contents of those sections constitutes your settings for your connection.

9) Compare those settings in knetworkmanager (which used to work) with the settings in the NM widget's settings file. You should be able to match them by looking at the individual settings' key. If they don't match, modify it (though I'd suggest backing up the original file first).

Try again after that. *Maybe* it'd solve your problem. If you find it too much trouble, well, as I said, try to fall back to knetworkmanager.

I don't wish to get into the whole "ready or not" debate here, it's been argued to death in many other forums.

P.S. to the package maintainer: I did note that the default settings for NM widget 3G connections are markedly different from that of knetworkmanager's. I'm not sure if that is the cause of some modems not being able to dial out but it may be worth looking into.

Hello Wong, I really appreciate your help, but i had already made that comparation among the two files and with the same settings it still just stay as I told you before.

I'm using wvdial to get 3g connection for now. I just don't want this bug to be marked as fixed just because some people started to get some kind of sucess as many other bugs.

I'm sorry for the previous complainment but I think that at least Kubuntu developers should know about that and include another tool to control connections by default. One with some decent support as the network-manger-gnome. But you are right, we shouldn't get into the whole "definitely not ready for non developers, nerds and people with average/high computer knowledge" debate here.

I hope it could be solved soon, so I can back to recommend Kubuntu for everyone :-)

It's all made for free with love and good will. Nobody is getting paid here for this.

Report was made and information was provided let's just wait now. :-p

For developers: If you need any other information to help you to solve this problem please feel free to ask and I will be glad to provide it quickly.

FilipK (filip-koczorowski) wrote :

Kubuntu 9.04 with Motorola V3xx here. Trying to use the phone as USB modem but Network Management plasmoid widget has option "Mobile broadband" disabled. I can connect successfully using UMTSMon tool so it's not a hardware issue, however it works only when run with "sudo".

PaulSmecker (paul-smecker) wrote :

same here with my k850i,
Mobile Broadband is disabled!

me too .. i cant connect using my usb modem huawei e106e
 Mobile Broadband is disabled!

affects: plasma-widget-network-manager (Ubuntu) → plasma-widget-networkmanagement (Ubuntu)
Changed in plasma-widget-networkmanagement (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in knetworkmanager:
status: Unknown → In Progress
summary: - kubuntu jaunty plasmoid-network-manager can't use mobile broadband
+ Mobile broadband connections fail to connect
Flemming Bjerke (flem) wrote :

Same same, but different.

I have an asus eee900 with eeeubuntu, i.e. gnome. Huawei e220 works fine with nm-applet and nm-system-settings. I have an hp 550 with kubuntu. Huawei e220 does not work. Not even when I remove knetworkmanager and network plasma-widget, and then install nm-applet and nm-system-settings.

nm-applet started from a console says: .... activate_connection_cb(): Connection activation failed: Connection was not provided by any settings service.

Doesn't this suggest that it is neither knetworkmanager nor network plasma-widget that fails, but something else with kde's network handling? Could kde interfere with the modem call sequences.

I will install gnome on my hp550 to see if it works when I switch to a gnome desktop.

@Flemming: Our workaround method of removing the widget and installing
knetworkmanager is working 100% for us.

From our internal docs: having installed knetworkmanager you need to
kill the thread knetworkmanager before starting knetworkmanager [new
network stuff has a thread with the same name as the old stuff...]. A
reboot will also suffice.

How are you connecting the bluetooth/mobile device e.g. we use Blueman.

Flemming Bjerke (flem) wrote :

Thank you, Chris. You are right. Having removed nm-applet and nm-system-settings (network plasma-widget was already removed), I installed knetwork manager. Now, I am online. No need for any gnome install. I don't use bluetooth, but plug the Huawei e220 into the usb. After a minut or two, it turns automagically up in the networkmanager-applet.

Flemming Bjerke (flem) wrote :

Well, after all, knetworkmanager turned out to be unstable on the Huawei e220, sometimes it worked, sometimes not. And this is, true eth0 and wlan0 as well! Moreover, kde displayed other bad sides, such as blurred wifi-icon, unstable touchpad features, overload. So, eventually, I installed ubuntu. Now the networksmanager works resonable well. On a lenovo z60t, kubuntu could not come on wan though lan was all right. In ubuntu, the lenova was on wan immediately. Kubuntus networkmanaging GUIs are not too good (for these two laptops).

Jonathan Thomas (echidnaman) wrote :

Ok, let's see if we can get a status update for Karmic.

To anybody who is running Karmic with the latest:
-Is the card being detected at all? Is the Mobile Broadband tab enabled?
 + If not, can you attach syslog, NetworkManager and ModemManager logs while the hardware
is attached, and the package versions for NM and MM as described here?
http://userbase.kde.org/NetworkManagement

-If the card is detected, does it connect?
 + If not, can you delete the current connection, make a new one and test if it works?
 + If nothing is working after that, could you provide the connection log and Mobile Broadband info as described at http://userbase.kde.org/NetworkManagement ?

If it is shown that KNetworkManager is not detecting modems that ModemManager can, I would like to split that out into a separate bug.

Thanks in advance.

Changed in plasma-widget-networkmanagement (Ubuntu):
status: Triaged → Incomplete
Chris Puttick (cputtick) wrote :

I'll sacrifice a netbook to this cause later; although note this will
be via bluetooth so presumably blueman - not sure if this is
supported, although we have 10 or so non-techie users making that
chain work happily.

Chris

-----------
Documents attached to this email may be in ISO 26300 format:
http://iso26300.info

Christiansen (happylinux) wrote :

@Jonathan Thomas in comment #39

Using a Hauwei E270 adapter in Kubuntu Karmic do not work by default for me neither, but by investigating the problem in Jaunty I've found a way to make it work with both Karmic and Jaunty (with KDE 4.3.x and a plasma-widget-networkmanagment grater than 0.1~svn100XXXX-0ubuntuX).

In Karmic since at least Alpha 6 I think, the OS do not detect the USB dongle on the first connection. Disconnecting and reconnecting it one or two times makes the OS detect the hardware correct as a GSM modem (se the attached dmesg.log for a two time reconnection). This must be a kernel issue, as Jaunty detects it fine on first go.

To make a connection with plasma-widget-networkmanagment (PWN) I just manual edit the appropriate connection-file from "/home/your-user-name/.kde/share/apps/networkmanagement/connections/". As of "PWN 0.1~svn1023224-0ubuntu1" I in fact only need to edit the [serial] section of the file and correct every single value here. To make PWN use the edited connection-profile a REBOOT IS DEMANDED, not doing so makes PWN use the wrong values created by the GUI (seen in daemon.log when trying to connect after editing the file).

Attaching a NotWorking profile created with the GUI, and a Working profile corrected by hand.

Linux K9-10 2.6.31-11-generic #36-Ubuntu SMP Fri Sep 25 06:37:51 UTC 2009 i686 GNU/Linux
network-manager-0.8~a~git.20090923t064445.b20cef2-0ubuntu1
plasma-widget-networkmanager-0.1~svn1023224-0ubuntu1

BTW I know a restart of the network-manager daemon sometimes can replace a reboot. Additional I have disabled the PIN code request on the dongle (SIM).

Christiansen (happylinux) wrote :
peterh (peter-holik) wrote :

network-manager-0.8~a~git.20091013t193206.679d548

did not work for me i got:

NetworkManager: <WARN> pppd_timed_out(): Looks like pppd didn't initialize our dbus module

i also saw no logs from pppd.

to see what happens i tried to get an strace output with

while :; do sleep .2; if pgrep pppd; then strace -s1000 -f -p $(pgrep pppd); fi;done

write(1, "Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.", 52) = ? ERESTARTSYS (To be restarted)
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---
--- SIGTTOU (Stopped (tty output)) @ 0 (0) ---

This means that pppd writes to stdout, but networkmanager did not read anything.

With this patch my huawai E220 is working now

--- network-manager-0.8~a~git.20091013t193206.679d548.orig/src/ppp-manager/nm-ppp-manager.c
+++ network-manager-0.8~a~git.20091013t193206.679d548/src/ppp-manager/nm-ppp-manager.c
@@ -921,7 +921,7 @@

        priv->pid = 0;
        if (!g_spawn_async (NULL, (char **) ppp_cmd->array->pdata, NULL,
- G_SPAWN_DO_NOT_REAP_CHILD,
+ G_SPAWN_DO_NOT_REAP_CHILD || G_SPAWN_STDOUT_TO_DEV_NULL || G_SPAWN_STDERR_TO_DEV_NULL,
                                        pppd_child_setup,
                                        NULL, &priv->pid, err)) {
                goto out;

Well it would be better to read from stdout / stderr and log it,

Christiansen (happylinux) wrote :

For the latest two releses of plasma-widget-networkmanagment in Karmic, it is not even possible to get a connection with the Huawei-E270 any more (se comment #41 above). Using both the RC Live CD with:
 0.9~svn1029786-0ubuntu1
and a clean installed RC updated with:
 0.9~svn1029786+ag1-0ubuntu1
the error below is logged in the deamon.log and the connection fails right away.

Error: NetworkManager: <WARN> wait_for_connection_expired(): Connection (2) /org/freedesktop/NetworkManagerSettings/2 failed to activate (timeout): (0) Connection was not provided by any settings service

Exact the same error is logge on Jaunty with KDE 4.3.2 from the Kubuntu Backports PPA and the plasma-widget-networkmanagment 0.9~svn1029786-0ubuntu2.1~jaunty1.

Deleting all connection entries, purging the PWNM package and installing 0.9~svn1023224-0ubuntu1 from:
 https://launchpad.net/ubuntu/+source/plasma-widget-networkmanagement/+publishinghistory
restarting and creating new connections entries makes connecting with the Hauwei-E270 possible again.

For Jaunty the same goes with the version found here:
 https://launchpad.net/~kubuntu-ppa/+archive/staging/+sourcepub/735190/+listing-archive-extra

Not sure if the logged error from PWNM is coursed by the what peterh describes above as the version of PWNM isn't mentioned, but at least it must be caused by some changes to the latest versions of PWNM.

Changed in plasma-widget-networkmanagement (Ubuntu):
status: Incomplete → New
Christiansen (happylinux) wrote :

Changed the status from Incomplete to New, as most of the comments found in this bug concentrate about the plasma-widget-networkmanagment. Following this bug for almost almost its full live, it seems completely overlooked by development - is this wrong ?.

Rocco (rocco) wrote :

The Gnome nm-applet works OK, so I had to switch to that instead. I don't like running gnome apps on my KDE desktop, and not in systray, but if I should be able to work with my computer, well then the change was inevitable.

I've also seen screenshot of KDE developers using nm-appet, so it might have been the wrong decision from Ubuntu to break networking in Kubuntu two releases in a row, by releasing with to early release of software which isn't finished yet.

To confirm, on Kubuntu 9.10, NetBook Remix version with a Huawei E156G 3G dongle, I am also seeing this issue, in that, I have the icon appear in the plasmoid to show that my phone is attached. I click on that entry, and get taken to a page of Wireless Hotspots. On canceling that screen, I can "Manage Connections" and complete the details for this device, but then selecting that connection from the list does not establish this connection.

I am currently working around this issue by performing

sudo apt-get remove knetworkmanager
sudo apt-get install network-manager-gnome
System -> System Settings -> Advanced -> Autostart -> New Program -> nm-applet

I know this is using the Gnome Network Manager, but it works for the moment.

James (james-ellis-gmail) wrote :

Hi

Stumbled on this bug report after going thru hell trying to connect using Three Australia Mobile Broadband on an unlocked E220 dongle using Karmic. The dongle comes from Austria and was working out of the box on Jaunty via BOB Breitband.

Based on on my investigations and digging around it would seem that the issues I was presented were due to incorrect/missing DNS server settings and/or dodgy firmware.

Prior to a firmware upgrade I was able to use nm-applet and force the DNS to the free opendns addresses. It worked but was slow, and heck nm-applet just looks rather ugly when in a KDE setting. I read about others having some issues and found this link: http://www.mobilebroadbandrocks.com/e220-72mbps-firmware-version-11117100200
I booted up a Windows box and flashed the E220 with the Maxis firmware (see link further down in that page) and the 'dashboard'. I set up the account on XP and was able to connect with no problems using the opendns DNS addresses.

Plugged the device back into KDE after reinstalling plasma network manager, set up the account again under "Mobile Broadband" and connected. The device was able to connect and I was able to browser around a few sites, after entering the APN and Number.

So, I'd suggest for those having trouble with the E220 (can't speak for other devices) is :
* check your firmware - it may be old and faulty
* flash the new one if it is old, on a Windows machine
* test connection on Windows
* try and connect in KDE
* tail /var/log/daemon.log to get hints on what's going wrong, if needed
* check your provider's DNS is good (browse by an IP address)

Finally, unfortunately, the KDE Network Manager doesn't allow specification of alternate DNS servers - so we're stuck with the ones a provider supplies (in my case they are flaky). Nm-applet allows DNS specification so it's obviously possible.

Hope that helps someone out there!

Packages:

Package: plasma-widget-networkmanagement
New: yes
State: installed
Automatically installed: yes
Version: 0.9~svn1029786+ag1-0ubuntu1

$ aptitude show plasma-widget-network-manager
Package: plasma-widget-network-manager
New: yes
State: installed
Automatically installed: no
Version: 0.9~svn1029786+ag1-0ubuntu1

Mobile broadband doesn't work for me; I get no visual confirmation, and in the syslog the following appears:

Nov 20 18:22:27 phosphor NetworkManager: <WARN> user_connection_get_settings_cb(): user_connection_get_settings_cb: Invalid connection: 'NMSettingSerial' / '(null)' invalid: 3
Nov 20 18:22:38 phosphor NetworkManager: <WARN> wait_for_connection_expired(): Connection (2) /org/freedesktop/NetworkManagerSettings/1 failed to activate (timeout): (0) Connection was not provided by any settings service

It seems it wants a serial port, but I have no idea how to set one. There is no option for this in the GUI.

erani (erani-mail) wrote :

On my Kubuntu 9.10 32bit also is not working :(
With nm-applet it's all ok

When I was using Kubuntu 9.10 Alpha5 the kde network-manager was working great, with upgrade to alpha6 it was not working anymore :(

A workaround for this problem might be
https://wiki.ubuntu.com/knetworkmanager/mobilebroadband

Sorry, if this was mentioned before, I could not find it after a quick view on this bug report

description: updated
tasklist (adriangheorghe1981) wrote :

in plasma-network-manager try setting prefer 2G or 3G, do not let "any".
write back if it works.

Nicu (nicu-inbox) wrote :

Hi,

I tried (now in Kubuntu 9.10).
But anyway there is no effect on clicking the connection name in popup
list, in attempt to get it working.

Cheers,
Nicolae

tasklist wrote:
> in plasma-network-manager try setting prefer 2G or 3G, do not let "any".
> write back if it works.
>
>

erani (erani-mail) wrote :

I also tried it in Kubuntu 9.10 KDE 4.4 RC2, no effect :(

erani (erani-mail) wrote :

@Christian Mangold what is suggested on the link you provide is not the bug fix, is work around. Maybe I, as a developer understand how to change this, but try to explain it to a simple pc user.

If I follow https://wiki.ubuntu.com/knetworkmanager/mobilebroadban I can click on the connection entry, and something happens. In other words: the menu item becomes clickable.

However, it doesn't actually connect. It fails almost immediately.

Feb 3 18:50:44 swbr1435l modem-manager: (ttyUSB0) opening serial device...
Feb 3 18:50:45 swbr1435l modem-manager: Registration state changed: 1
Feb 3 18:50:45 swbr1435l modem-manager: Got failure code 100: Unknown error

If I use Gnome's nm-applet, I get:

Feb 3 18:52:34 swbr1435l modem-manager: (ttyUSB0) opening serial device...

and NetworkManager continues happily.

If the modem has been correctly initialised (by, say, nm-applet), the line

modem-manager: Registration state changed: 1

disappears, and it ticks for a second before hanging up. However, the line

modem-manager: Got failure code 100: Unknown error

is still there. I've tried setting baud=115200 (which nm-applet does), but it has no effect.

If I edit under
[gsm]
band=0

instead of
[gsm]
band=-1

knetworkmanager connects. Woohoo! I also edited number=*99# instead of *99***1#, but that is editable in the GUI

However, it still leaves me with an empty /etc/resolv.conf

The problem with resolv.conf being empty affects nm-applet too, because the service provider in question provides incorrect DNS servers during the PPP negotiation.

However, in nm-applet, I can override the settings.

Mackenzie Morgan (maco.m) wrote :

Mobile Broadband is working for me with knetworkmanager in Lucid.

I'm using:
number: *99#
user/pass: blank
for APN, I installed mobile-broadband-provider-info and looked up my provider in serviceproviders.xml
and put my PIN in the PIN field

Mackenzie Morgan (maco.m) wrote :

Though hmm... is this bug only for Huawei or is it that mobile broadband connections fail in general?

Iris Miraballes (imiraballes) wrote :

Mobile broadband is not working with Huawei E176, and the message which appears is:

Archive: /media/Ancel/AutoRun.exe
[/media/Ancel/AutoRun.exe]
  End-of-central-directory signature not found. Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive. In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
zipinfo: cannot find zipfile directory in one of /media/Ancel/AutoRun.exe or
          /media/Ancel/AutoRun.exe.zip, and cannot find /media/Ancel/AutoRun.exe.ZIP, period.

Changed in knetworkmanager:
status: In Progress → Fix Released
Changed in knetworkmanager:
importance: Unknown → Medium
David Matějček (dmatej) wrote :

Natty is the first distro where NM works with Huawei K2540 ... nearly well.
1) I have usb-storage module on blacklist, because when it access the USB device first, usbserial module cannot. If it access it as the second, the connection is interrupted :-( . Historical occurence on my computers ...
Hardy - sometimes; I had to restart the system after that. Used wvdial or kppp.
Lucid - sometimes; I had to pull the USB and connect it again. Used wvdial or kppp.
Maverick - often; usb-storage blacklisted, then it was better, but sometimes I had to pull USB as well (driver state? hardware error?)
Natty - everytime if usb-storage not blacklisted; Using NM - and wvdial after NM connection interrupted.

2) Sometimes the connection is interrupted - I don't know if it is device error or driver error or server error, but then the kded4 hangs (see https://bugs.launchpad.net/ubuntu/+source/plasma-widget-networkmanagement/+bug/741200 ) and I have to use my old friend wvdial to become online again - and even sometimes reconnect the USB device.

Sanjaya Karunasena (sanjayak) wrote :

@dmatej #64:

This issue could be due to USB power stability issue discussed here http://ubuntuforums.org/showthread.php?p=10843659#post10843659.

Also there is a possible relevant issue I reported on ntrack https://bugs.launchpad.net/ntrack/+bug/786049.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-widget-networkmanagement (Ubuntu):
status: New → Confirmed
jimmykarily (jimmykarily) wrote :

For the record in my case just changing the number to *99# like berend-de-schouwer proposed made it work. Don't know why though

Maarten Bezemer (veger) wrote :

A year ago, an upstream fix was released. Could someone confirm whether this indeed fixed the (main) problem?

Changed in plasma-widget-networkmanagement (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.