Empathy doesn't apply avatar for MSN

Bug #631428 reported by Carroarmato0 on 2010-09-06
This bug affects 79 people
Affects Status Importance Assigned to Milestone
papyon (Ubuntu)

Bug Description

Binary package hint: empathy

DistroRelease: Ubuntu 10.10

Last known good version: 2.30.3-0ubuntu1

Carroarmato0 (carroarmato0) wrote :
description: updated
BenginM (sary) wrote :

Conforming , this effects me on Maverick beta.

Carroarmato0 , thanks for reporting .

Dudu.exe (stuffmail) wrote :

Affects me too on Ubuntu Beta 10.10

Empathy version Empathy

Brian Curtis (bcurtiswx) wrote :

Try a fully updated system. Empathy is at 2.31.92-0ubuntu2 soon to be 2.32.0-0ubuntu1

Changed in empathy (Ubuntu):
status: New → Incomplete
BenginM (sary) wrote :

Brian Curtis , will wait for that .. thanks.

pablomme (pablomme) wrote :

The problem is still present with empathy 2.32.0-0ubuntu1. Can be easily checked by going to Edit > Personal Information, selecting a display picture for the MSN account, closing the dialogue and opening Edit > Personal Information again, where no picture displayed.

Omer Akram (om26er) wrote :

Thanks for the bug report. This particular bug has already been reported and is a duplicate of bug 326321, so is being marked as such. Any further discussion regarding the bug should occur in the other report. Feel free to report any other bugs you may find.

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: Incomplete → New
affects: empathy (Ubuntu) → telepathy-butterfly (Ubuntu)
pablomme (pablomme) wrote :

That bug is far too old. I'm pretty sure this worked fine in Lucid. The symptoms are different (no Empathy restart required). Bug #326321 was most likely fixed at some point, and this is a new regression.

I confirm this bug (not a dupplication).

Setting a picture for a MSN account dont work.

pablomme (pablomme) wrote :

I hadn't realized bug #326321 is about the alias, not the avatar/display picture. It might still persist, I haven't tried to change my MSN alias in empathy. And this bug is definitely a regression from 10.04 and is different from that other bug, so I'm de-dupping.

Changed in telepathy-butterfly (Ubuntu):
status: New → Confirmed
tags: added: regression-potential

I'm using empathy to set an avatar on MSN protocol. It's not being stored. When I close the dialog and open it again, the picture is gone.

Nobody see it on conversations.

Avatar on GTalk accounts is fine.

telepathy-butterfly version is 0.5.14-1 (Ubuntu 10.10)

Omer Akram (om26er) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=631463

affects: telepathy-butterfly (Ubuntu) → empathy (Ubuntu)
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Changed in empathy:
importance: Unknown → Low
status: Unknown → New
turnick (turnickdbz) on 2010-10-16
Changed in empathy (Ubuntu):
assignee: nobody → turnick (turnickdbz)
status: Triaged → New
Omer Akram (om26er) on 2010-10-20
Changed in empathy (Ubuntu):
assignee: turnick (turnickdbz) → nobody
importance: Low → Medium
status: New → Triaged

I remove telepathy-butterfly and keep only haze for msn, and now it works for me. I can change the avatar and I don't have no more any problems connecting to that account.
I hope it works for you too...

description: updated
Changed in empathy (Ubuntu):
importance: Medium → Low
Changed in empathy (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → Low
tags: added: regression-release
removed: regression-potential

ok, but with telepathy-haze I can't change the alias (name).

same thing happens to me, in MSN protocol Ubuntu 10.04 & im using empathy to...
any help??

from my testing it seems like in empathy 2.30 the avatar did not change but the empathy's interface showed the changed avatar. i found an old related bug in launchpad too. to my testing pidgin does not change the avatar either.

the bottom line is that telepathy-butterfly did not had this feature implemented and previously empathy was lying which made people think their avatar was changing. ( i might be wrong) if the problem is old there must be another bug too but i was not able to find it. i am attaching the buttefly logs of the time when i change the avatar.

also reported: https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/631428

I've the same problem.

Changed in empathy:
status: New → Unknown

This bug will be fixed in next papyon release

Tamer (tameru) wrote :

I also confirm this bug on my Ubuntu 10.10

Dudu.exe (stuffmail) wrote :

Butterfly - no avatar
Haze - no Alias change...

its just sad to be a msn user =/

anabelli (anabelli) wrote :


  how can you ppl set this bug as low importance:
Q: Nowadays (2010 AD), what does the average user utilises a computer for?
A: Social networking..

Q: What's one of the most common IM protocols?
A: MSN..

Thesis: You just can't let the only officially supported IM client being broken to the bone.


If you're not willing to support/debug (because I don't think it's such a criminally difficult task to correct this bug) empathy set pidgin as default. You don't want to waste Canonical's man-hours? Just set it high and hope that the next bug fixing day someone is gonna notice it.

But, giving it "low importance" is surely not gonna help.

turnick (turnickdbz) on 2010-11-21
Changed in empathy (Ubuntu):
assignee: nobody → turnick (turnickdbz)
status: Triaged → Confirmed
Changed in empathy (Ubuntu Maverick):
assignee: nobody → turnick (turnickdbz)
Changed in empathy (Ubuntu):
assignee: turnick (turnickdbz) → nobody
Changed in empathy (Ubuntu Maverick):
assignee: turnick (turnickdbz) → nobody
BenginM (sary) wrote :

1+ for andrea-abelli , Dudu.exe .

I agree fully with #18.

Why is this bug set to Low Importance. There is still an old bug with ICQ too. Only my ICQ Number is sent to others in a chat. I can't change the Alias. That bug is set to low importance too.

It's unbelivable and the proof of the shortcomings of Linux.

Vlad Novak (vnovak06) wrote :

Windows users make fun of me for sticking to Linux, and concerning this social networking over MSN, they're quite right. :-/ I remember the old times using kopete and gaim, it all worked so fine then.

+1 for andrea-abelli and a confirm that this avatar bug affects me also.

Juan Montoya (th3pr0ph3t) wrote :

I agree with you both andrea-abelli and Vlad Novak.

In my case, it is difficult to defend Ubuntu in front of my friends when basic stuff doesn't work.

have this bug fixed in papyon yet? if yes is there a specific commit or we have to update the whole package?

Omer Akram (om26er) wrote :
Changed in empathy:
importance: Low → Undecided
status: Unknown → New
status: New → Invalid
affects: empathy (Ubuntu) → papyon (Ubuntu)
Changed in papyon (Ubuntu):
status: Confirmed → Triaged
Changed in papyon:
status: Unknown → Confirmed
Franco (francogpellegrini) wrote :

solved with:
deb http://ppa.launchpad.net/telepathy/ppa/ubuntu maverick main #Telepathy PPA

Changed in papyon:
importance: Unknown → Medium

We would like to have this fix in Ubuntu-10.10 and would be really helpful if you could point us in the right direction.

Rune K. Svendsen (runeks) wrote :

I agree with Franco in #24; this is solved by using the version of telepahy and empathy in the Telepathy PPA.

Johan Boss (johanboss) wrote :

This is working for me in 11.04. It does have the annoying habit of sometimes just forgetting about applying the picture, but if I manually reapply it works and same goes when it "remembers" to apply it at login.

bwat47 (bwat47) wrote :

This doesn't work for me in ubuntu 12.04 with msn or aim. only facebook has a workin avatar.

Daniel Holm (danielholm) wrote :

Same for me in Precise. So this is a bug thats two years old and unresloved?

John Coleman (johncoleman4829) wrote :

Ubuntu 12.04 Beta 1 (32-Bit)
Empathy 3.3.92

No Avatar for MSN
No Avatar for AIM

Not having trouble Avatar trouble with:
GTalk (gmail)

Adolfo Jayme (fitojb) on 2013-07-06
no longer affects: papyon (Ubuntu Maverick)

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/telepathy/telepathy-butterfly/issues/34.

Changed in papyon:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.