Ubuntu

packagekit says: The backend took too much time to process the synchronous request - you need to fork!

Reported by Khashayar Naderehvandi on 2008-09-20
232
This bug affects 22 people
Affects Status Importance Assigned to Milestone
PackageKit
Fix Released
High
packagekit (Ubuntu)
High
Unassigned
Nominated for Jaunty by Rafael Belmonte
Nominated for Karmic by Ladislav Maxa

Bug Description

This is a problem I'm having with the recently updated packagekit 0.3.3 on intrepid:
Every time I attempt something, such as installing a package, updating the system or what have you, packagekit says "an internal system error has occured" and that "The backend took too much time to process the synchronous request - you need to fork!". Unfortunately, I have no clue how to fork, which results in nothing getting installed or updated.

Please, tell me where to look for additional information about this.

Screenshot attached.

plun (plun) on 2008-09-20
Changed in packagekit:
status: New → Confirmed
Sebastian Heinlein (glatzor) wrote :

Does the command line tool pkcon work? E.g. "pkcon get-details xterm"

What kind of machine are you using? Is it a modern system?

On Mon, 2008-09-22 at 15:37 +0000, Sebastian Heinlein wrote:
> Does the command line tool pkcon work? E.g. "pkcon get-details xterm"
>
> What kind of machine are you using? Is it a modern system?
>

I get this all the time. The system isn't that old, but isn't brand
new one.

"Command failed: Could not find details for xterm"

pkcon get-updates gave the error the first time, and then didn't
for repeated runs, so it was probably the extra delay of going to
disk that caused the problem the first time.

Thanks,

James

James Westby (james-w) wrote :

On Mon, 2008-09-22 at 15:37 +0000, Sebastian Heinlein wrote:
> Does the command line tool pkcon work? E.g. "pkcon get-details xterm"

I can reproduce it reliably enough searching for a package in
gpk-application that I could investigate more.

Running the backend in debug mode shows that each time it is in
the

  DEBUG:Check apt cache and xapian database

phase when it gives the error.

Presumably this machine takes a little too long to open the databases,
leading to the error.

Thanks,

James

Hi,

Using the apt backend you quite often get the error message

"The backend took too much time to process the synchronous request - you need to fork!"

which stops the operation. If you choose a long operation, e.g.
"all packages" in gpk-application and you get this error then
the gui is unusable for a couple of minutes as the "Package"
signals from your request are being emitted, so if you choose
a category then more packages are shown than what is in this
category.

One of my comments from the Ubuntu bug report:

"I can reproduce it reliably enough searching for a package in
gpk-application that I could investigate more.

Running the backend in debug mode shows that each time it is in
the

  DEBUG:Check apt cache and xapian database

phase when it gives the error.

Presumably this machine takes a little too long to open the databases,
leading to the error."

Originally reported at

  https://bugs.launchpad.net/bugs/272410

Thanks,

James

I can confirm seeing this issue. I'm willing to test patches if need be.

Just wanted to toss this in: My experiences are in agreement with the others above.
My laptop is not state of the art, but it's not at dinosaur either.

I have noticed that sometimes, perhaps even most of the time, after at few attempts and clicking away the error message packagekit gets the job done. Right now, for example, it gave the error while I attempted to update the system. I pressed OK, and then made another attempt to update and it's working fine now.

Has anyone filed this upstream?

James Westby (james-w) wrote :

Hi,

I have reported this bug upstream at

  https://bugs.freedesktop.org/show_bug.cgi?id=17750

please add any more discussion of this bug that is not
Ubuntu specific there.

Thanks,

James

Changed in packagekit:
importance: Undecided → High
status: Confirmed → Triaged
Changed in packagekit:
status: Unknown → Confirmed

The error "you need to fork" is a developer message to the backend authors. What is means is the DBUS method took too long to execute, and "blocked" the daemon from any other activity.

What's meant to happen is that the daemon "forks" the command into the background, where it can process more reuests in the meantime. If the backend spends over 500ms processing the command without releasing control of the daemon, then you get this message.

Do you get this message on every transaction, or only on certain types? Can you reproduce it 100% reliably, or only when somehting else happens?

> Do you get this message on every transaction, or only on certain types? Can you
> reproduce it 100% reliably, or only when something else happens?

It's not 100% reliable on a particular command, but some are more likely
to trigger it than others. Some trigger it the first run when things aren't
cached, but then won't once they are.

Thanks,

James

The backend now forces serialisation of nearly all calls (4bc7370cac1564fa3109d2a62df53d62a5cba176).

Could you please test the latest version from the PPA or git? If the package signal is still delayed into the next method it seems to be a dbus issue and not a thread race condition.

Cheers

Hi,

This is still present with 0.3.5 from the PPA.

Thanks,

James

plun (plun) wrote :

Maybe a stupid comment... I found this within my ~/.xsession-errors

"process 30839: arguments to dbus_message_get_args() were incorrect, assertion "(error) == NULL || !dbus_error_is_set ((error))" failed in file dbus-message.c line 1667.
This is normally a bug in some application using the D-Bus library.
[WARN 30839] The SessionAdded signal on the org.freedesktop.ConsoleKit.Seat interface for object /org/freedesktop/ConsoleKit/Seat1 has the wrong signature! Your system is misconfigured."

ConsoleKit/Seat1 ? Has it something to do with this bug ?

Jean.c.h (slug71) wrote :

This no longer seems to be an issue with v3.6 in Jaunty's repos.

Étienne Deparis (milouse) wrote :

Bug still present with v3.13 on Intrepid using ppa repository...

The bug is still present in 0.3.14 on Ubuntu Jaunty. I'm able to reproduce it every time I run one of the tools.

GordonSchumacher (eleccham) wrote :

I am seeing this on a new install of Jaunty alpha6, FWIW.

*** Bug 19953 has been marked as a duplicate of this bug. ***

Confirming the same in Kubuntu Jaunty Alpha 6.

It's still issue in Kubuntu 9.04 Beta.

Thomas Kluyver (takluyver) wrote :

Seeing this in Kubuntu Jaunty beta as well, packagekit 0.3.14-0ubuntu4, kpackagekit 0.4-0ubuntu5

Rafael Belmonte (eaglescreen) wrote :

I just want to say that I have this issue in Kubuntu with kpackagekit, and my laptop is not older, Intel Pentium Dual-Core processor plus 2GB of RAM.
Watch Bug #272410

rizor (rizor-arcor) wrote :

I have the problem in Jaunty beta as well.
packagekit-0.3.14-0ubuntu4.amd64
kpackagekit-0.4-0ubuntu4.amd64

I have this with Jaunty beta too. Just finished updating.

Sebastian Heinlein (glatzor) wrote :

I ported the APT backend to a different backend mechanism. It now doesn't communicate using dbus but stdin/out. The work can be found in the apt-dispatcher branch of the 0.4 series. I will merge it soon.

kbit (klausbitto) wrote :

I have the same in the current jauty beta.

packagekit 0.3.14-0ubuntu4
kpackagekit 0.4-0ubuntu8

Harry Ranquist (harryranquist) wrote :

I get the same message with kpackagekit in jaunty rc after updating two xul related packages, today.

Kesekpl (robert-kesik) wrote :

I would like to say I recently upgraded from 8.04 -> 9.04 and as well have this bug in Jaunty.

I am on a rather old machine, Athlon XP 1800+ @ 1.9 Ghz, 1.5 Gb DDR... \

If there needs to be some testing done on such an ancient machine, I'll be glad to help.

Jonathan Riddell (jr) wrote :

Here is a diff which sets a longer timeout. I've uploaded packages to my PPA
deb http://ppa.launchpad.net/jr/ppa/ubuntu jaunty main

> I've uploaded packages to my PPA

Thanks, but don't we need a package name, or something, to install it?

I added the ppa repo...now what?

spacee (hofler) wrote :

This problem is also in KDE4 - when sw update manager finished update (see a screenshot).

Jeremy Wilkins (wjeremy) wrote :

Is there any update on this bug? I am still having troubles with this bug long after release. The strange part is that a new install doesn't seem to have the problem, but all my upgraded systems do.

spydouglas (ben-wibking) wrote :

I'm also still experiencing this issue. I've tried compiling from source, as I'm running ppc and there aren't any binary PPAs for powerpc, but without success so far.

Tsvi Mostovicz (tsvi) wrote :

I'm having this problem after every update. I have some ppa repositories turned on. My machine is a bit older (AMD Athlon XP 2600+ with 1 Gb of RAM)
Running Kubuntu Jaunty 9.04
Packages DO get updated most of the time, but I get this message toward the end.
kpackagekit 0.4.0, KDE 4.2.2

Rob Valkass (rvalkass) wrote :

I can confirm this on 9.04 installed from scratch (rather than updated). The first few times I have installed updates it has worked fine. This time it reported the error mentioned above. It also seems to have applied the updates, or is lying about there being none available afterwards.

This has become *much* worse on Karmic. It was almost working on Jaunty.

DerWurzelJan (derwurzeljan) wrote :

I am also still having this problem with Kubuntu Jaunty 9.04 (updated from Intrepid) KDE 4.2.2

Just experienced this using Kubuntu Jaunty/KDE 4.2.2 (clean install, not an upgrade) using the Software Updater. This machine is x86 and otherwise a fairly good spec laptop. Bought it ~2 years ago and it was fairly high-end back then.

Identical error message to everyone else. Kpackagekit reports that I no longer have any updates pending so hopefully that error didn't mean that my updates failed to install :s

Tim Makarios (tjm1983) wrote :

My Kubuntu Jaunty has the same problem. It appeared only in the last couple of days, even though I upgraded from Intrepid in April.

parmenpj (parmenpj) wrote :

To tell you the truth, I didin't like kpackage to begin with. I installed Synaptic, then removed kpackage and all libraries, etc. affiliated with it. I also installed Adept, and the system tray notifier. Beautiful. No need to FORK, whatever that means.

Hello,

I have Adept and Synaptic installed; this happens when I click on the system
tray notifier (a cog wheel) that let's me know updates are available. How
do you remove kpackage since it appears from what you wrote that it's a
separate app? Thanks.
--
David A. Foote

On Tue, Jun 9, 2009 at 10:31 AM, parmenpj <email address hidden> wrote:

> To tell you the truth, I didin't like kpackage to begin with. I
> installed Synaptic, then removed kpackage and all libraries, etc.
> affiliated with it. I also installed Adept, and the system tray
> notifier. Beautiful. No need to FORK, whatever that means.
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Jonathan Thomas (echidnaman) wrote :

With the latest updates on Karmic this is fixed for me.

David A. Foote (david-a-foote) wrote :

Hello,

What's Karmic and how can I apply this to my machine?

On Wed, Jun 17, 2009 at 2:27 PM, Jonathan Thomas <email address hidden>wrote:

> With the latest updates on Karmic this is fixed for me.
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
David A. Foote

zdenek.zikan (zdenek-zikan) wrote :

Karmic is future version of Ubuntu (9.10 Karmic Koala), which is in development and will be released in October. Right now, it's in very early development stage, so if you're asking in this way, it is probably not good for you.

David A. Foote (david-a-foote) wrote :

Thanks for the response; I thought it might have been an app or something
that would fix the issue.

On Wed, Jun 17, 2009 at 4:29 PM, zdenek.zikan <email address hidden>wrote:

> Karmic is future version of Ubuntu (9.10 Karmic Koala), which is in
> development and will be released in October. Right now, it's in very
> early development stage, so if you're asking in this way, it is probably
> not good for you.
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
David A. Foote

Automaton26 (automaton26) wrote :

Still happening in latest Jaunty, on an old slow laptop (Compaq Armada M700).

Problem always happens on first run of the application, but now seems OK on subsequent runs.

Haven't yet had opportunity to test whether updates can be applied without the same error again.

David A. Foote (david-a-foote) wrote :

Was trying to run update through console the other day and it gave me an
instruction to run a command using dpkg --configure -a; this not only helped
with console but it seems to have helped with with kpackage as well. The
last time I ran the update, I didn't get the error at the end.

On Tue, Jun 23, 2009 at 7:47 AM, Automaton26 <email address hidden> wrote:

> Still happening in latest Jaunty, on an old slow laptop (Compaq Armada
> M700).
>
> Problem always happens on first run of the application, but now seems OK
> on subsequent runs.
>
> Haven't yet had opportunity to test whether updates can be applied
> without the same error again.
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
David A. Foote

Hi,

This is fixed now that apt is a spawned backend.

Thanks,

James

James Westby (james-w) wrote :

Hi,

This is fixed in Karmic, but unfortunately the fix can't be applied to Jaunty as
it is far too large a change.

Thanks,

James

Changed in packagekit (Ubuntu):
status: Triaged → Fix Released

For now, I'm using Aptitude to do my updates in Konsole. Otherwise, I
assume I just have to wait for the next major upgrade and hope that it's
better than this one...thanks.

On Sat, Jul 4, 2009 at 2:23 PM, James Westby
<<email address hidden><jw%<email address hidden>>
> wrote:

> Hi,
>
> This is fixed in Karmic, but unfortunately the fix can't be applied to
> Jaunty as
> it is far too large a change.
>
> Thanks,
>
> James
>
>
> ** Changed in: packagekit (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
David A. Foote

I have not idea why, but my updates seem to work much better now. I haven't
 done anything to correct the problem. I just keep trying the update even if
I do get the error message, and it eventually works. Also, I don't get the
error message every time I attempt to update the computer. I will just wait
for the Karmic update to come out and then update to that and hope for the
best. Thanks for the occasional updates on the problem.

Joe Gunto
---- "David A. Foote" <email address hidden> wrote:
> For now, I'm using Aptitude to do my updates in Konsole. Otherwise, I
> assume I just have to wait for the next major upgrade and hope that it's
> better than this one...thanks.
>
> On Sat, Jul 4, 2009 at 2:23 PM, James Westby
> <<email address hidden><jw%<email address hidden>>
> > wrote:
>
> > Hi,
> >
> > This is fixed in Karmic, but unfortunately the fix can't be applied to
> > Jaunty as
> > it is far too large a change.
> >
> > Thanks,
> >
> > James
> >
> >
> > ** Changed in: packagekit (Ubuntu)
> > Status: Triaged => Fix Released
> >
> > --
> > packagekit says: The backend took too much time to process the synchronous
> > request - you need to fork!
> > https://bugs.launchpad.net/bugs/272410
> > You received this bug notification because you are a direct subscriber
> > of a duplicate bug.
> >
>
>
> --
> David A. Foote
>
> --
> packagekit says: The backend took too much time to process the synchronous request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

Changed in packagekit:
status: Confirmed → Fix Released
cheffe76 (p-letna) wrote :

Is the issue also fixed in Jaunty or just in Karmic?

It's not fixed in Jaunty; I've received emails that it's fixed in Karmic.
My workaround is to use Aptitude in Konsole and do a full upgrade in Jaunty.

David A. Foote

On Mon, Jul 6, 2009 at 5:22 AM, cheffe76 <email address hidden> wrote:

> Is the issue also fixed in Jaunty or just in Karmic?
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Massimo Bilvi (massimo-bilvi) wrote :

Same error on my system upgraded to Jaunty a few days ago.

Hello,

The problem is only fixed in Karmic. Sorry to say: It is not possible
to fix the problem for earlier versions of K/Ubuntu.

Cheers,

Sebastian

mattmill30 (mattmill30) wrote :

Will users be able to download Karmic when its released, if they're being affected by this bug?

As for me, its preventing me from downloading package lists.

Thanks,

Matthew Millar

mattmill30 (mattmill30) wrote :

Perhaps, if this can't be fixed in previous versions, it would be possible to downgrade to a previous version of Package Kit when it didn't require "apt to have a spawned backend" (final post on bug 17750).

So atleast then, other users won't download this version and be affected.

Thanks,

Matthew Millar

I use the "sudo aptitude full-upgrade" command from a terminal window to
install updates and this has worked without issue. I would think that once
Karmic is released that it will be available just like Jaunty was when it
was released, but I'm not a Linux expert...

David A. Foote

On Sun, Oct 18, 2009 at 4:01 PM, mattmill30 <email address hidden> wrote:

> Will users be able to download Karmic when its released, if they're
> being affected by this bug?
>
> As for me, its preventing me from downloading package lists.
>
> Thanks,
>
> Matthew Millar
>
> --
> packagekit says: The backend took too much time to process the synchronous
> request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Actually the spawned apt backend fixes this problem. Why should you
want to downgrade to a previous version?

Thomas Kluyver (takluyver) wrote :

I was regularly suffering from this bug, but I have successfully upgraded to Karmic beta. The OS upgrade uses a separate tool, which doesn't suffer from the problem.

Even better, packagekit in karmic works rather better, and no longer suffers from this bug.

Joe Gunto (tujfam4) wrote :

Thank you for letting all of us know that the upcoming distribution is
going to remedy this problem. I have been waiting for the release, and
will be upgrading as soon as the final release comes out.
Joe Gunto
---- Thomas Kluyver <email address hidden> wrote:
> I was regularly suffering from this bug, but I have successfully
> upgraded to Karmic beta. The OS upgrade uses a separate tool, which
> doesn't suffer from the problem.
>
> Even better, packagekit in karmic works rather better, and no longer
> suffers from this bug.
>
> --
> packagekit says: The backend took too much time to process the synchronous request - you need to fork!
> https://bugs.launchpad.net/bugs/272410
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.

Changed in packagekit:
importance: Unknown → High
Changed in packagekit:
importance: High → Unknown
Changed in packagekit:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.