oneconf-query crashed with ImportError in /usr/lib/python2.7/dist-packages/oneconf/packagesethandler.py: No module named distributor

Bug #934624 reported by Nadir Muzaffar on 2012-02-18
This bug affects 403 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
High
Unassigned

Bug Description

Error occurred after opening VLC then opening a nautilus window

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: oneconf 0.2.6.8ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic-pae 3.2.6
Uname: Linux 3.2.0-16-generic-pae i686
NonfreeKernelModules: fglrx
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Fri Feb 17 17:24:09 2012
ExecutablePath: /usr/share/oneconf/oneconf-query
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/oneconf-query --async-update
PythonArgs: ['/usr/bin/oneconf-query', '--async-update']
SourcePackage: oneconf
Title: oneconf-query crashed with ImportError in /usr/lib/python2.7/dist-packages/oneconf/packagesethandler.py: No module named distributor
UpgradeStatus: Upgraded to precise on 2012-02-17 (0 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Nadir Muzaffar (nadirabid) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Colin Law (colin-law) wrote :

Crashed after installing stellarium while bringing up the Dash.
oneconf-service crashed (apparently) immediately after.

before sudo aptitude autoremove

Ian Nicholson (imnichol) wrote :

Crashed when I checked for updates in update-manager

Saurabh Rawat (eklavya) wrote :

Always happens when I install somehting new.

Gediminas Paulauskas (menesis) wrote :

In version 0.2.6.8, oneconf.distributor was moved to a separate python package, but setup.py was not updated to include it.

Changed in oneconf (Ubuntu):
importance: Undecided → High
Tyler R (hunterkasy) wrote :

happend when I was trying to update the system

Error occurred after opening UpdateManager

a (tuomasjjrasanen) wrote :

Same problem occured also with oneconf-service. Happened right after succesful dist-upgrade from oneiric.

tags: added: patch
Péter Trombitás (trombipeti) wrote :

Apport told me about this after a successful dist-upgrade in Precise.

Guy Stone (stoneguy3) wrote :

Installing "dialog" via synaptic. Been noticing warnings about not having dialog available during other apt installs, so thought I'd bring it in to suppress messages. Using Gnome Classic No Effects.

egis (egdamo) wrote :

crashed after a new updates has been installed

John DeLuca (johnnyde94) wrote :

Crash after upgrading Ubuntu 11.10 to Ubuntu 12.04

Changed in oneconf (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Didier Roche (didrocks) wrote :

I got the apport crash this morning as well, fixed it and then saw Gediminas Paulauskas (menesis)'s patch (the same one I did) I integrated yours finally. Thanks a lot, the fix is pushed. :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.2.6.9

---------------
oneconf (0.2.6.9) precise; urgency=low

  * setup.py: Include missing oneconf.distributor package. (LP: #934624)
 -- Gediminas Paulauskas <email address hidden> Sun, 19 Feb 2012 19:03:16 +0200

Changed in oneconf (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers