Ubuntu

PCI Race Condition with COMPAL FL90

Reported by Martin Owens on 2010-10-15
216
This bug affects 42 people
Affects Status Importance Assigned to Milestone
System76
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
High
Unassigned

Bug Description

I'm reporting this bug so I can attach the three dmesg reports, one for nouvou, one for nvidia-173 and one for nvidia-260.

nouvou works but has low resolution.
nvidia-173 produces a black screen and crashes the entire machine (force power off required)
nvidia-260 dumps into command line

OS: Ubuntu 10.10
Card: Nvidia GeForce 8600M GT

Martin Owens (doctormo) wrote :
Martin Owens (doctormo) wrote :
Martin Owens (doctormo) wrote :
Martin Owens (doctormo) wrote :
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Alberto Milone (albertomilone) wrote :

The following lines in dmesg show that the driver complains about the fact that the card is not supported:

[ 18.981091] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407) installed
[ 18.981092] NVRM: in this system is not supported by the 260.19.06 NVIDIA Linux
[ 18.981093] NVRM: graphics driver release. Please see 'Appendix A -
[ 18.981095] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 18.981096] NVRM: available on the Linux graphics driver download page at
[ 18.981097] NVRM: www.nvidia.com.
[ 18.981103] nvidia: probe of 0000:01:00.0 failed with error -1
[ 18.981128] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 18.981130] NVRM: None of the NVIDIA graphics adapters were initialized!

I find it a bit weird as GeForce 8600M GT should be supported:
http://www.nvidia.com/object/linux-display-ia32-260.19.12-driver.html

I'm subscribing Nvidia to this bug report

summary: - All Nvidia drivers fail to load
+ Nvidia GeForce 8600M GT doesn't work with nvidia-current 260

nouveau isn't working either in these logs:

[ 19.040082] [drm] nouveau 0000:01:00.0: Unsupported chipset 0xffffffff
[ 19.040216] nouveau 0000:01:00.0: PCI INT A disabled
[ 19.040223] nouveau: probe of 0000:01:00.0 failed with error -22

Martin Owens (doctormo) wrote :
Aaron Plattner (aplattner) wrote :

The GPU is not responding correctly to CPU accesses, hence the nouveau error message of, "Unsupported chipset 0xffffffff". This is not a driver bug: it could be a bug in the kernel, or a hardware problem.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Glome (markus-ilmola) wrote :

I can confirm this bug.

I have GeForce 8600m GT on Acer ASPIRE 5920G laptop and have the identical problem. (low resolution with nouveau, black screen with nvidia-173 and only command line with nvidia-current (260)).

The same laptop with the same card works perfectly with Lucid using nvidia-current (195?) driver.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Invalid → Confirmed
Alberto Milone (albertomilone) wrote :

@Glom: it seems to be a kernel issue. See bug 661394

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Alex Bell (ubuntu-upb) wrote :

I've posted about this bug on forums.nvidia.com:
http://forums.nvidia.com/index.php?showtopic=199105
and on the www.nvnews.net:
http://www.nvnews.net/vbulletin/showthread.php?p=2424771#post2424771
Maybe someone will help us. :(

Alfred Homan (alfredhoman) wrote :

Still exists in today's 11.04. The only cure is to roll back to 2.6.32. Please make something.

Martin Owens (doctormo) wrote :

Yikes! This is a nasty problem made all the worse by system76 who don't believe us and can't reproduce it. :-/ I wonder if it's the nvidia plus compal board doing the nasty?

Jan Pešek (j-pesek) wrote :

I have the same problem with my MSI GX700px with nVidia Geforce 8600 GT. I can't boot to graphical mode because of the nVidia kernel module reports fail.

affects: nvidia-drivers-ubuntu → system76
Ken Alves (knalves) wrote :

Is there anything that can be done to get back into a somewhat normal boot mode? After the text "Kubuntu 11.04" comes up and some commands running underneath, the screen clears and then freezes. In Grub, I have to put a # next to: set gfxpayload=slinux_gfx_mode in order to get further into the boot sequence.

Is there a way to get back into graphical mode?

I'm getting the exact same symptoms (Unsupported chipset 0xffffffff / probe of 0000:01:00.0 failed with error -1), but I'm on a GeForce GTS 250, see my lspci output in bug 661394

daemonx (perutka-ondrej) wrote :

I agree with Alberto that it's most probably a kernel issue, because there are no problems in other distros (at least in Fedora and openSUSE). It could be a glitch in some of the ubuntu crazy kernel patches (I'd appreciate an option to turn them off)...

And finally, I have a question: Do you think there will be somebody going to fix this problem if this report is marked as invalid and all other related reports are marked as a duplicate?

@daemonx: I have the very same problem on Fedora rawhide, running kernel 2.6.38, so I don't think this is an ubuntu issue. (Fedora handles it silghtly better in that it will not give me a completely black screen, but actually boots up into graphical VESA mode).

daemonx (perutka-ondrej) wrote :

@Joakim: Sorry, this is a new information for me. I tried Fedora 14 a month ago and I had no problems.

Alfred Homan (alfredhoman) wrote :

It simply does not work with kernel > 2.6.32.
Affected all ubuntu systems > 10.04 LTS.
Changing nvidia driver does not help at all.

This is clearly not an nvidia-graphics-drivers but a regression in the linux kernel or kernel options.
Guys who build kernel for the ubuntu should just make a diff on 2.6.32 and find out what has been broken.

Affected hardware:

Asus M2N-68 (AMD on AM2) / NVIDIA GeForce 9800 GT (pci-e)
Acer Aspire 5920G (Intel Core 2 Duo T7300) / NVIDIA GeForce 8600M GT (pci-e)
some AMD 64 system / NVIDIA GeForce 7200 GS (pci-e)
N86PV-GS (AMD on AM2) / NVIDIA GeForce 9800 GTX (pci-e)

Solution I use for now:

sudo apt-add-repository "deb http://archive.ubuntu.com/ubuntu/ lucid main"
sudo apt-get update
sudo apt-get install linux-headers-2.6.32-21
sudo apt-get install linux-headers-2.6.32-21-generic
sudo apt-get install linux-image-2.6.32-21-generic

Ian Santopietro (isantop) wrote :

We tested a Serval SerP3 with an 8600M GT. With a fresh install of 11.04 and the latest Nvidia Driver (270.41.06). Everything runs fine. Please try a fresh installation of Natty and report back.

Ian Santopietro (isantop) wrote :

Sorry about the second comment. Please also run this command:

sudo dmidecode >> ~/dmiInfo

This creates a dmiInfo file in your home directory. Please send that to us via email or attach it to this bug report so we can check your specific hardware information.

Martin Owens (doctormo) wrote :

Attached is the dmi information, a fresh natty install just failed.

Did you install the nvidia driver yourself or did the system install it for you during the install?

Martin Owens (doctormo) wrote :
Alfred Homan (alfredhoman) wrote :

This is not only System76 issue, it's GTS 250, 9800 GT, 9800 GTX, 8600M, 9200M and probably a lot more.
There's atleast 15 ppl only on the launchpad.

Quotes:

"I am having the Exact same issue with my MSI GTS250"
"I have GeForce 8600m GT on Acer ASPIRE 5920G laptop and have the identical problem" - 2 with 5920g
"I'm getting the exact same symptoms (...), but I'm on a GeForce GTS 250"
"Asus M2N-68 motherboard and a generic 9800GT, all of which worked fine in Lucid"
"a similar Problem with my Dell Studio XPS 1340. (...) The 9400m works fine, but the 9200m is not working"

Nvidia site:

http://www.nvnews.net/vbulletin/showthread.php?p=2335295
"nvidia.ko says my GTS 250 is not supported on 260.19.xx"
"This is not an Nvidia issue, but a regression in the Linux kernel. The Ubuntu bug tacking this issue is:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/661394"

First time I faced this problem on 32-bit 10.10 (2.6.35), the only solution was kernel <= 2.6.32.
A few days ago I've tried an absolutely fresh installation of 11.04 x86_64.
No X server neither on default drivers nor latest nvidia drivers.
Had to roll back to 2.6.32 as well.

My system is AsRock N86PV-GS + Athlon 64 X2 + 9800 GTX
On any kernel >2.6.32 dmesg says: probe of 0000:02:00.0 failed with error -1

[ 9.563941] NVRM: The NVIDIA GPU 0000:02:00.0 (PCI ID: 10de:0614) installed
[ 9.563942] NVRM: in this system is not supported by the 270.41.06 NVIDIA Linux
[ 9.563943] NVRM: graphics driver release. Please see 'Appendix A -
[ 9.563944] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 9.563945] NVRM: available on the Linux graphics driver download page at
[ 9.563945] NVRM: www.nvidia.com.
[ 9.563951] nvidia 0000:02:00.0: PCI INT A disabled
[ 9.563975] nvidia: probe of 0000:02:00.0 failed with error -1
[ 9.564690] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 9.564692] NVRM: None of the NVIDIA graphics adapters were initialized!

dmiInfo attached

Alfred Homan (alfredhoman) wrote :

I think it might be somehow connected to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/342926

Alfred Homan (alfredhoman) wrote :

Just noticed after unplugging 9800 from the motherboard (N86PV-GS) 2.6.38 kernel works fine with the built-in card (GeForce 7050 PV in this case). Unfortunately there's no way to switch to it in the BIOS and it's not very fast.

TJ (tj) wrote :

This has no relationship to bug #342926.

To diagnose this issue it'd be useful to see the output of the lspci command for the video adaptor.

sudo sh -c 'lspci -nnvvvxxxx -q -d10de:* > /tmp/nvidia-lspci.log'

and then attach /tmp/nvidia-lspci.log to this bug report.

Alfred Homan (alfredhoman) wrote :

Attached.

daemonx (perutka-ondrej) wrote :

Here is my contribution...

daemonx (perutka-ondrej) wrote :

... and dmesg.

TJ (tj) wrote :

Thanks for the additional dmesg daemonx.

[ 25.243600] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[ 25.243608] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 25.243619] nvidia 0000:01:00.0: setting latency timer to 64
[ 25.243625] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[ 25.243660] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407) installed
[ 25.243661] NVRM: in this system is not supported by the 270.41.06 NVIDIA Linux
[ 25.243662] NVRM: graphics driver release. Please see 'Appendix A -
[ 25.243663] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 25.243664] NVRM: available on the Linux graphics driver download page at
[ 25.243666] NVRM: www.nvidia.com.
[ 25.243674] nvidia 0000:01:00.0: PCI INT A disabled
[ 25.243682] nvidia: probe of 0000:01:00.0 failed with error -1
[ 25.243714] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 25.243716] NVRM: None of the NVIDIA graphics adapters were initialized!

I zeroed in on the

 vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem

and looked at the git commit history of the VGA Arbitrator. It is present in v2.6.32 and therefore it's presence isn't the cuplrit.

I note that the nvidia drivers helpfully tells us that

nvidia: probe of 0000:01:00.0 failed with error -1

-1 is symbolically known as -ENOPERM (see include/asm-generic/errno-base.h) but in this case is not accurate. Looking at the nvidia kernel interface source-code I see:

    else
    {
        nv_check_pci_config_space(nv, FALSE);

        if (rm_is_supported_device(sp, nv) != RM_OK)
        {
            nv_printf(NV_DBG_ERRORS,
                "NVRM: The NVIDIA GPU %02x:%02x.%x (PCI ID: %04x:%04x) installed\n"
                "NVRM: in this system is not supported by the %s NVIDIA Linux\n"
                "NVRM: graphics driver release. Please see 'Appendix A -\n"
                "NVRM: Supported NVIDIA GPU Products' in this release's README,\n"
                "NVRM: available on the Linux graphics driver download page at\n"
                "NVRM: www.nvidia.com.\n",
                nv->bus, nv->slot, PCI_FUNC(dev->devfn), nv->vendor_id, nv->device_id,
                NV_VERSION_STRING);
            goto err_not_supported;
        }

so the crux is at:

rm_is_supported_device(sp, nv) != RM_OK

which is an Nvidia Resource Manager function:

$ grep 'rm_is_supported_device' /proc/kallsyms

f9e6fc68 t rm_is_supported_device [nvidia]

which is contained in the binary blob 'nv-kernel.o' for which we don't have source code.

grep -rn 'rm_is_supported_device' *
nv.c:4773: if (rm_is_supported_device(sp, nv) != RM_OK)
nv.h:618:BOOL NV_API_CALL rm_is_supported_device (nv_stack_t *, nv_state_t *);
Binary file nv-kernel.o matches

So this is an Nvidia issue with how Resource Manager compares the NV state pointer nvl->nv_state and the stack pointer sp.

Alex Bell (ubuntu-upb) wrote :

Installed 11.04 - not working.
Rolled back to 2.6.32 - working.
Well at least now I have 11.04 running notebook...

Aaron Plattner (aplattner) wrote :

TJ, that rm_is_supported_device function reads registers that it sounds like are reading back as 0xffffffff. You should be able to read the DWORD at BAR0 offset 0. If it reads as 0xffffffff, then the GPU is not configured correctly. You should be able to do that before even loading the NVIDIA RM.

daemonx (perutka-ondrej) wrote :

@TJ: Thanks for help. I mentioned the discovery at the nvnews forum...

TJ (tj) wrote :

@Aaron: Thanks for the explanation... we can dig back knowing what to look for now.

@demonx and others: Were the lspci results attached to your reports captured from a session where this bug was triggered? If not, can you boot those PCs into a configuration that triggers the bug and, if you have a console or SSH shell, re-run

sudo sh -c 'lspci -nnvvvxxxx -q -d10de:* > /tmp/nvidia-lspci.log'

and attach the results to a new comment that makes clear the log was captured whilst the bug was active.

Alfred Homan (alfredhoman) wrote :

@TJ: mine was made while the bug was active, no need to repost.

TJ (tj) wrote :

@Alfred: Thank-you! Looking at your log

https://launchpadlibrarian.net/70992967/nvidia-lspci.log

it shows that the BAR registers appear to contain sane values.

@Aaron: I think this is one for Nvidia, since we can't see what your binary blob is doing to cause the failure.

daemonx (perutka-ondrej) wrote :

@TJ: I checked my last lspci log and I'm sorry, it was wrong (I think I made it on system running 2.6.32 kernel). Attached is a new one. This one looks a bit different.

daemonx (perutka-ondrej) wrote :

Sorry again, I checked another lspci. Both my reports was correct :D...

Alex Bell (ubuntu-upb) on 2011-05-12
Changed in nvidia-graphics-drivers (Ubuntu):
status: Invalid → Incomplete
28 comments hidden view all 102 comments
marek k (marek-kozera) wrote :

I have the same problem on my laptop Compal FL90 and ubuntu11.10

when the bot system with kernel 3.0.0-10-generic error occurs offten
when the bot system with kernel 3.0.0-9-generic error not ocured

Previously, I had the same problem on other Linux distributions.

JANWAR (janwar) wrote :

Hi guys, its been a year since this bug has been found in ubuntu and now I'm tired of waiting for somone to fix it. Maybe its not worth to work on bugs that affects relative small group of users? Anyway, after 5 years using ubuntu I've switched to Sabayon because I dont't want to buy new hardware to be able to update my system (this is why I've switched from windows in the first place) . Now I'm on 2.6.39-sabayon and it's seams that this bug is not here. Everything works like a harm.

Martin Owens (doctormo) wrote :

Since the bug was introduced in 2.6.35 it's interesting that Saybon works without issues. Is it doing something different? Perhaps trying to install the Saybon kernel under Ubuntu to see if it works.

JANWAR (janwar) wrote :

I don't know what are the differences between Sabayon and Ubuntu kernels, but it works. Maybe installing Sabayon kernel in ubuntu will change something or maybe this is more complex problem. Anyway I can confirm that it works on kenel 2.6.39-sabayon, xorg-server-1.10.3, nvidia-drivers-280.13 packages from official sabayon repository. Sabayon6 x64. Oh and my hardware is Compal FL90 (Nvidia 8600M GT).

marek k (marek-kozera) wrote :
Download full text (3.5 KiB)

maybe this compal fl90 hardware problem ?? On my Ubuntu 11.10 only on kernel 3.0.0-9-generic bug no ocured

No good:
dmesg |grep 0000:01:00

[ 0.219419] pci 0000:01:00.0: [10de:0407] type 0 class 0x000300
[ 0.219468] pci 0000:01:00.0: reg 10: [mem 0xc6000000-0xc6ffffff]
[ 0.219521] pci 0000:01:00.0: reg 14: [mem 0xd0000000-0xdfffffff 64bit pref]
[ 0.219574] pci 0000:01:00.0: reg 1c: [mem 0xc4000000-0xc5ffffff 64bit]
[ 0.219609] pci 0000:01:00.0: reg 24: [io 0x2000-0x207f]
[ 0.219643] pci 0000:01:00.0: reg 30: [mem 0x00000000-0x0001ffff pref]
[ 0.257689] vgaarb: device added: PCI:0000:01:00.0,decodes=io+mem,owns=io+mem,locks=none
[ 0.257696] vgaarb: bridge control possible 0000:01:00.0
[ 0.328541] pci 0000:01:00.0: BAR 6: can't assign mem pref (size 0x20000)
[ 14.698217] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 14.698224] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 14.698236] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[ 14.698244] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 14.698255] nvidia 0000:01:00.0: setting latency timer to 64
[ 14.698261] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[ 14.698292] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407) installed
[ 14.698306] nvidia 0000:01:00.0: PCI INT A disabled
[ 14.698315] nvidia: probe of 0000:01:00.0 failed with error -1
[ 17.116986] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 17.116993] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 17.117005] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 17.117018] nvidia 0000:01:00.0: setting latency timer to 64
[ 17.117024] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=io+mem
[ 17.117060] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407) installed
[ 17.117076] nvidia 0000:01:00.0: PCI INT A disabled
[ 17.117087] nvidia: probe of 0000:01:00.0 failed with error -1
[ 17.161217] nouveau 0000:01:00.0: power state changed by ACPI to D0
[ 17.161223] nouveau 0000:01:00.0: power state changed by ACPI to D0
[ 17.161234] nouveau 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 17.161243] nouveau 0000:01:00.0: setting latency timer to 64
[ 17.162737] [drm] nouveau 0000:01:00.0: Unsupported chipset 0xffffffff
[ 17.163376] nouveau 0000:01:00.0: PCI INT A disabled
[ 17.163382] nouveau: probe of 0000:01:00.0 failed with error -22

OK

[ 0.231117] pci 0000:01:00.0: [10de:0407] type 0 class 0x000300
[ 0.231165] pci 0000:01:00.0: reg 10: [mem 0xc6000000-0xc6ffffff]
[ 0.231219] pci 0000:01:00.0: reg 14: [mem 0xd0000000-0xdfffffff 64bit pref]
[ 0.231272] pci 0000:01:00.0: reg 1c: [mem 0xc4000000-0xc5ffffff 64bit]
[ 0.231307] pci 0000:01:00.0: reg 24: [io 0x2000-0x207f]
[ 0.231341] pci 0000:01:00.0: reg 30: [mem 0x00000000-0x0001ffff pref]
[ 0.245657] vgaarb: device added: PCI:0000:01:00.0,decodes=io+mem,owns=io+mem,locks=none
[ 0.245664] vgaarb: bridge control possible 0000:01:00.0
[ 0.316558] pci 0000:01:00.0: BAR 6: can't assign mem pref (size 0x20000)
[ 0.318426]...

Read more...

marek k (marek-kozera) wrote :

nvidia bug repoort

JANWAR (janwar) wrote :

I don't think this is compal fl90 hardware bug, many people confirmed this bug on other hardware with 8600GT and 8600 GT mobile. Besides, this was working OK with older kernels and still works for me on Sabayon.

juliuszM (juliusz81) wrote :

Hi
I also have FL90 and this problem.
The last kernel I've been using without problems was 2.6.34. The next one was 2.6.36 and this one were generating errors. I couldn't load nvidia driver. It was random, I had to reboot two or three times to start properly. Now it's pernament. For quite a long time I've been using 2.6.34 kernel and installing the newest driver from source and it was working.
On some web page I've found solution which works for me.

  echo 1 > /sys/bus/pci/devices/0000\:01\:00.0/remove
  echo 1 > /sys/bus/pci/rescan

After that I can load driver and start X.
lspci -vvvxxx before and after gives results simmilar to that from Thomas Keil attachments

I attach whole lspci -vvvxxx output, maybe it will help

Martin Owens (doctormo) on 2011-09-23
summary: - Nvidia GeForce 8600M GT doesn't work with nvidia-current 260
+ PCI Race Condition with COMPAL FL90
2 comments hidden view all 102 comments
Chodid (philipp-chadid) wrote :

Any Progress on this Bug in the upcoming Release?

Martin Owens (doctormo) wrote :

Chodid - We're not sure, we know what the issue is, or there abouts, but have failed to attract the attention of a kernel developer to look into the problem.

Alfred Homan (alfredhoman) wrote :

Still exists on today's 10.11. Still no any solution whatsoever.
My configuration: N86PV-GS / NVIDIA 7200 GS / NVIDIA GeForce 9800 GT.
When I removed 9800 GT it worked fine on the embedded card (7200 GS).

Alfred Homan (alfredhoman) wrote :

Just found out, if I type the following:

sudo echo 1 > /sys/bus/pci/devices/0000\:02\:00.0/remove
sudo echo 1 > /sys/bus/pci/rescan

(sudo service lightdm start)

lightdm starts fine

But I can't figure out how to make it work automatically.
tried /etc/rc.local, /etc/init.d + all levels, inserted it right before lightdm.
The driver itself just fails in SysV (loading graphic drivers [fail]) and everything fallbacks to the console.

Any suggestions?

Alfred Homan (alfredhoman) wrote :

I just added those to the /etc/rc.local and the problem has been solved:
echo 1 > /sys/bus/pci/devices/0000\:02\:00.0/remove
echo 1 > /sys/bus/pci/rescan
service lightdm start

Legwan (legwanopole) wrote :

Can confirm that above method helps with Compal FL90 / GF 8600M GS
In my case device is called
/sys/bus/pci/devices/0000\:01\:00.0/remove

Before executing binary installer reports "no supported hardware"
After executing it goes fine and I even managed to kickstart xorg (i.e. got working unity with 3D)

Unfortunately it seems to have no effect on ubuntu drivers, only binary drivers from nvidia.com

Ale B (blackthunder87) wrote :

Hi, this solution works fine for me (Ubuntu Desktop 11.10 x86):

1 - clean install (from live CD)
* no download updates during setup
* no install 3rd party software during setup

2 - before rebooting PC after setup, run ctrl+alt+T
* sudo mount /dev/sda1 /mnt
* sudo mount --bind /dev /mnt/dev
* sudo mount --bind /dev/pts /mnt/pts
* sudo mount --bind /proc /mnt/proc
* sudo mount --bind /sys /mnt/sys
* sudo mount --bind /etc /mnt/etc
* sudo mount --bind /usr /mnt/usr
* sudo chroot /mnt

3 - che in the chroot terminal that only the nvidia-common are installed:
dpkg -l |grep nvidia

4 - if Yes, reboot PC else remove nvidia package and leave only the nvidia-common

5 - the 1st boot will work fine; at the login screen run ctrl+alt+Fn
6- in the teminal:
* sudo apt-get install -f
* sudo dpkg --configure -a

if it's all ok, do:

* sudo apt-get --purge remove xserver-xorg-video-nouveau
* sudo apt-get --purge remove nvidia*
* sudo apt-get clean && sudo apt-get autoclean && sudo apt-get autoremove

* sudo apt-get update && sudo apt-get install nvidia-common && sudo apt-get install nvidia-current
* sudo rm /etc/X11/xorg.conf*
* sudo nvidia-xconfig

* sudo nano /etc/default/grub

edit this and save:
GRUB_HIDDEN_TIMEOUT=""

7-
* sudo apt-get install --reinstall plymouth
* sudo update-grub2
* sudo update-initramfs -u
* sudo reboot

8 - now, you can try to boot s.o. from the kernel 3.0.0.14-pae

9 - if fail, reboot and select in grub > previous version the kernel 3.0.0.12

when the kernel load stop and seems to fail, press alt-ctrl+Fn and reply from "7"

I hope that this work for everybody ;)

Ale B (blackthunder87) wrote :

sorry, i forget to describe my PC: Acer Aspire 5920G@Intel Core 2Duo T7300 nVidia GeForce 8600M GT

Bryce Harrington (bryce) on 2012-02-04
Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Confirmed
Legwan (legwanopole) wrote :

Unfortunately blackthunder's method is not working for me (IFL90)

Recently I've tried two distros (namely ARCH and Fedora) and BOTH have the same problem as Ubuntu. Therefore problems seems to be in kernel itself

I've managed to dig out that compal and other VBI have graphic card BIOS (vbios) saved on mainboard instead of card itself. It would explain why some 8600M works while others don't.

Source: https://bbs.archlinux.org/viewtopic.php?id=110138

The same post gives some interesting ideas which I'll try soon... best bet is "pci=bios" in grub kernel invoke

Martin Owens (doctormo) wrote :

I can confirm the bios=pci method on this COMPAL FL90 (System76 Pangol') after testing every kernel option with multiple boots (7 each) it's the only thing that would start the computer even into safe mode... which is odd since you wouldn't think safe mode would have anything to do with the graphics card driver.

Legwan (legwanopole) wrote :

Confirmed - pci=bios solved the problem for me. Note it wont work on 64bit architectures.

Philipp Chadid (chodid) wrote :

How do I introduce the pci=bios into the kernel at the beginning of the boot process?
And is there any way to modify this solution in order to get it to work on 64bit?
Best regards

marcosegato (marco-segato) wrote :

You need to modify /etc/default/grub and add this line:
GRUB_CMDLINE_LINUX="pci=bios"
Than, make:
sudo update-grub

Admir Hodzic (adopilot) wrote :

Is there any chance that Unbuntu is going to release version that will work whit nvidia 8600m GT.
My laptop Acer aspre 5920 sucks without 3d drivers.
It justu works wit earlier versions of Unbuntu ?

Martin Owens (doctormo) wrote :

Admir - It's not an Ubuntu problem, it's a Linux kernel problem. Not that anyone will admit that long enough to look into fixing it ;-). for now we can all use the setting bios=pci in the grub's linux kernel init configuration.

and wait.

Admir Hodzic (adopilot) wrote :

@Martin Owens
Thanx for info,
I am totally new to linux,
Is there any step by step guide to edit grub's settings ans set bios=pci
Or can You be so kind to in short lines describe how i can set bios=pci settings.
Thanks in advanced

Martin Owens (doctormo) wrote :

Admir: The magic of AskUbuntu Answers: http://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

Just put bios=pci in instead of the example.

Thax a lot.

Forgive me,
Another question.
Should I
Install nvida driver and then do edits in kerner "bios=pci" ?

Or I need first to edit kernel and then to install nvdia driver.

Or I shoud skipp instaling nvidia driver at all until someone edit kernel
BUG.

Once again Thany a lot.
Best regards
Admir

Dana 5. travnja 2012. 15:30 Martin Owens <email address hidden> je napisao/la:

> Admir: The magic of AskUbuntu Answers:
> http://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-
> parameter
>
> Just put bios=pci in instead of the example.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/661248
>
> Title:
> PCI Race Condition with COMPAL FL90
>
> Status in System76:
> New
> Status in “nvidia-graphics-drivers” package in Ubuntu:
> Confirmed
>
> Bug description:
> I'm reporting this bug so I can attach the three dmesg reports, one
> for nouvou, one for nvidia-173 and one for nvidia-260.
>
> nouvou works but has low resolution.
> nvidia-173 produces a black screen and crashes the entire machine (force
> power off required)
> nvidia-260 dumps into command line
>
> OS: Ubuntu 10.10
> Card: Nvidia GeForce 8600M GT
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/system76/+bug/661248/+subscriptions
>

Chodid (philipp-chadid) wrote :

I just installed 12.04 beta2 and the pci=bios solution works flawlessly under 32bit.
After the initial installation you edit the grub settings and add the pci=bios option, then after update-grub you can install the nvidia drivers.

In a terminal type:
sudo gedit /etc/default/grub

look whether there already is an existing GRUB_CMDLINE_LINUX="" and change it to GRUB_CMDLINE_LINUX="pci=bios", if it doesn't exist then just add the GRUB_CMDLINE_LINUX="pci=bios" to the file and save it.

type sudo update-grub, install the Nvidia drivers and restart your computer - it should work.

Martin Owens (doctormo) wrote :

Admir,

Edit the setting while your computer is still working. Doing something
with nvidia before you have the setting in place could leave your
computer unable to boot.

Hello,

I'm runnung
--------------------------------------------------
Xubuntu 12.04
3.2.0-24-generic
On Aspire 5920G (as few others in this thread).
--------------------------------------------------

It has been a nightmare since I decided to updrade my Lucid which was perfectly working into a Pangolin.

I applied blackthunder's procedure to clean up the mess I might have done after my dozen of chroot remove / install drivers.
Plus I modified the grub with the bios=pci command suggested by Legwan.

I finally could reboot twice without a blank screen ! nvidia-settings even find the conf file. And I'm not stuck with an ugly standard resolution on my wide screen (I was starting to find everyone a bit slim in the street Oo)

So everything is working like a charm.
A big thank you to you all !

If needed I can provide some more logs but it seems we have enough and only need a kernel fix in here

Legwan (legwanopole) wrote :

Short update on my situation.
I had no problems whatsoever with Linux since I've moved back to 32bit. Furthermore I don't even need to use the pci=bios parameter anymore - as long as it's x86-32 Linux it just works out of the box.
It would be nice to have 64bit version though (for stuff like matlab or 3+ GB RAM native, without PA)

Main problems seems to be a "non-standard PCI host bridge" used with GF8600M configurations. Unfortunately it seems like never to be solved since less and less people tend to have this hardware (even I will get something new soon).

So far one partial solution - USE 32BIT VERSION, if still not working use "pci=bios" kernel parameter on boot

Martin Owens (doctormo) wrote :

Hey Legwan, the problem that the majority on this bug report are suffering, is with the 32bit version. That this version works for you, probably means it's a different bug. Or perhaps a related bug.

For everyone else using the 32bit version and getting creamed by a faulty linux kernel, try the fix suggested with pci=bios in your grub config.

Ian Santopietro (isantop) wrote :

Since this works in 64-bit, and since the FL90 is no longer a supported System76 System, this is being marked "Won't Fix" in System76.

Changed in system76:
status: New → Won't Fix
Displaying first 40 and last 40 comments. View all 102 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers