Comment 5 for bug 661248

The following lines in dmesg show that the driver complains about the fact that the card is not supported:

[ 18.981091] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0407) installed
[ 18.981092] NVRM: in this system is not supported by the 260.19.06 NVIDIA Linux
[ 18.981093] NVRM: graphics driver release. Please see 'Appendix A -
[ 18.981095] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 18.981096] NVRM: available on the Linux graphics driver download page at
[ 18.981097] NVRM: www.nvidia.com.
[ 18.981103] nvidia: probe of 0000:01:00.0 failed with error -1
[ 18.981128] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 18.981130] NVRM: None of the NVIDIA graphics adapters were initialized!

I find it a bit weird as GeForce 8600M GT should be supported:
http://www.nvidia.com/object/linux-display-ia32-260.19.12-driver.html

I'm subscribing Nvidia to this bug report