Ubuntu

Compal/nvidia breakage in system76 laptops

Reported by Martin Owens on 2010-10-15
This bug report is a duplicate of:  Bug #661248: PCI Race Condition with COMPAL FL90. Edit Remove
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

We found an odd bug in the maverick kernel 2.6.35 which prevents the nouvou and nvidia drivers from loading. (original bug https://bugs.edge.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/661248 )

The problem can be seen in the lspci -nnv output which reports the subsystem of devices as [0000:0000] instead of what's expected.

Attached is 3 failing dmesg logs, the lcpci output and the working dmesg log from the lucid kernel on maverick.

Martin Owens (doctormo) wrote :
Martin Owens (doctormo) wrote :
Martin Owens (doctormo) wrote :
description: updated
Jeremy Foshee (jeremyfoshee) wrote :

Thanks for the report. I have set the bug importance to Medium pending review.

~JFo

tags: added: kernel-core kernel-needs-review kj-triage
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
seraphym (seraphym) wrote :

Uh, is it possible to up priority for this issue? working in low-res soft-mode isn't all that fun :(

I also have this problem, here is my lspci -vvnn
Tell me if there is any more relevant information I can provide.

daemonx (perutka-ondrej) wrote :

Same problem. My dmesg and lspci are in the #664778 bug report.

Alfred Homan (alfredhoman) wrote :

Same problem. Went through all ubuntu kernels from 2.6.36 to 2.6.32 it works only on 2.6.32, looks like it was broken since LTS.

daemonx (perutka-ondrej) wrote :

Following solution worked for me:

1) add 'deb http://archive.ubuntu.com/ubuntu/ lucid main' into your sources
2) install linux-headers-2.6.32-21, linux-headers-2.6.32-21-generic and linux-image-2.6.32-21-generic packages
3) reboot and in the GRUB menu choose Linux kernel 2.6.32
4) use jockey to install NVIDIA current drivers
5) reboot

Booting in 2.6.32 works for me too, but it would be nice to not have to use an old kernel.

igloo (igloo-enzy) wrote :

This looks like the bug that's affecting me as well. Same symptoms - can't load any NVIDIA drivers on the 2.6.35 kernels. Tried 32 and 64bit kernels, and flipped every switch there is to flip in my BIOS. This is incredibly frustrating, and it's only one of many bugs I'm suffering from in Maverick.

This is a desktop machine with an Asus M2N-68 motherboard and a generic 9800GT, all of which worked fine in Lucid.

daemonx (perutka-ondrej) wrote :

The problem seems to be gone after the latest kernel update.

daemonx (perutka-ondrej) wrote :

Unfortunately it appeared again after couple of rebots...

Conker (conker-ts) wrote :

Hi, I think I've got a similar Problem with my Dell Studio XPS 1340.
There are 2 nvidia cards installed, a chipset 9400m and a 9200m gs.
The 9400m works fine, but the 9200m is not working.

[ 15.891446] NVRM: The NVIDIA GPU 0000:02:00.0 (PCI ID: 10de:06e8) installed
[ 15.891447] NVRM: in this system is not supported by the 260.19.06 NVIDIA Linux
[ 15.891448] NVRM: graphics driver release. Please see 'Appendix A -
[ 15.891448] NVRM: Supported NVIDIA GPU Products' in this release's README,
[ 15.891449] NVRM: available on the Linux graphics driver download page at
[ 15.891450] NVRM: www.nvidia.com.

Currently I'm just switching it off with this hack:
http://luizfar.wordpress.com/2010/06/29/how-to-switch-off-xps1340-discrete-video-card-on-linux/

Don't know if it's this bug, but this seems similar.

Glome (markus-ilmola) wrote :

I just tested Ubuntu 11.04 Alpha 1 and this bug is still present.
I also tested Fedora 14 and it does not have this bug.

Using Acer Aspire 5920G laptop with Nvidia 8600 GT video card.

Glome (markus-ilmola) on 2010-12-09
tags: added: regression-release
JANWAR (janwar) on 2010-12-18
description: updated
Dmitry (df2) wrote :

Confirm presence of bug in 10.10, really annoyed falling back to old kernel after every kernel update.

Glome (markus-ilmola) wrote :

Tested with Ubuntu 11.04 Alpha 2 and this bug is still present.
Has anyone else tested Ubuntu 11.04 to see if the bug still exists?

Glome (markus-ilmola) wrote :

Just tested OpenSUSE 11.3 and it does not have this bug.
Since Fedora 14 does not have this bug either it seems that this is Ubuntu only bug.
This is weird since both Fedora 14 and OpenSUSE 11.3 use kernel newer than 2.6.32 which is the last that works with Ubuntu.

Włodek (klata-pirata) wrote :

I confirm the existence of this bug on my system. It started showing right after the upgrade from 10.04. This is a VERY annoying bug as it happens randomly. Manually installed drivers do not work either...

Dmitry (df2) wrote :

It happens not randomly, but after each kernel update.

marcosegato (marco-segato) wrote :

I can confirm this bug, both in 10.10 and 11.04, when using kernel > 2.6.32

Chodid (philipp-chadid) wrote :

This bug affects me as well, my system having a NVIDIA Geforce 8600M GT graphics card.

Alex Bell (ubuntu-upb) wrote :

This bug affects me as well, my laptop have a NVIDIA Geforce 8600M GT graphics card.
I've read several reports of this bug, but didn't find thread about it at nvidia forum.
So I've created it: http://forums.nvidia.com/index.php?showtopic=199105

Alex Bell (ubuntu-upb) wrote :

Also I've tried to register and post here: http://www.nvnews.net/
But there is some trouble with registration and I can't get activation email.

Same problem with me too. I can confirm this bug too, in 10.10 and 11.04, when using kernel > 2.6.32. The last ubuntu distro that works for me is 10.04 LTS

Geforce 7200GS, amd64, 4GB Ram

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers