Far left character in panel (and launcher popups) distorted

Bug #927441 reported by D. Wegener on 2012-02-06
496
This bug affects 82 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Jay Taoko
Unity
Fix Released
High
Unassigned
Unity Distro Priority
Undecided
Unassigned
nux (Ubuntu)
High
Unassigned
Precise
High
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

After one of the recent Precise updates, I have noticed that the first character in the Unity panel is distorted. It almost looks like the character is being partially offset by a couple of pixels. A similar issue shows up in the popups on icons in the Unity launcher when hovering over the icon.

The distortion is also visible on the window close icon when the mouse is on the Unity Panel and the icons and menu are displayed.

I have screen shots of each distortion attached.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic 3.2.3
Uname: Linux 3.2.0-14-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: i386
CheckboxSubmission: 21a3f7508cdc22a53dbe8d10fbb1ff75
CheckboxSystem: 9c26adf6eed2f681ba41f94dd24c07e4
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,mousepoll,snap,gnomecompat,place,move,vpswitch,session,resize,grid,compiztoolbox,imgpng,animation,unitymtgrabhandles,wall,workarounds,expo,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Sun Feb 5 22:03:33 2012
DistUpgraded: Log time: 2012-01-14 19:12:09.789886
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Beta i386 (20100318)
MachineType: ASUSTeK Computer INC. 1005PE
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-14-generic root=UUID=e51e9d51-95b3-477e-ab92-4de17cfc33c3 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-01-15 (22 days ago)
dmi.bios.date: 06/23/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1202
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1005P
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1202:bd06/23/2010:svnASUSTeKComputerINC.:pn1005PE:pvrx.x:rvnASUSTeKComputerINC.:rn1005P:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1005PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.11.3-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901-1ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

D. Wegener (dpwegener) wrote :
Omer Akram (om26er) wrote :

I confirm it on my netbook that has intel GPU.

Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in unity:
importance: Undecided → High
status: New → Confirmed
milestone: none → 5.4.0
Omer Akram (om26er) on 2012-02-06
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
Jay Taoko (jaytaoko) wrote :

I can reproduce the issue on a Dell mini 9. It seems that only older Intel GPUs are affected. This points to a driver bug for those GPUs.

Omer Akram (om26er) on 2012-02-07
Changed in nux:
assignee: Jay Taoko (jaytaoko) → nobody
no longer affects: nux
affects: unity (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in unity:
milestone: 5.4.0 → none
status: Confirmed → Invalid
Omer Akram (om26er) on 2012-02-09
Changed in xserver-xorg-video-intel (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
KodduX (tvdkodde) wrote :

It also happens on ATI Radeon HD4850.

Omer Akram (om26er) wrote :

Tim, can you please attach a screenshot of the issue please. also paste the output of

$ lspci | grep "VGA"

KodduX (tvdkodde) wrote :

tim@bigtim:~$ lspci|grep "VGA"
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4850]

In the screenshot you see a distorted 'G' in the Unity panel (top left) and a distorted 'G' on the Chrome launcher.

KodduX (tvdkodde) wrote :

Same issue on VirtualBox

Omer Akram (om26er) wrote :

@Jay, now we have a confirmation with ATI as well, this may well fallback to NUX it seems.

Greg A (etulfetulf) wrote :

There's a thread of the forums about this: http://ubuntuforums.org/showthread.php?t=1919448

Just to add my contribution. Note in the screenshot the distortion on "Recent Apps" and also on the X button in the top left.

greg@greg-precise:~$ lspci|grep "VGA"
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Radeon HD 4350]
greg@greg-precise:~$

Changed in unity:
status: Invalid → New

I see the exact same thing as Greg Auger using RV780. HD3100, I think.

The same thing happens to the first character in the panel when it shows the window title, but when the window controls are displayed, there's no sign of it.

Omer Akram (om26er) wrote :

I had a chat with Jay yesterday and he is able to reproduce the issue as well. I have to test if the issue happened on Alpha2 and then just update Unity there on the live session and restart Unity to check if the issue happens. Since Jay thinks the issue is in mesa.. I'll do that tomorrow, unless someone else beats me to it ;-)

Omer Akram (om26er) on 2012-02-18
affects: xserver-xorg-video-intel (Ubuntu Precise) → unity (Ubuntu Precise)
Changed in unity:
status: New → Confirmed

I can reproduce this bug on an Acer D255 with Intel's N450 and a Sony VAIO VGN-C140G.
Screenshots are attached in duplicated Bug #931924

Andrea Grandi (andreagrandi) wrote :

I confirm this bug on my netbook too. I think I've the same Omer's netbook: Asus 1215P.

Omer Akram (om26er) wrote :

I just booted Precise Alpha 2 the issue was not there, then I just updated Unity (it pulled in latest NUX and compiz ofcourse). restarted Unity and the issue appeared so its an issue in NUX or Unity,.

Changed in nux:
importance: Undecided → Critical
status: New → Confirmed
importance: Critical → High
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
milestone: none → 5.6.0
David Raid (davidraid) wrote :

Same problem on an Acer 6920g with an ATI graphics card. It's visible on both the default opensource drivers and the FGLRX drivers, so I don't think it's a graphics driver issue. Quite annoying looking, wasn't present in Oneiric or Natty.

Anders Nor Berle (berle) wrote :

Confirmed for Intel 945GME.

Martin Pitt (pitti) on 2012-03-02
Changed in unity (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
brett johnson (nowerries) wrote :

Notice the distortion as well running amd radeon hd 4200 with ati catalyst driver 11.11.

André Lopes (zipatei) wrote :

The same issue...

Francesco Ferraro (ferraro96) wrote :

Same here.

~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)

Francesco Ferraro (ferraro96) wrote :

Same here.

~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)

Dario Cavedon (dcavedon) wrote :

Same here:

~$ lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]

Got the same on the Lenovo Ideapad s10e.

Tim Rawlinson (tim-r) wrote :

The same thing happens for me with many (most?) of the items on the Keyboard Shortcuts overlay. Screenshot attached.

abhijeet (abhijeetnayak) wrote :

This is also happening with the unity filter text.

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Christian Mariucci (cmariucci) wrote :

I've tried three different mainboard with IGP:
The ones with an intel gma 950 and an ati hd 4200 has this problem.
The mainboard with an Geforce 7050PV doesn't have this problem.

Sorry for my orrible English, btw I hope it's clear. :)

Britt Yazel (bwyazel) wrote :

I am running Precise with and AMD radeon HD 4200 just like the person above me ^ and I have this same problem along with a fair amount of screen flicker.

Daniel van Vugt (vanvugt) wrote :

Britt, the screen flicker is not related to this bug. Most likely it's caused by the default driver settings in the AMD Catalyst driver. Instructions for fixing that are near the top of bug 880707.

If you're not using Catalyst (fglrx) and are using the open source radeon driver then please log a new bug for the flicker issue, with video.

Britt Yazel (bwyazel) wrote :

Thanks for the tip. I reported the bug on the opensourced graphics drivers a while back (Bug #933289). If you have any tips for this please take a look at the bug as it has been stagnant for a while.

Josh Wood (ninjaschwa) wrote :

Same here

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series]

Britt Yazel (bwyazel) wrote :

It seems that there is a high number of people with this bug running the Mobility Radeon HD 4200 series. Is there something that could be only impacting the rs880 driver?

Jim (jimvernon) wrote :

I'm having this problem with a Radeon HD 4650. There's no difference between the AMD or open source drivers.

Britt Yazel (bwyazel) wrote :

Perhaps it is an issue with AMD cards in general. There didn't used to be this issue, and it is relatively new as of a few weeks.

David Raid (davidraid) wrote :

Possibly. I'm using a Radeon HD 3650 and I have the problem with both the default open source drivers and after compiling and installing the latest proprietary AMD catalyst drivers.

Daniel van Vugt (vanvugt) wrote :

The problem appears to be specifically the Unity textures rendered with Nux. Fortunately, it's already assigned to Jay...

zarquon42 (zarquon42) wrote :

I'm affected using my laptop with ATI HD 4670, both with open source and fglrx drivers. On my desktop with NVIDIA 9800gt everything is fine.

Michael Hope (michaelh1) wrote :

The first letter of each sentence in the keyboard shortut popup is streatched as well.

D. Wegener (dpwegener) wrote :

Based on comment #36 and textures, I notice that my .xsession-errors file contains some messages regarding compiz having problems binding a texture:

compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: failed to bind pixmap to texture
compiz (decor) - Warn: failed to bind pixmap to texture

Daniel van Vugt (vanvugt) wrote :

Those compiz warnings are not related to this bug. But compiz does have bugs with binding pixmaps to textures...

This bug appears to be just with Unity textures rendered using the Nux library.

greg (grigorig) wrote :

I think I figured this out. libnux does some elaborate adjustments to texture coordinates to make sure texels are always sampled at the midpoint, for clean nearest sampling, but this is wrong: the fragment sampling grid already ensures that! So the elaborate adjustment does the opposite: the sampling positions are moved to the boundaries between the texels, and that is why we're seeing this flaky behavior with different hardware.

greg (grigorig) wrote :

Here's Unity with linear sampling forced. The blurryness is a clear sign that centered sampling is not working, as that would yield a result similar to nearest sampling.

tags: added: rls-mgr-p-tracking
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
David Barth (dbarth) on 2012-03-23
Changed in nux:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
Britt Yazel (bwyazel) wrote :

This issue is not fixed on my system. There is no difference since the update today

Jim (jimvernon) wrote :

Britt, a committed fix is not necessarily in the repositories yet.

Omer Akram (om26er) on 2012-03-24
affects: unity (Ubuntu Precise) → nux (Ubuntu Precise)
Changed in unity-distro-priority:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
André Lopes (zipatei) wrote :

Let me take this topic to filter another bug 948445.

None of you have this problem of corruption of graphics?

http://imageshack.us/photo/my-images/818/screenshotfrom201203062.png/

Jim (jimvernon) wrote :

No, no issue like that Andre. Might want to try reinstalling your video drivers.

Also, I just installed the newest Unity packages from the Unity-Team/Staging PPA and the visual glitch with the far left characters seems to be gone.

Niclas Kiefer (niclas-kiefer) wrote :

It isn't yet fixed for me too ... But thanks Jim for the tip of adding the Unity-Team/Staging PPA. Unfortunatelly it didn't work out as i hoped.

Changed in unity (Ubuntu Precise):
importance: Undecided → High
Changed in nux (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Changed in unity (Ubuntu Precise):
milestone: none → ubuntu-12.04
David Barth (dbarth) on 2012-04-06
Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
burli (mb-embedit) wrote :

Still have this issue on a fresh installed HD4350 with Radeon driver. Also on a Laptop with GMA950 and a Netbook with Atom N450.

I do NOT have this issue on Atom 330 and Atom N455 (Viewsonic Viewpad 10)

Nekhelesh Ramananthan (nik90) wrote :

burli, could you run "unity --version" in the terminal without quotes and check which version of Unity you are running. This has been fixed in Unity 5.10 which has not been released yet. So you could be running Unity 5.8 which does have this fix yet and hence the cause for you to experience it.

burli (mb-embedit) wrote :

nik90, ok. I have Unity 5.8.0 here. I will wait than for 5.10 and test again. When will it land in Ubuntu?

Didier Roche (didrocks) on 2012-04-12
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Nekhelesh Ramananthan (nik90) wrote :

burli, it says fix released meaning you should get it very soon when the repos around the world have synced with the official ubuntu servers.

Joel Pickett (jpickett) wrote :

the -proposed package has fixed it

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/927441

tags: added: iso-testing
Kieran Hogg (xerosis) wrote :

Can confirm the -proposed fix has worked.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.10.0-0ubuntu1

---------------
nux (2.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_datalist_id_set_data_full() from ...
      from unity::PanelTray::~PanelTray() from ... from
      unity::panel::Controller::Impl::OnScreenChanged (LP: #921316)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - [dash] Dash does not render "panel line" (LP: #926344)
    - [multi-monitor] DND doesn't work for the launchers in other monitors
      (LP: #965025)
    - Unity dash can't select items using keyboard when ibus is active
      (LP: #973344)
  * debian/rules:
    - remove disable-tests are now tests are only build if the right build-dep
      are here.
  * debian/control:
    - add libxtst-dev as nux Makefile rules are broken and still try to include
      the .h files even if the pc file check failed.
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 15:14:45 +0200

Changed in nux (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers