provide support for changing volume labels

Bug #68924 reported by Dave Morley on 2006-10-28
202
This bug affects 21 people
Affects Status Importance Assigned to Milestone
HAL
Won't Fix
Wishlist
Nautilus
Expired
Wishlist
One Hundred Papercuts
Undecided
Unassigned
hal (Ubuntu)
Wishlist
Unassigned
Nominated for Lucid by komputes
nautilus (Ubuntu)
Wishlist
Unassigned
Nominated for Lucid by komputes

Bug Description

My old MP3MAN 1/2 gig mp3 player is able to be renamed in Windows but not in Ubuntu. I'm not sure if this is something that all players can do but it is something that could be well worth looking into (as I don't have a windows machine my mate renamed mine and I have a new samsung player now, for it's ogg support). Effectively in windows you right click on the player icon and hit rename and the player retains that name when you plug into any machine (I will send a screen shot) so mine now says DAVES MP3 rather than mp3man.

This is not an urgent bug by any means but it is one thing I noticed that can't yet be done. I want to see bug 1 stripped out as soon as possible but it is always the little things that annoy people.

* From duplicate bug #388207, I add emphasis that volumes should be re-namable using right-click. This may be obvious, but "let the record show" that volumes should act like all other files with respect to renaming.

Dave Morley (davmor2) wrote :

It would be nice if hal would export a dbus function API for changing the label of a volume. nautilus could then call this through gnome-vfs2 to provide intuitive changing of labels with F2 or 'Rename' on a volume icon.

Martin Pitt (pitti) wrote :

Indeed, the current lack of a possibility to change volume labels sucks.

AFAICS hal should explort a function to change the label of a volume, and nautilus/gnome-vfs should use it.

Changed in gnome-volume-manager:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in hal:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in hal:
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Triaged
chuyler1 (chris-huyler) wrote :

This bug has been open for 2 years and has eight duplicates and yet is still considered "wishlist"? Any chance in upping the priority on such a visible bug?

Sebastien Bacher (seb128) wrote :

the bug is a request for a new feature, that's a wishlist by definition

chuyler1 (chris-huyler) wrote :

Ok, but changing the volume name on a drive is hardly a "new feature". It's something people have been used to doing since the days of DOS. Is there at least a command-line work-around that could be posted for those that would really like to change the names of their removable memory cards?

A. Walton (awalton) wrote :

It is, however, a new feature for Nautilus. And it's a non-trivial issue, since setting volume labels properly needs root permissions on *N*X systems. We may work around this with a .desktop file on the volume's root (we're currently discussing this solution for removable devices on the GVFS mailing list), but it hasn't been decided as of yet.

Until then, you can set the volume label properly using the methods mentioned here:
https://help.ubuntu.com/community/RenameUSBDrive

And you can follow the discussion on the list:
http://mail.gnome.org/archives/gvfs-list/2008-August/msg00007.html (continues on into September).

Chris Coulson (chrisccoulson) wrote :

DeviceKit-disks exports a function to allow you to change volume labels, so this bug should be more trivial to fix once that is adopted shouldn't it?

Hmmm yes thanks Chris, I'm beginning to understand that these names are
volume labels...and that I will have to get used to that...

Chris Coulson wrote:
> DeviceKit-disks exports a function to allow you to change volume labels,
> so this bug should be more trivial to fix once that is adopted shouldn't
> it?
>
>

description: updated
pranith (bobby-prani) on 2009-06-20
Changed in hundredpapercuts:
status: New → Confirmed

dk-disks FTW

Changed in hal:
status: Confirmed → Won't Fix

This is not papercut-sized (it is relatively difficult to fix).

Changed in hundredpapercuts:
status: Confirmed → Invalid
Aleve Sicofante (sicofante) wrote :

I said it before, but let's go again:

Write a script that does this:

1- Ask for administrative permissions.
2- Unmount the volume if it is mounted.
3- Check for the file system in place.
4- Use the appropriate command to change the volume label.
5- Mount the file system back if it was mounted before.

You may say this is a workaround. You may say it's not "elegant" (whatever that means). You may say it's a hack. You may even say you simply do not want to do it, but please stop saying it's either difficult or not "papercut-sized".

To anyone else having some knowledge of bash scripting and willing to help: be kind and write that simple script.

Vish (vish) wrote :

Volume labels can be changed using gparted. It is not installed by default , but is present in the LiveCD.

This is not a solution , but IMO a better workaround.

Chris Coulson (chrisccoulson) wrote :

sicofante - this should be fixed properly using libgdu / devicekit-disks, and not by some hacky script.

Aleve Sicofante (sicofante) wrote :

coulson: why? End users don't give a damn about the implementation details. I can't see the advantage of not creating a solution that works in a couple of days instead of waiting endlessly for someone to do it "properly". Nothing stops you from doing the "proper" solution later. My proposal is definitely easy to implement and is a shortcut to what Gparted does already.

If this is about making life easier to end users, then "hacky" or "proper" is meaningless. If this is about academic correction then you're right.

(The discussion is somewhate futile. The Big Brother has already dismissed this and us poor end users will have to wait probably another three years. I can't believe this bug is from 2006.)

komputes (komputes) wrote :

Nautilus currently does not support renaming partitions, this bug proposes to change this. I completely agree.
Does this mean these packages will ship with the distro?:
ntfsprogs
jfsutils
reiserfsprogs
xfsprogs

If palimpsest (Disk Utility in Karmic) or gparted (GNOME Partition Editor) can re-label an unmounted disk, why not have nautilus do the same thing (i.e. call on the same command line programs that palimpsest and gparted use) to re-label disks?

I have a concern though. I have noticed is that you must *unmount* a disk before renaming in. In my (mac/win) experience you can rename a disk as is, in a mounted/unmounted state (in the finder/explorer). If this is a technical limitation, I think the label change can be held on to until the user unmounts the disk or shuts down the system.

If someone can explain why Mac/Win users can rename a disk while mounted but we have to unmount to rename, please let me know.

Chris Coulson (chrisccoulson) wrote :

This functionality will not be implemented in HAL

Changed in hal (Ubuntu):
status: Confirmed → Won't Fix
Aleve Sicofante (sicofante) wrote :

>>This functionality will not be implemented in HAL
>>
>>Changed in hal (Ubuntu):
>>status: Confirmed → Won't Fix

May I ask what does this mean exactly? That this is not HAL related or that someone with enough power to say so decided this bug will not be fixed ever?

Thanks for any explanation.

Chris Coulson (chrisccoulson) wrote :

It means that no new features are being added to HAL, as it's being deprecated. DK-disks already exports methods for changing volume labels.

Igor Wojnicki (wojnicki) wrote :

Chris. So what is the problem then? DK exports apropriate methods to relabel volumes, nautilus uses DK, so there should not be any problem with implementing it... is there any word from the upstream about that?

Is there any progress on this issue yet?
Creating a .desktop file for a new volume name definitely falls into the "hacky inelegant solution" bucket, since .desktop files aren't universally recognised.
Taking the gparted approach means that you're stuck with upper-case labels, i.e.: "CruzerKey" becomes "CRUZERKEY"
New Ubuntu users shouldn't have to resort to the command line to do something this simple, especially when it can be done from the GUI of other operating systems.
Nautilus can specify a volume label when formatting a volume (and it can be mixed-case), so why can't Nautilus rename a volume without formatting it?

komputes (komputes) wrote :

Hi AlwaysLearning,

From what I know there is currently nobody working on integrating partition label name changes into nautilus. There are currently utilities that can change the disk label. There are multiple command line utilities which do this, but this is undesirable for the average user. The graphical utilities that can accomplish this are gparted (only when creating a new partition, not after) and palimpsest (also known as Disk Utility, available in karmic).

The upstream freedesktop bug was marked as WONTFIX, so there is little chance there. Looking at the GNOME bugzilla, I could not find a bug, so I have created it and liked it to this bug. As well the description of this bug is not the best out of all 12 duplicates. Work should be done to select the best bug out of them all or clean up the description into a new Master/working bug and mark this one as a duplicate. Cheers.

https://bugzilla.gnome.org/show_bug.cgi?id=605783

Changed in nautilus:
status: Unknown → New
Changed in hal:
importance: Unknown → Wishlist
Changed in nautilus:
importance: Unknown → Wishlist
Changed in hal:
importance: Wishlist → Unknown
Changed in hal:
importance: Unknown → Wishlist
komputes (komputes) on 2012-03-20
tags: added: css-sponsored-p
Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Hans Deragon (deragon) wrote :

Fix released; that is great news. Will it be available shortly on Ubuntu 12.04 and 13.04?

Reuben Thomas (rrt) wrote :

I can find no evidence that this bug has ever been fixed, even in Ubuntu. Can anyone point me to evidence that it has been?

Changed in nautilus:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.