double tap does not open folders or files in Nautilus

Bug #1071922 reported by Jani Monoses on 2012-10-26
116
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
James M. Leddy
Quantal
Medium
James M. Leddy
ubuntu-nexus7
High
Unassigned
nautilus (Ubuntu)
Low
Canonical Desktop Team
Precise
Low
Unassigned
Quantal
Low
Unassigned
Raring
Low
Canonical Desktop Team

Bug Description

[Impact]

Nexus7 and some Dell touch screen devices do not work well with nautilus. This makes browsing files almost impossible in these devices. Further it's frustrating to the user because there is nothing that makes it immediately apparent that

[Test Case]

1. Install Ubuntu
2. Double tap to open a folder in nautilus

[Regression Potential]

Low, this fix just affects touch screen devices.

[Original Description]

On the Nexus7 device double-tapping does not work in Nautilus. Even single taps are not always registered.
In thunar navigating via double tap works fine.
The mouse settings panel's double tap timeout test works fine.

Jani Monoses (jani) on 2012-10-26
tags: added: mobile
Changed in ubuntu-nexus7:
status: New → Confirmed
Jeremy (elvis4526) wrote :

Almost same resut here. Can't open folder with double tap or single tap in Nautilus. I did not tried other file manager yet.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Eric Zig (zuric) wrote :

Same issue, work fine in the mouse settings but not work in nautilus

Eric Zig (zuric) on 2012-10-29
summary: - double tap does not open folders
+ double tap does not open folders or files

Same issue, I via menu "file->open" open file or folders,now

Matt Fischer (mfisch) wrote :

I think that double-tap might be broken in general, not just for nautilus.

Jani Monoses (jani) wrote :

As per the initial comment, and as of the latest image, thunar and mouse settings both handle double tap fine.

Matt Fischer (mfisch) on 2012-11-09
summary: - double tap does not open folders or files
+ double tap does not open folders or files in Nautilus
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Matt Fischer (mfisch) on 2012-11-13
tags: added: needs-upstream nexus7
Chris Wayne (cwayne18) on 2012-11-13
tags: removed: nexus7
Changed in ubuntu-nexus7:
importance: Undecided → High
Chris Wayne (cwayne18) on 2012-11-13
tags: added: nexus7
removed: needs-upstream
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Sean Feole (sfeole) wrote :

still affects 13.03.

Rocko (rockorequin) wrote :

For me on the nexus 7, double-tap doesn't work even in mouse settings. When I try 'Test Your Settings' it only ever detects a single click for a double-tap, even if I set the double-click speed to the slowest possible (or the fastest possible).

tags: added: rls-r-incoming
James M. Leddy (jm-leddy) wrote :
Changed in ubuntu-nexus7:
status: Confirmed → Invalid
Changed in nautilus (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → James M. Leddy (jm-leddy)

The attachment "fix_touchscreen_double_click_issue.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: raring
Changed in nautilus (Ubuntu):
assignee: James M. Leddy (jm-leddy) → Canonical Desktop Team (canonical-desktop-team)
James M. Leddy (jm-leddy) wrote :

Would someone that has a nexus7 please test Cosmo Cecchi's patch? I can't reproduce the bug on my x220t.

http://bugzilla-attachments.gnome.org/attachment.cgi?id=236201

Sebastien Bacher (seb128) wrote :

I've uploaded the upstream patch to raring for testing, setting quantal to wontfix, we don't intend to spend lot of times on SRUs for it at this point since we are getting close from raring and quantal is not a LTS

Changed in nautilus (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
Changed in nautilus (Ubuntu Quantal):
importance: Undecided → Low
status: New → Triaged
status: Triaged → Won't Fix
James M. Leddy (jm-leddy) wrote :

Thanks Sebastien! I'll fill out the SRU template too.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu6

---------------
nautilus (1:3.6.3-0ubuntu6) raring; urgency=low

  * debian/patches/16_unity_new_documents.patch: display the "new document"
    menu under unity, even if there is no template installed (lp: #1113648)
  * debian/patches/git_fix_touch_double_click.patch: upstream patch to try
    to fix double click not working on touch screens (lp: #1071922)
 -- Sebastien Bacher <email address hidden> Wed, 06 Mar 2013 18:49:59 +0100

Changed in nautilus (Ubuntu Raring):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

uploaded to the precise SRU queue as well, but the current SRU will need to be verified before this one can move in

Changed in nautilus (Ubuntu Precise):
status: Triaged → In Progress
Changed in nautilus:
status: New → Fix Released

Hello Jani, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.4.2-0ubuntu8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
James M. Leddy (jm-leddy) wrote :

I would appreciate it if someone with an effected machine could test raring to see if it is fixed. From there we can move to getting it in to Precise.

Sebastien Bacher (seb128) wrote :

@James: I did verify the raring fix on a nexus7 and confirmed it works, somebody needs to test on precise though

James M. Leddy (jm-leddy) wrote :

Thanks, I've asked the original reporter from my end to test precise-proposed on the Dell machines.

Changed in oem-priority:
status: In Progress → Fix Committed
debb1046 (debb1046) wrote :

Upgraded to raring today (nautilus 1:3.6.3-0ubuntu11) and problem is fixed on Samsung smart PC pro (amd64). Thanks.

James M. Leddy (jm-leddy) wrote :

Hi debb1046, is there any chance you would be able to test on precise-proposed?

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of nautilus from precise-proposed was performed and bug 1160932 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1160932 "bot-stop-nagging". Thanks!

tags: added: verification-failed
tags: removed: verification-failed
Kent Baxley (kentb) wrote :

I tested the proposed Nautilus package on the following:

Dell Inspiron 5521 with an Elan touchscreen.
12.04.2 64-bit

Before the nautilus fix, the double-tapping on folders didn't work.

After apply the nautilus update in proposed, I can now double-tap to drill down into folders and launch files, applications, etc.

tags: added: verification-done
removed: verification-needed

I can confirm that double-tap works on the touch screen of the Lenovo Thinpad Twist with Raring.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu8

---------------
nautilus (1:3.4.2-0ubuntu8) precise; urgency=low

  * debian/patches/git_fix_touch_double_click.patch: upstream patch to try
    to fix double click not working on touch screens (lp: #1071922)
 -- Sebastien Bacher <email address hidden> Fri, 08 Mar 2013 19:01:32 +0100

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.