Ubuntu

Huawei E220 and E1550 can't connect on Ubuntu 11.10/12.04

Reported by Akila Wajirasena on 2011-10-05
452
This bug affects 123 people
Affects Status Importance Assigned to Milestone
ModemManager
Fix Released
Medium
OEM Priority Project
Medium
Chris Van Hoof
Oneiric
Medium
Chris Van Hoof
Precise
Medium
Chris Van Hoof
modemmanager (Debian)
New
Unknown
modemmanager (Fedora)
Unknown
Unknown
modemmanager (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

[SRU JUSTIFICATION]
This changes reverts the rework of probing methods for Huawei devices which broke proper support for the Huawei E220, E1550 and some other specific models of Huawei 3G modems. It's low risk as it is known to work properly with most Huawei devices already; and only affects users of such devices. The E220, among others, remains one of the most common 3G modems available.

[REGRESSION POTENTIAL]
Low; this patch changes probing for Huawei devices only, and has been tested successfully with good support for the affected devices after the patch is installed, as well as unchanged behavior for many other devices (tested by cyphermox with a E1831 too).

[TESTING]
Requires Huawei 3G modem; needs to be the E220 or E1550 model for successfully testing the resolution of this issue. Testing with other Huawei devices is useful as control. Devices from other manufacturers are unaffected.

=======

I'm using Ubuntu in my HP Pavilion dv6745tx laptop. I cannot connect the Huawei E220 usb modem since 11.10 beta1 (now I'm in beta2). There is no problem in natty.

I have found this in syslog

Oct 5 07:10:51 ubuntu NetworkManager[1681]: <info> Activation (ttyUSB0) starting connection 'Dialog GSM Postpaid'
Oct 5 07:10:51 ubuntu NetworkManager[1681]: <info> (ttyUSB0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Oct 5 07:10:51 ubuntu NetworkManager[1681]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 5 07:10:51 ubuntu NetworkManager[1681]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Oct 5 07:10:51 ubuntu NetworkManager[1681]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Oct 5 07:10:58 ubuntu NetworkManager[1681]: <warn> GSM connection failed: (32) Sending command failed: 'Resource temporarily unavailable'
Oct 5 07:10:58 ubuntu NetworkManager[1681]: <info> (ttyUSB0): device state change: prepare -> failed (reason 'unknown') [40 120 1]
Oct 5 07:10:58 ubuntu NetworkManager[1681]: <warn> Activation (ttyUSB0) failed.
Oct 5 07:10:58 ubuntu NetworkManager[1681]: <info> (ttyUSB0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Oct 5 07:10:58 ubuntu NetworkManager[1681]: <info> (ttyUSB0): deactivating device (reason: 0).
Oct 5 07:10:58 ubuntu NetworkManager[1681]: nm_system_iface_flush_routes: assertion `ifindex > 0' failed
Oct 5 07:10:58 ubuntu NetworkManager[1681]: nm_system_iface_flush_addresses: assertion `ifindex > 0' failed

description: updated

I have attached the network-manager and modem- manager logs

I have the same problem.

I found such solution in the Internet. Please confirm if this work!!!!!

the recommend change should be applied to "usb_modeswitch.conf" ( if any) . try edit the

/lib/udev/rules.d/40-usb_modeswitch.rules

to disable the rule place a # at start of the line , example

Quote:
# Huawei E220, E230, E270, E870
# ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1003", RUN+="usb_modeswitch '%b/%k'"

this should allow the use of modems which require switching.

Akila,

Please try the above-mentioned fix; let me know if this works for you :)

Changed in network-manager (Ubuntu):
status: New → Incomplete

I tried that. But it doesn't work. The modem is not detected when I comment that lines.
girts,
Can you tell me the exact steps you did? and whether it works?

BTW there is thread on this issue in ubuntu forums.
http://ubuntuforums.org/showthread.php?t=1857506

I'm also facing the same issue. Huawei E220 worked in 11.04 after upgrade not working at all. Tried with Huawei E153 was able to connect Internet. So its E220 incompatibility issue. Appreciate if E220 can be fixed since I dont onw the E153. Ubuntu 11.10 is not usable until this is fixed and this force me to use window7.

Tried girts (girtsz-gmail) 's fix in 40-usb_modeswitch.rules . Not working ... Issue still exists.

Everyone can try Mobile Partner for Linux until bug will be fixed. You must configure Mobile Partner for Linux for your ISP!!
http://www.lmt.lv/files/modemu_atjauninajumi/E620_LMT_internet_Linux.zip

Mobile partner for linux works with Huawei E220 on ubuntu 11.10

Tomas (omas) wrote :

I'm not sure if something was done about this issue but from time to time I get my E220 working (M1330, Ubuntu 11.10 32bit), however usually I have to create a new connection to be able to do that. I didn't have this problem in a previous version.

ggonzar (ggonzar) wrote :

This is my case:

- I use Edubuntu 11.10 amd64
- when I plug the modem se system Load grows up (plus 4,0) and the laptop work in "flashes"...
- the modem work sometimes. When work the system load is OK.
- I try to comment the line of /lib/udev/rules.d/40-usb_modeswitch.rules and nothing happend.

It is like the system go in a loop when detecting de modem and this causes de system load grows up. But I can't tell how sometimes works.

Sleepy John (john-eyre) wrote :

I am experiencing similar problems after upgrading my Acer Aspire One to 11.10 from 11.04. Once connected, my E220 will disconnect and reconnect quite reliably provided it continues to be powered on via its USB connection. Howver if I unplug it or depower it by swirching off, I cannot get it to reconnect on 11.10, and I have to go either to Natty or to Windows to get it to work again. From there, a direct restart to 11.10 will deliver it it back in a condition from which it will connect again. More details on ubintuforums.org/showthread.php?t=1868014

Changed in network-manager (Ubuntu):
status: Incomplete → New
Sleepy John (john-eyre) on 2011-10-30
Changed in network-manager (Ubuntu):
status: New → Confirmed
Sleepy John (john-eyre) wrote :

For what it's worth, I've found this inelegant workaround will get me on-line again after my E220 has been depowered:

CODE
sudo usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R

Then unplug and replug the dongle, and now it will connect.

An lsusb check shows that the Device # for the E220 has been increased by 2

Roman Stingler (coolx67) wrote :

@Sleepy John

Thank you very much, this works perfect.
first
Bus 005 Device 003: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem
doesn't work
after
Bus 005 Device 005: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem
works perfect.

you are great.

Per Ronny Westin (vaxxipooh) wrote :

@Sleepy John

Well that:
--------------------------------------------------------------------------------------
CODE
sudo usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R
-------------------------------------------------------------------------------------

looks nice and make sense - how do we implement it to be sortof an steady fix ? Is it possible to put the line: "usb_modeswitch -v 0x12d1 -p 1003 -V 0x12d1 -P 1003 -R" in /etc/rc.local" or something ??

Anyway thanx for your great "Sherlock Holmes" work in this issue :-)

Sleepy John (john-eyre) wrote :

Thanks for two votes of confidence above, but seriously I don't see this code as anything more than a temporary workaround until a properly designed fix is found. In my setup, it only worked after a manual USB unplug/replug, and I'm sure there must be a better way of simulating this automatcally. Basically I would have thought looking into the differences in the way Ocelot handles an E220 compared to how Natty does it would be the best way forward, since it all works fine in Natty.

Fredrik Hultkrantz (fjutt) wrote :

I can also confirm that the workaround posted by Sleepy John fixes the problem for me. Thank you! Not the final solution perhaps, but at least I can use my 3g modem again from Ubuntu, which is a good thing.

Damjan Jovanovic (damjan-jov) wrote :

Sleepy John you're the man! This is what Ubuntu needs more of: working hardware.

Later on I'm going to dig up the workarounds for the old regression and see if they also work now. I see that udisks is polling /dev/sr0 - this did play a role before.

Indika Kodagoda (indikaimk) wrote :

@Sleepy John
Your solution worked for me too.

@Sleepy John
This didn't work for me :(

Changed in network-manager (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch-data (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-11-08
affects: udev (Ubuntu) → usb-modeswitch-data (Ubuntu)
Changed in usb-modeswitch-data (Ubuntu):
status: New → Confirmed
1 comments hidden view all 246 comments
Sleepy John (john-eyre) wrote :

Sorry, I'm not so familiar with the methods used to determine status and importance here, and am curious to know what factors lie behind the decision to classify this bug with importance "Low". From my own personal standpoint as someone who relies on an E220 for my regular daily internet access, I see this bug as a high nuisance value, and the inelegant workaround I've posted above as nothing more than a very short-term temporary alternative to being forced to regress to Natty where my E220 logged in without any difficulty. It would be interesting to hear from other E220 users about how important and how seriously this bug affects them.

Fredrik Hultkrantz (fjutt) wrote :

I can only agree with Sleepy John, for me the 3g modem is my the only way to get internet access for me and that it doesn't work, or forces me to do the kind of workarounds posted above is not for me a problem with low importance. Using my comp with no internet access is not very useful. So it feels like it could be upgraded :)

Bug is super important!!!!
It must be fixed. In such times when there is critical bugs need after fixing new iso images!!!
I am asking others for new iso images after bug will be fixed.
Canonical must have one distribution Ubuntu with one repository which is contributed from all people which creates packages for Ubuntu. KDE, WindowMaker, XFCE, KDE... must be in repositories.
By using such strategy will be faster to create and test bugs and solve them. No need Kubuntu, Lubuntu, Xubuntu... Eastest way how to install Ubuntu and choose what to use!

Per Ronny Westin (vaxxipooh) wrote :

I agree to the full with girts (girtsz-gmail) - it must be fixed . . . i have no other connection than USB Modem too (Huawei E220) - by the way i have seen people have issues with other models of Huawei GSM modems too . . .

Sleepy John (john-eyre) wrote :

Per Ronny - It might be helpful if you could do some checking and post on here the model numbers of any other GSM modems that are giving other people trouble on Ocelot. This could help to clarify how widespread the problem generally is, and aid developers in pinpointing the cause. If we can show that the problem is not only confined to E220 users, it will make it all the more urgent to try and get it fixed.

One of my friend said adding "blacklist usb_storage" to /etc/modprobe.d/blacklist.conf solved the issue

Can any one confirm it? I think several other Huawei modems also doesn't work.

There is also another method of fixing this using old network manager packages

http://www.technewsdaddy.com/2011/ubuntu-11-10-and-huawei-e220/

Sleepy John (john-eyre) wrote :

Yes!! Adding that "blacklist usb_storage" to /etc/modprobe.d/blacklist.conf has worked in my case. So long as it doesn't upset any other USB iunctions, that looks like a good fix to me! Thanks Akila.

Sleepy John (john-eyre) wrote :

I might have spoken too soon because I can't get that addition to blacklist.conf fix, which seemed to be working perfectly for me yesterday, to work at all today. Still checking, though. Is anyone else seeing it either working or failing?

Shrijit Nair (shrijith1) wrote :

I too can't get it to work with the blacklist.conf fix. Please note, I have a ZTE modem. Is this bug specific to Huawei modems ?

Sleepy John (john-eyre) wrote :

Shrijit - This bug thread was opened specifically to talk about about the problems that have appeared with the Huawei E220 on Ubuntu 11.10 that were not there on Ubuntu 11.04. It does appear from what some posters here say, that 11.10 is also causing the same or similar bugs to show up on other modems. The same fixes don't always apply across different modems though, and it's not safe to assume the fixes are universal. Some work, some don't, but it's worth giving them a try.

I still remain puzzled about that blacklist.conf fix because I'm pretty sure the tests I did with it yesterday proved that it was working OK, and yet today it's not working at all. Still interested to hear the experience of others on it.

quiricada (raraland) wrote :

same problem here, network-manager tries to connect and just hangs. everything was working fine in 11.04.

so am back to using terminal and wvdial; openvpn in terminal also when i need it.

Josua Dietze (digidietze) wrote :

To determine if the problem is caused by usb_modeswitch, please enable logging in
/etc/usb_modeswitch.conf.

Post the largest file (name starting with "usb_modeswitch") that is created in /var/log after you plugged the device.

DON'T comment out any entry in the "rules"file !!

Changed in usb-modeswitch-data (Ubuntu):
status: Confirmed → Incomplete
Josua Dietze (digidietze) wrote :

Furthermore I don't recommend to blacklist the "usb-storage" module. Several modems want to be initialized before the mode switch can successfully happen. The storage driver should not be able to keep any device from switching.

Again, please enable usb_modeswitch's logging.

Mark Robbie (mark-robbie) wrote :

I too have this problem with a Huawei E220 USB modem. I had no problems with Ubuntu versions 9.10 thru 11.04 but am seeing it now that I have installed 11.10. The problem also occurs if booting from the 11.10 ISO disk, so it is not due to a corrupt installation. I can use the sakis3g script to make a connection so there is no problem with the modem or ISP.

I have enabled logging in /etc/usb_modeswitch.conf which produces a single log file (/var/log/usb_modeswitch.log - attached) that is written at the time that I plug in the USB modem.

What looks interesting to me is that there is a list of USB devices in this log, but the modem is not listed (there is only one connected device which lsusb reveals to be the built-in webcam) and therefore usb_modeswitch concludes that there is nothing to do.

So despite the fact that the running of usb_modeswitch appears to get triggered by my plugging in the modem, the modem does not appear in the list of USB devices. Could it be that it takes some small time for the device to initialise and that usb_modeswitch is running before this has happened?

There are two other bugs/poor behaviour related to this issue but they don't bother me sufficiently to raise separate bug reports:
1. usb_modeswitch does not appear to run (there is no log file) if the modem is plugged-in before booting
2. If I bring up the link using some other method (e.g. using the sakis3g script) network-manager does not realise that a connection has been made so it grays-out the menu options to make my VPN connections unavailable.

Mark.

Josua Dietze (digidietze) wrote :

If udev starts usb_modeswitch, but usb_modeswitch can't find the device when searching the busses, it means that something else is affecting the device in the meantime. This should be visible when calling "dmesg" after plugging in.

Either it's a driver thing (I'll check the source code of usb-storage in a moment) or there is annother udev rule or hotplug mechanism kicking in. I'll have a look in my 11.10 installation.

Regarding the other problems you mention, no. 1 is a known problem fixed in version 1.2.0; about no. 2 I have no idea ...

Josua Dietze (digidietze) wrote :

It's the kernel.

I have forgotten about it - there is a switching function in usb-storage from the time when usb_modeswitch wasn't wide-spread. The affected devices are listed in "unusual_devs.h".

The bottom line is that usb_modeswitch can't be responsible for the reported bug. It is not needed for this device, but does not interfere if present.

I therefore remove usb-modeswitch-data from the list of affected packages.

Changed in usb-modeswitch-data (Ubuntu):
status: Incomplete → Invalid
Martin Pitt (pitti) on 2011-11-28
no longer affects: udev (Ubuntu)
no longer affects: usb-modeswitch-data (Ubuntu)
Roosweltcr (roosweltcr) wrote :

Thanks for Sleepy John (john-eyre) . it works fine with the command but time to time it will give headache, is there is a permanent solution for this??

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 868034

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Sleepy John (john-eyre) on 2011-11-28
tags: added: apport-collected oneiric
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in network-manager (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Confirmed → In Progress
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager:
importance: Medium → Unknown
status: New → Unknown
affects: linux (Ubuntu) → modemmanager (Ubuntu)
Changed in modemmanager (Ubuntu):
status: Invalid → New
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → New
Changed in modemmanager (Ubuntu):
status: New → Confirmed
Changed in modemmanager (Ubuntu):
importance: Undecided → Low
Changed in modemmanager (Ubuntu):
importance: Low → Medium
Changed in network-manager (Ubuntu):
importance: Low → Medium
affects: network-manager → modemmanager
Changed in modemmanager:
importance: Medium → Unknown
status: New → Unknown
Changed in modemmanager (Debian):
status: Unknown → New
Changed in modemmanager (Ubuntu):
status: Confirmed → Triaged
no longer affects: network-manager (Ubuntu)
summary: - Huawei E220 can't connect on Ubuntu 11.10
+ Huawei E220 and E1550 can't connect on Ubuntu 11.10
Changed in modemmanager:
importance: Unknown → Medium
status: Unknown → New
tags: added: patch
tags: removed: patch
Changed in oem-priority:
status: New → Incomplete
tags: added: regression-release rls-mgr-p-tracking
Changed in modemmanager (Ubuntu Oneiric):
status: New → Confirmed
Changed in modemmanager (Ubuntu Precise):
status: Triaged → Fix Released
Changed in modemmanager (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in oem-priority:
status: Incomplete → Confirmed
Changed in modemmanager:
status: New → Fix Released
Changed in modemmanager (Ubuntu Oneiric):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
description: updated
Chris Van Hoof (vanhoof) on 2012-03-19
Changed in oem-priority:
status: Confirmed → Fix Released
importance: Undecided → Medium
assignee: nobody → Chris Van Hoof (vanhoof)
status: Fix Released → Confirmed
Martin Pitt (pitti) on 2012-03-23
Changed in modemmanager (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Changed in modemmanager (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2012-04-03
Changed in oem-priority:
status: Confirmed → Fix Released
166 comments hidden view all 246 comments

Hey!! I'm glad to tell you that I've been able to make my huawei modem work with Mobile Partner.
The system still freezes when I plug the dongle, but I've tried several times and allways got a connection although network manager didn't recognizes the device.
I'll go on trying, and I'll try upgrading the firmware. (thanks madbiologist for your suggestion)

Pablo (pjferra) wrote :

What should I to update the firmware?
Please, post steps and where to download it

javierpedros (javierpedros) wrote :

Hello:
I solved this problem but a way not elegant.
In the Application disc ulitity I umount and safely disassemble the unit CD Huawei.
One minute after the 3G modem is recognized properly.

It works for me.
I think the problem is the CD-Huawei not the usb mass storage.

I have Ubuntu 12.04 and Huawei E156G (I think this is like E220)

Sleepy John (john-eyre) wrote :

I would like to second Pablo's request for step by step instructions.

I know there are some workarounds that will allow me to log-in with Oneiric and my E220 so I'm not totally cut off from the internet, but I am still confused about this bug supposedly now being "fixed", and yet I still have to use these workarounds. If updates incorporating the fix have already been issued, then why aren't I seeing the benefit of them?

I would like to know if the updates that have been issued will automatically replace my deliberately reverted modem manager with a latest fixed default version, or if I should be trying to do that manually?

My aim is to have a standard fully updated Oneiric that works with an E220 without having to adopt workaround procedures. Is that a realistic aim, or am I expecting too much?

Regarding Mathieu's #201 comment about the firmware maybe not being recent enough, isn't this ignoring the point that our E220s were all working perfectly satisfactorily in Maverick and Natty, and it was only when Oneiric came along that all this trouble started?

If I thought that an upgrade to Precise would make my E220 log-in any easier, I would upgrade and forget about trying to fix Oneiric, but is anyone seeing evidence that Precise works better?

madbiologist (me-again) wrote :
Download full text (4.7 KiB)

The fixed modemmanager 0.5-1ubuntu1.1 package from oneiric-proposed which is described in comment #171 did make it into oneiric-updates. You can view this at https://launchpad.net/ubuntu/+source/modemmanager
Comment #171 also states that this fix is in modemmanager 0.5.2. modemmanager 0.5.2.0-0ubuntu2 was released in precise and is the current precise version - you can view this a the same link I gave above for the oneiric version. To check your own installation you can run dpkg -l <packagename> or look in Synaptic Package manager.

Now we just have to figure out what else is preventing the device from working normally for you. I am reluctant to take the time to provide further information given your apparent preconception that it won't work, but here it goes anyway. I can't fully explain why a firmware update would work given that the E220's worked in Maverick and Natty, other than that some of the workarounds here remind me of some of the workarounds used in the old bugs. Feel free to ignore my suggestions if you like.

I'm pretty sure that in comment #199, Mathieu meant to say "modem is not working" instead of "modem is working". He seems to have vanished since your reply though. Regarding your question about whether the updates will automatically replace the modemmanager_0.4+git.20110124t203624.00b6cce-2ubuntu1 which you downgraded to, that will depend on whether or not you used apt (or it's front-end Synaptic) to perform the downgrade or not, and whether you have locked the version or not. If necessary you can just use apt-get install (or Synaptic) to install the new version and then you will get any later update from then on. See above for how to check your current version.

Obviously if you didn't have the fixed package you should try with that before upgrading the firmware. The following steps for upgrading the firmware are taken from comments #15 and #16 in bug #449394

- it is highly recommended to work on a notebook or a PC with UPS, to be protected from power failure or you may loose your E220 dongle
- on a Windows based machine, download archive from http://www.maxis.com.my/maxisbb/download/E220SoftwareUpgrade.zip
- unpack ZIP file in a separate directory, like c:/tmp/E220
- plug-in E220 and wait about 1 minute
- close any software that may autorun when E220 is plugged
- start the exe file with Firmware inside the name and follow on-screen instructions - upgrade will take several minutes, be patient
- unplug your E220
- this is how I did it on a XP Windows!

- It may happen that deviation could appear, based on Windows you have installed. You have to deal with this by yourself .

Unfortunately there is the major inconvenience of needing a Windows or MacOS X installation/machine to perform the firmware upgrade. All of the other people who upgraded their modem's firmware seem to have used Windows to do so. I have looked hard on the internet for a Linux-based update tool, but it seems that neither Huawei nor their vendors (mobile communications companies) have released one.

Other than the download link provided in the steps above, other possible download locations are http://www.vodafone.de/hilfe-support/technischer-s...

Read more...

madbiologist (me-again) wrote :

Actually, apt-cache policy <packagename> is better than dpkg -l <packagename> for checking what version you have installed. It doesn't truncate the package names the way that dpkg -l does. Sorry about that.

@madbiologist: the point is certainly not to have everyone upgrade their firmware, but that this course of action needs testing regardless.

The problem is, the E220 responds differently based on different firmware versions, and we can only make work the ones that we have to test with.

If someone can test the modemmanager package from Quantal as well (using a live CD or installing the package directly) that could also be very useful.

I'm resetting the states for this bug to Triaged for the Oneiric, Precise and floating tasks; it's evidently not fixed and the state should have been reset long ago.

Changed in modemmanager (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in modemmanager (Ubuntu Precise):
status: Fix Released → Triaged
Changed in modemmanager (Ubuntu Oneiric):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
status: Fix Released → Triaged
Changed in modemmanager (Ubuntu):
status: Fix Released → Triaged
Sleepy John (john-eyre) wrote :
Download full text (7.5 KiB)

Let me first express my thanks and appreciation to madbiologist for his #211 and #212 review and comments.
Sorry to be so slow in responding; the truth is that I lost my focus on this topic while I had access to an alternative landline broadband, but now that I'm trying to get back on my E220, I'm having to catch up.

Second, let me apologise for the negative tone of what follows, since my E220 still isn't working properly.

OK, more of my details in-line below:

[QUOTE]The fixed modemmanager 0.5-1ubuntu1.1 package from oneiric-proposed
which is described in comment #171 did make it into oneiric-updates. You
can view this at https://launchpad.net/ubuntu/+source/modemmanager
<https://launchpad.net/ubuntu/+source/modemmanager>[/QUOTE]

  Yes, I had previously regressed to modemmanager_0.4, but
  when I check it now, it's showing as 0.5-1buntu1.1, so
  it must have updated itself at some stage without me noticing.

[QUOTE]Comment #171 also states that this fix is in modemmanager 0.5.2.
modemmanager 0.5.2.0-0ubuntu2 was released in precise and is the current
precise version -[/QUOTE]

   Some people (including myself) have remarked that Precise is
   suffering from exactly the same symptoms as Ocelot, so that
   leaves me a little skeptical about the effectiveness of these
   fixes. However the timing of these releases and whether they
   made it in time to be incorporated in Precise's Live issue,
   would be critical.

[QUOTE]Now we just have to figure out what else is preventing the device
from working normally for you. I am reluctant to take the time to provide
further information given your apparent preconception that it won't
work, but here it goes anyway. I can't fully explain why a firmware
update would work given that the E220's worked in Maverick and Natty,
other than that some of the workarounds here remind me of some of the
workarounds used in the old bugs. Feel free to ignore my suggestions if
you like.[/QUOTE]

    Many of the original complainants on this bug were seeing it
    as something new that was happening with Ocelot. Everything
    had been fine with their E220s in Maverick and Natty, so I
    have a kind of gut feeling that we could be barking up the
    wrong tree, but I don't understand enough about the actual
    fixes to be adamant about that. Reversion to modemmanager_0.4
    made it easier to connect, but it wasn't a total fix. There
    was and I believe there still is something else.
 .

[QUOTE] Regarding your question about whether the updates will automatically
replace the modemmanager_0.4+git.20110124t203624.00b6cce-2ubuntu1 which you
downgraded to, that will depend on whether or not you used apt (or it's
front-end Synaptic) to perform the downgrade or not, and whether you
have locked the version or not. If necessary you can just use apt-get
install (or Synaptic) to install the new version and then you will get
any later update from then on. See above for how to check your current
version.[/QUOTE]

    I'm not sure how or when it happened, but I'm on MM 0.5 -1ubuntu1.1
    now

[QUOTE]Obviously if you didn't h...

Read more...

Joakim Lagergren (jb-lager) wrote :

Hi Sleepy John and others,

Since people still seem to have problems I thought I should chime in and share some of my experiences.

I had problems with connecting my E220 on 11.10 oneiric using MM 0.5-1ubuntu1 after upgrading the modem firmware to 11.117.10.02.00. (Don't remember what firmware version I had before the upgrade.)

I found a simple workaround that allowed me to connect reliably with ModemManager (detailed in duplicate bug #932824):
Prevent MM to probe /dev/ttyUSB1 by starting the command 'cat /dev/ttyUSB1' before MM starts its probing.

The updated version of MM currently in oneiric (which is supposed to fix this bug?), 0.5-1ubuntu1.1, does not work for me, but my workaround still works.

To test if you have the same problem as I have, you can try the following:
- Make sure the modem is physically disconnected.
- Open a terminal and run the command 'while true; do cat /dev/ttyUSB1; sleep 1; done'
(Before the modem is connected you will see messages like 'cat: /dev/ttyUSB1: No such file or directory' once every second. After the modem is connected and initialized you will see messages from the modem, such as ^BOOT:59866241,0,0,0,6 ^MODE:5,5 ^RSSI:27 and others.)
- Connect the modem to your computer.
- Connect using modem manager as usual.
Note: After ModemManager is done with its probing you can abort the cat /dev/ttyUSB1 command.

If this workaround works for you, you might want to try the "ports" branch of ModemManager which Aleksander Morgado mentioned in comment #145 (with more info available in the comments before and after). I've been using the ports branch since February and it has been working perfectly all the time.

IIRC, the MM_06 branch already comes with the previous 'ports' branch merged, you may want to try that one. git master also has the 'ports' functionality included, but lots of work to do there before being able to fully use it... :-/ help with the development welcome :-)

Marius B. Kotsbak (mariusko) wrote :

Maybe this patch will solve this problem?:

http://<email address hidden>/msg20874.html

Sleepy John (john-eyre) wrote :

Thanks Marius and Aleksander. I'd like to try this patch, but since I'm entirely dependent on my E220 and MM for my inernet access just now, I'm worried in case it doesn't work as planned and I can't get back on-line at all. What steps can I take to pre- save my existing MM and restore back to it in the event of problems?

Marius B. Kotsbak (mariusko) wrote :

You can just build a recent modemmanager (0.6 branch probably) with the patch and run its modem-manager before starting network-manager and you have restored your old configuration by just killing the new modem-manager.

No, that last patch is for the case where usbif 0 doesn't show up.

The problem in this bugreport is that the PCUI and modem ports get swapped when MM grabs them, and the proper fix for this should already be in MM_06 and git master.

Marius B. Kotsbak (mariusko) wrote :

Has anyone tested if this still is unresolved in Ubuntu 12.04?

Sleepy John (john-eyre) wrote :

Or is there an easy way I could download and test MM_06 on my Oneiric in such a way that I could revert to my MM_05 in case MM_6 failed and I completely lost my internet access as a result?

madbiologist (me-again) wrote :

modemmanager 0.6~git201206221719.8289a64-0ubuntu1 is in Ubuntu 12.10 "Quantal Quetzal" development repositories if you want to burn a LiveCD and test with that.

According to https://launchpad.net/ubuntu/+source/modemmanager there doesn't seem to be any modemmanager PPA's for Oneiric.

Right there isn't. I can very well provide MM 0.6 in a PPA for precise, but I'm not sure it really qualifies so well for an official updates package, since it's multiple patches, and we don't know exactly which ones.

summary: - Huawei E220 and E1550 can't connect on Ubuntu 11.10
+ Huawei E220 and E1550 can't connect on Ubuntu 11.10/12.04
Marius B. Kotsbak (mariusko) wrote :

Mathieu: that would be very useful anyway for people that has problems that is solved upstream and are willing to risk stability for solving those problems, and to check if issues are solved upstream for future Ubuntu packages.

I am using the following workaround sucessfully on two different 12.04 desktops & one linux Mint R13 laptop to connect with a huawei E220 Modem on 3G / 2G networks

#Running the following AS ROOT after the first unsuccesfulll connection attempt allows the modem to connect without problems until it is removed from the USB port:

   echo -e "AT+CNMI=2,1,0,2,0\r\nAT\r\n" > /dev/ttyUSB1

Without it I can't get a connection.

   I picked the commad from the C:\Program Files\Mobile Partner\Log\ATRecord.txt file on a Windows XP VM, after noticing that the modem would work properly in ubuntu after connecting first one time inside the XP VM, until the modem gets unplugged. Other AT command combinations don't have the same effect - it needs to be the exact above sequence.

Marius B. Kotsbak (mariusko) wrote :

There is a PPA available of MM_06, but it does not build. Seems like the patches that are upstream must be excluded from the build.

Mark Fraser (launchpad-mfraz) wrote :

I'm running Kubuntu 12.10 on a netbook and I'm still unable to connect using a E220 modem.

Naresh(OpenERP) (nch-openerp) wrote :

I have the same problem I am not able to connect my Huawei E1550 on latest ubuntu 12.10...Network manager detects perfectly the modem but when I click to connect its just says "Modem Disconnected" you are now offline.

LinaPorras (linaporras) wrote :

I have the same problem but with a Huawei E353, I have tried so many things, some of the errors are that is that the device is not dettected in TTY, also all the solutions that you have propposed didn't work....
I have Ubuntu 12.10 64Bit in a ASUS N56vj laptop, but I have another PC computer with Ubuntu 12.10 64 BIt and in there I don't have the problem... it's a little weird...

Sorry about the english... I Dont'speak it perfectly

Sleepy John (john-eyre) wrote :

No need to apologise for your English, KinaPorras, it's fine!
But sorry to read this trouble is still ongoing, now on an E353 as well as E220. I've been holding off on an upgrade to 12.04 from my 11.10 in the hope that a real solution to this bug will be found.
This whole problem started in 11.10. E220 worked fine in Natty, and it doesn't seem as if the basic change that was introduced in Oneiric and which is responsible for this failure has been adequately addressed in any of the fixes since then . All the new releases, it appears, are coming out with the same basic error that started with 11.10. I wonder if there's any chance that 12.04.2 (just out I believe) is compatible with E220 and E353. Anyone been able to test it??

Marius B. Kotsbak (mariusko) wrote :

You could just try it yourself using a live CD/USB stick. It would also ve interesting to know if a firmware upgrade would solve it.

I bought a E220 just for the sake of testing it; and it worked fine both with 0.6.x and git master.

madbiologist (me-again) wrote :

Thanks Aleksander. Which version of Ubuntu are you having success on? If 12.10, did you use the default shipped MM 0.6.x or a version you compiled yourself? What firmware version does your E220 have? Can you please post the output of lsusb -v

Do you boot with the E220 connected or disconnected?

I don't use Ubuntu; I'm using Fedora and a self-compiled MM 06/master.

madbiologist (me-again) wrote :

What version of Fedora? What firmware version does your E220 have? Can you please post the output of lsusb -v (I'm not sure if Fedora has such a command, but I assume there is something similar).

Do you boot with the E220 connected or disconnected?

2 comments hidden view all 246 comments

My E220 has the following revision ID: 11.117.10.03.99

I usually test the modems plugging them, not with them already connected.

Pablo (pjferra) wrote :

Try this (it worked for me with ubuntu 12.04 64 bits):
1) using gedit create a text file with the following commands:
          modprobe -r option
          modprobe -r usb_wwan
          modprobe -r usbserial
          modprobe usbserial vendor=0x12d1 product=0x1003
2) save it anywhere (I've saved it as /opt/modem.sh)
3) asign execut permission
4) in a terminal type: sudo gedit /etc/rc.local
5) add the following lines at the end of the file
           /opt/modem.sh ## or the path and name you choosed for your file
           exit 0
6) save and exit
7) reboot
8) try your modem

Sleepy John (john-eyre) wrote :

Marius B K wrote [QUOTE]You could just try it yourself using a live CD/USB stick. It would also ve interesting to know if a firmware upgrade would solve it.[/QUOTE] Yes, reasonable suggestion, and I do now have a working live 12.04.2-desktop-i386 USB stick. but sorry, no valid data-enabled simcard at the moment. I only use my E220 for 3 or 4 months of the year when I'm travelling, but of course during those months it becomes an essential lifeline.

In post #234 madbiologist asks [QUOTE] What firmware version does your E220 have?[/QUOTE]. In June 2012 I tried an upgrade to 11.117.10.03.99, the same as Aleksander is now using, and I also changed to Maxis Broadband as recommended in post #211 but neither of these made any improvement.

Although the upgrade to modemmanager 0.5 and subsequent patches to it have made it a little easier to get a successful connection, and this applies particularly in cases where I've left my E220 and simcard plugged in between subsequent Oneiric boots, I'm still left with a gut feeling or hunch that there's still something basic that changed between Natty and Oneiric that we've missed. I don't know what it is, but it appears to have carried forward and still be causing the same problems in Precise and Quantal. If I plug my E220 in to an already booted Oneiric, or if I use my E220 or my simcard in some other device between Oneiric boots, then I can expect trouble and I have to go through some usb_modeswitch commands and some unplugging and re-plugging sequence before I can connect. My post #115 refers.

This discrepancy in how successful attempts to connect are, depending on the recent past history of my E220 and simcard, takes me back to Joshua Dietze's reply in post #76 saying he doesn't think there can be anything retained in flash memory when the device is powered down. My evidence points to the contrary; past history of what I've been doing with the device between Ocelot boots *does* affect my results. This is leading me to speculate that Ocelot can't be re-initialising the E220 (or maybe even the simcard??) to exactly the same state as Natty was. Maybe I should point out that I sometimes use my E220 to connect on a Windows partition between Ocelot boots, and at other times I remove the simcard from my E220 and use it quite independently in a smartphone. On the other hand if I leave my E220 and simcard plugged in and depowered between Ocelot boots, I've a much better chance of a successful connection next time.

Could we perhaps take a closer look at the differences between the early part of the re-initialisation sequence that Maverick and Natty used to perform, compared to what Ocelot and subsequents are now doing?

Marius B. Kotsbak (mariusko) wrote :

Aleksander, both Precise and Oneiric use MM 0.5. Could you please test that too? And also compare between 0.5.0 and 0.5.2, as that was the change between those distro releases:

http://packages.ubuntu.com/search?keywords=modemmanager&searchon=names&suite=all&section=all

Marius B. Kotsbak (mariusko) wrote :

Other people having issues, please post your firmware versions.

In 0.5.0 we introduced a Huawei-specific patch which ended up not being good enough for the E220; we reverted the patch for 0.5.2, though. See:

http://cgit.freedesktop.org/ModemManager/ModemManager/commit/?h=MM_05&id=7e406c27af9a3d2fb7266daa55d12cd0ba00f6fc

In 0.6.x, the Huawei-specific behaviour is handled by the new ports reorganization logic, same as in git master.

I'll try to gather older MM logs later.

madbiologist (me-again) wrote :

Sleepy John wrote:-

> Could we perhaps take a closer look at the differences between the early part of the re-initialisation sequence that Maverick and Natty used to perform, compared to what Ocelot and subsequents are now doing?

Sure. Can you please attach the log file/s from Natty and the log file/s from Oneiric after plugging in the modem? (See http://wiki.ubuntu.com/DebuggingNetworkManager) My apologies if you have provided this information before, but this bug is getting rather long and it would be easier if you could provide them again at this point.

> I'm still left with a gut feeling or hunch that there's still something basic that changed between Natty and Oneiric that we've missed. I don't know what it is, but it appears to have carried forward and still be causing the same problems in Precise and Quantal.

This has indeed been a protracted and frustrating issue. Many networking things were changed in Oneiric, some in the kernel, some in usb-modeswitch, some in modemmanger and some in network-manager. Reverting them en masse is likely to break other things. Some of them may not be able to be reverted individually/separately as they may be inter-related to others. However focusing on the past might be counterproductive given that the problem seems to be finally fixed in a newer version. More on that in a moment.

Is there any particular reason that you want to continue using Oneiric? Also, official Canonical support for Ubuntu 11.10 "Oneiric Ocelot" ends in April 2013 - see https://wiki.ubuntu.com/Releases

This problem might have been fixed in Precise by the patch reversion mentioned in comment #244. However comments #203, #226 and #240 say otherwise. It is almost certainly fixed in Quantal's modemmanager 0.6.0.0.really-0ubuntu1, as stated in comments #220 and #233. I realise that comments #228, #229 and #230 say otherwise, but two of them are different modems (E1550 and E353) and we don't have their USB product IDs to see if they are the same as the one that you, Pablo and Aleksander have (1003). The E220 in comment #228 is more of a concern but we don't have it's USB product ID either. It has been shown previously that some E220's are in fact a rebadged E156/E169/E1550 (I can't remember which one anymore).

Mark Fraser, Naresh and LinaPorras - can you please attach the output of lsusb -v

If we can get some more people testing E220s on Quantal that would be good. When doing so please attach the output of lsusb -v and the firmware version of your modem.

Pablo (pjferra) wrote :

Have tried adding

modprobe usbserial vendor=0x12d1 product=0x1003

to the /etc/rc.local file?

Displaying first 40 and last 40 comments. View all 246 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.