network-manager does not detect mobile usb modem

Bug #455493 reported by Alexandre Cunha on 2009-10-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
modemmanager (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Alexandre Cunha

Bug Description

Binary package hint: network-manager

This bug appeared few days after the karmic (9.10) beta release and can be verified using one of the latest live CD daily builds (tested with daily build 2009-10-17) with both amd64 and i386.

How to reproduce the bug:
- Boot up with live CD (daily build 2009-10-17)
- coonect a USB mobile broadband modem (tested with huawey e220 and e620)
- the wizard to configure the modem does't start up
- do "sudo lsusb" and the modem is listed
- try manually configure the modem with NM but this is not possible because the modem is not listed/detected

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] Ficheiro ou directoria inexistente
Date: Mon Oct 19 15:21:57 2009
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 172.16.0.0/21 dev wlan0 proto kernel scope link src 172.16.5.26 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 172.16.0.1 dev wlan0 proto static
Package: network-manager 0.8~a~git.20091013t193206.679d548-0ubuntu1
ProcEnviron:
 LANGUAGE=pt_PT.UTF-8
 LANG=pt_PT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: network-manager
Uname: Linux 2.6.31-14-generic x86_64

New test with daily build live CD 20091019
http://cdimage.ubuntu.com/daily-live/20091019/

- boot with live CD
- connect Huawey e620 modem
- modem not detected, wizard to configure the connection does't start (the apposite as happens with 9.04)
- "sudo lsusb" show the modem

The same bug affects daily build live CD 20091019
http://cdimage.ubuntu.com/daily-live/20091020.1/

sorry, I its daily build live CD 20091020
http://cdimage.ubuntu.com/daily-live/20091020.1/

Testing the 9.10 release candidate.
The same problem!

Alexander Sack (asac) wrote :

most likely dupe of bug 430011 which is fix committed and scheduled to be fixed shortly after release. maybe check if the symptoms match your issue and mark as dupe if thats right.

affects: network-manager (Ubuntu) → modemmanager (Ubuntu)
Changed in modemmanager (Ubuntu):
status: New → Incomplete

Thanks Alexander

Meanwhile, I made some tests and found:
- with kernel 2.6.31.11 - modem is detected
- with kernel 2.6.31-13 - modem NOT detected
- the latest kernel 2.6.31-14 - modem NOT detected

Using kernel 2.6.31.11 and everything seems OK.

I will continue testing when new kernel updates and report here.

There is a small problem with the string name of the modem but this is a minor problem. I will check this later to see if there is any open bug about the same issue.

The same problem on Ubuntu 9.10 final release

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers