Ubuntu

freezes with 3D applications on VIA Unichrome K8M800, KM400

Reported by xanmoo on 2006-05-05
160
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
High
X.Org X server
In Progress
High
openchrome
Fix Released
Unknown
Ubuntu
Undecided
Unassigned
mesa (Ubuntu)
High
Unassigned
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-driver-via (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-via (Ubuntu)
Undecided
Unassigned

Bug Description

For some days now, my acer 1362LMI (sempron 2800+) can start with the via driver for K8M800.(xserver-xorg-driver-via 33.2 ubuntu4)

However most of the application using opengl (mesa) freeze the computer . This is the case with :
egoboo
tuxracer
some screen savers
torcs

openuniverse and xcompmgr/transset are ok.

I configured the video with dpkg reconfigure xserver-xorg with or without framebuffer, and I chose 16bits as color depth. I tested two kernels 2.6.15.21-i386 and 2.6.15.22-k7 with the same result.

glxgears yields around 700 FPS (16bits + Kernel K7)

I can play dvd smoothly

[lspci]
00:00.0 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 01)

Created an attachment (id=3841)
Trivial workaround

A trivial workaround for unichrome DRI module which allows you to run Trigger
but not other games.

The situation appears to be more complicated than I thought initially. I've did
additional debugging and now think that all games are suffering from the same
bug in a driver - the symptoms are quite similar. However, there are many ways
to "activate" this bug, so every game (or GL app in general) has it's own
workaround. For instance, in Trigger you should avoid GL_LINEAR_MIPMAP_LINEAR,
in Torcs you should disable GL_ALPHA_TEST when rendering multitextures (it is
always connected with textures somehow) and so on. Usually, the program hangs
between return statement and the next line of code, i.e. in the sample code below:

int some_func() {
  ...
  printf("BEFORE\n");
  return 1;
}
...
while (some_func) {
  printf("AFTER\n");
}

you will see "BEFORE" line but not "AFTER".

So, I've prepared a very simple demo program (see attachement) below which hangs
my computer. Hope it will help debugging driver. More details are in attachment
comments.

Created an attachment (id=4010)
Demo program

This small program is suffering from the described bug. It should display two
rotating triangles (blue and white) but it hangs instead. I've made a program
intentionally simple (no real textures - just autogenerated plain color, no GLU
calls for mipmapping etc) so it has minimum GL calls. To make the program work,
one should either change mipmapping mode or render texture on both triangles.
You will find the comments on which line to remove/modify inside the file. The
bug is highly reproducable with this program but in rare cases you may need to
run the program several times before it hang the computer.

I have the same problem on K8M800. I ran attached demo program and compter
locks up if this line is not commented out:
glDisable(GL_TEXTURE_2D);

Commenting out this line or not doesn't seem to manke any difference:
glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER,
GL_NEAREST_MIPMAP_LINEAR);

I'm running Mandriva Linux 2006 (32bit) with thac&ze
xorg-x11-6.9.0+openchrome+mesa-6.5.0+dkms-drm RPMs:
http://www.mde.djura.org/2006.0/RPMS/

This issue appears to be hitting me as well. The demo program behaves as
described, plus I get a lockup with geartrain and some of the other demos. Note
the gears works fine ( 450 fps ).

I'm using Mesa 6.5 ( downloaded from mesa3d.org ), xorg 7.0 ( xorg-server
1.0.2-r3 from gentoo ) and the openchrome ( http://openchrome.org/ ) driver. I
have a K8M800 chipset and am running on a x86_64 notebook.

I've built mesa 6.5 with debug enabled and set LD_LIBRARY_PATH to point to the
libs in my build tree. I see the following on the command line :-

  bash$ ./geartrain
  __driCreateNewScreen_20050727 - succeeded
  Mesa warning: couldn't open libtxc_dxtn.so, software DXTn
compression/decompression unavailable

The initial geartrain window appears and then the display is locked. Sometimes,
the whole machine is locked up.

Please advise if there is anything I can do to aid debugging this further.

For some days now, my acer 1362LMI (sempron 2800+) can start with the via driver for K8M800.(xserver-xorg-driver-via 33.2 ubuntu4)

However most of the application using opengl (mesa) freeze the computer . This is the case with :
egoboo
tuxracer
some screen savers
torcs

openuniverse and xcompmgr/transset are ok.

I configured the video with dpkg reconfigure xserver-xorg with or without framebuffer, and I chose 16bits as color depth. I tested two kernels 2.6.15.21-i386 and 2.6.15.22-k7 with the same result.

glxgears yields around 700 FPS (16bits + Kernel K7)

I can play dvd smoothly

Vytas (vytas) wrote :

What happens when it freezes? If it is only Xorg lockup, try pressing Alt+F1. Does it help? How often does it freeze, every time you run the mentioned programs, or just sometimes? at the launch time, or after use?

I had issues with my Xorg locking up after prolonged and extensive 3D usage, but it was hardware related (Windows responded with a reboot at the same use cases), most probably that was overheating

Changed in xserver-xorg-driver-via:
status: Unconfirmed → Needs Info
xanmoo (jeanpat-pommier) wrote :

The keyboard does not answer (no Alt F1, can't restart gdm too).
It freezes every time I try to start one of the mentionned applications.

Tomy Weber (tomy) wrote :

I have the same problem on my MSI K8MM-V motherboard with the VIA K8M800 UnichromePro graphics chip -- planetpenquin-racer (aka tuxracer) starts but freezes the computer at the beginning of the race but the sound continues. Ctrl-Alt-Fx does nothing and I am forced to power down.

I also have a MSI KM4AM-V motherboard with the VIA KM400 Unichrome graphics chip. This works fine using the same "via" driver in xorg.conf.

Both computers have a fresh install of dapper beta2.

Tomy Weber (tomy) wrote :

The discouraging sentence in that thread is:
">Thomas said that the unichrome part of Mesa is unmaintained. :( "

This bug causes computers with the UnichromePro graphics chip to randomly freeze if Ubuntu Dapper Drake is installed.

Why? Because Dapper Drake is set (by default) to randomly choose a screen saver and several of the screen savers freeze the computer solid. You must power down. Several times I have had corrupted disk space because of this bug.

Nobody is working on this?? It has been six months since this bug was reported.

Could I pay someone to fix this???

Tomy

I am an end-user not a developer. If I knew how to fix this I would certainly help.

Andy (shadowfirebird) wrote :

I have the same problem. <https://launchpad.net/distros/ubuntu/+bug/57062>

Can anyone tell me what the chances are of this getting looked at?

Gaurish Sharma (gslive) wrote :

well i think this a serious problem and needs more info to fix the bug.

Changed in xserver-xorg-driver-via:
status: Unconfirmed → Needs Info
status: Needs Info → Confirmed
Gaurish Sharma (gslive) wrote :

well i am also unsing this chipset and faceing the same problem. so i am pretty sure this bug report is right!.well we need to repair it fast.

Changed in xserver-xorg-video-via:
status: Needs Info → Confirmed

This problem is also very similar to bug #62093

To simplify things for the Ubuntu bug team, I have marked bug #62093 and bug #57062 as duplicates of this report.

I now have what appears to be the same problem with Wine on Edgy.

See bug #68761

It appears Wine now uses 3d, and we will start to see 3d calls in classpath.

I think the bug importance should be escalated. The bug also has security and data integrity implications as this can be used by a userspace program to cause DOS.

I can confirm.

I have a ASUS ASPIRE 1360LM laptop with a Via Unichrome Pro IGP.

The video card is a K8M800 and works very well with 2d applications like photo, web, email, video, ecc...

The problem is when I run 3d applications...

Tha systems freeze and I can'd to anything. No alt+FX, no ssh... nothing!

I can only reboot pressing the power button per some seconds.

I have this problem since Ubuntu Dapper Drake. Now I have Ubuntu Edgy and It's the same.

I've seen this strage kernel messages when I switch from virtual consoles to X:

irq 185: nobody cared (try booting with the "irqpoll" option)
 <c0139a14> __report_bad_irq+0x24/0x80 <c01745bd> touch_atime+0x5d/0xb0
 <c0139aef> note_interrupt+0x7f/0x240 <c0139383> handle_IRQ_event+0x33/0x60
 <c0139483> __do_IRQ+0xd3/0x100 <c0105169> do_IRQ+0x19/0x30
 <c010361e> common_interrupt+0x1a/0x20
handlers:
[<c022ba60>] (via_driver_irq_handler+0x0/0x1c0)
Disabling IRQ #185
irq 185: nobody cared (try booting with the "irqpoll" option)
 <c0139a14> __report_bad_irq+0x24/0x80 <c0139aef> note_interrupt+0x7f/0x240
 <c0139383> handle_IRQ_event+0x33/0x60 <c0139483> __do_IRQ+0xd3/0x100
 <c0105169> do_IRQ+0x19/0x30 <c010361e> common_interrupt+0x1a/0x20
 <c0101aca> default_idle+0x2a/0x60 <c0101b3c> cpu_idle+0x3c/0x60
 <c04486ce> start_kernel+0x26e/0x320 <c0448210> unknown_bootoption+0x0/0x250
handlers:
[<c022ba60>] (via_driver_irq_handler+0x0/0x1c0)
Disabling IRQ #185

I hope this can be useful...

xanmoo (jeanpat-pommier) wrote :

Same problem.

What should we do ? Protesting at http://forums.viaarena.com/categories.aspx?catid=28&entercat=y

until via decides to release informations to produce a good driver?

xanmoo (jeanpat-pommier) wrote :

I forget to mention that the bug happens under edgy running on an acer 1362LMI K8M800 laptop

*** Bug 7456 has been marked as a duplicate of this bug. ***

Surricani: Your problem with the lost IRQ probably has nothing to do with this bug report. Please check out https://wiki.ubuntu.com/DebuggingIRQProblems
and, if necessary, file a separate bug.

For all the others: It would be helpful if you could have a look at https://wiki.ubuntu.com/TriagingXBugs and https://wiki.ubuntu.com/DebuggingXAutoconfiguration and post your logfiles here. Thanks in advance.

Changed in xserver-xorg-driver-via:
status: Confirmed → Needs Info
Changed in xserver-xorg-video-via:
status: Confirmed → Needs Info
Surricani (surricani) wrote :
Download full text (61.2 KiB)

Thanks for the information about IRQ problems... but the problems (about irq) persist. I know, this is another story/bug...

Also the lockup for 3d applications persist.

So, all work fine. 2d is very good... But when I run 3d application the screen become black and the system freeze. I can only press the power button for some seconds and reboot the system. No alt+Fx or remote connection works. It seems that all system stop.

I can't give you a dump or detailed log because I have to reboot the system and nothing is saved.

But I can give you the following information:

lspci

00:00.0 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:0b.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
00:0b.1 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
00:0b.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter (rev 01)

lspci -n:

00:00.0 0600: 1106:0204
00:00.1 0600: 1106:1204
00:00.2 0600: 1106:2204
00:00.3 0600: 1106:3204
00:00.4 0600: 1106:4204
00:00.7 0600: 1106:7204
00:01.0 0604: 1106:b188
00:0b.0 0607: 104c:ac8e
00:0b.1 0607: 104c:ac8e
00:0b.2 0c00: 104c:802e
00:10.0 0c03: 1106:3038 (rev 80)
00:10.1 0c03: 1106:3038 (rev 80)
00:10.2 0c03: 1106:3038 (rev 80)
00:10.3 0c03: 1106:3104 (rev 82)
00:11.0 0601: 1106:3177
00:11.1 0101: 1106:0571 (rev 06)
00:11.5 0401: 1106:3059 (rev 50)
00:11.6 0780: 1106:3068 (rev 80)
00:12.0 0200: 1106:3065 (rev 74)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
01:00.0 0300: 110...

DominikBodi (dominik-bodi) wrote :

the interrupt problem might be worked around with by using the "irqpoll" kernel command line option. I'll do some research on freedesktop.org bugzilla.

Changed in xserver-xorg-driver-via:
assignee: nobody → ubuntu-x-swat
status: Unconfirmed → Confirmed
Changed in xserver-xorg-video-via:
assignee: nobody → ubuntu-x-swat
status: Needs Info → Confirmed
DominikBodi (dominik-bodi) wrote :

Thanks for the additional info. Judging the bug reports I found at freedesktop.org, I think we can safely confirm this bug. It seems the lost interrupts might have something to do with it actually.

Unfortunately, there doesn't seem to be much activity there. According to the comments at https://bugs.freedesktop.org/show_bug.cgi?id=7456 this seems to be a well-known problem. Unfortunately, the comments also claim nobody's actively maintaining the via unichrome driver at the moment.

As a workaround, you could always use the vesa driver instead of the via one. That would prevent the lock-ups. However, opengl performance would suffer when using the vesa driver.

Btw, you can also paste your logfiles and debug output snippets into files and use the "attach file" option. That makes the comments a wee bit more readable.

Regards, Dominik

Ubuntu bug:
https://launchpad.net/distros/ubuntu/+source/xserver-xorg-video-via/+bug/43154

Which has 3 bugs, has been associated with this bug.
affecting: Screensavers, Wine (windows non-emulator) with any application,
Games, Potentially classpath when 3D enabled.

Changed in xorg-server:
status: Unknown → Confirmed

I can confirm that the IRQ problem is related to the via driver, because when i set the string

Option "DisableIRQ" "true"

in the xorg.conf the kernel message go away.

ahaslam (anthonyhaslam) wrote :

Is anyone on this problem?

Georg Duffner (mcduff) wrote :

there is the openchrome project which provides opensource-drivers for the via chipsets (http://www.openchrome.org/). they know about these problems but developement seems quite slow over there.

I have always problems. No 3d with edgy end VIA K8M800

2007/2/13, Georg Duffner <email address hidden>:
> there is the openchrome project which provides opensource-drivers for
> the via chipsets (http://www.openchrome.org/). they know about these
> problems but developement seems quite slow over there.
>
> --
> computer freezes with some applications using 3D
> https://launchpad.net/bugs/43154
>

I've been using the openchrome svn for some time, the problem still persists. Of course this is apparent under every Distro, but this seems to be the only place where such a large number of users have confirmed the issue. I suppose my question should have been, 'are the Ubuntu dev's planning to help, or are we hoping that mesa becomes maintained?'

Tony.

Andy (shadowfirebird) wrote :

I've come to the conclusion that the sensible solution is to buy a new graphics card.

For those with laptops I accept that that is not much help.

But it does not appear to me that anyone is actively working to fix this problem.

1 comments hidden view all 176 comments

Thats a big Problem, because in Austria ( and possibly in lot more Country's) Computers sold as Linux PC(!) with Asus K8V-MX Motherboard and Mandriva Linux.

People who want to change the Platform and buy an esp chilliGREEN Experience that can't handle 3D will never come back.

Timo Aaltonen (tjaalton) wrote :

Can you try with Feisty Herd5?

Timo Aaltonen (tjaalton) wrote :

Raising severity so that this stands out from the rest of the bugs.

Changed in xserver-xorg-video-via:
importance: Medium → High
Timo Aaltonen (tjaalton) wrote :

Please someone test Feisty beta?

Changed in xserver-xorg-video-via:
status: Confirmed → Needs Info

I've tested it one hour ago...

Same results... :-(

2007/3/25, Timo Aaltonen <email address hidden>:
> Please someone test Feisty beta?
>
> ** Changed in: xserver-xorg-video-via (Ubuntu)
> Status: Confirmed => Needs Info
>
> --
> computer freezes with some applications using 3D
> https://launchpad.net/bugs/43154
>

Timo Aaltonen (tjaalton) on 2007-03-29
Changed in xorg:
status: Confirmed → Rejected

I don't think.

I tried the beta release but the problem persist.

2007/3/30, gary4gar <email address hidden>:
> Is this bug fixed in Feisty?
>
> --
> computer freezes with some applications using 3D
> https://launchpad.net/bugs/43154
>

Georg Duffner (mcduff) on 2007-03-30
Changed in xserver-xorg-video-via:
status: Needs Info → Confirmed
Bryce Harrington (bryce) on 2007-06-25
Changed in xserver-xorg-driver-via:
status: New → Invalid
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → Invalid
Changed in linux:
status: Invalid → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Timo Aaltonen (tjaalton) on 2007-09-22
Changed in xorg:
assignee: ubuntu-x-swat → nobody
Changed in xorg-server:
status: Confirmed → In Progress
96 comments hidden view all 176 comments
Gaurish Sharma (gslive) wrote :

^^^^
posted your comment on DRI :)

stinke (redhat-tux) wrote :

Thanks, I saw it. I don't have an account there.

:)

> No and I don't have those files.
Confirm. I don't have those files in my archive (md5: eed5daf69f0b970aec0a654fdfcb731e) either. Blobs there are standard parts of Mesa DRI driver (unichrome_dri.so and libGL.so). The only strange part is libglx.so, but according to vinstall script it's used on FC6/7 only. But whether those blobs can be generated for the sources provided and what are the licensing terms for them (and last but not least does them suffer from the bug 5092) is still unknown, so I'd rather agree with #33 - lets stop posting here unless we have some specific information regarding the bug.

(In reply to comment #37)
> > No and I don't have those files.
> Confirm. I don't have those files in my archive (md5:
> eed5daf69f0b970aec0a654fdfcb731e) either. Blobs there are standard parts of
> Mesa DRI driver (unichrome_dri.so and libGL.so). The only strange part is
> libglx.so, but according to vinstall script it's used on FC6/7 only. But
> whether those blobs can be generated for the sources provided and what are the
> licensing terms for them (and last but not least does them suffer from the bug
> 5092) is still unknown, so I'd rather agree with #33 - lets stop posting here
> unless we have some specific information regarding the bug.
>

Yes, the driver package contains some binary libraries. I've tried to compile the source on my Debian sid amd64 machine, and find out regardless it would work or not all necessary .so should be able to generated from the given source.

Via utils and mpeg decoding binaries didn't come with source, but I don't care about them.

The dri libraries was written against mesalib 6.5.2- which need some modification to successfully compiled in current mesalib 7.0.2+. But the result .so still crash my X when working with my old drm kernel module.

The drm kernel modules was written against kernel 2.6.18-(for Debian) which was also a bit out of date and will cause lot of compile warnings. And the result .ko refused to work with exist X. According the xorg.log AIGLX report "operation not perrmitted" will initialing and glxinfo also report "operation not permitted", this is really strange, my /etc/dri/card0 was already set to 0666 and I have correct DRI section in my xorg.conf file.

I also tried to compile the v4l modules, but failed.

The 2D driver compiled, but didn't work in my environment.

Anyone else working on this? Any good news?

(In reply to comment #38)
You appear to know your way around source code; you may wish to join #unichrome on Freenode.net.

Is there anyone who successfully installed the driver & the freezing problem is there or "it just works"?

Changed in linux:
status: Confirmed → In Progress
Gaurish Sharma (gslive) on 2008-01-08
Changed in xserver-xorg-video-via:
status: Confirmed → In Progress
ahaslam (anthonyhaslam) wrote :

Via's new source release gave me a black screen on Debian Etch.

Timo Aaltonen (tjaalton) wrote :

Please try hardy alpha3 livecd, which defaults to openchrome now, and it has a newer mesa which might have a fix for this.

Changed in xserver-xorg-video-via:
assignee: ubuntu-x-swat → nobody
status: In Progress → Incomplete
ahaslam (anthonyhaslam) wrote :

K8M800 laptop still freezes with hardy alpha3. Only tested the 'antinspect' screensaver, it took two seconds to lock up.

Gaurish Sharma (gslive) wrote :

Dear Friends,

I have just read and signed the online petition:

   "DECENT VIA GRAPHICS DRIVERS FOR LINUX"

hosted on the web by PetitionOnline.com, the free online petition
service, at:

   http://www.PetitionOnline.com/vialinux/

I personally agree with what this petition says, and I think you might
agree, too. If you can spare a moment, please take a look, and consider
signing yourself.

Best wishes,

Gaurish Sharma

Changed in mesa:
status: Incomplete → Confirmed
mikko (mikko-) wrote :

Alpha 4 livecd, freeze when I tried to start F-spot, Via K8M800

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/+bug/89467

Edney Matias da Silva (edney) wrote :

Hi!

Just to add, same problem here and know X crashes when loging into kde4.

lspci output
00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video (rev 01)

I'd tried it with -openchrome and -via driver availble in ubuntu repository redering the same results.

uname -a
2.6.22-14-generic

Running Ubuntu 7.10 with kde packages from http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu gutsy main.

Signing the petition (http://www.petitiononline.com/vialinux/).

See ya.

tech0007 (tech0007) wrote :

Hi,

Installed the 0.8 binary driver from www.viaarena.com. Wine, f-spot, and a few 3d apps/games are now working fine, (google earth complains that I only have less than 16mb of video). But I still have 3 major issues:

1. glxinfo yields:
libGL warning: 3D driver claims to not support visual 0x22
libGL warning: 3D driver claims to not support visual 0x23
libGL warning: 3D driver claims to not support visual 0x24
libGL warning: 3D driver claims to not support visual 0x25
libGL warning: 3D driver claims to not support visual 0x26
libGL warning: 3D driver claims to not support visual 0x27
libGL warning: 3D driver claims to not support visual 0x28
libGL warning: 3D driver claims to not support visual 0x29
libGL warning: 3D driver claims to not support visual 0x2a
libGL warning: 3D driver claims to not support visual 0x2b
libGL warning: 3D driver claims to not support visual 0x2c
libGL warning: 3D driver claims to not support visual 0x2d
libGL warning: 3D driver claims to not support visual 0x2e
libGL warning: 3D driver claims to not support visual 0x2f
libGL warning: 3D driver claims to not support visual 0x30
libGL warning: 3D driver claims to not support visual 0x31

2. 3d apps and games that require textures locks up X so I have to do ctrl-alt-bckspce.

3. Still no compiz.

lspci | grep VGA
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)

Djainette (djainette) wrote :

Still buggy in Hardy alpha 5. Xorg was supposed to fix the problem.
And Vesa won't even start (no screen found)

Changed in linux:
status: In Progress → Confirmed
Timo Aaltonen (tjaalton) wrote :

Uh, votes mean nothing.. you should need upstream attention, and looking at the upstream bug they are asking for people to help debugging this. So head on to #unichrome (irc channel) on freenode.net, and help the developers.

Djainette (djainette) wrote :

Iv' just tried re-enabling DRI with Hardy beta. It seems to be working so far. I've tried glxgears, winecfg and the GLMatrix screensaver.

Changed in linux:
status: Confirmed → Invalid

with the new via (0.8) for 7.10 ubuntu i got 3D, and (!) Compiz working (just need to add to whitelist btw...) but with black boarders : (

and i got a problem too, my screen (1440x900) was splitted

and the "superior part" was a mirror from the "Inferior part"

weird problem, with a monitor on VGA port, the monitor was ok. nice to see compiz running...

with that "split" problem i needed to go back to xserver-xorg-driver-via. ~750fps on glxgears need at least 32mb ram to play games with wine/cedega (played starcraft/total annihilation) dont have tested with linux games, i will try xmoto but on old versions i got that problem where X Freezes.

only alt+sysrq+k saves when x freezes.

On Mon, Apr 21, 2008 at 7:32 AM, Gerson fserve Barreiros
<email address hidden> wrote:
> with the new via (0.8) for 7.10 ubuntu i got 3D, and (!) Compiz working
> (just need to add to whitelist btw...) but with black boarders : (

I'm interested in this; what does "with black borders" mean exactly?

xanmoo (jeanpat-pommier) wrote :

The gpu was even not recognized during Hardy installation (see attached file for lspci output),whereas the graphic cards (K8M800) was detected with gutsy.

glxinfo yields

glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2

xanmoo (jeanpat-pommier) wrote :

I modified the xorg.conf file to activate 3D acceleration. The computer still freeze with some 3D app.
The performance of the via driver compared to the vesa driver are poor: glxgears yields around 400FPS with via vs 200 FPS with vesa (acer 1362LMI S3 unichrome Pro K8M800) at 1024x768 24 bits .

Recouper (grant-howat) wrote :

Well, I'm getting the issue with n nVidia card. My whole mother board is VIA K8M890CE, so maybe it's the host bridge that's doing it. But if you're thinking of just getting a new gfx card to fix this issue, just beware, it may not fix this.
Man, the frustration!
For quite a while now I was thinking that this was an nVidia issue. Graphics problem... must be the graphics card/driver. But it looks like there's a little more to it than that. 3D games hang my system in matter of seconds and Compiz-Fusion can go for about five minutes... if I'm lucky.
BTW, I signed that petition mentioned a little further back.
Good luck to the rest of you struggling with this.

Gaurish Sharma (gslive) wrote :

@Recouper
I have a K8M800 board & i have been using a nVidia card for past 2 years.
No problems faced yet.

Edd (eduard-budulea) wrote :

Hi, I have a wibrain tablet (chipset vx700) that the producers have put some deb packages for ubuntu 7.04 and 8.04.
They work for all via graphics. The problem is that you will be stuck with the kernel versions that are there.
look at:
http://code.google.com/p/wibrain-b1l/downloads/list
after the instalation the graphics package will modify your xorg.conf to make it work with an lcd of 1024x600, you have to adjust it again.
I can confrm that this packages works with compiz on 7.04 and 8.04
have fun, I know this is not a true solution but better then nothing.

xanmoo (jeanpat-pommier) wrote :

I have removed ubuntu from my acer 1362LMI. Did you try hardy? Does it fix the K8M800 VIA IGP Pro freeze issue?

xanmoo (jeanpat-pommier) wrote :

oops
I meant intrepid ibex

Gaurish Sharma (gslive) wrote :

No, the issue it not fixed.
Its not a Ubuntu problem, rather a upstream bug which is not likely to
get fixed soom. it occurs in all linux distros.
Regards,
Gaurish Sharma
www.gaurishsharma.com

On Mon, Sep 22, 2008 at 4:23 AM, xanmoo <email address hidden> wrote:
> oops
> I meant intrepid ibex
>
> --
> freezes with 3D applications on VIA Unichrome K8M800, KM400
> https://bugs.launchpad.net/bugs/43154
> You received this bug notification because you are a direct subscriber
> of the bug.
>

datatec (datatec) wrote :

This is even worse for my box, using ibex beta, live cd and installed os freeze when it boots up to the login screen.

it basically justs shows a offblue screen an empty space for the login info and a frozen please wait spin circle (no motion)

If I move the mouse around a lot then suddenly a few of these wait circles appear on the screen (I assume at locationss where the mouse was)

I have tried this in video safe mode, using startx from the command prompt. always ends the same. :(

This box works perfectly with hardy. Isn't there any way to fix it for the ibex release?

if it helps to diagnose:
Gigabyte GA-K8VM800M-R2 FB
AND SEMPRON 2600+ using the UniChrome TM2 onboard graphics

Gaurish Sharma (gslive) wrote :

@datatec

Try Using VESA driver.

Regards,
Gaurish Sharma
www.gaurishsharma.com

On Tue, Oct 14, 2008 at 6:33 PM, datatec <email address hidden> wrote:
> This is even worse for my box, using ibex beta, live cd and installed os
> freeze when it boots up to the login screen.
>
> it basically justs shows a offblue screen an empty space for the login
> info and a frozen please wait spin circle (no motion)
>
> If I move the mouse around a lot then suddenly a few of these wait
> circles appear on the screen (I assume at locationss where the mouse
> was)
>
> I have tried this in video safe mode, using startx from the command
> prompt. always ends the same. :(
>
> This box works perfectly with hardy. Isn't there any way to fix it for
> the ibex release?
>
> if it helps to diagnose:
> Gigabyte GA-K8VM800M-R2 FB
> AND SEMPRON 2600+ using the UniChrome TM2 onboard graphics
>
> --
> freezes with 3D applications on VIA Unichrome K8M800, KM400
> https://bugs.launchpad.net/bugs/43154
> You received this bug notification because you are a direct subscriber
> of the bug.
>

muzzamo (murray-waters) wrote :

Gaurish: whats the easiest way to force it to use the vesa driver?

Bryce Harrington (bryce) on 2008-11-14
Changed in xserver-xorg-video-via:
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

open for mesa already.

Changed in xserver-xorg-video-via:
status: Confirmed → Invalid
Bryce Harrington (bryce) on 2009-01-16
description: updated

More than a year passed... does anybody know anything new? I tried mesa 7.4, xorg server 1.5.3, libdrm 2.4.7, linux 2.6.28.9, openchrome 0.2.903. And I see the same hanging problem, maybe related to textures, because glxgears works well, but no other gl apps.

I have some self-made gl programs which only put points (no wireframe, no surfaces, ...), and that also hangs all.

Changed in openchrome:
status: Unknown → Fix Released
Bartosz Kosiorek (gang65) wrote :

This bug was fixed in the openchrome svn 749. The 3D application will not freeze any more. It use software rendering

Thanks. I no longer have the laptop in question though.

On Thu, Aug 13, 2009 at 2:03 PM, Bartosz<email address hidden> wrote:
> This bug was fixed in the openchrome svn 749. The 3D application will
> not freeze any more. It use software rendering
>
> --
> freezes with 3D applications on VIA Unichrome K8M800, KM400
> https://bugs.launchpad.net/bugs/43154
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
" Carpe Diem! Rejoice while you are alive;
enjoy the day; live life to the fullest;
make the most of what you have."

- Horace

I appreciate all of the developers' hard work as well, but I no longer have my laptop either.

--- On Thu, 8/13/09, Chris George <email address hidden> wrote:

From: Chris George <email address hidden>
Subject: Re: [Bug 43154] Re: freezes with 3D applications on VIA Unichrome K8M800, KM400
To: <email address hidden>
Date: Thursday, August 13, 2009, 9:54 PM

Thanks. I no longer have the laptop in question though.

On Thu, Aug 13, 2009 at 2:03 PM, Bartosz<email address hidden> wrote:
> This bug was fixed in the openchrome svn 749. The 3D application will
> not freeze any more. It use software rendering
>
> --
> freezes with 3D applications on VIA Unichrome K8M800, KM400
> https://bugs.launchpad.net/bugs/43154
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
" Carpe Diem! Rejoice while you are alive;
enjoy the day; live life to the fullest;
make the most of what you have."

- Horace

--
freezes with 3D applications on VIA Unichrome K8M800, KM400
https://bugs.launchpad.net/bugs/43154
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Bryce Harrington (bryce) wrote :

Closing as believed-fixed as per the last few comments.

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
ahaslam (anthonyhaslam) wrote :

Not fixed.

K8M800 locks up solid with ant-spotlight screensaver in alpha 5.

beblasl (beblasl) on 2009-11-24
Changed in mesa (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

I have this problem on an new install from:
Ububtu v9.10 desktop amd64 (downloaded 2010-Feb-25)

Is this fixed?
Where can I get the fix?
How do I apply the fix?

-Joshua

Changed in xorg-server:
importance: Unknown → High
Alberto Jovito (thedemon007) wrote :

I have this problem on an new install from: Ububtu v10.10 desktop amd64 with driver vx800

Alberto Jovito (thedemon007) wrote :

Open wine freezes when using drivers openchrome not the case with the vesa driver if works well

Bryce Harrington (bryce) on 2010-11-27
tags: added: omit
Changed in linux:
status: Invalid → Unknown
Changed in linux:
status: Unknown → Invalid
Changed in xorg-server:
importance: High → Unknown
Changed in linux:
importance: Unknown → High
Changed in xorg-server:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 176 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.