Kernel Hard Freezing Very Often

Bug #908335 reported by Jmadero on 2011-12-24
210
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
High
linux (Ubuntu)
High
Unassigned
linux (openSUSE)
Invalid
Critical

Bug Description

I (and others in the forums) are experiencing MANY hard freezes in Ubuntu since upgrading to Kernel 3.0. Here is as much information as I can give now but I'll run anything (including the possibility of allowing a remote connect) to diagnose this problem as I think it is serious and has the potential to ruining machines as I'm frequently having to hard shut down which of course runs the possibility of damaging a hard drive.

Problem: Hard freeze very often (I've had as many as 5 in an hour). Hard freeze definition from me:

1. Mouse stops moving
2. Keyboard actions have no response (including alt+cntrl+f1)
3. Hard drive spins for a shor time but then stops
4. Only way to fix is hard shut down

What's been done:

1. Checked logs (willing to provide any but I couldn't see any problem)
2. Tried finding out if software is triggering it, seems to be random, could be wrong

Again I think that this is a major problem so I'll do whatever it takes to provide information. Thank you in advance

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-12-generic 3.0.0-12.20
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joel 1738 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc700000 irq 46'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:111d7675,102802a0,00100103 HDA:80862802,80860101,00100000'
   Controls : 20
   Simple ctrls : 11
Date: Fri Dec 23 23:12:36 2011
HibernationDevice: RESUME=UUID=90f593d0-5fa7-400f-a725-a895731a11cb
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Dell Inc. Studio 1737
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=e1aae5f2-06b0-45a0-bf21-9ede9bd5263d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 11/25/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0m824g
dmi.board.vendor: Dell Inc.
dmi.board.version: A08
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A08
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd11/25/2009:svnDellInc.:pnStudio1737:pvrA08:rvnDellInc.:rn0m824g:rvrA08:cvnDellInc.:ct8:cvrA08:
dmi.product.name: Studio 1737
dmi.product.version: A08
dmi.sys.vendor: Dell Inc.

Note book QOSMIO X500
Freeze randomly after 12.1 fresh install.
Was running fair before on 11.3.
Run now fair after downgrading to 11.4.
SEE : http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/468609-12-1-fresh-install-opensuse-forum-freeze-system.html
kernel will start flashing the capslock LED
Ksysguard is frozen in a non overload state
CTRL-ALT-Fn as no effect

+++ This bug was initially created as a clone of Bug #732667 +++

User-Agent: Opera/9.80 (X11; Linux x86_64; U; de) Presto/2.9.168 Version/11.52

On my Netbook, an ASUS EeePC 1201T openSUSE freezes randomly. I tried different apps trying to find out which application may cause the freeze. I tried KDE, Gnome, openSUSE 11.4 and 12.1 without any success.
Sometimes it runs hours and sometimes only a few minutes. It freezes and I can't do anything except for hard reboot.

Alt+Print+B doesn't work, Ctrl+F1 doesn't work either... I checked the Netbook for around 13 hours with memtest86+ without any warning about a broken RAM.

I ran the Netbook for almost a day without any problems so I think it might be problem with the Kernel but I'm not sure where to start the search for informations.

Reproducible: Sometimes

Steps to Reproduce:
1. Turn on and wait
Actual Results:
The complete Netbook freezes and I can't do anything.

Expected Results:
It shouldn't freeze.

Jmadero (jmadero) wrote :
Brad Figg (brad-figg) on 2011-12-24
Changed in linux (Ubuntu):
status: New → Confirmed
Phil. V (philip.v) on 2011-12-24
tags: added: regression-release
67GTA (67gta) wrote :

I have seen reports of brcmsmac freezing systems. This freeze happens with wl also. It is independent of DE, running apps, etc. I recreated the freeze with 3.0.0-15(with all updates applied) last night. This is a complete HARD freeze with no logs being created. The machine was even unresponsive trying to get a crash dump with ssh/telnet. Ctrl+Alt+F1 and REISUB are useless. So far every kernel I've tested after 2.6.39 has this bug. I will be happy to contribute if anyone knows how to gather crash info.

Also affected.

Dell Studio 1569. This is a complete system freeze. Ctrl+F1 or REISUB are useless. No system logs are recorded for clues as to the crash. Only a hard shutdown/reboot works. Telnet/ssh will not connect for crash dump either. Please advise on how to collect data.

Changed in linux (openSUSE):
importance: Unknown → Critical
status: Unknown → Confirmed
67GTA (67gta) wrote :

I just got something while running tail -f /var/log/kern.log. Right before the freeze there was a mention of a cron hourly job starting (not sure which cron job). Then "rcu_sched_state detected stall on CPU 0".

I just got something while running tail -f /var/log/kern.log. Right before the freeze there was a mention of a cron hourly job starting (not sure which cron job). Then "rcu_sched_state detected stall on CPU 0".

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2-rcN kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

tags: added: kernel-da-key needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
z06gal (z06gal) wrote :

I am also affected by this. It is freezing multiple times a day and could not be more annoying. The only thing to do is a hard shutdown as nothing else works. I am running Mint 12 32bit

Hello, I am also suffering from this issue with openSUSE 12.1. I believe the problem to be related to Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller.

http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/468609-12-1-fresh-install-opensuse-forum-freeze-system.html

The person suffering from this issue has the wireless card as myself. Also, this problem affects Fedora 16, but not Chakra Linux, which uses the 3.1.4 kernel. Perhaps it has already been fixed or the problem is related to rpm distributions?

Jmadero (jmadero) wrote :

I'll try installing kernel 3.2 tonight, I know Ubuntu 12.04 is using it so I might be able to do it easily enough in Ubuntu 11.10

Jmadero (jmadero) wrote :

I'm now running 3.2 and haven't hit any snags (had locked three times this morning on 3.0.) I'll post back if my system does lock but if not, just go grab the 3.2 kernel image and generic header from kernel.ubuntu.com and you should be set. The only issue is that installing the STA driver for wireless doesn't work through additional hardware, going to try to install it after work manually.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: kernel-fixed-upstream-v3.2
removed: needs-upstream-testing

I have the same symptoms, thought it was RAM problem. I was using openSUSE 12.1 since release and this bug started to appear not so long ago: 1-2 months or something like that.

Same as Daniel Yaren, I am using Realtek Semiconductor Wireless LAN Controller.

__
Linux solar 3.1.0-1.2-desktop #1 SMP PREEMPT x86_64 GNU/Linux

Danny Goodall (danny-onebloke) wrote :

I also appear to be a victim of this problem. I am running Ubuntu 11.10 kernel 3.0 on a Dell Latitude e6400 laptop. The system works fine when running out of my docking station but when it is docked it will freeze as described above anything from 2 minutes to 3 hours. I seldom get more than 10 minutes usage before it needs a hard reset. It also runs fine under Ubuntu 10.10 - either docked or undocked.

I had 'assumed' that the problem was down to running multiple monitors and the custom Nvidia driver but now I may look into disabling the on board network (which is not present when un-docked) following the discussion above.

Please let me know if I can help to narrow this down.

Jmadero (jmadero) wrote :

Try the new kernel, it will probably fix it as it has fixed my issue.

http://kernel.ubuntu.com/~kernel-ppa/mainline/

Danny Goodall (danny-onebloke) wrote :

Jmadero. Thanks for taking the time to respond. I installed the 3.2.1 kernel image from the link you pointed me to. The machine booted to console not the desktop as I guess my Nvidia drivers were not available and therefore the x config is wrong.

I logged in to the shell but after about 2 minutes the system hung again. Booting away from my docked station appeared to work with no problems. Problem still there.

I had previously tried disabling the docking station's Ethernet port and also booting with the wireless networking disabled (as a post above suggested that Realtek network hardware might be a problem - although I'm pretty sure my Dell e6400 has Intel WiFi hardware). Disabling both still caused 11.10 Ubuntu with kernel 3.0.0-15 to hang.

As I said before the odd thing about this behaviour is that I can use 11.10 all day with zero problems running 3.0.0-15, but as soon as it is docked I experience these hard lock-ups.

Danny Goodall (danny-onebloke) wrote :

Can I ask if anyone else is experiencing these symptoms even though they've tried kernel 3.2.x ?

Or has using kernel 3.2.x cleared this problem for everyone?

I'm just trying to establish if I'm experiencing this issue or a separate one.

Thanks.

I am using thinkpad x220 with osuse 12.1 and kernel 3.1.9 and 3.2.4. Both kernel versions have random freeze (SysRq keys don't work) that needs hard reset. Previously used osuse 11.4 and didn't had this problem. Nothing usually is running when the freezes happen.

I have "Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection" LAN controller and "Intel Corporation Centrino Advanced-N 6205" network Controller.

Is this the same as https://bugzilla.novell.com/show_bug.cgi?id=732667 and https://bugs.launchpad.net/ubuntu/+source/linux/+bug/908335 ?

Bamoqi (bamoqi) wrote :

I am using thinkpad x220 with opensuse 12.1 and kernel 3.1.9 and 3.2.4. Both
kernel versions have random freeze (SysRq keys don't work) that needs hard
reset. Previously used opensuse 11.4 and didn't had this problem. Nothing usually
is running when the freezes happen.

I have "Ethernet controller: Intel Corporation 82579LM Gigabit Network
Connection" LAN controller and "Intel Corporation Centrino Advanced-N 6205"
network Controller.

Jmadero (jmadero) wrote :

My question is how is this a critical bug for OpenSuse but only a medium bug for Ubuntu? To me random freezes should always be high priority

I too am having this difficulty. Have two terminal Windows open and Three Firefox windows all with three or more tabs. In addition have YAST2 control center open and printer configuration in it. Switched to printer configuration window and then back to one of my Firefox windows and the system locked. The mouse cursor went from an arrow to a 'I' and never changed. Could move mouse cursor all around -but- no action from the buttons... and no response from the keyboard. Only result was to hit the Power Off button. Upon restart everything worked OK, in fact all my tabs in Firefox restored themselves. YAST2 stayed closed though.

This happens randomly -and- does not seem to have a pattern. I also use VMware and DID NOT have it running this time -but- have had this lockup whilst in VMware inside one of my Virtual Windows.

As far as I can tell ...from my experiences... it happens primarily when I switch from one window to another. IF that can be of some help.

My System is an HP m7480n with an nVidia 7300 LE.

Thanks,
Chuck
P.S.
   I, like the others DID NOT have this problem in prior versions of SuSE or openSuSE.

Back on the possible problem -or- symptom. Maybe some of you others experiencing this problem can confirm it. It appears that switching from one window to another is when it gets lost. Some of this indication is because of the mouse cursor. When I have had lock-ups, sometimes the mouse cursor is an Arrow and other times it is the 'I'. This "appears" to be dependent on what you were doing in the window that you left. It seems that the switch doesn't get completed. Perhaps there is a stack overflow or something like that. I'm not sure how to detect just what is happening. IF anyone has any suggestions I will try them.

My System is an HP m7480n with an nVidia 7300 LE... with openSuSE 12.1 KDE 4.8.

Thanks,
Chuck

Danny Goodall (danny-onebloke) wrote :

@Chucktr I can leave my Ubuntu 11.10 machine to boot while in the docking station and when I come back to it (3-20 minutes later) the system will have hung at the login password prompt. This is repeatable 99.9% of the time. If I log in straight away then I will either get <3 minutes use (90+% of the time) or I will be able to use it for 30-180 minutes before it hangs - but it always hangs.

If I boot out of the docking station then 11.10 runs wonderfully with zero hangs. As for the cursor, which I'm not sure is important in my case, it is either a vertical bar or has completely disappeared by the time it hangs.

Also my system hangs completely. No movable mouse cursor, no keyboard response (ALT+Fn) and no led status light activity. The screen is left as it was when it hung and it requires a hard reset to turn off.

Dell Latitude E6400, latest BIOS A31, NVIDIA drivers (295.20), twin monitors while docked, Ubuntu 11.10, kernel 3.0.0.12-16 (also tried kernel 3.2.1 as described above)

I'm not familiar with the process for triaging and fixing problems like this. Is this the right place to post this stuff? If so why is it apparently being ignored. If not can someone please direct me to the right channel for reporting issues with Ubuntu like this?

Many thanks.

Hi Jean-Claude,

Flashing keyboard lights are the symptom for a general class of problems:
kernel panics. In order to fix this issue we first have to narrow down what is
going on. In order to do this I suggest three possibilities to capture some
logs at the time of the panic:
1) configure a serial console
   This requires a serial port (not a usb adapter type) on the affected
   machine, a second machine with a serial port (usb or not) and a null modem
   cable
2) configure netconsole
   This requires a wired network connection on the affected machine and a
   second machine on which you can run ex. netcat.
3) configure kdump
   This only requires configuring some extra packages.
   As root, run
           # zypper install yast2-kdump
           # yast2 kdump
                pick Enable kdump
                in "Dump filtering" uncheck everything, this will reduce the
                size of the dump file
        You can find some information about configuring kdump here:
        http://doc.opensuse.org/documentation/html/openSUSE/opensuse-tuning/cha.tuning.kexec.html#cha.tuning.kdump.basic.yast
   Reboot. The next time there is a kernel panic, kdump will create a dump of
   the system memory and store it in a subfolder of /var/crash (in the default
   configuration). The screen may be garbled while the dump is taking place
   and it may take a few minutes; the machine will restart automatically after
   it is done. Once rebooted, tar-up the newly created folder (found under
   /var/crash), give the archive a significant name, upload it to
   ftp.novell.com/incomming and leave a comment in this bug entry with the
   name of the file.
        # cd /var/crash
        # tar -jcf bnc738547-kdump-2012-03-27-11-39.tar.bz2 2012-03-27-11\:39/
        # ftp -u ftp://ftp.novell.com/incoming/ bnc738547-kdump-2012-03-27-11-39.tar.bz2
   This ftp has write-access only from the outside. Only people within SUSE
   will be able to access your kdump.

Changed in linux (openSUSE):
status: Confirmed → Incomplete
Danny Goodall (danny-onebloke) wrote :

OK, as Ubuntu 10.10 has just hit end of life, I really need to solve this issue so I can go to 11.10.

Can someone, anyone, please advise me if this thread is the right place to discuss and hopefully create a fix for a critical problem in 11.10?

If not, can someone please point me in the right direction to log and escalate this problem?

As Jmadero asked above. How can ostensibly the same issue be categorised as Medium impact in Ubuntu and Critical in openSuse.

Many thanks.

Jmadero (jmadero) wrote :

Danny have you tried Beta 12.04? It's almost final release at this point, give it a try and see if you still have problems

Danny Goodall (danny-onebloke) wrote :

Many thanks for the response Jmadero. No I haven't tried 12.04 but I will do when I get time.

I'm more interested in whether this is the right mechanism for raising critical bugs like this with Ubuntu.

Can you comment on that?

If it's not the right mechanism then I'd gladly be pointed somewhere else.

If it is the right place then I'm losing a bit of faith with the Ubuntu process. I'm not an uber-geek. I'm a technology marketing guy - a tech-savvy ex-Windows user that has been really happy with Ubuntu as my platform of choice for the last 18 months.

But now I find myself between the proverbial rock and a hard place. 10.10 is EoL and an apparently critical bug in 11.10 is not fixed or even commented on despite months of me and others trying to get feedback. Plus I've no confidence that the same issue isn't in 12.04 - as you'll see above I've tried a 3.2x kernel.

I guess I'm the sort of user that Ubuntu must reach out to if its to reach a more mainstream audience and I'm struggling to justify my decision to use it at the moment.

I don't want that to sound too dramatic, I really value that OS movement, love using Ubuntu and recognise the value that I've already had, but this is very frustrating. I have to believe that I must be in the wrong place to post these reports if they are just being ignored.

One more time, can anyone tell me how to escalate this bug report?

Thanks for your time.

Jmadero (jmadero) wrote :

This is the place to report and it's out of my control (or yours) to escalate, that's up to the developers to decide importance. I'm no longer using Ubuntu, I left it about 4 months ago for a branch of it (Bodhi Linux) which I've been quite happy with.

Have you also tried downgrading your kernel? If there is no reason to upgrade (ie. the new one supports your hardware better) there isn't any harm done going back to an older kernel. As I've moved away from ubuntu which is all about cutting edge, many developers think "if it's not broken, don't upgrade".

With this philosophy in mind I now have two installs, one really basic one that I keep up to date for testing the other stable which I only upgrade after the test version has worked well for 1-2 months doing normal day to day stuff.

I do think you should try 12.04, maybe it's a X problem which will be upgraded in 12.04, or a video driver issue which maybe was solved in 12.04. I think that the main issue is that as it gets so close to release of a new LTS they're probably focusing on this instead of looking at bugs on older releases (just a guess)

Changed in linux (Ubuntu):
importance: Medium → High
Joseph Salisbury (jsalisbury) wrote :

@Danny

It would be helpful if you could test the latest mainline kernel. That will tell us if the bug is already fixed upstream. If it is, we can perform a bisect to identify the commit that fixed this bug and figure out if it can be backported to Oneiric.

The latest upstream kernel is available from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc2-precise/

It would also be good to know if this is fixed in the 3.2 kernel, which is available from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.14-precise/

tags: added: kernel-fixed-upstream
removed: kernel-fixed-upstream-v3.2
Danny Goodall (danny-onebloke) wrote :

Joseph, I will try both Kernels and report back. I did try 3.2.1 as noted earlier in this thread but the issue of hanging was still there.

Just to be clear, the last time I did this, the link allowed me to install the kernel and boot to a terminal prompt but does not link in my Nvidia drivers or the X system. Is that OK or should I carry out some further procedure to allow me to start X?

Thank you very much for taking an interest in this problem.

@jmadero - thanks again for your helpful suggestions.

Danny Goodall (danny-onebloke) wrote :

@joseph, the problem is still there with both versions of the kernel that you suggested I try.

Firstly, I confirmed that the problem is still there in 3.0.0-16 (I think this is the latest release kernel) under 11.10.

I booted with my laptop being UN-docked and, as usual, all was fine. I was able to download the kernel images you suggested and installed them. I then booted under 11.10 kernel 3.0.16 with my laptop DOCKED. I left it at the X (GUI) login screen for ~3 minutes and as usual it hung necessitating a hard rest.

OK - so I knew the problem is still there and reproducible.

I then booted DOCKED into 3.2.14 and because I only installed the kernel image I just got the character screen terminal login (No X). I waited for 5 minutes and was able to login. I logged out and waited again but was still able to login. Then I typed sudo shutdown 0 and in typing my password the system hung. When this happens the screen freezes and the keyboard doesn't respond at all (including ALT+Fx. Caps lock, etc). It requires a hard reset at this point.

I then booted DOCKED into 3.4.0rc2 and this time I waited 5 minutes at the terminal login screen and it had hung as above. Another hard reset.

Finally I booted 3.2.14 whilst UN-docked and used it at the character terminal for 10-15 mins with no problems whatsoever.

I can use 11.10 kernel 3.x all day long when UN-docked with no problems.

I can use 10.10 kernel 2.x all day long DOCKED or UN-docked with no problems.

The problem appears to be readily reproducible whenever my laptop is DOCKED under 11.10 with a 3.x kernel. That said I have had a VERY small number of occasions when I was able to use 11.10 DOCKED for 10-180 minutes before it finally hangs. But this has happened so few times it's almost not important. It always hangs eventually. I mention it in case it helps to narrow down the issue.

What would you like me to try next?

Many thanks for your help with this.

Jmadero (jmadero) wrote :

Try to download kernel from 12.04 repository and install it in 11.10 manually

sudo dpkg -i packagename.deb

Joseph Salisbury (jsalisbury) wrote :

@Jmadero

Do you see this issue if you install the 12.04 kernel on 11.10?

Jmadero (jmadero) wrote :

I left Ubuntu some time ago and haven't seen the problem with my current distro. I'm only running 3.0.0-12 though so not sure if I'd see the problem if I put in 3.2.

I'm willing to test it out if Danny is uncomfortable with trying it, it'll just take me a couple days to get a test machine up and running

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Jmadero (jmadero) wrote :

I haven't tested the latest upstream kernel, I said I'm willing to, not that I have ;) If I test this weekend and it has problems I can report to upstream bug

Danny Goodall (danny-onebloke) wrote :

Joseph, as I've seen no further information about an upstream bug being reported for this issue, I will attempt to raise one over the next couple of days.

Thanks again for your help.

Danny Goodall (danny-onebloke) wrote :

@joseph salisbury

Joseph, I have raised the issue at kernel.org as you requested. The bug reference there is 43133. See

https://bugzilla.kernel.org/show_bug.cgi?id=43133

Can you advise how I should track the issue from here?

Thanks again for your help.

Jmadero (jmadero) wrote :

Thanks Danny for taking care of this. I ended up being voluntold to work the weekend so I didn't get any time to install Ubuntu and do the testing.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Danny Goodall (danny-onebloke) wrote :

@joseph salisbury - just to confirm that the problem still exists in 12.04 Ubuntu with kernel 3.2.0-24.

I have updated my kernel bug report...

https://bugzilla.kernel.org/show_bug.cgi?id=43133

...accordingly.

Changed in linux:
importance: Medium → High
Brendan Brigham (brigham) wrote :

Will also confirm that this is an issue with kernel 3.2.0 in Ubuntu 12.04
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/993187
Listed confirmed but undecided as importance o.O

Danny Goodall (danny-onebloke) wrote :

Additional information. I've also tried 12.04 on 3.2.0-24 with the Nouveau drivers in case it was related to Nvidia (which I must admit I thought it was), but the same issue occurred.

I've updated my bug report at kernel.org accordingly

https://bugzilla.kernel.org/show_bug.cgi?id=43133

@ joseph salisbury - can you advise what is happening with the bug I reported here and the one I reported at kernel.org?

Sorry for my naivety but I assumed that I would see status changes or at least have some form of communication or feedback.

I am stuck on 10.10 without updates as no upstream release works for me.

Danny Goodall (danny-onebloke) wrote :

@ Brendan Brigham - I'm not sure that this is the same issue because reading through the logs there it seems that the problem relates to heavy graphics use, and perhaps the Intel Ivy Bridge chipset.

Plus some users there suggest that they are able to open a shell and interact with the machine.

When my system hangs. It requires a power-off - no response.

I guess they might be related though so thanks for cross-posting it.

Luis Henriques (henrix) wrote :

The ideal scenario to help debugging this would be to get the kernel log during a system freeze through a serial console, but I guess your laptop does not have a serial port.

The other thing that *could* help finding the cause of this issue would be to compare the logs of a kernel that is known to freeze the system with your laptop docked and un-docked. So, you could:

  - Un-dock your laptop, boot, and get the kernel logs
  - Dock your laptop, boot and get the kernel logs

The important thing here is to use the same kernel in both runs, and to pick a kernel that is known to trigger the issue. Would you be able to append these two kernel logs to this bug report?

 You can get the kernel logs by simply booting and running "dmesg > kernel.log" in a terminal. (This will create a file named "kernel.log", that you should append to the bug report).

Danny Goodall (danny-onebloke) wrote :

This file was created by a dmsg > filename soon after booting in DOCKED configuration. This is the state that will eventually hang.

Danny Goodall (danny-onebloke) wrote :

This file was created by a dmsg > filename soon after booting in UN-DOCKED configuration. This is the state that will run with no problems.

Danny Goodall (danny-onebloke) wrote :

@ Luis Henriques - thank you very much for your reply.

I've attached the files as requsted. Thanks for the interest in this problem, please let me know if you need any further information.

BTW I do have a serial port on my docking station (although not the laptop itself). I don't think I have a cable but I'm sure I can get one. Let me know if we need to go down that root.

Regards

Danny Goodall

Luis Henriques (henrix) wrote :

Thank you for providing this information. I took a quick lock at the logs and the first thing that caught my attention were the additional devices provided by the docking station. Next, I say the following at the end of the kernel-docked.log:

[ 42.445360] retire_capture_urb: 36 callbacks suppressed
[ 42.696115] delay: estimated 310, actual 1
[ 43.419428] delay: estimated 354, actual 1
[ 43.423747] delay: estimated 177, actual 0
[ 43.465214] delay: estimated 354, actual 1
...

This again suggests something related with a USB device. So, there are a couple of things we could try here. The first one would be, if if possible, to disconnect all the devices attached to the docking station. For example, the Wireless Headset, the USB Receiver and all the others. If this does actually solve the problem, we can try to go and start adding the devices one by one and see which one (or which combination) actually triggers the issue.

If it is not possible to disconnect these devices (or if this does not solve the problem), another thing to try would be to compare the kernel modules loaded in both configurations (docked/un-docked). The list of kernel modules can be obtained through the command "lsmod". We could then try to blacklist the modules that are loaded only when the system is docked and try to find a possible buggy driver.

Please post any additional information (success/failure) you can get from the tests suggested above.

Brendan Brigham (brigham) wrote :

@ Danny Goodall ...I am having hard freezes that have nothing to do with any graphics. When I was rebuilding my conky files with gedit that wouldn't cooperate with 12.04 I was having a freeze every 5-8 minutes for 2 hours. Once it freezes I am not able to have any interaction with the desktop and have to use the power button or reset button. I don't think I gave my system specs here so I will to hopefully clear up some needed questons...

Intel® Core™ i3 CPU 540 @ 3.07GHz × 4
3.8 GiB DDR3
3.2.0-24-generic-pae 32bit
MSI H55M-E33 motherboard
Asus ENGT 240 using Ubuntu supplied drivers as the Nividia drivers don't work with xscreens for some reason.

Could be an issue with compize or Unity as many of us have been testing in 2d without a single problem, when logged in 3d is where the freezes are. I am on day 4 in 2d now without any problems.
Let me know if there's any other information you would like :)

Jmadero (jmadero) wrote :

@Brendan, I don't think the comment was that it's high graphics usage, just the card itself (ie. just using it with xorg regardless of what you are using it for) is causing some kind of a hiccup.

I haven't tested with 12.04 but I remember with 11.10 I was having freezes in 2d & with Gnome-Shell

Brendan Brigham (brigham) wrote :

Danny wrote "reading through the logs there it seems that the problem relates to heavy graphics use", I was just relating that mine aren't related to "heavy graphics use". I could be using a simple text editor and have the problem. On the other bug report there are users who have added graphics cards and also those using built in graphics and both having the same problem.
Miserable little bug no matter how ya look at it lol.
Another little note, compared to 11.04 I noticed a lot higher cpu temps, I went from averaging around 75f, now 95f. I know it's well within accepted parameters, but a quite noticeable jump none the less.

Danny Goodall (danny-onebloke) wrote :

@Louis Henriquez - OK so I *MIGHT* have some good news.

I'm writing this entry from Ubuntu running 12.04 3.2.0-24 DOCKED! It's early days yet and I could yet be disappointed, but it *looks* like with your help I've narrowed down the problem and found a work around.

It appears to be a conflict between my Dell PR02X docking station's USB sub-system and the Logitech C-UAK42 Mini Receiver wireless keyboard and mouse controller. I'll explain this long-hand below in case others are searching for the issue, or it provides clues to anyone trying to fix the it.

I followed your advice of removing USB devices under the docked configuration where I knew that the system would eventually fail. I've triple checked each of the results and run the system for long duration in docked configuration so it *looks* like this is the problem. But as I've been trying to resolve this for over a year and had many a false dawn, I'll only know it's fixed after more use.

So booting docked, with just the Logitech C-UAK42 Mini Receiver plugged into my Dell PR02X docking station and simply waiting at the login screen was enough for the system to hang in under 5 minutes. Booting docked but with the Logitech C-UAK42 Mini Receiver removed from the docking station meant that in each of the three tests I ran, I was able to leave it at the login prompt for ~20 minutes.

The problem was that without it I was obviously without a keyboard and mouse. So out of hope more than science I ran the same test above but this time with the Logitech C-UAK42 Mini Receiver plugged into my laptop (using its in-built USB system - not the docking station's). In this configuration I was able to run the system for >3 hours and through a couple of reboots last night with no problems at all. I'm using it again this morning and so far so good. I've never been able to use a 3.x kernel in that configuration for that long before.

I'll keep you updated and *if* this proves to be more conclusive I will update my kernel bug report too.

Thank you once again for your help and I'd be more than happy to run further tests if anyone is interested in tracking this down further.

Danny Goodall

Danny Goodall (danny-onebloke) wrote :

@Brendan Brigham - yes I think I should more correctly have said that there appeared to be a variety of issues causing the hanging on the other bug report, rather than suggesting they were all relating to video stressing. That wasn't my intention.

Also the actual type of hang reported appears to be different too - some requiring power off, others fixable through keyboard intervention. I suspect that there are many root issues on that thread that should really be reported separately but Ubuntu 12.04 hanging is a catch-all.

As with the 'solution' I've just posted, I can quite imagine that I am the only person on this bug report that is suffering from exactly this Logitech->Dell issue. I guess it does point to a core instability somewhere between drivers and the kernel though. Perhaps all these reports are related? Who knows? All I do know is that something in 2.6x kernel/drivers was able to deal correctly with my Logitech C-UAK42 mini receiver keyboard controller and since 3.x it's broken.

Anyway, good luck with your issue and fingers crossed that I really have found a workaround. This has been driving me mad!

Danny Goodall

Danny Goodall (danny-onebloke) wrote :

As promised a further update from me and confirmation that I have definitely found a work-around. I've been running 12.04 Ubuntu with 3.2.0-24 for 3 days now with none of the hanging problems I'd previously experienced.

That said I've realised that the problem isn't necessarily with the C-UAK42 mini receiver keyboard controller as stated above, it actually appears to be a problem between my Dell PR02X docking station and any USB device connected to it whilst running a 3.x kernel.

As a test I plugged my Logitech wireless headphone received into the PR02X docking station and the system hung within 5 minutes.

As promised I will update my kernel bug report in the hope that someone will follow through and identify what the issue is with the Dell PR02X docking station.

Thanks one and all for the help and advice - enjoying life under 12.04!

Danny Goodall

pureblood (freeseek) wrote :
Download full text (5.0 KiB)

I confirm I have the same problem with a Dell Vostro V131 (with 8GB and a Seagate Momentus 500GB hybrid) I bought six months ago. After upgrading to Ubuntu Precise I started to experience hard freezes, 2-3 times a day, for no reason at completely random moment, even if I am leaving the computer alone. I have tried upgrading and downgrading the kernel but it doesn't help. When the system freezes, keyboard and mouse do not respond, SysRq does not respond, ssh is not possible, after a while the machine becomes quiet and the hard drive stops spinning(!). No useful logs get recorded. Here is the output of lspci:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
09:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
0b:00.0 USB controller: Texas Instruments Device 8241 (rev 02)

here is the output of lsmod:

Module Size Used by
ums_realtek 18248 0
usb_storage 49198 1 ums_realtek
rfcomm 47604 12
bnep 18281 2
parport_pc 32866 0
ppdev 17113 0
binfmt_misc 17540 1
joydev 17693 0
dm_crypt 23125 0
snd_hda_codec_hdmi 32474 1
snd_hda_codec_conexant 62128 1
dell_wmi 12681 0
sparse_keymap 13890 1 dell_wmi
dell_laptop 18119 0
dcdbas 14490 1 dell_laptop
snd_hda_intel 33773 3
snd_hda_codec 127706 3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 13668 ...

Read more...

Hi Benjamin i do not know if the matter is resolved. I have stumbled upon several freezes of my opensuse 12.1 installation. I followed your instructions and uploaded a crashdump from kdump in novell ftp server. Hope it helps and let us know if you get somewhere. For the record my symptoms are a complete freeze no mouse or keyboard activity so hard restart is the only option. System works fine before freeze. Some extra info in case you want me to add something in terms of hardware details. I have an nvidia 7600 GS video card (driver 295.49) running twinview with two monitors. I also use sunergy+ from another machine to control the opensuse box although freezing takes place both with and without synergy+ client running.

thanks
Evans

By the way i used this bug's id (bnc737834) in the naming of my tar file and not bnc738547 as suggested to your comment. I hope i did not messed it up.

Apologies for continuous posting, please delete my previous one its my mistake the name of the file is bcn737834-kdump-2012-06-11-20-00.tar.gz2

Thanks
Evans

Download full text (3.6 KiB)

Hi Evans,

Thank you for taking the time to collect a kdump and uploading it. Here's the backtrace from the crash:

[13862.813072] BUG: unable to handle kernel NULL pointer dereference at 00000188
[13862.813084] IP: [<f9a26b7e>] _nv004005rm+0x51c8/0xb1de [nvidia]
[13862.813373] *pdpt = 000000002f9da001 *pde = 0000000000000000
[13862.813381] Oops: 0000 [#1] PREEMPT SMP
[13862.813390] Modules linked in: ip6t_LOG xt_tcpudp xt_pkttype ipt_LOG xt_limit af_packet ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_raw xt_NOTRACK ipt_REJECT iptable_raw iptable_filter ip6table_mangle nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv4 nf_defrag_ipv4 ip_tables xt_conntrack nf_conntrack ip6table_filter ip6_tables x_tables cpufreq_conservative cpufreq_userspace cpufreq_powersave acpi_cpufreq mperf microcode fuse nvidia(P) iTCO_wdt ppdev iTCO_vendor_support parport_pc tpm_infineon sky2 tpm joydev i2c_i801 sr_mod cdrom sg button serio_raw snd_hda_codec_realtek parport floppy tpm_bios pcspkr snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd soundcore snd_page_alloc edd autofs4 fan processor ata_generic thermal thermal_sys
[13862.813495]
[13862.813500] Pid: 0, comm: swapper Tainted: P 3.1.10-1.9-desktop #1 transtec AG /D915GUX
[13862.813511] EIP: 0060:[<f9a26b7e>] EFLAGS: 00010046 CPU: 0
[13862.813786] EIP is at _nv004005rm+0x51c8/0xb1de [nvidia]
[13862.813791] EAX: 00000000 EBX: 00088004 ECX: 00000012 EDX: 00000000
[13862.813796] ESI: f00a8004 EDI: f00a8304 EBP: f1bd7fe4 ESP: f4409e08
[13862.813800] DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
[13862.813806] Process swapper (pid: 0, ti=f4408000 task=c0a8efa0 task.ti=c0a88000)
[13862.813810] Stack:
[13862.813813] 00000000 f00a8004 f00a8304 00088004 00000004 f00a8004 f00a8004 f6aac400
[13862.813828] f9a269e8 f00a8004 00000000 00088004 00000004 f882e004 f00a8004 f6aac400
[13862.813843] f9c77d8c f00a8004 00000000 00088004 00000004 f6cf04e0 f6da9480 ffffffea
[13862.813857] Call Trace:
[13862.813915] Inexact backtrace:
[13862.813917]
[13862.814030] [<f9a269e8>] ? _nv004005rm+0x5032/0xb1de [nvidia]
[13862.814030] [<f9c77d8c>] ? rm_check_pci_config_space+0x7a5/0xe19 [nvidia]
[13862.814030] [<c059310f>] ? uhci_submit_interrupt+0x6f/0xf0
[13862.814030] [<f9c9454c>] ? nv_verify_pci_config+0x6c/0x90 [nvidia]
[13862.814030] [<f9c6c60e>] ? _nv014526rm+0x22/0x69 [nvidia]
[13862.814030] [<f968358c>] ? _nv016109rm+0x240/0x7e1 [nvidia]
[13862.814030] [<f9683e2d>] ? _nv016117rm+0x300/0x31e [nvidia]
[13862.814030] [<f9c6c182>] ? _nv014585rm+0x92/0x3ae [nvidia]
[13862.814030] [<f9c6954d>] ? _nv014597rm+0x56/0xb9 [nvidia]
[13862.814030] [<f9c7303a>] ? rm_isr+0x13b/0x25e [nvidia]
[13862.814030] [<c055fc8d>] ? ata_bmdma_interrupt+0x14d/0x1c0
[13862.814030] [<f9c9385f>] ? nv_kern_isr+0x2f/0x70 [nvidia]
[13862.814030] [<c02ac58a>] ? handle_irq_event_percpu+0x4a/0x250
[13862.814030] [<c02ac7c4>] ? handle_irq_event+0x34/0x60
[13862.814030] [<c02ae910>] ? unmask_irq+0x20/0x20
[13862.814030] [<c02ae956>] ? handle_fasteoi_irq+0x46/0xb0
[13862.814030] <IRQ>
[13862.814030] [<c0203cbd>] ? do_IRQ+0x3d/0xc0
[13862.814030] [<c0711f29>] ? common_interrupt+0x...

Read more...

Dear Benjamin,

Thanks for your prompt response and your time to look into this. The problem persists after upgrading to kernel 3.4.2-28 from tumbleweed and using the nvidia 295.59 downlowded and installed by nvidia since the opensuse nvidia repository has not updated the driver for kernel 3.4. The problem is here since i am having what appears to be kernel panics, although less frequent than with 3.1 kernel, to this day. If anyone experiences this (freezing machine and keyboard leds blinking) i guess is safe to say that please check you nvidia driver installation. One last hint to that could be of some help; in my case i predominantly experience freezes in GNOME 3 and its derivative cinnamon, i am not having many freezes with KDE 4.8.

Lets hope that this will be resolved soon either from nvidia or from opensuse.

Thanks to all
Evans

Changed in linux (openSUSE):
status: Incomplete → Invalid
Rich Price (rich-gandalf) wrote :

I am going to place my issue here even though it probably should be placed under another [or perhaps a new] Bug ID. I would appreciate information on a better place to document this issue.

This is another case of a hard freeze which started happening after upgrading to Ubuntu 12.04. The freeze usually happens when using Firefox to access something like a Youtube video. Though this is not always the case.

The Desktop is a Dell Inspiron 530 and I will attach an ishw output and a dmesg output below. The dmesg was taken just after booting the PC. I cannot get one at the time of the freeze because the PC is totally frozen at that time.

Rich Price (rich-gandalf) wrote :

This is a screen shot I took with my camera (computer was unresponsive) in the course of troubleshooting random freezes I started experiencing with ubuntu 10.04. I have tried revery release including the present 12.04 with the same result.

Hardware
HP dv4 laptop
Intel i3 processor
Intel video

This was created by booting to a command shell (no x-server involved) and attempting to write an iso to CD.

Although the messages indicate a hardware error, I reinstalled Windows 7 on this machine in 2010 and it has run flawlessly for the last 2-1/2 years.

Since the resolution of problems at such a fundamental level exceed my current abilities, I gave up on ubuntu for day-to-day use. I hope someone can interpret what is going on here.

Alecz20 (alexguzu) wrote :

I also had the hard freeze on Lucid with an Atheros-based wireless card.

I installed the "linux-backports-modules-wireless-lucid-generic" and the problem seems to be fixed.
See bug 426130 for details:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/426130

sglafata (sglafata) wrote :

I have two different makes and models of computers running Ubuntu Server 12.04.1 LTS and they are experiencing the same freezing that others are experiencing.

One is a Dell Dimension 4600 and the other is a HP Pavilion 8679F. I know these are old, but previously they both were running 10.04 flawlessly without the freezing.

I use the HP for DNS/DHCP in home and the Dell is my kids' Minecraft server. The HP has little load on it and the Dell is has load when my kids play Minecraft, otherwise it sits there throughout the day while the kids are in school.

I am finding that on average, the freezes/hang state occurs every 24-48 hours. All currents updates have been installed on both machines. I am running the '3.2.0-31-generic-pae' kernel on both machines. I do not run X on either machine, although I installed Xrender on the minecraft server because it complained that Java needed it.

After reading through this thread, I installed the 'linux-crashdump' package on both machines and will report what I get from it the next time this issue happens.

Also, per a previous entry in this thread, I added the kernel parameter 'drm_kms_helper.poll=0' to grub as well. I never had this entry before, so we will see if that has any affect.

In either case, I wanted to inform the relevant parties that this issue persists in the latest LTS release, and it does not matter what your hardware configuration is.

ReneS (mail-03146f06) wrote :

I am running 12.04 LTS and got the same problem. So far, I could reproduce it by running Filezilla. The machine completely freezes, no mouse, no terminal, not even the magic kernel commands work anymore, and yes, the fan spins up.

Machine T530, Intel i915, FullHD display.

What I tried:

Ubuntu 12.04.01 LTS from HDD upgraded from 10.10 via 11.04/11.10
Ubuntu 12.04.01 LTS from thumbdrive, plain installed from ISO
Ubuntu 12.10 from thumbdrive, plain fresh ISO

Gnome3 3.4 and 3.6
Gnome3 Fallback
XFCE 4.10
Cinnamon 1.6.7
Unity

Compiz
Metacity

With and without external display

I cannot get kernel 3.3 or higher to work on my machine with the installed Ubuntu on HDD. Somehow the graphics fail but I currently have a 13.04 alpha running from thumbddrive and will see if this works ok or not.

Already had a freeze without Filezilla open when I was starting Firefox. Survied an entire day when not using Filezilla, but since I had a freeze without it today, this is rather a lucky incident than system. But at least Filezilla seems to provoke it.

Nothing in any log files, because the system stops instantly. So I suspect the kernel in conjunction with the T530 hardware. Turned of hyperthreading, power management, and so on... all the same. Because it happens with an 3.5 kernel as well, it is not only a 3.2 problem.

Raphael Raccuia (blindekinder) wrote :

Same problem with 12.04... can happen at anytime, but often when I change desktop (ctrl+alt+[down]). Image freezed between two desktop.
Happens more or less once per day

ciriffo (piccoccio) wrote :

i see that the kernel logs and the output of dmesg show this error:

[drm:intel_dsm_platform_mux_info] *ERROR* MUX INFO call failed

drm: registered panic notifier

intel hd 4000 my graphics. i have three pc with ubuntu 12.04. one is working with intel hd 400 sandy bridge, 32 bit. no problem, no issue at all. one is working with ati on 64 bit, and there are no problem. this one, with intel hd 4000, and frequent freezes. Since it is the only one wich use a uefi bios, i wonder if the bug is related with the uefi bios...

Mercer Rivière (vincentuq) wrote :

Similar problems. Example

[ 4750.600194] Pid: 0, comm: swapper/0 Tainted: P
...
[ 4750.600306] [<c18340a9>] ? i386_start_kernel+0xa9/0xaf
[ 4750.600308] handlers:
[ 4750.600420] [<f94f3050>] nv_kern_isr

Or:
[10478.427688] Pid: 5872, comm: mplayer Tainted: P
...
[10478.427795] [<c1570000>] ? add_i2c_device+0x126/0x166

...
[10478.427909] [<f951b050>] nv_kern_isr

I.e. my bet is it's nvidia.

i think it's a me, too.

DMI: Dell Inc. Latitude E6320/087HK7, BIOS A04 05/11/2011

Debian testing
Linux xxx 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux

i think it's not related to the docking station, happened twice today without it.

i started to have recently these hard lockups. although, in very rare cases i have the mouse moving?! but even then nothing else works, including ctrl+alt+f1 to switch to text consoles. this mouse thing might be unrelated, maybe just a different gnome lockup issue...

happens about once a day.

cron.hourly seems to be related, but /etc/cron.hourly/ is empty for me.

happened twice today, here are the relevant syslog parts:

Jun 20 16:17:01 lelap /USR/SBIN/CRON[15695]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Jun 20 16:22:59 lelap kernel: imklog 5.8.11, log source = /proc/kmsg started.

Jun 20 17:17:01 lelap /USR/SBIN/CRON[6956]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Jun 20 17:22:09 lelap kernel: imklog 5.8.11, log source = /proc/kmsg started.

i'm not positively sure it's the cron, but that's the last entry in my syslog after reboot.

Brains (brains) wrote :

yea... got the same problem as well. Have reported on it many many times. Have even sent an email to Mr. Shuttleworth's assistant (over it - maybe indeed). Fact is, I have been more than happy with Ubuntu ever since my definite migration from windows to 9.10. Thanks to Canonical and its community - sincerely. I did also start making publicity for Canonical's and the community's great efforts!

However, even though all updates went fine, I ran into the problem mentioned here, first on 12.04. My first _clean_ install since 9.10, mind! After rebooting and anxiously looking forward to the new possibilities, it crashed not 10 minutes later - without installing anything additional! Just browsing the web. Hard reset only option. It kept on doing so...

I mostly used 11.10 in the mean time, as 12.10 did not fix the problem. 13.04 initially seemed a lot more stable on my machine. But it quickly started to break up as well. Did I really need to back to Windows? I wanted GIMP 2.8 and LibreOffice 4.0!

No.

Wheezy was released, and, since it was installed about two weeks ago, I have not experienced a single crash - well one, but it was recoverable through PTYx. It is fast, has the latest versions of the programs I wanted to update and it seems rock-solid. Should I put in a Ubuntu background, I might not even notice a difference at all on Gnome3. I switched from Ubuntu to Debian because of necessity, but given Canonical's indifference to these showstopper problems and Debian's stability, I think I will stay...

whatever was the cause of my freezes, they are gone since i upgraded my kernel. currently i use this version:

Linux xxx 3.10-0.bpo.3-amd64 #1 SMP Debian 3.10.11-1~bpo70+1 (2013-09-24) x86_64 GNU/Linux

rsoika (ralph-soika) wrote :

I have the same problem. And I am also using kernel version 3.10-0.bpo.3-amd64 from debian
My system is more stable. But I have still feezes and I had a freeze just now. But it can happen that my systems works 1-3 dayes without a problem. So in summary I can not confirm that with 3.10-0.bpo.3 the problem is solved for me.

Jmadero, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-a09
Changed in linux (Ubuntu):
status: Triaged → Incomplete
rsoika (ralph-soika) wrote :

I was also affected from that issue. Finally it seems that I found in my case a solution. The "Memory Frequency Limiter" in BIOS was set to 'AUTO' and I changed it to one of the lowest values. Since than my system runs stable.

Huh seems like the bug still exists and works very fine :(
I've Dell Vostro V131 with Intel Core i5, Intel Graphics +
Ethernet: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
Wifi: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)
USB 3.0: Texas Instruments TUSB73x0 SuperSpeed USB 3.0 xHCI Host Controller (rev 02)

My laptop from time to time just freezes hard. Nothing with Sysrq work, there is no sign of anything in logs or dmesg. I've thinking this is RAM or SSD issue but after repleacing them the issue still exists.
Now I've installed mainline kernel from PPA: Linux vostro-v131 3.17.1-031701-generic #201410150735 SMP Wed Oct 15 11:36:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux the issue still exist and the hangs still happens.

rsoika / Marcin Jabrzyk, thank you for your comment. So your issue may be dealt with as soon as possible, and so your hardware may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu repository kernel via:
ubuntu-bug linux

For more on why this is most helpful, please read the official Ubuntu documentation from the respective Ubuntu developer groups, and triage teams:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

I had the same problem.
As far as I understood the problem occurs with lot more probabilities when a video is playing, and it starts with some lag of it (with no relation with CPU load or memory).
Ubuntu kernel has the issue, Liquorix kernel (http://www.liquorix.net/) on both Ubuntu and Debian, but no problems with Debian stable kernel (had no choice to test unstable and testing ones).

Hope it can help in some way.

Giorgio Salluzzo, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

I'm not using Ubuntu right now (due to this problem), is there a way to file a new report via browser?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.