Internal microphone doesn't work on Asus eeePC 1005HA

Bug #449855 reported by Jim Braux-Zin on 2009-10-12
352
This bug affects 66 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
edinaldojr
Declined for Karmic by Daniel T Chen
linux-backports-modules-2.6.31 (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Daniel T Chen

Bug Description

External microphone works fine, but no internal microphone on my Asus eeePC 1005HA-m. Changing the settings "Input source" in alsamixer doesn't solve the problem.

A few people reported the same problem on the same machine here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/440251. Let me know if I can do something else to help.

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jim 16972 F.... pulseaudio
 /dev/snd/pcmC0D0p: jim 16972 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104383ce,00100004'
   Controls : 15
   Simple ctrls : 10
CheckboxSubmission: af33802e14559ea72cb98c14e2e08b69
CheckboxSystem: 9c26adf6eed2f681ba41f94dd24c07e4
Date: Mon Oct 12 22:54:40 2009
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: alsa-driver
Tags: ubuntu-unr
Uname: Linux 2.6.31-13-generic i686

Jim Braux-Zin (j-brauxzin) wrote :
Luigi Di Gaetano (luigidg85) wrote :

An image of the Sound Preferences Windows can be useful. In input device only one device is shown (internal audio analog stereo) but it corresponds to external mic.

Luigi Di Gaetano (luigidg85) wrote :

the audio device has 1 input (not correct) and 1 output

Siegfried Gevatter (rainct) wrote :

Installing the latest kernel release candidate fixes this (you can find packages for Ubuntu at http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32-rc4/, but be aware that they are completely unsupported by Ubuntu's kernel team).

Do you think the appropriate modules could be backported like it is done for
the wireless drivers?

2009/10/13 Siegfried Gevatter <email address hidden>

> Installing the latest kernel release candidate fixes this (you can find
> packages for Ubuntu at http://kernel.ubuntu.com/~kernel-
> ppa/mainline/v2.6.32-rc4/, but be aware that they are completely
> unsupported by Ubuntu's kernel team).
>
> --
> Internal microphone doesn't work on Asus eeePC 1005HA
> https://bugs.launchpad.net/bugs/449855
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Daniel T Chen (crimsun) wrote :

On Tue, Oct 13, 2009 at 11:32 PM, Jim Braux-Zin <email address hidden> wrote:
> Do you think the appropriate modules could be backported like it is done for
> the wireless drivers?

That's precisely what's being done now. See ubuntu-karmic-lbm at
kernel.ubuntu.com/git

Victor (victor-s) wrote :

I'm having this issue with the Final release of Karmic, just downloaded it today. What's the fix?

Daniel T Chen (crimsun) wrote :

@Victor Install linux-backports-modules-alsa-karmic, and reboot.

Flo (spam01) wrote :

Don't forget to enable the backports repository first!

Daniel T Chen (crimsun) wrote :

@Flo No, you do not need the backports repo enabled.

On Oct 30, 2009 1:55 AM, "Flo" <email address hidden> wrote:

Don't forget to enable the backports repository first!

-- Internal microphone doesn't work on Asus eeePC 1005HA
https://bugs.launchpad.net/bugs/449855 Yo...

Victor (victor-s) wrote :

@Daniel

I installed linux-backports-modules-alsa-karmic and rebooted. Once I was back up my wired network vanished. I ran lspci and it only showed the wireless adapter. I didn't know how to get it working again, so I had to reinstall Karmic.

I'm afraid of trying it again. I'm without wireless.

I have the same problem with 1101HA.
I can only get white noise from the internal mic channel.

Installing linux-backports-modules-alsa-karmic didn't help unfortunately.

@Victor: I saw no nasty effects on ethernet drivers. Can you paste
the output of

sudo apt-get install linux-backports-modules-alsa-karmic-generic
(don't confirm the installation)

maybe the installation triggered the update of some other package.

Jim Braux-Zin (j-brauxzin) wrote :

Same for me, the backport-modules-alsa didn't help but luckily they didn't
break anything on my 1005HA.

2009/10/30 lino <email address hidden>

> I have the same problem with 1101HA.
> I can only get white noise from the internal mic channel.
>
> Installing linux-backports-modules-alsa-karmic didn't help
> unfortunately.
>
> @Victor: I saw no nasty effects on ethernet drivers. Can you paste
> the output of
>
> sudo apt-get install linux-backports-modules-alsa-karmic-generic
> (don't confirm the installation)
>
> maybe the installation triggered the update of some other package.
>
> --
> Internal microphone doesn't work on Asus eeePC 1005HA
> https://bugs.launchpad.net/bugs/449855
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Victor (victor-s) wrote :

I reinstalled karmic after my wired adapter vanished, do you still want the output?

Victor (victor-s) wrote :

The Asus 1005ha is listed as tier 1 in the UNR list of compatible hardware. Should this be changed?

Vincenzo Ciancia (vincenzo-ml) wrote :

I have the 1005ha and installing linux-backport-modules-alsa-karmic-generic solved the problem. Of course, then you need to go into the audio settings (in your gnome menus) and play with the input settings.

Jim Braux-Zin (j-brauxzin) wrote :

Really ? Can you explain exactly what you did ? I have the
backport-modules-alsa installed but still no internal mic.

2009/10/31 Vincenzo Ciancia <email address hidden>

> I have the 1005ha and installing linux-backport-modules-alsa-karmic-
> generic solved the problem. Of course, then you need to go into the
> audio settings (in your gnome menus) and play with the input settings.
>
> --
> Internal microphone doesn't work on Asus eeePC 1005HA
> https://bugs.launchpad.net/bugs/449855
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Anivar Aravind (anivar) wrote :

Affects me too. eeepc 1005HA Backport installation not helped to solve it

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Flo (spam01) wrote :

Maybe installation of the pulseaudio volume control (package "pavumeter") helps. It shows the current input level while you change the volume control, so you instantly see if the internal mic records any noise.

Jero (jbuencuerpo) wrote :

After installation of the backport I could record with the gnome-recorder, but in the Pulse Audio window there is no change, it doesn't notice about the internal mic .No problem with external mic ( Asus eeepc 1005H)

Jero (jbuencuerpo) wrote :

One more thing `pavumeter --record` notice about it.

Jim Braux-Zin (j-brauxzin) wrote :

Yes you are right! Maybe there is some hope after all. I have been able to
hear my own recorded voice with gnome-recorder.

In the Pulse Audio window, the slider to adjust the mic level actually
works. However, the indicator level in the Pulse Audio configuration window
remains empty.

pavumeter --record unexpectedly shows the correct input level.

Now, the only thing I need is a way to make it work with Skype (while
keeping pulseaudio if possible).

Thank you, I think we are close to solving this issue!

2009/11/1 Jero <email address hidden>

> One more thing `pavumeter --record` notice about it.
>
> --
> Internal microphone doesn't work on Asus eeePC 1005HA
> https://bugs.launchpad.net/bugs/449855
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Victor (victor-s) wrote :

After re-installing Karmic I install the back-ports module. I can confirm what Jero is experiencing, I too can record with gnome recorder but in pulse no change. In skype it does not work cause i think it goes through pulse.

Jim Braux-Zin (j-brauxzin) wrote :

The thing is I am almost sure Gnome Recorder uses pulse as well. There is
indeed no settings for the input in Gnome Recorder...

2009/11/2 Victor <email address hidden>

> After re-installing Karmic I install the back-ports module. I can
> confirm what Jero is experiencing, I too can record with gnome recorder
> but in pulse no change. In skype it does not work cause i think it goes
> through pulse.
>
> --
> Internal microphone doesn't work on Asus eeePC 1005HA
> https://bugs.launchpad.net/bugs/449855
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Flo (spam01) wrote :

Does the behavior change when you mute/unmute the input device in pavumeter? I sometimes had to do this to enable recording.

pberndt (phillip-berndt) wrote :

To make sound work with skype and ekiga deactivating pulseaudio did the job for me.

https://wiki.ubuntu.com/PulseAudio for how to disable it
http://pastebin.com/f2e3141cd for a ~/.asoundrc optimized for eee 1005 ha (mixes input down so the mic isn't on one channel only, equalizes sound output so it sound's better with the internal speaker)

Now /all/ of my sound applications work great. I guess this isn't a good idea unless you've got a bit of experience though... :-)

Textureglitch (textureglitch) wrote :

I had the same problem with Karmic UNR on an EEE 901 pc. Neither the internal microphone nor the plug on the side were working.

Walkaround was installing the linux-backports-modules-alsa-karmic-generic and rebooting.
Then installing the pavumeter application.

I had to open pavumeter, go to the input tab and then the microphone started working in all applications (including Skype).

I'm assuming pavumeter resets or does something to pulseaudio that makes the mic work. I previously tried changing capture volume levels in alsamixer, but it made no difference.
Just installing the pavumeter without the backport package might work too, I didn't try that.

Plouj (plouj) wrote :

Installing linux-backports-modules-alsa-karmic-generic (2.6.31.15.28) (I already had pavumeter installed in UNR) did not enable the internal microphone for me on ASUS 1005HA.

Installing linux-backports-modules-alsa-karmic-generic did the job on my Eee 1005HA, Karmic fresh install. Thank you.

Installed both "linux-backports-modules-alsa-karmic-generic" ans "pavumeter" and then tried playing with the settings... but could not manage to make it work on my 1005HA-H. :(

Daniel T Chen (crimsun) wrote :

For those of you still having problems with the int mic, attach output from
amixer (in a Terminal). Make sure that you have installed
linux-backports-modules-alsa-karmic-generic and rebooted.

On Dec 2, 2009 6:01 PM, "Eraldo" <email address hidden> wrote:

Installed both "linux-backports-modules-alsa-karmic-generic" ans
"pavumeter" and then tried playing with the settings... but could not
manage to make it work on my 1005HA-H. :(

-- Internal microphone doesn't work on Asus eeePC 1005HA
https://bugs.launchpad.net/bugs/449855 Yo...
Status in “alsa-driver” package in Ubuntu: Confirmed

Bug description: External microphone works fine, but no internal microphone
on my Asus eeePC 1005HA...

Jim Braux-Zin (j-brauxzin) wrote :

Hi,

Here is my amixer output. My current situation is that gnome-recorder and pavumeter can see the internal microphone but not pulseaudio (and Skype).

I hope it helps!

I've been experimenting and It may not be a pulseaudio issue, it may be the snd-hda-intel driver being incorrectly loaded.

/etc/modprobe.d/alsa-base.conf
adding model=basic/auto/acer ...
options snd-hda-intel model=auto power_save=10 power_save_controller=N

seems to be reflected in pulseaudio with connectors appearing with some configurations. at one point i had mic1 mic2 and line in as options. no working internal mic but it looks promising.

this document may help
http://www.kernel.org/pub/linux/kernel/people/tiwai/docs/HD-Audio.html

slight update and a work around for skype this is on an aspire one but its similar enough to help I think

in /etc/modules

I added the line snd-hda-intel model=acer

there are a number of alternative models that may help the difference largely is the availability of a connector for inputs which will exist in some configurations but not in others when you select sound preferences.
not sure if its needed in
/etc/modprobe.d/alsa-base.conf

My real issue was and is skype since it doesnt allow the selection of input in its preferences and at best I could only get a very very low output from the internal microphone.

As a work around for skype may I suggest you launch skype with this command

/bin/sh -c "PULSE_SERVER=127.0.0.1 skype"

Skype will not be able to connect to the pulse server and will fall back to alsa allowing
 hda intel, ALC268 Analog (hw,0,0) to be selected.

I hope this helps, at least it is an improvement over uninstalling pulseaudio.

Eric Langlois (ericlngls1) wrote :

It seems that alsa-1.0.21 solve the problem:
http://bbs.archlinux.org/viewtopic.php?id=85449

Eric Langlois (ericlngls1) wrote :

In fact
~$ cat /proc/asound/version
give me:

Advanced Linux Sound Architecture Driver Version 1.0.21.
Compiled on Dec 2 2009 for kernel 2.6.31-16-generic (SMP).

but I still have alsa-utils and alsa-base 1.0.20 and I still have the problem. Maybe by using also alsa-utils and alsa-base 1.0.21 will solve the problem

Daniel T Chen (crimsun) wrote :

No, alsa-utils and alsa-base have nothing to do with it.

You should make sure you have the appropriate mic selected using alsamixer.

On Sun, Dec 13, 2009 at 3:40 PM, Eric Langlois wrote:
> In fact
> ~$ cat /proc/asound/version
> give me:
>
> Advanced Linux Sound Architecture Driver Version 1.0.21.
> Compiled on Dec  2 2009 for kernel 2.6.31-16-generic (SMP).
>
> but I still have alsa-utils and alsa-base 1.0.20 and I still have the
> problem. Maybe by using also alsa-utils and alsa-base 1.0.21 will solve
> the problem

Luigi Di Gaetano (luigidg85) wrote :

Updating to kernel 2.32.3 (via ppa:apw/green) the internal mic go well out of the box, but the external one doesn't work. In audio preferences i see that the system recognize 1 input and 1 output (as shown in the image attached).
[OT: with new kernel the performance of the wireless card have improved]

exactt (giesbert) wrote :

I have a 1005HGo here with BIOS version 0117. installing linux-backports-modules-alsa-karmic-generic fixed the microphone problem for me. thx!

Jim Braux-Zin (j-brauxzin) wrote :

@exactt Are you using pulseaudio?

Jim Braux-Zin (j-brauxzin) wrote :

Hi everyone, it is finally working, even with Skype! I found the workaround on this bug about the same problem on the Acer Aspire One: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/433055.

So here is the thing:
1. Install pavucontrol
2. With pavucontrol unlock the left and right channels of the microphone and set one channel to 0% for example
3. Skype should work fine

Beware of not changing the input level with the default sound dialog as it would lock the two channels again.

It seems this is PulseAudio badly handling the microphone...

Good luck!

exactt (giesbert) wrote :

@Jim Braux-Zin : yes. regular netbook remix installation. just added linux-backports-modules-alsa-karmic-generic and it worked out of the box...

Daniel T Chen (crimsun) on 2009-12-28
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: New → Fix Released
weders (stephen-wedley) on 2010-01-01
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Mahesh Rumale (mrumale) wrote :

Has there been any development on this issue?

I have tried all the options I could get my hand on. None of them work.
I have a Eee PC 1005HA-VU1X. Came with Win XP, and the internal microphone works fine in it.

phaedral (beau-oblios-cap) wrote :

Adding backports did not fix; unlocking channel and setting one to zero as suggested by Jim Braux-Zin in response 41 did the trick. eeePC 1005-hab, running UNR 9.10 from 8gb SD card.

Jero (jbuencuerpo) wrote :

Jim Braux-Zin fix works as a charm for skype and others. Thank you very much.

abdulet (abdulet) wrote :

Yes it works for me finally!!!

just installed the linux-backports-modules-alsa-karmic-generic and pavmeter
open pavucontrol, unlock the channels and set a different level in each channel
after tha you can lock the channels again

good luck!!

Robin Dexters (robin-dexters) wrote :

Did all off the above. Nothing helped. Still no working mic.

Santiago Gala (sgala) wrote :

My guess is that pulseaudio is mistaking a dual microphone designed to cancel noise for a stereo microphone. When both channels are exactly at the same level it won't work, or something similar...

edinaldojr (edinaldojr) on 2010-03-06
Changed in linux (Ubuntu):
assignee: nobody → edinaldojr (edinaldojr)
meldethmet (dtm-eurosport) wrote :

Well I have a 1005HA that was experiencing the Skype microphone problems as well, but now it's working beautifully. I tried the suggestions above:

1. sudo apt-get Install linux-backports-modules-alsa-karmic-generic
2. sudo apt-get install pavmeter
3. sudo pavucontrol, unlocked the channels and set a one channel to base and the other to max, then locked them again
4. The Skype test call works beautifully when testing microphone playback!

Good luck to those of you still struggling!

-Nickolai

meldethmet (dtm-eurosport) wrote :

p.s. - Please don't copy and paste my commands, I can already see that I made some mistakes! (like "Install" instead of "install") (and "pavmeter" instead of "pavumeter")!! sudo with care :-)

Mr. Aljoriz Dublin (aljoriz) wrote :

thank I hope they can built this fix in Lucid when it comes out and have the multi touch pad working on the fly

viannabugs (viannabugs) wrote :

works for me with the tips all gave here
but now when i plug the headphones i keep having sound at internal
before i do this install i plugged the headphones and the sound stoped automatically just working on headphone
now to turn off internal sound i must go to preferences and select "output headphones" then i have sound only at headphones
any tip to this work automatically?

hope they fix on 10.04 to work perfect without any other instalations.

Roger Keays (roger-ilikespam) wrote :

After adding linux-backports-modules-alsa-karmic-generic I have the same problem as viannabugs. When I plug in the headphones, sound continues through the speakers (and headphones).

Just want to notice that the problem

 "When I plug in the headphones, sound continues through the speakers (and headphones)"

was introduced after kernel upgrade 2.6.29 -> 2.6.30 and all newer...

I still can't fix this on my ASUS EeePC 1005HA so the solution is to switch ti internal/external manually.
Are there some specialists in this question?

Artem Litovskikh (artemios-) wrote :

after installing backports-modules the sound was steel playing after inserting headphones. Also the quality of recordered voice was lowest than in xp, sound stuttering. Asus EeePC 1005 HA-M. Also in ubuntu 10.04 beta1 nbr was the same bug, as it was in the eeebuntu 3.0.

Artem Litovskikh (artemios-) wrote :

the microphone is, digital array mic, and is not working correctly even after installing backports. The background noise is not filtered, because it hasnt full support of realtek drivers. After installing clean copy of windows 7, recording sound with default microsoft driver, was relult to high amount of background noise and stuttering, but, after installing realtek drivers, sound filters, noise canselation, echo filter option where available.

freeride (bschonhorst) wrote :

To recap above suggestions, here is what worked for me:

9.10 (Netbook Remix) Asus EEEPC 1005HA
Enable Unsupported Updates (karmic-backports)in Synaptic Settings → Repositories → Updates

sudo apt-get install linux-backports-modules-alsa-karmic-generic
sudo apt-get install linux-backports-modules-karmic' (for wireless, should be unrelated)
reboot

Install Skype:
echo "deb http://download.skype.com/linux/repos/debian/ stable non-free #Skype" | sudo tee -a /etc/apt/sources.list > /dev/null

sudo aptitude update && sudo aptitude install skype

sudo apt-get install pavucontrol
Open Pulse Audio Volume Control, unlock Input Devices, made Front Right 0 and Front Left 100

Skype now seems to be working properly. Thanks for all the help everyone!

pablomme (pablomme) wrote :

A few notes:
- This bug also affects the Eee PC 1201N
- As of Lucid there is no need to install the ALSA backports. This may
  be true of Karmic too as some people report above - I haven't tried.
- Santiago's comment #48 above describes what seems a very likely
  cause for this bug. Is there any way of hacking ALSA or pulseaudio
  to make them aware of the fact that the purpose of the second mic
  channel is to cancel noise, not to build a stereo signal?

Jonathan B Peterson (jbp12005) wrote :

After I installed the pavumeter package on my Asus 1005PE I used the advice from the Ubuntu hardware support page:

https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Asus Eee PC 1005PE

which suggests to set the front left channel to 90% and the front right channel to 10%. I then received feedback from the internal mic. However, there is a setting on skype (if that is what you are using the mic for) that allows it automatically adjust the internal audio levels. Once it moved from my 90/102 levels the mic would not work. The solution was to go to options on skype and the sound devices and deselect "Allow skype to automatically adjust my mixer levels." After making this adjustment my mic and skype work just fine.

Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

How come this has been marked as resolved? Is it because it's considered that this a fault in the hardware and not in Linux?

That's not the best approach because the end-result for the user is that Linux doesn't seem to work. Sure - there is a complicated work-around for Skype. But it's not possible to tell Gmail voice chat to not adjust mic-volume so this service is not usable.

Seems like this should be fixed by not even showing the broken channel as a mic or something...

Gary M (garym) wrote :

I still have this problem in maverick with an Asus eeepc 1001HA, which uses the 1005HA mainboard. Muting one of the input channels only gives a small improvement, which is the same in karmic even with the backported alsa.

tags: added: karmic lucid maverick
tags: added: natty
Marius B. Kotsbak (mariusko) wrote :

From bug #555542 it seems like this is still not fixed in Natty, and there seems to be no alsa backport packages available.

I confirm this bug still alive...

lsb-release :
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.3 LTS"
uname -a = Linux ... 2.6.32-34-generic #77-Ubuntu SMP Tue Sep 13 19:40:53 UTC 2011 i686 GNU/Linux

 I've tried installing linux-backports-modules-alsa-lucid without any improvment, from audio manager mic is not available.

It seems something has changed after selecting, from pulseaudio volume control panel - configuration tab "Analog surround 4.0 output + Analog stereo input" ...it seem mic is working with speaker audio too... but with a bad quality, sound is somewhat cawing...
I've faced another drawback as well, skype often hang after trying an echo test or simply closing it... if I come back at normal audio confiuration nothing matter and no more drawback.

I hope this annoying issue will be fixed, thx in advance.

Let me know, If I can help in some way...

Alessio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers