Internal microphone does not work on Lenovo X300

Bug #440251 reported by Ducane7 on 2009-10-01
148
This bug affects 28 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by LK-
Nominated for Lucid by lopetegui
Nominated for Maverick by lopetegui

Bug Description

Karmic Koala beta does not have a working internal mic out-of-the-box on a Lenovo X300 (intel hardware).

This bug was also present in Intrepid. However, in Intrepid, adding the following to /etc/modprobe.d/alsa-base.conf caused the microphone to start working:

  ## Intrepid fix for internal microphone
  options snd-hda-intel model=thinkpad

but this does not seem to have any effect for the Karmic beta.

ProblemType: Bug
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cas 1772 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfa220000 irq 17'
   Mixer name : 'Analog Devices AD1984A'
   Components : 'HDA:11d4194a,17aa20fb,00100200'
   Controls : 13
   Simple ctrls : 9
CheckboxCommand: alsa_record_playback
CheckboxTest: alsa_record_playback_internal
Date: Fri Oct 2 00:01:39 2009
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: alsa-driver
Tags: checkbox-bug
Uname: Linux 2.6.31-11-generic i686

Ducane7 (ducane7) wrote :
gunbladeiv (gunbladeiv) wrote :

it does affect my machine which is Acer 4736. Below is my lspci output for Audio Device.

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
 Subsystem: Acer Incorporated [ALI] Device 0260
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at 58800000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- RBE- FLReset+
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

gunbladeiv (gunbladeiv) wrote :

it affect me too. I've been having this issue since Jaunty. But i'm not using lenovo. Im using Acer 4736Z

Martin Kriegel (mkriegel) wrote :

Same here on Karmic and ASUS eeePC 1005HA... does not recognize internal microphone. There does not seem to be a problem with a plug-in mike or USB mike, only the internal one does not work.

Jim Braux-Zin (j-brauxzin) wrote :

I also have an ASUS eeePC 1005HA, running the latest Karmic ubuntu netbook remix. I can't get any input, either from the internal mic or an external one.

Flo (spam01) wrote :

Same here, eee pc 1005HA-H, daily build of Karmic from 2009-10-08.

The microphone jack seems to be available in the Pulseaudio configuration but not the internal mic.
The commandline "alsamixer" knows the internal mic, I can switch the "Input Source" between "Front Mic" and "Int Mic". But this has no influence on a running pulseaudio and recording does not work.

In Jaunty, it was possible to change from "front" to "int" using the gnome-volume-control but the new volume control has no such option.

Jim Braux-Zin (j-brauxzin) wrote :

Actually using the commandline alsamixer, there is the option "front"/"int" (you may have to press tab to see it), but it didn't make my microphone work. Are you saying that external microphones are working out-of-the-box for you?

Jim Braux-Zin (j-brauxzin) wrote :

Yes, actually external microphones are working on my computer, maybe I used the wrong jack :). So I am exactly in the same situation as other 1005HA users above: no internal microphone.

Siegfried Gevatter (rainct) wrote :

Same problem here (EeePC 1005 HA).

Changed in alsa-driver (Ubuntu):
status: New → Confirmed

On Mon, Oct 12, 2009 at 4:11 PM, Siegfried Gevatter <email address hidden> wrote:
> Same problem here (EeePC 1005 HA).

Please, please file separate bugs using "ubuntu-bug alsa-base"!

There are different culprit HDA codec models here, and "me too"s
become increasingly difficult to debug and resolve.

Ok, I created a bug https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/449855 for the 1005HA as this bug is dedicated to Lenovo X300.

Paweł T. Jochym (jochym) wrote :

I have the same issue with the same hardware. Running latest (21/10) updated karmic beta.
The external jack microphone works fine.
I have noticed one thing though. If I run gnome alsa mixer with working microphone I get picture like the first screenshot:
the mic and capture channels are switched on recording and PA control shows signal from the ext mic.
When I switch internal Mic checkbox I get the second screen: BOTH mic & Capture channels are switched off (rec) and
in PA sound control the Mute checkbox appears. There is no signal from the internal mic. If I switch capture rec on in gnome-alsamixer (third screen) there is still no signal in PA control and no signal from the mic and the Mute check stays put. If I unmute the PA control in the right window the Internal mic is switched off and mic switched on - back to the first screen situation.
It is the same if I put model=thinkpad in alsa-base.conf or not.

Paweł T. Jochym (jochym) wrote :
Paweł T. Jochym (jochym) wrote :
Ducane7 (ducane7) wrote :

I can confirm Pawel's observations. I have the same switching behaviour:
- In (gnome) alsamixer there is a distinction between internal/external/mixed
- In the audio settings applet (I assume this uses pulseaudio?) there is only a single mic channel.
- If alsamixer is used to switch the input to either "mixed" or "internal", the settings applet window immediately switches to "muted" on the single channel.
This occurs also when using alsamixer in a terminal, and it occurs also on a clean install without any (other) programs running.

manuel (amador-manuel) wrote :

Confirmed in Lenovo X300 running Karmic (64bit)

Ducane7 (ducane7) wrote :

I think this bug is related to this one:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/418617

It is more detailed and suggests the source of the problem; it also seems that the bug occurs in many more machines.

The suggested fix there (for a Dell XPS) is to install linux-backports-modules-alsa-karmic-generic or linux-backports-modules-alsa-karmic-generic-pae (depending on your kernel).

However, this did not work for my Lenovo X300, so it's not resolved yet, but maybe somebody can use the information to construct a solution for the Lenovo's as well.

joseph O Neill (ianomaolc) wrote :

ASUS 1005HA

Just upgraded to 9.10. Everything fine except mic. (Hot keys not working but easily fixed)

 I note that here: https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Asus%20Eee%20PC%201005HA, that the mic is said to work out of the box.

which it doesn't.

Haven't been able to locate a fix yet.

manuel (amador-manuel) wrote :

The suggested fix from Ducane7 above (to install linux-backports-modules-alsa-karmic-generic or linux-backports-modules-alsa-karmic-generic-pae) didn't work for me either in my X300.

@manuel You should adjust your mixer settings using alsamixer in a Terminal.

For the 1005HA, the dedicated bug is this one: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/449855. It looks like the backports-modules-alsa are a good step in fixing the problem: have you tried to do a recording with Gnome Recorder? It should work, but there is still a problem maybe on the pulseaudio side which most notably prevents it from working with Skype.

manuel (amador-manuel) wrote :

@Daniel I have tried to do that, and doesn't work for me. Sound Recorder still records nothing unless I plug in the external mic. What exact settings did you put with the alsamixer?

farchumbre (farchumbre) wrote :

i can confiirm the same problem with the internal mic in lenovo x300.
it used to work with 9.04, but it stopped working after upgrade to 9.10

Markus Kopp (mkopp) wrote :

I have installed the Backported Modules, but couldn't find the Internal Microphone in alsamixer, only Internal Mic Boost is available.

Ducane7 (ducane7) wrote :

Many people seem to be having problems with snd-hda-intel. A wiki with some summary information for various codecs is here

https://wiki.ubuntu.com/SndHdaIntelSoundProblems

I just added there my Lenovo X300 codec info and status there. Please add your information there too (if you have different results or different codecs) in order to help developers.

Slingshot (slingshot) wrote :

Confirm internal digital mic not working on my Thinkpad x300 6478-14G with 9.10 64Bit

jzleibo (joel-jzleibo) wrote :

Confirm, this bug affects me as well. I am running a Lenovo x300 laptop with Karmic Koala. My codec is Analog Devices AD1984A. The internal mic does not work, I don't have an external one so I haven't tested that. Changing the settings around in alsamixer doesn't seem to have any effect.

Jerone Young (jerone) wrote :

@jzleibo
            You need to install pacakge "linux-backprts-alsa-karmic-generic". Then the internal microphone will work.
             I've tested this on my X301 and it works. It auto switches when you plugin the microphone into the jack.

edu-cr (indiodesnudo) wrote :

Same problem here with a Dell Inspiron 1310... installing linux-backprts-alsa-karmic-generic or linux-backprts-alsa-karmic-generic-pae DO NOT fix the problem... actually with latter my wireless gets lost!

It used to work just fine in Jaunty :-(

Brad Figg (brad-figg) wrote :

Please, if you are still having issues, test with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 440251

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds .

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

Please let us know your results.

tags: added: karmic mic-int
Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jim 1290 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf7db8000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104383ce,00100004'
   Controls : 12
   Simple ctrls : 7
CheckboxSubmission: af33802e14559ea72cb98c14e2e08b69
CheckboxSystem: 9c26adf6eed2f681ba41f94dd24c07e4
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Tags: lucid ubuntu-une
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I am running the Lucid beta and the behaviour seems to be exactly the same as previously with backport-modules. That is to say for the microphone to work with Pulseaudio, the two channels still have to be unlocked and one set to zero.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
Tom Goh (tomgohj) wrote :

I can confirm this in a Thinkpad x300 running Ubuntu 10.4 (32 bit).

Codec: Analog Devices AD1984A
$ cat /proc/asound/card*/codec\#*|grep -i codec

Alsainfo.sh
http://www.alsa-project.org/db/?f=e6a49bb0278d6f171f8990b39d947d0451f0109d

Kaspar Metz (kap) wrote :

Also confirming this bug on a Thinkpad X300 running 10.04.

summary: - Internal microphone does not work
+ Internal microphone does not work on Lenovo X300
David Henningsson (diwic) wrote :

First, the original reporter has a PCI SSID of 17aa:20ac, so if this terminal command:
lspci -vvnn | grep 17aa:20ac
does *not* show the following line:
 Subsystem: Lenovo Device [17aa:20ac]
You're having different hardware and should file separate bugs (e g using the "ubuntu-bug audio" terminal command).

Second, I'm looking through the bug comments but I could use a sum up.

1) Is there any way, under 10.04, to get the Internal Mic working, and if so, what are the steps you have to take to get there?

2) Is there anything else, except the Internal Mic, that does not work?

Ducane7 (ducane7) wrote :

(I'm the original poster)

Current status/developments:
I've been updating my system consistently since the original bug report and the microphone is still not working
Testing has been performed both on my running system as well as on (clean) live distributions of each version.
I've now tested up to and including Maverick Meerkat Alpha 3.

My answers to the questions in comment #44:

1) I have tried several suggestions found around forums (including L&R balancing tricks etc) but none of them fixed the microphone problem.

2) Nothing else seems to be wrong: everything else on my system works as expected.

I still hope this bug gets fixed because it's quite a hassle to bring along an external mic on trips.

David Henningsson (diwic) wrote :

I'm trying to figure something out here. According to the description, it says that:

  ## Intrepid fix for internal microphone
  options snd-hda-intel model=thinkpad

...should enable the internal mic. This makes no sense to me, as the quirk for automatically applying the thinkpad model to 17aa:20ac was committed at the same time as the thinkpad model itself. Can we get a confirmation on that statement, i e, would it be possible for someone to dig up an old Intrepid installation, verify that the Int Mic is actually working, and then post an alsa-info according to https://wiki.ubuntu.com/Audio/AlsaInfo ? I would then compare that result to a non-working int mic, and look for differences.

Tom Goh (tomgohj) wrote :

My Microphone was working with Thinkpad X300 several versions ago (after hardy sometime) but can't remember which exact version though. It did take some fiddling around to get it working. Sorry I can't test Intrepid at the moment as I need my machine running.

David Henningsson (diwic) wrote :

There is another interesting thing in the commit logs though. This is a long shot, but there was some mic-related stuff added after the initial commit. I've tried reverting it, and that can be tested here: http://people.canonical.com/~diwic/temp/alsa-hda-diwic-lenovo-x300-dkms_1.0.23.diwic_all.deb
First uninstall any linux-backports-modules you have installed, then install the above package and reboot. It probably won't work, but I figured it might be worth a try. :-)

Ducane7 (ducane7) wrote :

I tried the suggestion by David Henningsson (#48) and it didn't make any difference. I followed the instructions and the package installed without problems,

After reboot, the mic still doesn't work, and the weird interaction between console alsamixer and the pulseaudio applet persists: when using alsamixer on the command line to switch to 'internal' or 'mixed' inputs, it switches, but does not cause the audio to work. Then, going to the applet shows the mic as 'mute'. Unmuting the mic in the applet causes the input source in the alsamixer to revert to 'external'.

On a side note: I have several colleagues with X301's and for them it seems to work out of the box. Maybe (slightly) different hardware.

Jiehan Zheng (jiehanzheng) wrote :

All I got is noise, and the song currently playing... But my sound cannot be captured. 10.10.

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

To post a comment you must log in.