cpulimit.c: Received request to terminate due to CPU overload.

Bug #344057 reported by Greg Grossmeier on 2009-03-17
78
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Daniel T Chen
pulseaudio (Ubuntu)
Undecided
Daniel T Chen

Bug Description

Binary package hint: pulseaudio

Opening bug about this cpulimit pulseaudio bug as I am experiencing it with latest Jaunty (and crimsun's PPA enabled).

My steps to reproduce:
1) open gmusicbrower (audio player)
2) play mp3/ogg
3) switch between desktops (with compiz "Normal" settings)
4) pulse crackles then stops all sound right when I switch desktops (takes about a minute or more after starting a song until it does this)

I can then restart gmusicbrowser and it will work again.

Exact same steps to reproduce if viewing a flash video in Fx or mpg move in Totem.

alsa-info.sh output:
http://www.alsa-project.org/db/?f=aa7e83be8191618d19c06328424019ee9979c0e0

attached last lines from /var/log/syslog

Daniel T Chen (crimsun) wrote :

Please try changing /etc/pulse/daemon.conf from
; disable-remixing = no
to
disable-remixing = yes

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Daniel T Chen (crimsun) wrote :

(see also bug 226342)

Changed that line but it still failed. This time with a bit of crackling before losing sound entirely.

From the syslog:

Mar 17 01:30:59 alexandria pulseaudio[12466]: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
Mar 17 01:30:59 alexandria pulseaudio[12466]: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
Mar 17 01:30:59 alexandria pulseaudio[12466]: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Mar 17 01:33:58 alexandria pulseaudio[12469]: cpulimit.c: Received request to terminate due to CPU overload.
Mar 17 01:33:58 alexandria kernel: [55697.727241] pulseaudio[12469]: segfault at 7f9ee4355fa0 ip 00007f9ee4355fa0 sp 00007ffff5003688 error 14 in module-null-sink.so[7f9ee4b7c000+3000

Changed in pulseaudio (Ubuntu):
status: Incomplete → New
Daniel T Chen (crimsun) on 2009-03-17
Changed in pulseaudio (Ubuntu):
status: New → Confirmed

Note:

Changing that line has caused Banshee to be unable to play Internet Radio stations. It can still play last.fm music though. (gmusicbrowser, which is just local files, is able to play audio fine, and Fx is able to play audio via flash just fine).

Re-commenting out that line enables Banshee to play Internet Radio stations.

Spider (spider-alternating) wrote :

the CPU overload still happens here:

grep CPU /var/log/user.log
Mar 20 09:11:32 Waves pulseaudio[4586]: cpulimit.c: Received request to terminate due to CPU overload.
Mar 20 09:11:43 Waves pulseaudio[6137]: cpulimit.c: Received request to terminate due to CPU overload.
Mar 20 09:12:25 Waves pulseaudio[6232]: cpulimit.c: Received request to terminate due to CPU overload.
Mar 20 09:56:51 Waves pulseaudio[6244]: cpulimit.c: Received request to terminate due to CPU overload.

That was after all updates

pulseaudio:
  Installed: 0.9.14-0ubuntu14
  Candidate: 0.9.14-0ubuntu14
  Version table:
 *** 0.9.14-0ubuntu14 0
        500 http://se.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

uname -a
Linux Waves 2.6.28-11-generic #35-Ubuntu SMP Wed Mar 18 21:55:34 UTC 2009 x86_64 GNU/Linux

On Fri, Mar 20, 2009 at 5:00 AM, Spider <email address hidden> wrote:
> the CPU overload still happens here:
>
> grep CPU /var/log/user.log
> Mar 20 09:11:32 Waves pulseaudio[4586]: cpulimit.c: Received request to terminate due to CPU overload.

Please see https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-March/007501.html

Spider (spider-alternating) wrote :

> Please see https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-March/007501.html
Installed it and will do further testing with it.

Daniel T Chen (crimsun) on 2009-03-26
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Changed in pulseaudio (Ubuntu):
assignee: nobody → crimsun

Tried with 2.6.28-11-generic #38~lp330814crimsun2 SMP Wed Mar 25 20:09:32 UTC 2009 x86_64 GNU/Linux

I played mp3s with mplayer for about 20 minutes (far more than before), but pulseaudio crashes with the following message:

  Mar 26 03:48:18 butterfly pulseaudio[3810]: module-console-kit.c: GetUnixUser() call failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetUnixUser" with signature "" on interface "org.freedesktop.ConsoleKit.Session" doesn't exist
  Mar 26 03:48:20 butterfly last message repeated 2 times
  Mar 26 03:48:40 butterfly pulseaudio[3810]: cpulimit.c: Received request to terminate due to CPU overload

lspci:

  04:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)

Daniel T Chen (crimsun) wrote :

released in jaunty's -11.38

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
MFeif (matt-feifarek) wrote :

I still have this problem on an up-to-date Jaunty.

Not sure what "jaunty's -11.38" means... but I THINK it means kernel. My kernel rev is 2.6.28-11.42 (386).

"cpulimit.c: Received request to terminate due to CPU overload." is the exact error.

Some other notables:
Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

I'm streaming audio to this computer via another system running mpd, using the standard gnome-installed controls to advertise the audio sinks via avahi. No custom settings in /etc/pulse.

I don't see any cpu spikes around the problem, and I'm not doing ANYTHING else with the box. It's running the desktop, but no applications (save applets) are running. No significant background tasks are running either (but a sshd that's letting me run 'top').

When running top, pulseaudio seems to eat 6-9% of the cpu when playing music.

Changed in linux (Ubuntu):
status: Fix Released → New
Daniel T Chen (crimsun) wrote :

This should be fixed in 0.9.15.

Changed in linux (Ubuntu):
status: New → Fix Released
Changed in pulseaudio (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: New → Triaged
Daniel T Chen (crimsun) wrote :

For those of you experiencing this symptom with updated (from jaunty-proposed) linux and pulseaudio, please try changing /etc/pulse/daemon.conf to use:

resample-method = trivial

then, killall pulseaudio. Simply invoking "speaker-test -c2" afterward will trigger an autospawn.

(Reporting on behalf of my brother, a new Ubuntu user)

We're experiencing what may or may not be the same bug. Most programs run fine (e.g. audacious plays sound), but pavucontrol causes pulseaudio to quickly die with a CPU limit error.

We're using the -proposed version of pulseaudio, with resample-method = trivial. We've also set default-sample-channels = 8 to get all the speakers working, if that's relevant.

alsa-info.sh is here: http://www.alsa-project.org/db/?f=2d36098489a51f5fe93c610dafdb42d0d4c3fe08

Attached is the output of running pulseaudio in a terminal, then starting pavucontrol.

emmeda (emmeda) wrote :

Pulseaudio needs a complete core, when I play an .ogg-file in Rythmbox and gets killed 4-10 seconds later:

grep CPU /var/log/user.log
May 9 13:10:01 itchy pulseaudio[3390]: cpulimit.c: Received request to terminate due to CPU overload.

I put a lot of hopefully helpfull output in the attachment file "debugoutput.txt". Here is the order of all commands, which output is in the attachment:
$ pulseaudio --version
$ cat /etc/pulse/daemon.conf
$ lsb_release -d
$ uname -a
$ lspci | grep -i audio
$ lsmod | grep "snd"
$ cat /proc/asound/cards
$ head -n 3 /proc/asound/card0/codec#0
$ head -n 3 /proc/asound/card0/codec97#0/ac97#0-0
$ head -n 3 /proc/asound/card0/codec97#0/ac97#0-0+regs
$ aplay -l
$ aplay /usr/share/sounds/question.wav
$ asoundconf list
$ cat ~/.asoundrc
$ ps -C esd
$ ps -C arts
$ ps -C pulseaudio

I just thought, that it is better to post too much, than too less. So I postet all recommended output from this page:
http://wiki.ubuntuusers.de/Soundprobleme/Audio-Fehler-Beschreibung .. and a bit more.

@Daniel T Chen:
That worked, had no further problems with pulse. Thanks.

urho (vonturha) wrote :

tried resample-method = trivial, no help at least when using spotify with wine 1.0.1

Jeremy Nickurak (nickurak) wrote :

Getting this running rhythmbox or ogg123 in jaunty, pulseaudio 1:0.9.14-0ubuntu20.2

Jeremy Nickurak (nickurak) wrote :

No change with resample-method = trivial

For those of you experiencing this symptom with updated (from jaunty-proposed) linux and pulseaudio, please try changing /etc/pulse/daemon.conf to use:

resample-method = trivial

then, killall pulseaudio. Simply invoking "speaker-test -c2" afterward will trigger an autospawn.

The problem persists with resample-method = trivial

no-cpu-limit = yes

fixed the problem for me, resample-method = trivial didn't work

Daniel T Chen (crimsun) wrote :

Please note that in Karmic the cpu-limit is disabled by default.

On Oct 22, 2009 11:51 AM, "tonyhartfield" <email address hidden>
wrote:

no-cpu-limit = yes

fixed the problem for me, resample-method = trivial didn't work

-- cpulimit.c: Received request to terminate due to CPU overload.
https://bugs.launchpad.net/bugs/...

Status in “linux” package in Ubuntu: Fix Released Status in “pulseaudio”
package in Ubuntu: Triaged ...

Binary package hint: pulseaudio Opening bug about this cpulimit pulseaudio
bug as I am experiencing...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+341-g62bf-0ubuntu1

---------------
pulseaudio (1:0.9.22~0.9.21+341-g62bf-0ubuntu1) lucid; urgency=low

  * New snapshot based on stable-queue git branch (testing requested
    specifically by upstream)
    - LP: #164745, #173212, #201391, #204536, #207796, #210016, #221038,
    - LP: #226342, #230408, #236423, #237443, #250059, #269585, #274304,
    - LP: #274577, #275474, #277532, #277566, #277932, #278025, #280534,
    - LP: #283049, #286816, #287036, #292732, #298011, #298301, #300290,
    - LP: #302038, #311497, #311853, #324062, #339448, #344057, #348979,
    - LP: #350829, #356206, #367379, #367544, #369822, #371897, #374846,
    - LP: #375570, #381801, #399515, #402950, #403786, #408169, #409322,
    - LP: #409723, #410326, #410446, #417695, #417976, #419271, #421072,
    - LP: #422774, #423979, #424655, #425028, #427016, #431072, #432660,
    - LP: #437640, #437996, #442191, #443306, #443389, #446719, #449762,
    - LP: #455417, #461532, #464652, #483191, #497537, #503780
  * debian/patches/:
    + add: 0099-change-configure-git-version-tag.patch: Match released
           upstream 0.9.21 for shlibs and LIBPULSE_VERSION_INFO
    - drop: 0004-set-tsched0.patch (no longer relevant)
            0050-revert-pacmd-poll-argv.patch (no longer relevant)
            0056-dont-bail-on-sound-class-modem.patch (merged)
            0056-ignore-sound-class-modem.patch (merged)
            0058-Backport-4c793.patch (merged)
            0059-Backport-978d3.patch (merged)
            0060-fix-implicit-func-decl-cpu-arm.patch (merged)
            0061-Backport-c5fdb.patch (merged)
            0070-dont-bail-on-sound-class-modem-devs.patch (merged)
    + refresh: 0001-change-resample-and-buffering.patch
               0090-disable-flat-volumes.patch
               0091-dont-load-cork-music-on-phone.patch
               0057-load-module-x11-bell.patch
 -- Daniel T Chen <email address hidden> Thu, 14 Jan 2010 20:33:05 -0500

Changed in pulseaudio (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.