Ubuntu

[Jaunty] wireless rt2860 not connecting to WPA

Reported by Vladimir Yakovlev on 2009-03-09
244
This bug affects 37 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by kwan
Nominated for Jaunty by LumpyCustard
Nominated for Karmic by kwan

Bug Description

NOTE: before considering to post anything new in here, try to install linux-backport-modules-jaunty and reboot. Also, please no more ME TOO comments.

NOTE 2: The Ralink 2.1.2.0 sources seem to solve the problem which people have been having. Please try upgrading to those. Alternatively, wait for the ubuntu team to release a new kernel which incorporates the fix. If the 2.1.2.0 driver still doesn't work you can try it with a patch. For that please see Bryan Stephenson and James Dupin's HOWTO's at https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/339891/comments/47 and https://bugs.launchpad.net/ubuntu/+source/linux/+bug/339891/comments/35 before posting another comment.

Binary package hint: network-manager
Ubuntu 9.04 LiveCD daily
I have Eee PC 901. Built-in wi-fi RT2860STA detected, wireless networks listed correct. When try to connect, it doesnt, like bad password, or so.

In /var/log/wpa_suplicant.log:
Trying to associate with XX:XX:XX:XX:XX:XX (SSID=XXX freq=XXX)
Authentication with 00:00:00:00:00:00 timed out

USB WiFI Linksys WUSB54GC on this notebook works fine.
In /var/log/wpa_suplicant.log:
Trying to associate with XX:XX:XX:XX:XX:XX (SSID=XXX freq=XXX)
Associated with XX:XX:XX:XX:XX:XX
WPA: key negotination complited with XX:XX:XX:XX:XX:XX [PTK=CCMP GTK=TKIP]

Maybe problem in wrong mac 00:00:00:00:00:00? Linksys uses correct mac
On Ubuntu 8.10 (with rt2860sta drivers installed manually) connecting properly.

description: updated
description: updated
description: updated

I was able to connect until a few days ago. I was assuming it was an updated kernel. Trying to connect to a WPA2 wireless router.

justinc (justin-conover) wrote :

This is all I get out of var/log/messages

Mar 10 07:05:55 comatose kernel: [ 118.565942] ===>rt_ioctl_giwscan. 1(1) BSS returned, data->length = 118
Mar 10 07:05:55 comatose kernel: [ 118.566776] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=11)

justinc (justin-conover) wrote :

Sorry, didn't mean to save with out adding var/log/wpa_suplicant.log too

CTRL-EVENT-SCAN-RESULTS
Trying to associate with 00:1f:b3:99:e5:f9 (SSID='GoodMonsters' freq=2462 MHz)
Associated with 00:1f:b3:99:e5:f9
WPA: Key negotiation completed with 00:1f:b3:99:e5:f9 [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to 00:1f:b3:99:e5:f9 completed (reauth) [id=0 id_str=]
WPA: Group rekeying completed with 00:1f:b3:99:e5:f9 [GTK=CCMP]
WPA: Group rekeying completed with 00:1f:b3:99:e5:f9 [GTK=CCMP]
CTRL-EVENT-SCAN-RESULTS
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
CTRL-EVENT-SCAN-RESULTS

justinc (justin-conover) wrote :

Same results from updated kernel.

2.6.28-9-generic

Giorgos Logiotatidis (seadog) wrote :

I can confirm this behaviour with the latest 9.04 kernel. WEP and unsecure wifi works fine but WPA does not.

Damien Laureaux (timoa) wrote :

Same problem with RT2860STA...

I have a Eeebox B202 with this chipset and when i tried to connect, it don't connect with WPA.

If i'm connect without authentification, no problem to have connection...

Now, my Eeebox was connected to WIfi Hotspot (open auth) only for update but not in my network...

The driver from Ralink have a no standardised config file and you have 2 options :
- Active WPA authentification
- Active WPA authentification on Network Manager

But i don't know if it's Network Manager or module of kernel the problem...

Damien Laureaux (timoa) wrote :

The last version of driver for Ralink RT2860sta have options with "=n" on originally driver config file :

# Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y

# Support Native WpaSupplicant for Network Maganger
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

Giorgos Logiotatidis (seadog) wrote :

I still can get it to work although I edit the config file as Damien suggests and recompile. But I was lucky with the 1.7.1.1 version of the driver, which I downloaded from arrays.org website

[1] http://www.array.org/ubuntu/dists/intrepid/eeepc/binary-i386/rt2860-dkms_1.7.1.1_all.deb

You have to force the installation because this driver is older than the one already installed. Now everything works fine

justinc (justin-conover) wrote :

I've installed the UNR for Alpha-6 +updates and mine is working on WPA2 for what ever reason, I changed my channel around on my POS 2wire wireless router and am able to connect, I seem to have to change channels around often on it.

http://cdimage.ubuntu.com/releases/jaunty/alpha-6/jaunty-netbook-remix-i386.img

Changed in network-manager:
status: New → Confirmed

Hi,

I have the same problem on a Medion E1212 netbook with Ralink 2860 wireless chipset. I tried jaunty netbook remix, daily image from 22nd of March. Lsmod lists the rt2860sta module; ifconfig lists ra0 interface, Network manager shows all wireless networks available. When trying to connect to my network it just works without security or with WEP 128 bit. WPA / WPA2 does not work. Network manager shows icon with one, then two green points, but then fails to connect.

What else can I do ??

Regards,
Martin

SGosnell (spamtrap47) wrote :

I get the same result from the beta on my EEE 900, and on a Toshiba Satellite. WPA will not connect. Using Alpha 6, it worked fine, and with the .29 kernel it works fine. I'm using the .29 kernel, and probably won't use the .28 kernel at all. Something changed between alpha 6 and the beta, and not for the better.

Hello again,

in the meantime I tried
 - to compile the 1.8.00 - driver from ralinktech.com.tw : same behaviour with jaunty netbook remix: no connection with WPA / WPA2.
 - to use another kernel: in the jaunty-repositories I only find another .28 kernel version. With this one out-of-the-box driver: no connection with WPA/WPA2. Raliktech-driver: No connection with WPA/WPA2.
 - to get a .29 kernel: I downloaded one from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29/linux-image-2.6.29-020629-generic_2.6.29-020629_i386.deb , but with this one there is no rt2860sta - driver included, and i am not able to compile the Ralinktech-driver with this kernel.

To SGosnell: Where do you get your .29 kernel from ?? I would like to test your version on my netbook !

Thanks so far,

Martin

Hello again,

as mentioned above I tried to get the older driver from

http://www.array.org/ubuntu/dists/intrepid/eeepc/binary-i386/rt2860-dkms_1.7.1.1_all.deb

This driver installs against kernel .28 and works without problems ! (WPA/WPA2 encryption)

The problem seems not to be one of network-manager, but one of the Ralink-driver. What has happened between the versions 1.8.0.0 and 1.7.1.1 ???

Have a nice day !

Martin

Nathan McCorkle (nmz787) wrote :

I am having the same problem... installed the array drivers 1.7.1.1 and voila! I wish the newer ones worked though :(

fix instructions:
http://ubuntuforums.org/archive/index.php/t-1110957.html

justinc (justin-conover) wrote :

My updated Jaunty has been running fine.

Matthijs (matthijsvanwolferen) wrote :

As I have had no problems with the wireless whatsoever, I would like to add the following (as I was thinking about reporting it as a bug)

When I switch the WiFi off in Windows XP via the function key and turn the Eee pc off, I can't get WiFi running in Jaunty on reboot.

I don't know why, as all the networks are shown and apparently networkmanager works as well, it just can't connect. The blue light is (as always) on.

If I then reboot into XP, turn WiFi off en then on again (because after the reboot the WiFi is on in XP because of Jaunty, but doesn't work), THEN boot into Linux again, everything works just fine.

Should I file a separate bug?

Chris Myers (chris-ascent) wrote :

I have had intermittent problems connecting with Jaunty with my laptop where previous versions were rock solid.

Wireless fails to connect to password protected network & then eventually falls back to connect to a local unsecured network.

lspci -v produces:

04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
 Subsystem: Intel Corporation Device 1111
 Flags: bus master, fast devsel, latency 0, IRQ 2297
 Memory at f8000000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: [c8] Power Management version 3
 Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
 Capabilities: [e0] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 8d-3a-47-ff-ff-e8-13-00
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

Alexander Sack (asac) wrote :

driver issue.

Maybe check whether installing linux-backport-modules-jaunty improves your situation.

affects: network-manager (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Rémi (pazelty) wrote :

hello like I wrote in an other bug-report https://bugs.launchpad.net/ubuntu/+bug/352218

I have make some test with my wireless router
I have 4 modes for the encryption :
    * WEP
    * WPA (TKIP)
    * WPA (AES/CCMP)
    * WPA (TKIP + AES)

all are working on jaunty exept the last WPA (TKIP + AES)

on intrepid with array.org kernel, all is working even WPA (TKIP + AES)

copycat (info-pcxpert) wrote :

Same here on a new MSI WIND U100 notebook with the netbook remix 9.04 downloaded and installed today.(RC?)
I already had it on the BETA 9.04 on my thinkpad T61, but this was only tested on the usb boot.

Can confirm on EEEPC 901 with 9.04 RC.

rt_ioctl_giwscan. 4(4) BSS returned, data->length = 486
rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=8)

CTRL-EVENT-SCAN-RESULTS
Trying to associate with xx:xx:xx:xx:xx:xx (SSID='xx' freq=2447 MHz)
Authentication with xx:xx:xx:xx:xx:xx timed out.

Worked perfectly with Ubuntu 8.10

rusart (ruslan-levitskiy) wrote :

I have the same problem on amilo laptop with RaLink 2860 when connecting to D-Link DWL-2100AP access point. It was fixed by setting "Cypher alg." to "AES" instead of "Auto". But it was my own access point, and i haven't access to all access points in the world. :)

nicolas kleinklaus (nknico) wrote :

Same thing ...This bug could be related to wpa-supplicant, don't you think ???

summary: - [Jaunty] wireless rt2860sta not connecting in 9.04
+ [Jaunty] wireless rt2860 not connecting to WPA

This bug report based on the topic is limited to RT chipsets. However, I have a Thinkpad T41 with ipw2100 chipset that is working perfectly with 8.10, but if I try with 9.04RC I fail to connect my WPA secured access point. The WLAN itself does work, I can succesfully connect to open APs.

Bryan Stephenson (acreda) wrote :

just getting all my wifi drivers including 1.7.1.1 incase when I upgrade to Jaunty that i cant connect through WPA as I can with 1.8.0.0 but have just been to the Ralink website and driver 2.1.0.0 as been uploaded. dont think it will change anything but here's the changelog:-

[2.1.0.0]
 1. New generation schema for multiple OS porting
 2. Fixed Ad-hoc ping failed in noisy environment. (Probe Response has too many retry packet then cause "not enough space in MgmtRing")
 3. Fixed WPA(2)PSK issue when group cipher of AP is WEP40 or WEP104.
 4. Modified iwpriv ra0 get_site_survey:
  In scan list result: Security shows "NONE" when AP is OPEN/NONE, shows "WEP" when AP is OPEN/WEP or SHARED/WEP, shows "WPAPSK(WPA2PSK)/TKIP(AES)" when AP is WPAPSK(WPA2PSK)/TKIP(AES) shows "WPA(WPA2)/TKIP(AES)" when AP is WPA(WPA2)/TKIP(AES)
 5. Support kthread.
 6. Add New A band channel list region 15 contains the whole channels in the A band region 4 and the new CE channel 167,169,171,173
 7. Add New IEEE802.11r functionality.
 8. Fixed WPA2-Enterprise failed when AP reboot or turn off then turn on.
 9. Fixed STA cannot connect to 11B only AP when the setting of is PHY_11GN.

I think i will compile it and install before jaunty and see what happens, if i can't connect after upgrade (assume the system will have 1.8.0.0 re-installed,) I'll try it again and if all else fails i will load 1.7.1.1

Vladimir Yakovlev (nagos) wrote :

Ubuntu 9.04 netbook remix, reliased, all work fine.

Michael Schurter (schmichael) wrote :

Suddenly started working for me on a WPA2 (TKIP and AES) network that it failed on before. Not sure what changed, didn't notice any kernel or networking related updates.

James Dupin (james.dupin) wrote :

jaunty up to date. still can't connect to (TKIP + AES)

spongeblunt (deshman02) wrote :

New to Linux but been using Ubuntu on my Netbook as a replacement to Xandros for a couple of months now.When I installed Inrepid I had this problem but it was solved by installing the Array.org Kernel, now I've upgraded to the new release (9.04 Netbook Remix) and the problem is back - I cannot access any wireless networks that use WPA TKIP + AES.

I also noticed thanks to Bryan Stephenson that there's a new version (2.1.1.0) of the driver available with the following release notes:

[2.1.1.0]
 1. Fixed driver would send zero IWEVASSOCREQIE to Native WpaSupplicant.
 2. Fixed driver would send non-zero BSSID to Navtive WpaSupplicant when STA disconnecting to AP.

I've been reading up for about 6 or 7 hours now and I've noticed a lot of references to WpaSupplicant in bug reports but no real solution and being new to Linux I'm not entirely sure how I would install this driver myself to see if it solves the problem. Has anyone tested this driver or can anyone point me in the right direction to get going myself?

Bit disappointed this wasn't fixed as it's a large part of the functionality of a Netbook.

Greenie (greenie-green) wrote :

Just so everyone knows, there is an array.org kernel for Jaunty:

sudo -s
echo "deb http://www.array.org/ubuntu jaunty main" > /etc/apt/sources.list.d/array-jaunty.list
wget http://www.array.org/ubuntu/array-apt-key.asc
apt-key add array-apt-key.asc
apt-get update
apt-get install linux-netbook-eeepc
sudo apt-get remove linux-generic linux-image-generic linux-restricted-modules-generic
exit

These commands will add the new jaunty repository and install the kernel, the apt-get remove will remove the metapackages to stop the generic kernel from updating, but will not remove the current kernel.

This kernel has solved my issues with WLAN with WPA (TKIP). I'm not sure about what's different, havent looked into that yet, but adamm would be the guy to ask :)

Bryan Stephenson (acreda) wrote :

well tried all the above that I said I was going do but no luck. Im still using the Graber packaged dkms deb driver 1.8.0.0 and connected by WPA (TKIP) only rather than WPA2.

I have also retried to compile the new 2.1.0.0 driver from source and also from the "webUI" package which compiles a browser GUI, module and comes with a wpa_supplicant source code and both could not connect to WPA will the 1.8.0.0 can currently.

so i think supplcant is not to blame now and I think only leaves us two options:-

1. The driver is not communicating/using wpa_suppaplicant properly ( im getting either "WPA: No wpa_ie set - cannot generate msg 2/4")

2 Or the driver does work but maybe the ubuntu distro has files/config are missing or not configured properly for the driver.

Considering that i have got Wpa connection on the 1.8.0.0 i would think its the 1st option. Maybe Stephane Graber could have a quick look over the situ, but i think he is on different projects at the mo.........

spongeblunt (deshman02) wrote :

Tried my hand at compiling the new 2.1.1.0 driver but with the instructions as complex as they were I'm not sure I did it right and I'm not sure how I'd verify if they were installed. If they were installed they didn't work.

After this I tried the 1.8.0.0-3 deb package which installed but didn't change anything - still no WPA2 connection.

I just tried the array.org kernal method listed above and I've now got a connection. The only thing I'm worried about is to boot into the correct kernal I had to press ESC at Grub and choose the array.org kernal as it was 2.6.28.8. The original kernal was showing as 2.8.28.11, is it bad to be running an old kernel?

Dries Harnie (dharnie) wrote :

I installed a wireless router today and found I couldn't connect to it with my new Jaunty install. I had a similar issue at the university with a network of Airport Extreme stations.

I tried the 2.1.1.0 version on the web site but that didn't help.

I decided to compare the 1.7.1.1 and 1.8.0.0 versions and found a place where they didn't quite finish refactoring; I fixed it, reloaded my module, and it worked!
I had to remove the "official" driver from /lib/modules/2.6.28-11-generic/kernel/drivers/staging/rt2860/rt2860sta.ko before my new driver was seen.

Can anyone verify these patches work? I made one for 1.8.0.0, but it also works for 2.1.1.0. You'll have to compile your own version of the drivers and disable the ubuntu-supplied one as shown above. They work for me and I can now connect to my wireless at home without issues. Yay!

Hope it works for you guys too. :)

Baggers (chris-bagley) wrote :

Would love to test this patch but am not sure how. Anyone care to explain?
Got two laptops to test this on.

Bryan Stephenson (acreda) wrote :

no problem:-

I tried this patch and I now have the 2.1.0.0 driver working on WPA again but not WPA2 but that is better than the last post where i could get any WPA connection.

I don't know how to use the patch the file so i looked at the patch, figured out the sytax and realise that what it does is change a value in the file located in "username"/DPO_RT2860_LinuxSTA_V2.1.0.0/common called "cmm_wpa.c" as it took me a bit to find the line in the file and copy over the change I have attached it to my post. download it and copy it to the common folder where you have extracted the ralink driver so it overwrites it.

These are the steps that I took to get here:-

1. Fire up synaptic (System -> Administration -> Synaptic), for me this was to remove the 'rt2860-source' package I installed. But also check that the staging rt2860 driver is removed from the kernel to make sure there is not conflict, as
Dries stated check the directory /lib/modules/2.6.28-11-generic/kernel/drivers/staging/rt2860/ and make sure there is no file called rt2860sta.ko.

2. Copy the file cmm_wpa.c to the /common directory where you have extracted the driver.

(Now I'm working from the README_STA file..............)

3. Open the Makefile and make sure at the top two lines are as follows:- (this is always the case from driver to driver so I normally skip this...)
RT28xx_MODE = STA
TARGET = LINUX
save the file.

4. then go to the directory os/linux and open the file called config.mk.

5. You then have two choices to make on how the driver works with your system, either control the driver and connection with the Gnome network Manager, or by the wpa supplicant & the driver directly, I always use the network manager to keep in line with the gnome experience.

if you want to use the Network Manager then make sure that HAS_WPA_SUPPLICANT and HAS_NATIVE_WPA_SUPPLICANT_SUPPORT are set to y

--------------------------------------------------------------------------------------------------
after this, the file asks you to type in this command, I've never been able to make sense or correctly use the command. Can you help Dries???? :-
=> #>cd wpa_supplicant-x.x
=> #>./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d

if you wish to do the other method the instructions are in the makefile but i wont touch on them as i think most would be happy with the first option
-------------------------------------------------------------------------------------------------

6. Now all the config has been done, open a Terminal window and go to the extracted driver directory, for me this would be:-
=>cd DPO_RT2860_LinuxSTA_V2.1.0.0

7. time to start the process...
=>sudo make
[enter password]

8. As long as that has compiled with out an Error you then need to copy the config file....
=>sudo cp RT2860STA.dat /etc/Wireless/RT2860STA/RT2860STA.dat

9. Time to load the driver module!
=>cd os/linux
=>sudo /sbin/insmod rt2860sta.ko

Reboot and see what happens, i think this is the first time that someone has been able to change the code and get success so i hope a lot more people can try this when they have a spare 20mins,....

Dries Harnie (dharnie) wrote :

Bryan: Thanks for the write-up and testing it!

Some remarks though:

You can apply the patch with "patch -p1 < /path/to/file.path" if you are inside the base directory for the driver (DPO_RT2860_LinuxSTA_V2.1.0.0 in your case)

The wpa_supplicant stuff is indeed not necessary as NetworkManager does this on the fly for you.

Finally: you might have to take the interface offline and unload the current version before installing the new one:

$ sudo ifconfig ra0 down
$ sudo rmmod rt2860sta
$ sudo mv /lib/modules/`uname -r`/kernel/drivers/staging/rt2860/rt2860sta.ko /tmp # just in case it's still there

You can also do "sudo make install" instead of steps 8 and 9 as follows:
(in the source directory)
$ sudo make install
$ sudo modprobe rt2860sta
$ sudo ifconfig ra0 up

Hope that helps, time for breakfast :)

Bryan Stephenson (acreda) wrote :

Yep, I forgot to mention that i did remove the currently running driver by ordering network manager to close down the wireless interfaces but unchecking the box when right-clicking on the icon and then just running a rmmod command in a terminal window. was going to change that but can edit posts on here from what i can see..............

had a feeling that the network manager was doing the wpasupplicant as and when or I would not be able to use WPA in the first place! one thing I have learned by starting out with Opensuse then going on to ubuntu is that distro are flexible when it comes to directory structure, could not find the supplicant .conf file and it ending up turning up in /etc about 4 or 5 levels down!

thanks for the tip on the patch command, makes more sense now..

I guess that I need wait to see if other people are able to do WPA2 on the 2.1.0.0 driver, and trawl through the logs it see there are any functions or warning coming up that may be related to wpa or the driver.

for the record i am running:-
rt2860 driver 2.1.0.0 patched with Dries' file
Ubuntu standard Kernel 2.6.28-11-generic
Connected to the Belkin N+ modem router with WPA (TKIP) encryption only

Dries Harnie (dharnie) wrote :

I assume you mean 2.1.1.0 ? In any case, I'm running that one with the patch.
I can now connect to my home network (Dlink DIR-635) with 802.11G+N and WPA2 (TKIP+AES).

Bryan Stephenson (acreda) wrote :

yes, apologies again, I think my brain knows it's Sunday, when you next connect to your router can you post your /var/log/daemon.log and syslog file so I can see if there is anything else going on to compare to my system, at least I'm only one step behind where you are....

Hesperus (james-a-sampson) wrote :

Just to confirm that the patch works for me. Took some time to get it to work. Had to follow Bryan's instructions exactly, don't know why Dries amended instructions didn't work as they should have? I have also managed to get WPA2 with a netgear dg834pn to work.

Dries Harnie (dharnie) on 2009-04-27
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Alexander Sack (asac) on 2009-05-02
description: updated
Dries Harnie (dharnie) on 2009-05-17
description: updated
Dries Harnie (dharnie) on 2009-05-24
description: updated
64 comments hidden view all 144 comments
Michael Schurter (schmichael) wrote :

I should mention as well that I've felt my connection has been "flaky" with 2.1.2.0. It connects OK (not fast, but I wouldn't say slow... its maybe a minute?), but I usually work via SSH & vim and regularly get pauses of around 30 seconds.

I thought maybe it was the servers I was connected to at first, but they're very reliable servers and I don't have pauses when connecting from my wired desktop.

Let me know if there's some way I can diagnose this further.

jeorsch (georg-geiser) wrote :

I had to do a fresh install of kubuntu jaunty due to some others reasons and now everything works out-of-the-box without any patches or workarounds!
The only difference is that I use the "network management" applet that attaches to the kicker bar. With my old installation I manually started knetworkmanager that shows up in the system tray since I did not know about the applet.

Troy Ready (troyready) wrote :

Just did a custom compile of kernel 2.6.30 (under jaunty) to test it's driver (modinfo shows it as version 1.8.1.1).

Still cannot connect to my WPA2 802.11n network at home; no issues with my seperate WEP network. WPA2 router is a D-Link DIR-635.

Dries Harnie (dharnie) wrote :

Troy: interesting. I just did the same thing and I have the same wireless router, but i am able to connect just fine! I only get g speeds though (54 Mbit) but i can live with that :)
Did you change anything in your RT2860STA.dat? i've attached mine.

Bryan: Sorry, I still haven't found the time to look at the code, work is starting to pile up here ..

Vladimir Yakovlev (nagos) wrote :

I have wi-fi router d-link dir-300. It can be configured for wpa tkip and wpa ccmp.
WPA with CCMP all work fine with out of the box kernel 2.6.28-11-generic.
With WPA TKIP work only array.org kernel.
Troy Ready, try to change encryption, until bug not fixed.

Walter_Wittel (wittelw) wrote :

I would like to compile the current ra2860-sources with Adam's patch Gro-Tsen pointed us to, howver I've had no luck. I got ra2860-sources from a debian repository at http://debian.oregonstate.edu/debian, but I get quite a few HUNK FAILED errors (and also had to change the paths to a number of the files because they are in different places).

Can anyone tell me how to get the current jaunty ra2860-sources so I can try the patch on them? I am able to compile and run the debian driver but of course it has the usual problems without the patch.

GNUbee40 (docnino) wrote :

Hello Everyone!

I guess it is important to sort Driver related problems from Router related ones!
I run Ubuntu Jaunty with unmodified rt2860 staging driver (that makes it ver. 1.8.1.0 I guess - forgot how to check it), but a modified RT2860.dat file, which enables N-speeds. I currently use Network manager ver. 0.7.0.100.
We have 3 different APs in our shared flat. One of it is the D-Link DIR-635. Connection to this router can be troublesome: prolonged authentication time, failure to connect, sudden loss of connection, or loss of SMB or internet connections while staying associated to the router. In the last case the router cannot be reached by Ping either, even though connection seems to be maintained. I'd like to stress, that this router seems to show similar problems with various Windows clients: they get connected to the router, but not to the internet! This occurs rather randomly and might be related to running the Router in mixed 802.11 mode (n,g,b),
With the Belkin 54 G (802.11g+WPA) and the Level One AP (802.11g+WPA2) there seems to be no such trouble.
Right now I am connected to the DIR-635. Settings are: Mixed 802.11 Mode (n,g,b), WPA Auto, Cypher set to TKIP (WPA). It can be set to AES (WPA2) as well, but I find it slows Authentication a lot, sometimes so much that NM jumps to the Belkin instead. However, for some time I ran the router with Cypher: AES; WPA mode: WPA2, without major trouble.
I presently cannot connect to WPA Enterprise network at my university (eduroam). This was possible with earlier versions of the driver.
To round things up: testing connections with different routers or testing routers with different clients might be essential to get a better grip of what the driver trouble consists of. Some of the newer routers with Draft n have their own issues. For sure is, that mixed cypher continues to be non-functional both with WPA Personal and Enterprise. The first patch seems to work for some, but there is at least 1 case reporting total loss of connectivity to encrypted networks after applying it.

I have a (somewhat) working connection now, so I am reluctant to try both later drivers or patches. But I would like to participate in an ordered approach to sort this out.
Regards

Les Moss (les-sierrasol) wrote :

I am not up to recompiling drivers, so I updated to the 2.6.28-13 kernal to see if that solved the problem. It did not.

But, I changed the access point configuration from Cypher TKIP/AES to TKIP only and that solved the problem for me. This works on two access ponts with different hardware (Trendnet and Zonet). Mode setting remains WPA/WPA2 on both.

I also note that the connection information gives the speed as 54Mb while in Windows it reports 135Mb for this access point. which is configured as G,N mixed mode. So, that may be another bug.

Is there a Ralink utility for Ubuntu as there is for Windows? It is useful for seeing whats going on with multiple access points.

fossy (fossy2001) wrote :

Hi,

i also use 2.6.28-13 kernal and my router is set to WPA2/AES, i cant login.
My password has some special characters, but even my printer is connecting to my wlan.

NorCal-IC (norcal-ic) wrote :

I've been struggling with this issue and patiently waiting for a resolution since I first purchased my Asus Eee PC 1000 several months ago.

I converted to Eeebuntu NBR 2.0 and WICD and have never had a problem using WPA2-PSK on my home net. However I've never been able to get a 802.11n connection either. I really felt, based on everything I'd read, that the issue was driver related and that I just needed to wait for a good solution to surface. It did.

After backup everything up I followed the instructions on this link...
http://www.ayetea.com/updating-the-rt8260-80211n-wireless-network-driver-from-source.html
and this morning I had a fast and rock solid 802.11n connection with WPA2-PSK.

It looks as though Ralink has, with v2.1.2.0, corrected the 802.11n issue and if the proper WPA_SUPPLICANT mods are made to the config.mk file then both the issues are resolved.

Cheers!

Tony Espy (awe) wrote :

Since this is clearly a driver bug and has been marked FixCommitted, I'm changing the status of the network-manager component of this bug to Invalid, as there's clearly no action required with respect to the network-manager source package.

If anyone feels strongly that this is not correct, please re-open and add your reasoning.

Changed in network-manager (Ubuntu):
status: New → Invalid
couzin2000 (couzin2000) wrote :

I'm not too familiar with all that's been posted here previously, but -- following up on the lastest posts, I can say this much.

-Have a Asus EEEPC 901, with Ubuntu Netbook Remix Jaunty.
-Have a D-Link DIR-625.

Here's stuff I did:

-follow these instrcutions to a T: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/339891/comments/114
-afterwards, updated to an array.org kernel, though I mot sure how to check the version I got.

Tried connecting, still nothing.
I can however tell you that every time, the wifi DID see a network, did pickup on my SSID, tried to connect - even the router received the MAC adress of the EEE. So there is clearly some communication between both.
Also, everytime, it would try to connect, then ask me for a password. When I put it in, the password was a simple 8-letter word. However, everytime it could not connect, the windowed request comes back, and I see more black spots then before -- so I check the "show letters" checkbox and I see that the pass is now in HEX value.

I went back to the router, changed the security level and went to WPA personal-only -- it's not specified exactly if this is TKIP, but this is what I'm led to believe. As soon as I took off the AES-level security from the router, BOOM -- the EEE connected!

This looks to me like the problem is related to AES security. Not sure how I would adress it, but I figured you could use the info at the very least. Hope this helps.

On 16/07/09 17:07 -0000, couzin2000 wrote:
> I'm not too familiar with all that's been posted here previously, but --
> following up on the lastest posts, I can say this much.
>
> -Have a Asus EEEPC 901, with Ubuntu Netbook Remix Jaunty.
> -Have a D-Link DIR-625.

I'm running Ubuntu Karmic nowadays, and wireless works as it should out
of the box. So people who haven't gotten my patch or the most recent
ralink driver to work can try a 2.6.30+ kernel.

MichaelT (mike-on-launchpad) wrote :

I originally opened a different bug which got linked to this one. I've tried all the ideas here with little success. Like couzin2000 I ended up with an array.org kernel which seems to work OK for me on most normal wireless networks - however it steadfastly fails to operate on a hidden-SSID, AES, WPA-Enterprise network. I will try the Karmic upgrade, but can't do it yet - I need the eee901 working and can't afford to experiment at this time.

Dries Harnie (dharnie) wrote :

On 16/07/09 19:45 -0000, MichaelT wrote:
> I will try the Karmic upgrade, but
> can't do it yet - I need the eee901 working and can't afford to
> experiment at this time.

You can just snarf the karmic version of linux-image-2.6.30 and install
it, I think.

Philip Muškovac (yofel) wrote :

how about trying a newer mainline kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/ ?

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

Fix Released?? Where/When/How? Which version?

Thanks in advance :)

ollesbrorsa (ollesbrorsa) wrote :

I'm with LumpyCustard! Any news as of yet where we can give the fix a testdrive?

Br,
ollesbrorsa

Walter_Wittel (wittelw) wrote :

Karmic has had a working driver for the last several releases, and in the last few days (or maybe longer) the function key to toggle the radio on/off on my eeepc 901 has been working :-).

BTW, the driver implementation in Karmic (don't know the source) is *much* better than the RaLink 2.1.2.0 driver I've been limping along with on Jaunty (see comment above https://bugs.launchpad.net/ubuntu/+source/linux/+bug/339891/comments/104). The only thing[s] keeping me from switching entirely to Karmic at this time are the occasional brakages on updates and the screen saver / suspend timers don't currently work (at least on my eeepc 901, 'though I can suspend using the function key / closing the lid).

AFAIK there have been no relevant updates to the kernel in Jaunty and I have to rebuild / install 2.1.2.0 every time the Jaunty kernel gets updated.

sykorat (sykorat) wrote :

I have spent several days toying around with the various solutions proposed. I especially concentrated on installing the Ralink 2.2.0.0 driver with and without the patch (the changes to cmm_wpa.c) all without success.

Parsing the syslog, I found that a connection was made to my access point, but the call to DHCKDISCOVER by dhclient kept timing out.

So long story short, I eventually got my rt2860sta driver working with WPA2 by following the advice on this thread: http://ubuntuforums.org/archive/index.php/t-1110957.html (scroll down to the post by tanvach on April 6th, 2009, 08:19 AM).

Basically, reverting to the 1.7.1.1 version of the driver made my wireless connection work.

Note: I did have to perform a couple commands before installing the .deb package to circumvent an installation error due to the presence of a newer driver.

ifconfig ra0 down
#ra0 is my alias for rt2860sta driver
rmmod rt2860sta

then I followed the rest of the instructions in the his post. Hope this helps whoever is experiencing this issue.

nilsey (nkrause) wrote :

RE # 47

It seems the path in comment # 47 has been expiered

wget http:// www.ralinktech. com.tw/ data/drivers/ 2009_0424_ RT2860_ Linux_STA_ V2.1.1. 0.tgz

can you provide a new location please?

krutoileshii (krutoileshii) wrote :

Ok guys here is what needs to happen to get it working properly form the get go, this is caused by the missing RT2860STA.dat file in /etc/Wireless/RT2860STA/ folder.

Tested it since 8.10 and this is consistent , all i have to do to get it working is create the folder above, copy the file there and restart the interface. we need this file included with the driver by default and everything would work. My guess is that firmware is using it somewhere.

Once you copied the file do
sudo ifconfig ra0 down
sudo rmmod rt2860sta
sudo modprobe rt2860sta
sudo ifconfig ra0 up

this fixes the problem so i gues we just need to include the RT2860sta file with the driver and place it in the directory specified

1 comments hidden view all 144 comments
krutoileshii (krutoileshii) wrote :

I have personally tested this on more then 100 machines (our company uses a bunch of linux laptops and they all had RT2860 chips. so this rules out hardware and leaves teh software since the software was the same and only think i did was copy the file and restart the interface, i'm pretty confident that this is the cause.

krutoileshii (krutoileshii) wrote :

I still had this issue in Karmic fresh install.

krutoileshii's fix unfortunately did not work on my EeePC 1000h and a Linksys WRT160N WPA2 router.
My workaround is to use an array.org eeepc kernel.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed

Several people here confirmed that RT2860+WPA works in Karmic. Also for me Karmic fixed the issue. Setting to "Fix Released".

krutoileshii, does it work for you now? On multiple machines? Feel free to set the status back to confirmed if not.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Yuri (linux-colombi) wrote :

It's fixed for me (AP: Linksys WRT54G, WiFi using WPA2-Personnal, host: EeePC 901/Karmic).

GNUbee40 (docnino) wrote :

I would like to stress, that WPA (TKIP) and WPA2 (AES) always have been functional. The problem is mainly related to connecting to Routers which offer both Encryption methods at the same time = mixed Cypher. This is standard setting on most routers for compatibility.
WPA Enterprise has also been problematic. Thus reports about accessing Institutional or Corporate Networks with the new driver are needed.
For me, the Jaunty driver (1.8.1.0) has ceased to work reliably also in single cypher (maybe a problem with the router). For now i have downgraded to 1.7.1.1.
Will test 9.10 soon.

GNUbee40 (docnino) wrote :

Well, well! Currently testing out the staging driver in Karmic (v. 1.8.1.1). Even though this is not the latest driver, I enjoy full connectivity with Router set to mixed Cypher. Also the wireless throughput seem much improved. I have acceptable speed even in less favorable locations. Will test with Eduroam network tomorrow.

Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
krutoileshii (krutoileshii) wrote :

Ok i. have done a bunch of tests over the weekend with this on karmic. Here is what i was able to to get working:

1 wpa 1 and 2 with both encryption methods at the same time
Wep

Haven't tried corporate wpa as we do not use it in the office.

rictec (rictec-netcabo) wrote :

using karnic an i have this problem now mu eeepc 1000h had wi-fi connection allways

Changed in linux (Ubuntu):
status: Fix Committed → Invalid
rictec (rictec-netcabo) wrote :

hi
There are more to this bug then just rt2860 not connecting to WPA or jts rt2860 driver
i cant not connect to wpa from network manager or ubuntu karmic from intell based wireless cards also
all my machines have karmic installed all of them stop working on last update

3 laptops and two eeepc so its not only rt2860

RIctec

taka khumbartha (scar) wrote :

hi, um, so is there clear solution for jaunty? i am confused with the status set to "fix released" and then back to "invalid"

if there is a clear solution, can it please be re-iterated? i have tried various patches mentioned here, as well as various version of the source from ralink. so, who knows what is on my system now?

please indicate correct way to wipe out all old versions of the driver/module and ensure the correct one is installed.

thank you and sorry for my confusion.

andrewdodd13 (andrewdodd13) wrote :

My rt2860 in my eee901 was working fine with 2.6.32, but I upgraded to Lucid and 2.6.33 appears to have brought this issue up again.

Set the wireless mode also its wlan0 now

On May 1, 2010 8:54 AM, "andrewdodd13" <email address hidden> wrote:

My rt2860 in my eee901 was working fine with 2.6.32, but I upgraded to
Lucid and 2.6.33 appears to have brought this issue up again.

--
[Jaunty] wireless rt2860 not connecting to WPA
https://bugs.launchpad.net/bugs/339891
You recei...

Kevin Snow (kgs-mvs-gmail) wrote :

I also ran into this problem when I moved from 8.04 to 10.04. I have an ASUS Eee PC 1000 that I tested with the final lucid live CD. When I first booted up and tried to connect to my router, it connect right away, but after just a few minutes it disconnected. When it tried to reconnect, it reported that the security phrase was wrong. I was able to get it to connect by turning the wifi card off using eee-control, turning the networking off, then turning the wifi card back on and restarting networking. It didn't always work, but it would usually connect after 3 or 4 rounds of this activity.

After reviewing the notes in 344022, I made a change to the security settings on my router to use WPA2-PSK (AES encryption) for authentication rather than WPA-PSK + WPA2-PSK (TKIP + AES encryption) and that appears to have resolved the issue for me. I realize that it's not a good solution for others who can't make changes to router settings. It's strange that the mixed cypher worked in previous revisions of the driver, but not in newer ones.

deebuntu (dduke-iprimus) wrote :

WPA authentication problem occurs on Netgear WG511 v2 with all Ubuntu versions up to 10.04. Workaround found to work in 10.04 when WPA key is set to EXACTLY 104 bits (=13 ASCII characters). This workaround not tried with previous versions so success unkown.

Vladimir Yakovlev, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

no longer affects: network-manager (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Invalid → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Displaying first 40 and last 40 comments. View all 144 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers