Comment 141 for bug 339891

Kevin Snow (kgs-mvs-gmail) wrote :

I also ran into this problem when I moved from 8.04 to 10.04. I have an ASUS Eee PC 1000 that I tested with the final lucid live CD. When I first booted up and tried to connect to my router, it connect right away, but after just a few minutes it disconnected. When it tried to reconnect, it reported that the security phrase was wrong. I was able to get it to connect by turning the wifi card off using eee-control, turning the networking off, then turning the wifi card back on and restarting networking. It didn't always work, but it would usually connect after 3 or 4 rounds of this activity.

After reviewing the notes in 344022, I made a change to the security settings on my router to use WPA2-PSK (AES encryption) for authentication rather than WPA-PSK + WPA2-PSK (TKIP + AES encryption) and that appears to have resolved the issue for me. I realize that it's not a good solution for others who can't make changes to router settings. It's strange that the mixed cypher worked in previous revisions of the driver, but not in newer ones.