Ubuntu

Dell Laptop vostro 1310, Internal Keyboard and Touchpad not working anymore on 9.04 jaunty

Reported by yeus on 2009-02-25
160
This bug affects 17 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I think this bug occured after a (very small) kernel upgrade from 2.6.28-8.24 to 2.6.28-8.25 but I am not really sure, because there were several updates at once and I am not really in to that stuff...

All I can say is: after the upgrade my keyboard and Touchpad do not work anymore. I am running Kubuntu 9.04 on a Dell Vostro1310 with 1.8GHz intel core duo

Booting using the kernel 2.6.28-6 makes no problems. And I can still use the internal keyboard in grub. Also USB-mouse and usb keybaord work as expected (this is how I fill this bugreport).

description: updated

hmm.. with another update to 2.6.28-8.26 everything works again...

Josh Marshall (catchjosh) wrote :

Tested Jaunty Beta Live CD today, and had the same problem -- no keyboard or trackpad response. Am willing to do more testing / system information grabbing, just let me know what is needed.

Josh Marshall (catchjosh) wrote :

Sorry, first time posting a bug -- forgot to mention that I have a Vostro 1310 with 2.0GHz Core 2 Duo. Also, the 8.10 Live CD detected the trackpad, keyboard, etc. perfectly, if that helps.

Phil Longstaff (plongstaff) wrote :

Affects me too on Vostro 1510, Jaunty beta. If I reboot, the problem seems to correct itself.

Same Problem here with 2 Vostros 1310.
But Keyboard & Touchpad are working when booting with AC attached.

papelhigienico (papelhigienico) wrote :

The bug #366527 have a step by step to reproduce the bug in vostro 1510.
The bug #341094 have two ways to solve this.

papelhigienico (papelhigienico) wrote :

I tested it with a clean install (9.04) and the bug continue...
Then I swap from i386 to amd64 (9.04) and the problem continue yet...

Confirmed here also on my Dell Vostro 1310, who was working fine before upgrading to 9.04.
Seems that it's really some X thing. When the keyboard and mouse becomes locked, it gives an error, check the syslog message:

Apr 28 13:04:29 neo kernel: [ 66.554074] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
Apr 28 13:04:29 neo kernel: [ 66.556092] mtrr: no MTRR for d0000000,10000000 found
Apr 28 13:04:29 neo gdm[2585]: DEBUG: gdm_server_stop: Server pid 2589 dead
Apr 28 13:04:29 neo gdm[2585]: DEBUG: gdm_slave_quick_exit: Killed everything from the display
Apr 28 13:04:29 neo gdm[2582]: DEBUG: gdm_display_unmanage: Display stopped
Apr 28 13:04:29 neo gdm[2582]: DEBUG: Attempting to parse key string: xdmcp/Enable=false
Apr 28 13:04:29 neo gdm[2582]: DEBUG: Attempting to parse key string: daemon/ServAuthDir=/var/lib/gdm
Apr 28 13:04:33 neo bluetoothd[2549]: bridge pan0 removed
Apr 28 13:04:33 neo bluetoothd[2549]: Stopping SDP server
Apr 28 13:04:33 neo bluetoothd[2549]: Exit
Apr 28 13:04:34 neo exiting on signal 15
Apr 28 13:05:31 neo syslogd 1.5.0#5ubuntu3: restart.

The restart there is when I pressed the power button, because there were nothing more to do with the keyboard and touchpad locked.

I can confirm this... I think it started with an upgrade from last week. Don't know exactly which one.

Changed in ubuntu:
status: Invalid → New
cracklinrain (cracklinrain) wrote :

I have the same problem with Ubuntu 9.04 (64bit) on my Dell Vostro 1310.

But i can report some positive experiences:

When I start it with external power and my bluetooth mouse, it works sometimes by itself.
If I join the GRUB menu by typing ESC directly after startup, it was starting always fine!

But nevertheless the system freezes very often.

Felix (meteofelix) wrote :

I also have the problem on my Vostro 1310 using Ubuntu 9.04 (32bit). It appears when the external power supply is removed during boot process. After booting the system I can unplug the cable and everything is still works.
I don't have any other problems like system freeze.

shizow (glukkon) wrote :

same Problem here with Vostro 1310.
Since my upgrade from Kubuntu 8.10 to 9.4, keyboard and mouse freezes always at the login, if there is no AC adapter present.
With AC adapter present everything is nice.

So it seems only Vostro 1310 and 1510 are effected, who will solve this problem? is this a (K)ubuntu specific problem?

This workaround seems to fix it on my side https://bugs.launchpad.net/ubuntu/+bug/341094/comments/8

cracklinrain (cracklinrain) wrote :

It's the same for me: The workaround (added parameters at the grub) works.

But the cooler is now noising the hole time.
Do I have to reconfigure this or is it part of the problem?

Thank you for your assistance!

Steve Dodier-Lazaro (sidi) wrote :

Still happening. I linked it to xserver-xorg-input-evdev as one of its about to expire duplicates. Is there any info needed in order to get this bug fixed ? If so, please ask.

relo (ubuntu-eulerpfad) wrote :

I have done quite some testing about this bug before coming hree.

It occurs on my vostro 1510 with kernel 2.6.28-11 and not with the (still installed) 2.6.27-11. I have a 64 bit installation. I have found two working methods to reproduce the bug.

1. Have the machine run with inserted battery (here: no AC)
2. Have the display closed while bootup (with AC)

Probably a powerstate problem?

I tested the fix proposed above in grub and it works much better here.
Apparently the mobo would be sending, in some conditions, wrong informations
about the available hardware ? Should we post a bug at kernel.org ?

Same issue with a Vostro 1710. The keyboard and mouse are locked at login prompt. It stopped working in Ubuntu 8.10. I thought the problem would be solved with Ubuntu 9.04 but it was the same. It only worked once, after the install. It stopped working at the next reboot.

I cannot use Ubuntu because of this bug. It is really horrible...

After some kernel and xorg drivers updates, my Vostro 1310 keep locked
on the first boot.
I'm wondering why it keep this way just on the first boot after turned
off for a long time.
If it locks and I turn off and on again, everything goes fine.
My workaround is to put it on hibernation, not making a "cold" boot.

corck (corck) wrote :

Hi,
I experience the same on my Vostro 1510, kernel 2.6.28-12.
My experience is similar to Taq's. Mostly the next morning it doesn't work, and after a few (usually between 1-3) everything works normal.

.... This bug was first logged on 2009-02-25 and there's still no update, stays on status new?

Steve Dodier-Lazaro (sidi) wrote :

I linked to the upstream kernel.org bug.

Changed in evdev:
importance: Undecided → Unknown
status: New → Unknown
Changed in evdev:
status: Unknown → Confirmed

Occurence is 99%. The laptop is started without battery.

Yet another confirmation on my three day old Dell Vostro 1720 - no keyboard or mouse on cold boots. I'm using a clean install of Kubuntu 9.04 and Kernel 2.6.28-13-Generic (64-bit). Occurrence for me is 100% on cold boot only, regardless of being on battery power or on AC power. The only work around thats working for me is to load Windoze MEII upon first cold boot.

Steve Dodier-Lazaro (sidi) wrote :

This should be fixed in 2.6.30. Please try Karmic when the Alpha 3 is out,
and let people know if it's fixed.

Karsten Horsmann (witchdoc) wrote :

The Workaround with the attanded kernel line "i8042.reset i8042.nomux i8042.nopnp i8042.noloop" breaks for me in Kernel 2.6.28.13 and external Keyboards (via USB connected to my Dell Vostro 1510).

kernel /boot/vmlinuz-2.6.28-13-generic root=UUID=aa6577a8-fec3-4628-b0db-90e400355d15 ro vga=791 i8042.reset i8042.nomux i8042.nopnp i8042.noloop

with Kernel 2.6.28-11-generic and the Workaroudn works all perfect (internal and external Keyboard)

kernel /boot/vmlinuz-2.6.28-11-generic root=UUID=aa6577a8-fec3-4628-b0db-90e400355d15 ro vga=791 i8042.reset i8042.nomux i8042.nopnp i8042.noloop

Swift Arrow (swiftarrow9) wrote :

I can confirm the same problem with a Dell Vostro 1510. I've been able to define it exactly:

Cold boot (adaptor or battery):
Kbd and Trackpad do not work at login screen. Solution is to keep adapter plugged in, keep battery in, press power button, laptop powers off, then immediatly press power button to power it on again. If you wait too long (a minute or so) it won't work.

Cold boot (battery):
kbd and trackpad do not work at login screen. Workaround is to plug in external mouse and press reboot button. This does not completely power off hardware between cycles.

Looking through the logs, I see that on the first boot, where it doesn't work, two less modules are detected. In the boot where it works, it detects more hardware and configures the stuff. I'm attaching the relevant logs.

I have the same problem with a Dell Vostro 1520, running Jaunty x64. I have now edited the kernel boot options as mentioned above and am watching whether the problem can be solved with these settings...

i8042.reset & i8042.nomux is all that I needed.

corck (corck) wrote :

i8042.reset & i8042.nomux worked for me as well.
was getting really annoyed to reboot sometime up to 5 times until it worked

GLDBacon (gldbacon) wrote :

Confirm working fix provided by Karsten Horsmann on Dell Vostro 1510, Ubuntu 9.04, 2.6.28-13-generic

Solution provided by nukedathlonman works for me as well. I have a Dell Vostro 1310.

reinhard (protux) wrote :

this problem appeared to me since around the beginning of july, with ubuntu 9.04 on a Dell 1310, which worked perfectly before since May!!!!
I use kernel 2.6.28-14-generic but it don't matter if I load an older installed kernel, because none of them was able to make my keyboard and touchpad working...

But, thanks to launchpad people, I was able to fix this by just adding 'i8042.reset' to the kernel boot option.

My 'diabolic' interim solution was to first boot the pre-installed vista and then choose reboot from vistas login screen - and that's no joke! ;)

Whatts (tomklaverblad) wrote :

I had the same problem on my Dell Vostro 1510 with Ubuntu 9.04 kernel 2.6.28-11-generic since yesterday (new to Ubuntu and Linux in general).
My first cold reboot was when I trying to show a friend that it "really just works", and sure enough that's when the keyboard and trackpad go dead.

Adding the "i8042.reset i8042.nomux i8042.nopnp i8042.noloop" line seems to have solved the problem completely.

Steve Dodier-Lazaro (sidi) wrote :

I think that it is completely pointless to add comments stating that the fix
works. Instead, what would be useful is that several people install Karmic
on their Vostro and check if the bug still happens in Karmic (without adding
anything to the menu.lst). This bug is meant to be fixed in 2.6.30 but noone
confirmed upstream yet.

So please confirm that it is _really_ fixed, in the upstream bug, if you are
on Karmic.

rsoika (ralph-soika) wrote :

I have had same issues on Dell Vostro 1520 with Intel Integrated GMA 4500MHD.
Adding the kernel options "i8042.reset i8042.nomux i8042.nopnp i8042.noloop" seems not to work for me. Tested with Kernel 2.6.28.11 and 2.6.28.14..
Now I installed Kernel 2.6.30.4 from http://kernel.ubuntu.com/~kernel-ppa/mainline.

This seems to solve all my problems. Keybord works. Graphic improved. No system frees after login.

John Ward (automail) wrote :

I can confirm on the Vostro 1510 as well, kernel 2.6.28-14-generic still has his problem.

Simply adding "i8042.reset" to my "kopt" section seems to have cured it, no need for the other options.

For me it was a little different - rather than 80% of the time it works - 80% of the time it doesn't. I would restart around 6, 8 times and nothing (on battery). If I would wait a period of time (an hour, maybe more or less) it would fix itself. Plugging in power might change things, sometimes didn't but it has some effect. Then again when it wasn't working and I was on AC, going to battery could fix it. Very odd, but nonetheless fixed and happy campers all around.

rsoika (ralph-soika) wrote :

I must correct my last posting. Also after upgrating to Kernel 2.6.30-4 and updating Intel Graphics driver to 2.7.1 I run again into a situation where system freezes some minutes after I logged in. This issue did only occure if I boot with battery. When I have plugged in power it seems to work without hangs.

Sean Hodges (seanhodges) wrote :

Same issue with a Dell Vostro 1710.

Changing my #kopt setting in /boot/grub/menu.lst, then running "sudo update-grub" fixed it for me:

# kopt=root=UUID=a4b503e2-d661-43dc-ad8c-0b2df4797313 ro i8042.reset i8042.nomux i8042.nopnp i8042.noloop

rsoika (ralph-soika) wrote :

I have a silly question: I only added the i8042 options directly to the menu entry of a specific kernel version. And I did not add these options to the kopt entry. And so I did no "sudo update-grub" after all. Is this a wrong procedure? And is it necessary that I do the "sudo update-grub" even if I did not change the kopt property?
So mybe my comments concerning this issue are waste?

I to have this, or a very similar problem as the original poster. Dell Vostro 1310. On boot, usually to 1st or 2nd boot, no internal keyboard or mouse, then, after a few reboots, it works. Does not start working if I leave it booted.

It works in Grub PRIOR to boot. It worked with original flavor 9.04 ISO, but once I brought it up-to-date, it started having problems.

plnnightsky (plnnightsky) wrote :

I am running vostro 1510 with very similar issues. If I start up with out the power adaptor connected The keyboard and mouse will not respond to any input. Unfortunately I can't remember after which upgrade this started to happen. The interesting thing is even if I boot from earlier versions it still will not work.

When powering down, by holding the power switch, earlier keyboard input can be seen in the top left corner of the screen just before the power shuts down.

I have tried all the recommend quick fixes but none of them work for me (assuming I did them correctly).

This is getting to be a very serious issue for me. If I cannot find a fix in the next couple of days, I will have to dump Ubuntu and go with another OS. It is basically making the laptop almost useless.

Swift Arrow (swiftarrow9) wrote :

Try this:
After booting up, read the grub instructions. You should be able to press e
to edit one of the boot options. press e. select the kopt line (Kernel
options line) to edit, press e again (if I remember correctly).

Add i8042.reset i8042.nodemux to the end of the line. then boot from that
line.

Now your keyboard should work when you get to ubuntu.

edit (as root) your /boot/grub/menu.lst file to include "i8042.reset
i8042.nodemux" to the end of the kopt line.

Save it. Your problems shoudl be solved until next update. Next time you
upgrade your kernel, those options that you just added won't be carried
forward. To carry them forward automatically, add those options to the
default kernel options in the automagic kernels list section of menu.lst,
and run sudo update-grub

On Mon, Aug 24, 2009 at 4:53 AM, plnnightsky <email address hidden> wrote:

> I am running vostro 1510 with very similar issues. If I start up with
> out the power adaptor connected The keyboard and mouse will not respond
> to any input. Unfortunately I can't remember after which upgrade this
> started to happen. The interesting thing is even if I boot from earlier
> versions it still will not work.
>
> When powering down, by holding the power switch, earlier keyboard input
> can be seen in the top left corner of the screen just before the power
> shuts down.
>
> I have tried all the recommend quick fixes but none of them work for me
> (assuming I did them correctly).
>
> This is getting to be a very serious issue for me. If I cannot find a
> fix in the next couple of days, I will have to dump Ubuntu and go with
> another OS. It is basically making the laptop almost useless.
>
> --
> Dell Laptop vostro 1310, Internal Keyboard and Touchpad not working anymore
> on 9.04 jaunty
> https://bugs.launchpad.net/bugs/334249
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in xserver-xorg-input-evdev: Confirmed
> Status in Ubuntu: New
>
> Bug description:
> I think this bug occured after a (very small) kernel upgrade from
> 2.6.28-8.24 to 2.6.28-8.25 but I am not really sure, because there were
> several updates at once and I am not really in to that stuff...
>
> All I can say is: after the upgrade my keyboard and Touchpad do not work
> anymore. I am running Kubuntu 9.04 on a Dell Vostro1310 with 1.8GHz intel
> core duo
>
> Booting using the kernel 2.6.28-6 makes no problems. And I can still use
> the internal keyboard in grub. Also USB-mouse and usb keybaord work as
> expected (this is how I fill this bugreport).
>

plnnightsky (plnnightsky) wrote :

Thanks
i8042.nodemux is not recognized and appears not to be needed.

Your memory was good. The only thing I could not figure out was how to save it from the grub editor. What i did was edit the menu.lst with out running update-grub and this seems to work with just i8042.reset added to the end of the line.

Not sure I have the default set correctly. This is what I put in:
kopt i8042.reset
and it was removed after running sudo update-grub

It is usable again not perfect

Swift Arrow (swiftarrow9) wrote :

Here's a snippet from my menu.lst, on a vostro 1510. I initially had the
same problem as you.
Edit yours to look like this (note the kopt line), and run sudo update-grub,
you should be good to go!

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=5b57a778-aea9-454c-832e-4fda8cd2fac3 ro i8042.reset
i8042.nodemux resume=/dev/sda2

skype: swift.arrow
facebook: facebook.com/linkeshd
Lakshya (Association of Mechanical Engineers)
Medicine for Tibet (Australian Charity)
People for Animals (Kollam Chapter)
Indian Youth Climate Network
Agents of Change: Political Strategy Working Group
President: Wise Earth Publishers

Website designer/developer. Computer wizz.
FOSS guy. Engineer. Environmentalist.
I fancy I can Think.

On Tue, Aug 25, 2009 at 7:59 AM, plnnightsky <email address hidden> wrote:

> Thanks
> i8042.nodemux is not recognized and appears not to be needed.
>
> Your memory was good. The only thing I could not figure out was how to
> save it from the grub editor. What i did was edit the menu.lst with out
> running update-grub and this seems to work with just i8042.reset added
> to the end of the line.
>
> Not sure I have the default set correctly. This is what I put in:
> kopt i8042.reset
> and it was removed after running sudo update-grub
>
> It is usable again not perfect
>
> --
> Dell Laptop vostro 1310, Internal Keyboard and Touchpad not working anymore
> on 9.04 jaunty
> https://bugs.launchpad.net/bugs/334249
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in xserver-xorg-input-evdev: Confirmed
> Status in Ubuntu: New
>
> Bug description:
> I think this bug occured after a (very small) kernel upgrade from
> 2.6.28-8.24 to 2.6.28-8.25 but I am not really sure, because there were
> several updates at once and I am not really in to that stuff...
>
> All I can say is: after the upgrade my keyboard and Touchpad do not work
> anymore. I am running Kubuntu 9.04 on a Dell Vostro1310 with 1.8GHz intel
> core duo
>
> Booting using the kernel 2.6.28-6 makes no problems. And I can still use
> the internal keyboard in grub. Also USB-mouse and usb keybaord work as
> expected (this is how I fill this bugreport).
>

RomanIvanov (ivanov-jr) wrote :

I have very similar problems with keyboard/mouse on my Dell Vostro 1510 Xubuntu 9.04.
- when I boot, my keyboard works fine in Grub and do not in Log-in screen, neither mouse nor keyboard does not respond any action.

It is very annoying, and make me be dependent on Windows a lot.

Workaround: I make a boot in Vista first and after that have successful login in Xubuntu.

Solved with "i8042.reset i8042.nomux i8042.nopnp i8042.noloop" in /boot/grub/menu.lst

Thanks!

-Eric

Did solve the problem running Jaunty on Dell Vostro 1510, thank you!
But now the issue reappeared in Karmic Alpha 6. Anyone else having this problem in Karmic? I am goint to post again after having tried the workaround.

Regards,
henning

Robert Hrovat (robi-hipnos) wrote :

Same here with Karmic beta. Keyboard and mouse does not work! Plugged in USB mouse or keyboard works.

Also solved on Dell Vostro 1310 with "i8042.reset i8042.nomux
i8042.nopnp i8042.noloop" in
/boot/grub/menu.lst

Adding i8042.reset and i8042.nomux as bootparameters works for me with Karmic.

MikeCamel (mike-hingston) wrote :

On Karmic beta (with 2.6.28-15-generic) - problem reoccurs. Haven't tried fix yet.

On Karmic the Problems eems to be solved... This problem didn't occur again for me.. without changing anything in grub

This problem doesn't affect me too in Karmic.

MikeCamel (mike-hingston) wrote :

No problems for me on Karmic RC (and not sure if I was correctly testing on beta, sorry).

RomanIvanov (ivanov-jr) wrote :

No problems for me on Karmic Xubuntu 9.10. Thanks.

Seems that Karmic fixed here on 1320 also. Thanks.

Changed in ubuntu:
status: New → Fix Released
sunethra (mailsuna) wrote :

Same problem occurs with Dell Vostro 1520, uses Intel GMA X4500 MHD card. Just installed Ubuntu 9.04 Same problem with Fedora 10 and 11. Updating the system and will see if the problem persists.

In case it does then upgrading to karmic helps? or should I edit /boot/grub/menu.lst as seen on earlier posts?

Changed in ubuntu:
status: Fix Released → Fix Committed

Uh-oh, seems the problem is back on 9.10 with the latest updates.
Today was the second time I booted my Vostro 1310 just with the
battery and the trackpad and keyboards were dead again, exactly the
same way on 9.04.
I'll apply the extra config on grub and see what happens.

I forgot that now we have GRUB2. What is the best way to insert i8042.reset i8042.nomux i8042.nopnp i8042.noloop on GRUB2? And should we open this bug again or make a new entry to 9.10?

Saivann Carignan (oxmosys) wrote :

This bug has been confirmed to be fixed by yeus, who reported the bug. Therefore, I'm marking it as fix released. However if you still get the issue, first make sure that you use latest ubuntu version without any workaround (such as adding i8042.reset i8042.nomux i8042.nopnp i8042.noloop in grub), this should not be necessary for this bug to disappear. If you can reproduce this bug with ubuntu without any workaround, please open a new bug report for "linux" package, by typing "ubuntu-bug linux" (without the quotes "") in a terminal and put a reference to this bug ( bug #334249 ) in your new bug description. This will help developer to track the issues individually. Thanks for your participation in launchpad!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Erik Landgren (elandgren) wrote :

I have a Dell Vostro 1510 .. and the problem is real.
Nevertheless, if you follow Sean Hodges steps, problem is fixed.

Thanks!!

rsidd (rsidd) wrote :

This bug was intermittent for me (on Dell Vostro 1710) through Karmic. I mostly suspend to RAM and rarely reboot, but occasionally reboots would result in non-working keyboard and touchpad. With Lucid (kernel 2.6.32-21-generic #32-Ubuntu SMP), the keyboard always comes up but the trackpad fails to work roughly 4 out of 5 boots. Kernel options i8042.reset i8042.nomux fixed it for the next boot but I haven't tried repeatedly rebooting so am not sure whether it's really fixed or just happened to work at that time.

Changed in evdev:
importance: Unknown → Medium
Changed in evdev:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.