Realtek ALC883 speakers don't mute when headphones plugged in

Bug #253422 reported by OrelEagle on 2008-07-30
60
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Hello,

I have a laptop LG E500.V.APSCG and installed Ubuntu Hardy on it. I had a few problems at the beginning since it's a new laptop, but it works well now.

One of the few remaining bugs (together with ACPI not working) is that pluging in headphones don't mute the laptops speakers.

I've found an interesting thread in the forums which deals exactly with this problem: http://ubuntuforums.org/showthread.php?t=616845.

My sound card is listed there (ALC883) and I've tried all the possibilities from the list. Unfortunately none of them works… I've also tried with "3stack-lg" but it does nothing.

For more information:

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC883
Codec: Generic 11c1 ID 1040

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SIS966 [HDA SIS966], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SIS966 [HDA SIS966], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

OrelEagle (oreleagle) wrote :

I've run the Alsa script, and it gave me this URL:
http://pastebin.ca/1090222

I hope it helps.

Kevinf (siegfri3d) wrote :

Hello there,
I have a MSI laptop with the same card and problem.
head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC883

==> /proc/asound/card0/codec#1 <==
Codec: Generic 11c1 ID 1040

I hope you can fix this.. i tried installing the alsa-* from upstream but the problem remains.

cheers

Kevinf (siegfri3d) wrote :

I forgot to mention that the "headphones" volume was not changing anything, however the main and PCM volumes were modifying the headphones and speakers volumes at the same time.

A little workaround to have only headphones working, put:
options snd-hda-intel model=6stack-dig
at the end of /etc/modprobe.d/alsa-base
reboot
then in the tool to control the volume, go in parameters and uncheck "headphones" (checking/unchecking will change what is working: speakers/headphones), that did it for me.

Kevinf (siegfri3d) wrote :

Tried ubuntu intrepid and it's affected as well.. hope you can fix it til october :<

OrelEagle (oreleagle) wrote :

Thanks for the workaround, I confirm it works. If you're using external speakers (plugged in the headphone jack), the problem is almost transparent.

Of course, it would be good to fix this bugs, but I think there are plenty of more critical sound problems ;)

inversus (inversus) wrote :

I have the same bug.

I'm using running Ubuntu 8.04 Hardy on LG e500 LP55P.
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

-> Plug headphones wont mute speakers
-> Can't control individually headphones and speakers in gnome volume. (changing one => change both)

So, my headphones are not working :/

Mackenzie Morgan (maco.m) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information. Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

Changed in alsa-driver:
status: New → Incomplete
OrelEagle (oreleagle) wrote :

Thanks for pointing to that wiki page. Here is the link to the sound information:
http://www.alsa-project.org/db/?f=57c93f2e0b97251e372c6898232b749a313252e2

Attachments are coming next.

OrelEagle (oreleagle) wrote :
OrelEagle (oreleagle) wrote :
OrelEagle (oreleagle) wrote :
Mackenzie Morgan (maco.m) wrote :

You mention model=6stack-dig. With this setting, what happens, exactly? Speakers go dead but line-out works?

OrelEagle (oreleagle) wrote :

After adding model=6stack-dig and restarting, you get a new tab in the volume control, called "Switches". There is just 1 tickbox with the text "Headphone", enabled by default.

If you enable the tickbox you get sound from both the headphones and the laptop's speakers (same behaviour as without model=6stack-dig). If you disable it, you always get sound from the headphones, even if they're not plugged in. If they are plugged in you get the expected behaviour (sound only through the headphones) but if they're not you don't get any sound at all.

description: updated
Mackenzie Morgan (maco.m) wrote :

This appears to have been fixed in Intrepid. Please test it and respond back as to whether it is working for you or not.

Daniel T Chen (crimsun) on 2008-09-21
Changed in linux:
importance: Undecided → Low
status: Incomplete → Triaged
Kevinf (siegfri3d) wrote :

It still doesn't work for me in intrepid.

Tarmo Ilves (koolobus) wrote :

I have the same bug.
ubuntu intrepid beta
Asus laptop F3Ke Realtek HD audio

Mackenzie Morgan (maco.m) wrote :

Koolobus, we need your output from the wiki page linked above as well.

Kevinf (siegfri3d) wrote :

I was using 6stack-dig as a workaround the way i mentioned above. Now i use:
options snd-hda-intel model=targa-2ch-dig
(or targa-dig)
And it works the way it should! (the speakers mute when i plug headphones, and headphones work)
But i have to be sure that in the parameters of the HDA intel mixer "headphones" is checked.
My laptop is MSI, so it might not be the same fix for everybody..

http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt
search for ALC883/888 and try different models.

OrelEagle (oreleagle) wrote :

I confirm that this fix works. Thanks a lot Kevinf for finding it!

So I think this bug is fixed. I'd like to change the status, but I don't know which one to choose: fix released or fix committed?

It worked for me too! :D
tnks a lot.

(it worked on hardy and intrepid)

2008/10/21 Kevinf <email address hidden>

> I was using 6stack-dig as a workaround the way i mentioned above. Now i
> use:
> options snd-hda-intel model=targa-2ch-dig
> (or targa-dig)
> And it works the way it should! (the speakers mute when i plug headphones,
> and headphones work)
> But i have to be sure that in the parameters of the HDA intel mixer
> "headphones" is checked.
> My laptop is MSI, so it might not be the same fix for everybody..
>
>
> http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt
> search for ALC883/888 and try different models.
>
> --
> Realtek ALC883 speakers don't mute when headphones plugged in
> https://bugs.launchpad.net/bugs/253422
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On Wed, 2008-11-05 at 09:56 +0000, OrelEagle wrote:
> I confirm that this fix works. Thanks a lot Kevinf for finding it!
>
> So I think this bug is fixed. I'd like to change the status, but I don't
> know which one to choose: fix released or fix committed?

Neither. For it to be fixed in Ubuntu would mean you don't need to put
model= at all. It should be automatic. If you all can confirm that
targa-2ch-dig makes *everything* work properly (headphones speakers,
microphone, and since it's -dig, I guess you guys have SPDIF too?), we
can make it automatic.

The only "trouble" I found so far was one button in Volume Control named
"headphones". When turned off sound don't work at all.

Don't know what SPDIF is :S how can I test it?

2008/11/5 Mackenzie Morgan <email address hidden>

> On Wed, 2008-11-05 at 09:56 +0000, OrelEagle wrote:
> > I confirm that this fix works. Thanks a lot Kevinf for finding it!
> >
> > So I think this bug is fixed. I'd like to change the status, but I don't
> > know which one to choose: fix released or fix committed?
>
> Neither. For it to be fixed in Ubuntu would mean you don't need to put
> model= at all. It should be automatic. If you all can confirm that
> targa-2ch-dig makes *everything* work properly (headphones speakers,
> microphone, and since it's -dig, I guess you guys have SPDIF too?), we
> can make it automatic.
>
> --
> Realtek ALC883 speakers don't mute when headphones plugged in
> https://bugs.launchpad.net/bugs/253422
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On Wed, 2008-11-05 at 17:50 +0000, inversus wrote:
> The only "trouble" I found so far was one button in Volume Control named
> "headphones". When turned off sound don't work at all.
>
> Don't know what SPDIF is :S how can I test it?

One of your headphone-looking jacks would say S/PDIF if you have it. If
you don't have that, you probably shouldn't be using -dig. Not so sure
how to test it...it's an optical output of sound, so...if you know
anyone with fancy sound equipment they could help but it's not *really*
necessary, I guess...

Um, when you say "sound don't work at all" do you mean it kills
headphones or it kills headphones and speakers?

> Um, when you say "sound don't work at all" do you mean it kills
> headphones or it kills headphones and speakers?
>
It kills headphones and speakers.

I guess I don't have any headphone-looking jacks named SPDIF.

2008/11/5 Mackenzie Morgan <email address hidden>

> On Wed, 2008-11-05 at 17:50 +0000, inversus wrote:
> > The only "trouble" I found so far was one button in Volume Control named
> > "headphones". When turned off sound don't work at all.
> >
> > Don't know what SPDIF is :S how can I test it?
>
> One of your headphone-looking jacks would say S/PDIF if you have it. If
> you don't have that, you probably shouldn't be using -dig. Not so sure
> how to test it...it's an optical output of sound, so...if you know
> anyone with fancy sound equipment they could help but it's not *really*
> necessary, I guess...
>
> Um, when you say "sound don't work at all" do you mean it kills
> headphones or it kills headphones and speakers?
>
> --
> Realtek ALC883 speakers don't mute when headphones plugged in
> https://bugs.launchpad.net/bugs/253422
> You received this bug notification because you are a direct subscriber
> of the bug.
>

with "targa-2ch" I got the same as before changing to "targa-2ch-dig".

btw, tnks for helping :)

2008/11/5 Mackenzie Morgan <email address hidden>

> Can you try targa-2ch instead of targa-2ch-dig then?
>
> --
> Realtek ALC883 speakers don't mute when headphones plugged in
> https://bugs.launchpad.net/bugs/253422
> You received this bug notification because you are a direct subscriber
> of the bug.
>

NuZeb (nudelzebra) wrote :

I have the same problem here on a Samsung NC10 netbook. Here is my alsa-info output:
http://www.alsa-project.org/db/?f=25e72e6b6e18d778bbf4ef7433e0e4fa00a080e2

i486 (andreasreinhardt) wrote :

From studying the datasheet of the ALC272 (which is used in Samsung's NC10), the jack must be polled periodically if headphones are connected. Herefore, sending the following verb is required:

(NID) (Verb) (Param)
0x21 0xF09 0

If this method returns a one in the MSB of the 32bit word (1<<31), headphones are connected. The according sequence to deactivate the internal speakers then is:

0x21 0x707 C0 (Enable headphone out pin)
0x21 0x3 B000 (Unmute headphone pin)
0x14 0x4 B080 (Mute internal speakers)

While the sequence to deactivate the headphones (when not attached) would be:

0x14 0x70C 02 (Enable external amplifier power)
0x14 0x3 0xB000 (Unmute speaker pin)
0x21 0x3 0xB080 (Mute headphones)

I have tried to set these with hda-verb, but didn't quite make it as there is no /dev/sdn/hw* device. Hence, I could not try things out. Hope this helps anyway.

OrelEagle (oreleagle) wrote :

Hi,

targa-2ch-dig makes everything work correctly: when headphones are plugged in, sound comes only from the headphones and when I unplugg them, sound comes from the laptop's speaker. Unchecking the "headphones" checkbox in the sound preferences works like turning off the headphones, which I suppose is the expected behaviour.

I don't have SPDIF jacks, but targa-2ch doesn't work: the same problem as with the default settings occurs.

So I suggest to make this setting (adding model=targa-2ch-dig at the end of /etc/modprobe.d/alsa-base) automatic.

Mackenzie Morgan (maco.m) wrote :

You actually *do* have S/PDIF. It says so in your alsa-info.sh output. I double-checked. We can't make a permanent change unless we know this works too. One of your line-out or headphone jacks doubles as S/PDIF. On my laptop, there's a headphone symbol with "S/PDIF" written under it. If you or someone you know has a digital receiver, you can test it that way.

Also, did you test your microphone?

OrelEagle (oreleagle) wrote :

I didn't know I had SPDIF... There are 3 connectors on my sound card: microphone, headphones and a blue one. There is a symbol which makes me think of an antenna (similar to http://www.wpclipart.com/telephone/antenna.png without the pedestal) and no SPDIF written under it.

According to wikipedia (http://en.wikipedia.org/wiki/Sound_card#Color_codes) it should be an analog line level audio input, so I don't think it's SPDIF (as you wrote it's an optical audio output) except if they use the same colour (wikipedia doesn't tell which colour is used by SPDIF).

If I get the opportunity to test a SPDIF system, I'll post the result here.

Microphone has always been working perfectly.

levidos (levidos) wrote :

thanks everybody. finally, targa-2ch-dig is working for me, too, yaay \:D/
I have an MSI EX600X-251EU notebook, with realtek ALC888. But I still don;t know how to use all the 5.1 channels if i want to connect the notebook to my external speakers which have 3x2 headphone jacks (front, rear and sub+center). umm... i guess i'm going off-topic :D

tanas (macarvalho) wrote :

I just wanted to add that the option targa-2ch-dig also solved my problems in a MSI laptop, model MS-1637 (PR600)

I understand that it seems to fix it, but we need confirmation that ALL
features of the sound card work with this quirk before it can be made
default in the kernel. That means the SPDIF needs to be tested.

inversus (inversus) wrote :

I dont have spdif, but i also tested microfone and it is also working. I
hope someone could test the SPDIF so this could be made default

2009/1/2 Mackenzie Morgan <email address hidden>

> I understand that it seems to fix it, but we need confirmation that ALL
> features of the sound card work with this quirk before it can be made
> default in the kernel. That means the SPDIF needs to be tested.
>
> --
> Realtek ALC883 speakers don't mute when headphones plugged in
> https://bugs.launchpad.net/bugs/253422
> You received this bug notification because you are a direct subscriber
> of the bug.
>

tanas (macarvalho) wrote :

I don't have spdif either, but I've been using this workaround for more than a year now (since Gutsy), and everything worked fine with mic, headphones.
And another thing, I didn't choose targa-2ch-dig because I found this bug report - it didn't exist back then - I tried the different options at ALSA-Configuration.txt for ALC883, and this was the only one that made things work back then. One detail, the options available in ALSA-Configuration.txt were a lot less one year ago (something like 6 or 7, now there are 21). So it may be that there is some other option that makes it all work.

levidos (levidos) wrote :

no spdif here either, i mean i don;t know what's that and how to test it, sorry. but i definitely agree with morgan that all the features of the sound card must work... but will it detect if that;s the right sound card??

Mackenzie Morgan (maco.m) wrote :

SPDIF is the optical output. It's often the same physical jack as your
headphone. If any of you know someone with a digital receiver, that's
what you need to test with. If you can connect the digital receiver to
your headphone jack and have it work through the receiver, then it
passes the test.

And yes, you do have SPDIF. It's listed in your alsa-info.sh outputs.
Went over this a few comments ago.

I've got the same problem here on my laptop: an msi s271
Running Intrepid with the latest kernel.
There is sound coming from the speakers and my headphone, but the speakers aren't muted when i plug the headphone in.

http://www.alsa-project.org/db/?f=533495de41c479144402879c8d2decc31ec1a137

Adding model=targa-2ch-dig at the end of /etc/modprobe.d/alsa-base unfortunatly doesn't seem to solve the problem. :(

hell yeeeeah :)))))))
Ubuntu 9.04
amilo 2510 here alc833 same problem....
SOLVED!!!
Searching 1 week to solve this problem....
It could be so easy...
I'm testing Debian 5 today...
Hardware support for my amilo notebook is bad.
It is not the newest hardware. X1200 Graphic Card alc833 Sound Chip.
Bios ACPI Problems this sucks..
Don't know if bios update or boot parameters will help.

Matías (matiasnfrias) wrote :

Problem solved here (SPDIF not tested). Just adding "options snd-hda-intel model=targa-2ch-dig" to my "/etc/modprobe.d/alsa-base.conf" configuration file. A little detail; now, headphones and speakers shares the same volume control. I'm using Ubuntu 9.04, in a LG E500 model GP02B6 (Core2Duo T7100 1.8 GHz, with Intel ALC883). I've tried "auto" and "3stack", but nothing happened. I used /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz for reference.

Here some extra info:

matias@matias-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC883
Codec: LSI ID 1040

matias@matias-laptop:~$ aplay -l
**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC883 Analog [ALC883 Analog]
  Subdispositivos: 0/1
  Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 1: ALC883 Digital [ALC883 Digital]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

http://ubuntuforums.org/showthread.php?t=616845
http://ubuntuforums.org/showthread.php?t=314383

Thanks! I hope this helps someone.
Matías.

PD: Sorry, my english... sucks.

ledenjes (jpa-rijks) wrote :

It worked for me, too!

I added the line "options snd-hda-intel model=targa-2ch-dig" to the file "/etc/modprobe.d/alsa-base.conf".

Now, headphones and speakers (indeed) share the same volume control.
You get a separate separate window called "Switches" (in Dutch: "Schakelaars") in which you can enable/disable the headphones output. Only now, (in my case) the speakers are muted and cannot be unmuted/enabled, anymore.
I don't care about that, because I don't use sound unless I'm watching a movie or listening to a song, which I only intend to do by using the headphones.

My stuff:
Operating System: Ubuntu Jaunty Jackalope 9.04 AMD64
Computer: Fujitsu-Siemens Amilo Pa1510 (AMD64 processor)
Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (Realtek ALC883)

Mackenzie Morgan (maco.m) wrote :

What do you mean by:
> Now, headphones and speakers (indeed) share the same volume control.
> You get a separate separate window called "Switches" (in Dutch:
> "Schakelaars") in which you can enable/disable the headphones output. Only
> now, (in my case) the speakers are muted and cannot be unmuted/enabled,
> anymore.

Are the speakers always muted, or is it that if you turn on the headphones
manually, the speakers become muted? Do you have to manually toggle that?

And since there are a ton of different pieces of hardware using ALC883, can you
paste the output of "lspci -nv | grep -A1 0403" so I can see if you're really
using the same hardware as the others?

ledenjes (jpa-rijks) wrote :

It means that the separate headphones volume control vanishes.

Yes, speakers are always muted, no matter whether the headphone switch is turned on or off.

My output of "lspci -nv | grep -A1 0403":

00:14.2 0403: 1002:437b (rev 01)
 Subsystem: 1734:10b8

synlub (sihendra) wrote :

Mine: http://www.alsa-project.org/db/?f=91caf04e5a5351b0e6c753c3830ebad1220f5d14

I added "options snd-hda-intel model=targa-dig" to the file "/etc/modprobe.d/alsa-base.conf".
the speaker muted after I insert the headphone but new problem occurs: the microphone doesn't not working (it worked before adding "options snd-hda-intel model=targa-dig")

synlub (sihendra) wrote :

Sorry for the lack of details, the microphone previously can be used as playback: When I speak against the microphone, I can hear my own sound in the speaker, but after adding "options snd-hda-intel model=targa-dig" no michrophone slider in the playback tab ( I already checked it in the volume control > preference )

otakuj462 (otakuj462) wrote :

http://www.alsa-project.org/db/?f=d22277b67c81eb98568b37a58cf97299691ca215

I've so far tried models 3stack, acer, acer-aspire, laptop, targa-2ch-dig, targa-2ch, and targa-dig, and nothing has succeeded in correcting this problem on my Acer Aspire 5536-5255 on Ubuntu 9.04. I actually haven't succeeded in getting any audio output to the headphone jack at all.

Mackenzie Morgan (maco.m) wrote :

You put them into the modprobe config file then rebooted, right? Not just change
it and plug in headphones?

Maybe there's a mixer element you're overlooking as well. They can change
when you change quirks. For my Realtek, "surround" means headphones.

otakuj462 (otakuj462) wrote :

I did reboot each time. Some configurations gave me no audio at all, most gave me audio only through the built-in speakers (no audio at all through headphones), however the lenovo* were the most promising, as they gave me headphone audio, but did not mute the built-in speakers. I also checked the mixer each time to make sure I wasn't missing something. It's always possible I overlooked something subtle.

I finally pulled ALSA 1.20 from upstream and compiled/installed it. This didn't fix things, but it did change them. When I set it to "auto", and started the computer without headphones in the jack, then it would only direct audio through the PC speakers. But when I started it with headphones in the jack, it would only give direct audio through the headphones.

Unfortunately, I won't be able to offer a more complete report on this, as I'll be returning this computer tomorrow due to an unrelated issue.

goto (gotolaunchpad) wrote :

I had this same problem.

Laptop: ASUS F3Ke / X53K series

bash-3.1$ head -n 1 /proc/asound/card0/codec*
Codec: Realtek ALC660-VD

ash-3.1# lspci | grep Audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

bash-3.1# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC660-VD Analog [ALC660-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

This workFaround works for me for now, add following line to alsa-base.conf (the probe_mask=1 bit is important):
options snd-hda-intel model=lenovo probe_mask=1

Outcome: Still plays from speakers AND Headphones but now you can mute speakers in alsamixer mute the "Front" volume control then sound only comes through the headphones. =) I hope they fix this though.

script output: http://pastebin.ca/1547928

Note I ran this on Slackware 13.0 but everything is the same also on Ubuntu.

spear1bearer (spear1bearer) wrote :

Still a problem for me, on Acer Aspire 5050 with Ubuntu Jaunty 9.04, after trying a bunch of values for model= . '

Basically, with the best profile I found I was able to independently control and mute speaker and headphone volume, but none detected the headphones (manual muting was required). What's particularly annoying is that acer-aspire profile actually DIDN'T work on my Acer Aspire...

Some test results:

targa-dig - Speakers don't mute when headphones are plugged in.
tagra-2ch-dig - can't get speakers to work. Headphones work.
acer-aspire - The Headphone switch DOES work. Speakers DON'T work.
acer, 6stack-dig - Speakers on "Surround" channel, headphones on "Front". Either can be independently muted, but only manually (no automatic speaker muting). Headphone switch doesn't work.
3stack - can't get speakers to work. Headphones switch doesn't work. Headphones do work.
3stack-dig - speakers work, but don't mute with headphones plugged in. Headphones work.

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Conexant ID 2c06
Codec: Realtek ALC883

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

utils_alsa-info.sh: http://www.alsa-project.org/db/?f=6f0a3764ea1e693cdb50090df3992ef0414dc7de

ledenjes (jpa-rijks) wrote :

I finally found it! My speakers now automatically mute when I plug in the headphones!
I added the following line to the file "/etc/modprobe.d/alsa-base" (without the quotes):

"options snd_hda_intel model=fujitsu-pi2515"

This is supposed to work for every Fujitsu Siemens laptop. If not you can try the following line:

"options snd_hda_intel model=fujitsu"

My computer: Fujitsu-Siemens Amilo Pa1510 (AMD64 processor)
My audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (Realtek ALC883)

If you have Ubuntu, just install Ubuntu 9.10 Karmic Koala (as soon as it arrives), since this version solves the headphones/speakers issue in total.

Mackenzie Morgan (maco.m) wrote :

ledenjes:
lspci -nv | grep -A1 0403

What's that say? That's a more specific ID for your audio device. And can you
confirm that *all* functionality still works with it? Does the mic continue to
work? If you have a screen mic and a plugin mic do both work? Speakers unmute
again when you unplug the headphones? If there's a S/PDIF out, does that work
too?

ledenjes (jpa-rijks) wrote :

lspci -nv | grep -A1 0403 says:

00:14.2 0403: 1002:437b (rev 01)
 Subsystem: 1734:10b8

Yes, the speakers mute when I plug in the headphones and unmute as soon as I unplug the headphones.

Yes, the mic continues to work, whether the headphones are plugged in or not.

I don't have a S/PDIF out.

Kevinf (siegfri3d) wrote :

I confirm it is fixed for me in karmic!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers